Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 17/02/2015, à 09:28

malbo

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

GG84,
Pour qu'on puisse examiner un peu mieux ton installation "de Maître" (suivant l'expression de kalunux), je te prie de copier la commande suivante :

dpkg -l | grep grub 

et de la coller dans un terminal puis valider par la touche Entrée. Tu posteras dans ta réponse le résultat de cette commande qui apparaît dans le terminal.

En ligne

#27 Le 17/02/2015, à 10:13

Bougron

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

kalunux a écrit :

....
Surtout pas supprimer cette partition "sda9" pourquoi ?
Car notre ami à fait sans le vouloir une installation de Maître. Je m’explique, actuellement cette machine démarre aussi bien en mode EFI qu’en mode Legacy, et ceci est un avantage d’où l'installation de Maître. wink

Bonjour.
Je n'avais pas réalisé que cela fonctionnait aussi en boot LEGACY!!!!.
C'est  le premier cas  que je rencontre  d'un boot réussi via  cette partition 'bios-boot" d'autant plus qu'elle est installée en fin de disque!
Jusqu'à ce jour, les conseils étaient plutôt (à mon grand désespoir) de dire qu'avec un bios legacy, il fallait convertir le disque en "MSDOS".
Perso  il y a 6 mois je n'avais pas su  'populer" correctement cette partition car je voulais le faire avec un bios positionné EFI.
   
Effectivement c'est à conserver à titre d'exemple.
Cette partition a été créée lorsque le bios était positionné en LEGACY (Voir le premier boot-info)
Mais elle ne supporte pas le "MIXED"  boot     ubuntu en LEGACY et windows en EFI qui la raison de l'ouverture de cette discussion.

Dernière modification par Bougron (Le 17/02/2015, à 10:26)

Hors ligne

#28 Le 17/02/2015, à 15:33

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Bonjour
Pour l'instant, pas de panique les gars, je ne maîtrise pas grand chose ( partitions, Legacy et tutty quanti). C'est pour moi un peu du chinois.
Le seul conseil que je pourrais donner à ceux ou celles qui voudrait comme moi installer Ubuntu sur un PC identique au mien serait de se cantonner à votre forum ou tout est expliqué pour faire une installation correcte.
J'ai du péché quelque par sur internet qu'il fallait désactiver le Lauch csm alors qu'il ne fallait pas le faire.
J'ai entre autre téléchargé Ubuntu sur ma clef USB d'une façon différente de celle expliqué par Malbo.
Rien que ces 2 trucs ont suffit à me foutre le petit bordel que vous avez certainement lu ci dessus.

Je vous propose de rajouter le lien https://doc.ubuntu-fr.org/live_usb
(je sais qu'il y est + bas aussi mais c'est la que nous avons besoin de charger la clef)
dans ce paragraphe

Installer rapidement Ubuntu sur un PC récent (sans se soucier de l'EFI)

Si votre PC est récent (>2010) et que vous ne savez pas ou vous n'avez pas besoin d'installer Ubuntu en mode UEFI, vous devriez être en mesure d'installer Ubuntu rapidement et correctement en suivant les étapes suivantes :

gravez un DVD ou un liveUSB ******** LIEN ICI *******de Ubuntu international (>=12.04.2) 64bit

Ce paragraphe se trouve
dans https://doc.ubuntu-fr.org/uefi#identifi … n_mode_efi

Sans ces 2 erreurs je pense que les menus de Windows 8.1 permettent de faire l'installation sans problème.

@+ GG

Hors ligne

#29 Le 17/02/2015, à 16:20

malbo

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Pas de panique +1
Peux-tu répondre à ma demande du post #26 ?

En ligne

#30 Le 17/02/2015, à 18:20

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

malbo
Je n'avais pas vu ta demande car resté sur page 1

1424193586.jpg

Hors ligne

#31 Le 17/02/2015, à 18:29

malbo

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

GG84,
Tu t'es trompé en tapant la commande. Je t'ai précisé le mode opératoire dans le post #26 à savoir utiliser le copier-coller et ne pas essayer de taper toi-même la commande. Peux-tu faire comme j'ai demandé ? De plus, je ne t'ai pas demandé d'envoyer une photo du résultat mais de seulement copier le résultat de cette commande et le coller dans ta réponse.

En ligne

#32 Le 17/02/2015, à 18:30

kalunux

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Le "-" et le "l" minuscule coller sans espace.
Puis copie/colle le retour entre balise tout simplement.

Hors ligne

#33 Le 17/02/2015, à 18:48

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Malbo
J'avais utilisé le CtrlC et CtrlV comme ca ne donnait rien dans le terminal je t'ai fait un clic clac

gg@gg-X751LK:~$ dpkg -l | grep grub
ii  grub-common                                           2.02~beta2-9ubuntu1                                 amd64        GRand Unified Bootloader (common files)
ii  grub-efi-amd64                                        2.02~beta2-9ubuntu1                                 amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 version)
ii  grub-efi-amd64-bin                                    2.02~beta2-9ubuntu1                                 amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 binaries)
ii  grub-efi-amd64-signed                                 1.34.1+2.02~beta2-9ubuntu1                          amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 version, signed)
ii  grub-pc-bin                                           2.02~beta2-9ubuntu1                                 amd64        GRand Unified Bootloader, version 2 (PC/BIOS binaries)
ii  grub2-common                                          2.02~beta2-9ubuntu1                                 amd64        GRand Unified Bootloader (common files for version 2)
gg@gg-X751LK:~$

Hors ligne

#34 Le 17/02/2015, à 18:55

kalunux

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Merci smile

On a trouver la solution parfait.

Hors ligne

#35 Le 17/02/2015, à 19:04

malbo

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Ben non justement : il n'y a pas le paquet grub-pc
Donc cette installation ne peut être démarrée qu'en mode EFI (pas en mode Legacy)

En ligne

#36 Le 17/02/2015, à 19:14

kalunux

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Ben Moi je dis que si smile

grub-pc-bin

Je pense que cela devrait suffire
Si notre ami veux bien faire l'essai.

Hors ligne

#37 Le 17/02/2015, à 21:54

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

gg@gg-X751LK:~$ grub-pc-bin
grub-pc-bin : commande introuvable
gg@gg-X751LK:~$

Hors ligne

#38 Le 17/02/2015, à 22:02

kalunux

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Non !!
Essaye de démarré Ubuntu en mode Legacy. C'est-à-dire, tu désactives UEFI donc "Disabled" et tu mets Legacy qui est pour toi logiquement Lauch csm sur "Enabled" depuis le Bios puis fait un essai en redémarrant STP Merci.

Dernière modification par kalunux (Le 17/02/2015, à 22:06)

Hors ligne

#39 Le 17/02/2015, à 22:42

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Ça marche pareill
Bios avant modif
1424208804.jpg
Je passe le launch csm a enabled - save
Ca redémarre sur le choix.
Ouvre Ubuntu. C'est correct. Éteint le PC. Redémarre sur le choix. Ouvre windowss.
Bios après modif.
1424209236.jpg

Hors ligne

#40 Le 17/02/2015, à 22:53

kalunux

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Merci !!
Je vous souhaites une très bonne soirée. wink

Hors ligne

#41 Le 17/02/2015, à 22:54

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Je laisse comme ca ou je remets disabled

Hors ligne

#42 Le 17/02/2015, à 23:07

kalunux

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Oui tu peux remettre sur "Disabled" !!
Mais avant, essaye de démarré Windows depuis Grub en gardant Lauch csm sur "Enabled".
Puis dis nous si Windows démarre STP.

Dernière modification par kalunux (Le 17/02/2015, à 23:08)

Hors ligne

#43 Le 17/02/2015, à 23:19

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

C'est avec le Grub que j'ai ouvert Windows. Moi j'appelais ca le choix

Hors ligne

#44 Le 18/02/2015, à 10:59

malbo

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Bien que tu aies passé "Launch CSM" sur Enabled, je crois qu'en fait tu as démarré en mode EFI sur le menu Grub. C'est grâce à cela que tu as pu sélectionner Windows dans le menu Grub et parvenir à le faire fonctionner. J'ai vérifié que quand le mode de démarrage du système UEFI est sur Legacy, il est impossible de démarrer un Windows 8.1 installé en mode EFI (*). Tu as cru démarrer en mode Legacy mais en fait tu as démarré en mode EFI. Pour t'en convaincre, tu peux refaire la même manip (avec "Launch CSM" sur Enabled) et quand tu arrives sur le menu Grub, choisis Ubuntu. Arrivé dans ta session de Ubuntu, fais la vérification du mode de démarrage en passant la commande suivante dans un terminal (source) :

[ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"

  (n'essaie même pas de la taper cette commande : utilise le copier-coller)

Tu verras que le résultat sera : Session EFI

(*) voici l'extrait de ton fichier de configuration de Grub qui concerne Windows :

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Boot Manager (sur /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-efi-CED6-8E55' {
	insmod part_gpt
	insmod fat
	set root='hd0,gpt1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1  CED6-8E55
	else
	  search --no-floppy --fs-uuid --set=root CED6-8E55
	fi
	chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

L'entrée "Windows Boot Manager (sur /dev/sda1)" du menu Grub pointe vers un fichier .efi (le fichier bootmgfw.efi en l’occurrence). Or un fichier .efi ne peut être lu que quand le "Boot Mode" est sur "UEFI" (si le "Boot Mode" est sur "Legacy", ce fichier .efi ne peut pas être lu). Il est donc impossible de démarrer ton Windows 8.1 par ce moyen.

Dernière modification par malbo (Le 18/02/2015, à 12:49)

En ligne

#45 Le 18/02/2015, à 13:06

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

gg@gg-X751LK:~$ [ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"
Session EFI
gg@gg-X751LK:~$

Hors ligne

#46 Le 18/02/2015, à 13:46

kalunux

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

@Malbo
Mais si tu peux Malbo
Au pire tu modifies la config et ajoute cette config dans le fichier "/etc/grub.d/40_custom".

Dernière modification par kalunux (Le 18/02/2015, à 13:55)

Hors ligne

#47 Le 18/02/2015, à 14:39

malbo

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

@GG84 : je suis en train de me demander si le démarrage en mode Legacy est seulement possible avec le paramétrage que tu as fait ("Launch CSM" sur Enabled). Si ça se trouve, malgré ce paramétrage, tu continues à ne pouvoir démarrer qu'en mode EFI. Soit c'est une anomalie de fonctionnement de ton système UEFI, soit il faut en plus passer le paramètre "Launch PXE OpROM policy" sur "Enabled" (au lieu de Disabled) comme expliqué dans ce tuto concernant un modèle Asus très proche du tien : https://gouessej.wordpress.com/2015/02/ … ld-ty052h/

En ligne

#48 Le 18/02/2015, à 18:59

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

Passe Launch PXE OpROM policy a [Enabled]
Prend photo
1424281500.jpg
F10 save
Ca redémarre sur Grub
Choisi Ubuntu
C ok
Arret PC
Allume PC
Grub
Choisi windows
C ok
Arret PC
Allume PC
Prend photo
1424281897.jpg
F10 save
Ca redémarre sur Grub
Choisi Ubuntu

Hors ligne

#49 Le 18/02/2015, à 18:59

GG84

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

gg@gg-X751LK:~$ [ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"
Session EFI
gg@gg-X751LK:~$

Hors ligne

#50 Le 18/02/2015, à 20:52

malbo

Re : Cohabitation Windows 8.1 Ubuntu 14.04.1 LTS Pas de choix au démarrage

En somme, tu n'arrives toujours pas à démarrer en mode Legacy. Laisse tomber si tu veux, on s'en fout c'était juste par curiosité pour tester ton installation "de Maître"...

En ligne