Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#76 Le 09/08/2008, à 22:21

duxy

Re : hardy heron et fake raid

J'ai un problème.

Je lance, le live cd de hardy heron, j'installe bien dmraid, ensuite j'exécute les commandes suivantes et voila ce que j'obtiens :

sudo dmraid -r

/dev/sdb: isw, "isw_cbbhhigbbc", GROUP, ok, 976773166 sectors, data@ 0
/dev/sda: isw, "isw_cbbhhigbbc", GROUP, ok, 976773166 sectors, data@ 0

ls /dev/mapper

control

Le problème c'est que je n'ai que control dans /dev/mapper alors que je devrai avoir la liste de mes partitions actives. C'est quoi le problème docteur ?

Hors ligne

#77 Le 11/08/2008, à 14:04

BuissonVert

Re : hardy heron et fake raid

Essaie en remplaçant sudo dmraid -r par

sudo dmraid -ay

Hors ligne

#78 Le 13/08/2008, à 16:32

duxy

Re : hardy heron et fake raid

Merci mais ce ne donnait rien non plus.
J'ai du formater vista et réinstaller, maintenant c'est bon.

Juste une précision, tu dis d'installer grub sur hd0 mais si notre pc est tatoué, que devons nous faire ?

Edit : j'ai choisi de ne pas installer grub lors de l'installation.
Ensuite j'ai monté les partitions, installer grub à l'aide de apt-get et ensuite configurer comme il faut.
Ca marche.

Merci à vous tous.

Dernière modification par duxy (Le 13/08/2008, à 18:14)

Hors ligne

#79 Le 14/08/2008, à 14:58

BuissonVert

Re : hardy heron et fake raid

Content que ça ait marché, au final.

Pour ce qui est des PC tatoués, aucune idée... Il me semble qu'il y avait moyen d'installer un Ubuntu sur un PC tatoué, mais je ne sais pas comment, donc je ne saurais pas dire non plus si ma méthode marche pour/est adaptable à un PC tatoué hmm

Hors ligne

#80 Le 21/08/2008, à 11:05

matthlb

Re : hardy heron et fake raid

Ben Merci BuissonVert , avec le tuto + ton intervention dans ce topic j'ai réussit. Cependant windows ne bootait plus, j'ai essayé d'ajouter "makeactive" (un peu au pif ma foi mais ça sonnait bien et c'etait présent sur le grub de mon laptop non raid ainsi que dans l'exemple du grub) et ça a marché.

donc pour moi la fin du menu.lst

title         Windows
root         (hd0,0)
makeactive
chainloader      +1

Dernière modification par matthlb (Le 21/08/2008, à 11:06)

Hors ligne

#81 Le 29/08/2008, à 22:42

nickoula

Re : hardy heron et fake raid

Un grand merci a toi buisson !!!!! je te dois beaucoup tongue

Hors ligne

#82 Le 11/09/2008, à 15:12

Gorion

Re : hardy heron et fake raid

Buisson, as-tu réussi à réglé ton problème de wifi, et était-il lié au fakeraid ?
Car ma carte n'est même pas reconnue dans lspci.
J'ai la carte wifi intégrée à la carte mère p5Q3 de chez ASUS.

Merci de l'information (et merci pour ce tuto)

#83 Le 11/09/2008, à 21:23

BuissonVert

Re : hardy heron et fake raid

J'ai réglé le problème, oui, mais simplement en réinstallant Ubuntu (j'ai encore quelques réflexes typiquement Windowsiens, comme le formatage par exemple tongue). Comme je n'avais pas encore de données importantes sur ce PC (qui avait quelques jours seulement) et qu'une réinstallation me prenait une 20aine de minutes...

Pour ton problème, il est peut-être possible de le résoudre via Ndiswrapper, en utilisant les pilotes XP? Bizarre cependant que ta carte ne soit pas mentionnée par lspci... J'imagine qu'évidemment lsusb ne donne rien non plus? Je ne sais pas comment elle est branchée, cette carte wifi hmm

Il doit bien être possible de la faire fonctionner : après tout, l'Express Gate est basée sur Linux, et j'imagine bien que le wifi de la carte mère est reconnu... Jette un coup d'oeil sur le CD de pilotes livré avec ta carte-mère, peut-être qu'il y a un pilote Linux pour ta carte WiFi, ou quelque chose d'utile.

Dernière modification par BuissonVert (Le 11/09/2008, à 21:25)

Hors ligne

#84 Le 12/09/2008, à 23:30

fab13

Re : hardy heron et fake raid

Bonsoir,

J'ai un léger problème pour installer Hardy sur un système fake raid 0.

D'abord le matériel :
- Gigabyte GA-965P-DS4 avec controleur RAID ICH8R
- 2 Maxtor SATA 160 Go en raid 0 (brancher sur port SATA intel 0 et 1)
- 1 WD SATA 120 Go (brancher sur port SATA intel 2)

J'ai déclaré mes 2 disques en raid 0 dans le menu dédié, j'ai installé Vista sans problème. J'ai crée 2 partitions sur le volume raid via vista (une pour vista, l'autre pour linux).

Quand je veux installer hardy, là ça se complique.

J'ai des messages d'erreur lorsque que j'utilise dmraid

ubuntu@ubuntu:~$ sudo dmraid -s
ERROR: sil: only 2/4 metadata areas found on /dev/sdc, electing...
ERROR: isw device for volume "Raid" broken on /dev/sdb in RAID set "isw_jihhcfghe_Raid"
ERROR: isw: wrong # of devices in RAID set "isw_jihhcfghe_Raid" [1/2] on /dev/sdb
*** Active Set
name   : sil_afaieiaiafaa
size   : 234440110
stride : 0
type   : linear
status : ok
subsets: 0
devs   : 1
spares : 0
*** Group superset isw_jihhcfghe
--> Subset
name   : isw_jihhcfghe_Raid
size   : 312574208
stride : 256
type   : stripe
status : broken
subsets: 0
devs   : 1
spares : 0

Déjà je vois pas trop pourquoi j'ai 2 grappes de détectées (sachant que sur ma carte y a effectivement 2 controleurs RAID possibles, mais le second ne possède pas de disques et de toute façon n'est pas définis en temps que controleur RAID (je l'ai mis en IDE).
En plus la première grappe ne correspond à rien niveau de la taille.

De plus le statut "broken" de la seconde grappe (qui semble être la bonne) ne présage rien de bon.
Chose confirmée puisque qu'evidemment je ne vois pas mon volume raid ni les partitions

root@ubuntu:~# dmraid -ay
ERROR: sil: only 2/4 metadata areas found on /dev/sdc, electing...
ERROR: isw device for volume "Raid" broken on /dev/sdb in RAID set "isw_jihhcfghe_Raid"
ERROR: isw: wrong # of devices in RAID set "isw_jihhcfghe_Raid" [1/2] on /dev/sdb
RAID set "sil_afaieiaiafaa" already active
RAID set "sil_afaieiaiafaa1" already active
root@ubuntu:~# dmraid -ay
root@ubuntu:~# ls /dev/mapper/
control  sil_afaieiaiafaa  sil_afaieiaiafaa1

La partition qui apparait correspond à rien, si ce n'est peut être à mon troisième disque (si je compare la taille). Mais bon, celui-ci n'étant pas en raid...

Bref, si quelqu'un a une idée lumineuse...

#85 Le 13/09/2008, à 10:43

fab13

Re : hardy heron et fake raid

Salut,

Bon la seconde grappe venait bel et bien du 3ieme disque. Je l'ai viré et je n'ai plus de grappe "sil".

Par contre la grappe liée au raid 0 intel est toujours HS.

root@ubuntu:~# dmraid -s
ERROR: isw device for volume "Raid" broken on /dev/sdb in RAID set "isw_jihhcfghe_Raid"
ERROR: isw: wrong # of devices in RAID set "isw_jihhcfghe_Raid" [1/2] on /dev/sdb
*** Group superset isw_jihhcfghe
--> Subset
name   : isw_jihhcfghe_Raid
size   : 312574208
stride : 256
type   : stripe
status : broken
subsets: 0
devs   : 1
spares : 0
root@ubuntu:~# dmraid -ay
ERROR: isw device for volume "Raid" broken on /dev/sdb in RAID set "isw_jihhcfghe_Raid"
ERROR: isw: wrong # of devices in RAID set "isw_jihhcfghe_Raid" [1/2] on /dev/sdb

Et toujours rien dans /dev/mapper

#86 Le 14/09/2008, à 16:05

BuissonVert

Re : hardy heron et fake raid

Si j'ai bien compris le problème, il ne détecte qu'un seul disque sur deux pour ta grappe en RAID0, et donc forcément il y a un problème... Vérifie que tous les branchements sont bien faits (j'imagine que oui, sinon je ne vois pas comment Vista pourrait fonctionner).

Le problème vient peut-être du fait que tu as partitionné via Vista, je ne sais pas...

Sinon, le "ls /dev/mapper" de ton premier post donne un résultat normal ou presque : control qui est toujours là, sil_afaieiaiafaa le contrôleur RAID, sil_afaieiaiafaa1 une partition. Donc, là aussi, on dirait que c'est le partitionnement qui pose problème : il n'y a qu'une seule partition au lieu des deux que tu mentionnes.

Hors ligne

#87 Le 23/09/2008, à 23:12

fab13

Re : hardy heron et fake raid

Salut

Le problème n'était ni matériel, ni lié au branchement effectivement

En fait sil_afaieiaiafaa est sensé être le contrôleur Silicon Image qu'il y a en plus sur ma carte mère. Et je n'ai aucun disque sur ce contrôleur (qui en plus est définis en IDE dans le bios), donc avoir une partition c'est quand même étrange.

Mes disques eux sont tous branchés sur le contrôleur intel. J'ai d'ailleurs toujours pas compris en quoi le fait d'enlever le troisième disque (non raid) du controleur intel a pu faire disparaitre cette fameuse grappe "sil".
Parceque le plus drôle c'est qu'après quelques essais....Je l'ai remis mon disque (sur le même port)...et la grappe sil elle n'est pas revenue pour autant.   

Ceci dit j'ai réussi en partie à résoudre le problème à force de longs tâtonnements, d'épluchage de logs et de recherches.

La non détection du contrôleur intel venait d'un conflit avec le hpa (Host Protected Area). Il a fallu que je boot le liveCD sur la busybox (via break=top) pour pouvoir forcer l'ignore de ce fameux hpa dans /etc/modprobe.d/libata-options (via l'option libata ignore_hpa=0).

Avec cette option là, mon dmraid ne me flingue plus la grappe intel et détecte toutes mes partitions.
J'ai pu installer mon ubuntu sans problème...

Le "hic" c'est qu'une fois le système linux installé (j'avais jamais eu ça avec uniquement vista), et au bout d'un nombre aléatoire de reboot j'ai mon raid 0 se fout en l'air...dans le bios du controleur Intel. Faut que je rentre dans le bios du controleur, que je sorte (sans rien toucher), que je reboot et là mon raid est de nouveau opérationnel. Et au bout d'un moment ça remerde.

J'ai tout virer, casser le raid, tout réinstallé plusieurs fois, toujours la même chose : tant que je reste avec vista, aucun problème, dès que j'installe ubuntu, ça part en cacahouète au bout de 3-4 allumages de la machine.

Du coup, bon, comme en plus j'ai récup un disque Atlas IV 10000tr/min j'ai ressortis ma carte scsi du fond des tiroirs et j'ai définitivement laissé tomber le fake-raid sur cette config

#88 Le 25/09/2008, à 18:59

BuissonVert

Re : hardy heron et fake raid

Hum, ben ça relève du parcours du combattant tout ça yikes

Enfin, j'suis content pour toi que ça marche, au final (même si t'as dû laisser tomber le fakeraid pour ça ^^')... Avec un peu de chance, la 8.10 sera plus aboutie au niveau de la gestion des fakeRAIDs.

Hors ligne