Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 06/02/2008, à 10:55

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

Salut à  tous les deux big_smile

désolé je ne vois vos messages que ce matin...la je suis au boutot !
yleetiny, je testerais la commande énoncée dans ton post #23 ce soir wink merci !!
makrook, yes ca peut etre très interressant de comparer en effet...pas de probleme si ca peut aider d'autres personnes !
sinon en effet le module sony-laptop est deja intégré normalement..apres si les touches Fn ne sont pas encore utilisables, au pire c'est pas très grave..du moment que je peux au moins régler la luminosité par script c'est deja ca !

Dernière modification par Tortue Genial 69 (Le 06/02/2008, à 10:56)


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#27 Le 06/02/2008, à 11:30

yleetiny

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@Tortue Geniale 69
Pour ceux qui n'ont pas la possibilité de régler le backlight, j'ai édité mon premier post, pour vous faire parvenir des scripts/programme permettant de régler la luminosité de façon software...

donc à  Tester!!!
(faites moi des retours, pour que je puisse l'améliorer, toute critique est bienvenue)


Ordinateurs : SONY VAIO C2Z/B & EEEPC 701
Merci de mettre [RESOLU] dans vos postes si le problème est réglé,
et Merci de partager vos expériences

Hors ligne

#28 Le 06/02/2008, à 11:53

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

Tortue geniale,

yleetiny est le gars qui s'y connait, moi je comprends pas grand chose a tout ca.
mais, vu que le resutat de nos lshal sont les memes et que je me souviens avoir eu
le meme message, sans me souvenir comment j'ai regle le probleme (je viens de regarder le precedant thread avec yleetiny parlant de ca et je ne vois rien, il me semble bien que je n'ai fait qu'installer xbacklight, puis j'ai eu des problemes quand j'ai installe compiz).
donc, question idiote mais sait-on jamais : est-tu sur d'avoir installe le bon driver pour notre CG X3100 ?

Hors ligne

#29 Le 06/02/2008, à 12:40

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

et bien concernant la CG X3100, je n'ai rien installé du tout en fait...tout a été reconnu d'entrée. sauf bien sur xbacklight que j'ai installé, xgl-server pour compiz et c'est tout...ou j'ai raté un truc alors ?
d'ailleurs les effets 3D marchent sans problème chez moi, je n'ai pas de ratées, ni sur l'affichage, ni sur les DivX (sauf en full screen ou cela saccade un peu mais surement un probleme de codec)...idem les MP3 marchent bien...j'avais lu sur un autre post que compiz et les effets 3D pouvaient avoir un effet sur ça justement (et que Totem ne fonctionnerait plus)..info ou intox, bref moi j'ai pas de probleme.

@yleetiny -> yes je testerais ca et je te ferais un retour très vite, mais meme de facon software, si le reglage marche moi ca me va nickel wink !

Dernière modification par Tortue Genial 69 (Le 06/02/2008, à 12:41)


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#30 Le 06/02/2008, à 12:49

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

tortue

ben en fait, de mon experience, le xgl pose probleme avec xbacklight : une histoire de sortie video qui n'est plus la meme.il doit donc falloir modifier un parametre je ne sais plus ou pour que xbacklight trouve la sortie video sur laquelle il peut agir.

a plus competent de t'eclairer plus avant,moi j'ai abandonne les effets 3D pour cause de trop de problemes depuis quelques semaines smile

Dernière modification par makrook (Le 06/02/2008, à 12:52)

Hors ligne

#31 Le 06/02/2008, à 12:51

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

ou sinon comme on me l'a souvent indique a l'epoque, oublier le reglage du backlight et trouver comment poser un filtre sur l'affichage avec compiz, j'ai cherche a l'epoque, j'ai pas trouve.desole.

Hors ligne

#32 Le 06/02/2008, à 13:11

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

oki dac je note pour le coupe de la sortie video...mais bon pour l'instant, bien que xgl-server soit installé, je n'ai pas activé les effets 3D, donc l'environnement reste neutre...mais effectivement s'il y a un paramètre à  modifier je suis preneur wink


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#33 Le 06/02/2008, à 14:04

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

en fait pas forcement neutre.vu que si je me souviens bien, cette histoire de sortie video qui n'est pas la bonne depend du server installe precisement, ceci que tu actives les effets 3d ou pas.

Dernière modification par makrook (Le 06/02/2008, à 14:06)

Hors ligne

#34 Le 06/02/2008, à 23:09

BigHope

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

Bonjour et merci pour ce topic.

J'utilise Xbacklight, enfin, "utilisais" car après une désinstallation de xgl-server Xbacklight ne fonctionne plus.
J'ai également désinstallé compiz-fusion pour des problèmes de plantages/artefacts assez récurents. Vivement une nouvelle série de drivers pour le X3100 (gma965)

Voici donc ma configuration :

smbios.system.product = 'VGN-NR11Z_S'  (string)
laptop_panel.access_method = 'general'  (string)

info.udi = '/org/freedesktop/Hal/devices/computer_backlight'  (string)
linux.subsystem = 'backlight'  (string)
linux.sysfs_path = '/sys/class/backlight/acpi_video0'  (string)


> cat /etc/X11/xorg.conf | grep -i driver
        Driver          "kbd"
        Driver          "mouse"
        Driver          "synaptics"
        Driver          "wacom"
        Driver          "wacom"
        Driver          "wacom"
        Driver          "intel"

Hors ligne

#35 Le 07/02/2008, à 22:50

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

yleetiny a écrit :

donc ceci devrait fonctionner :

echo "1" | sudo tee /sys/class/backlight/*/brightness

tu peux changer "1" par la valeur que tu souhaites entre 0 et max_brightness (donné par "cat  /sys/class/backlight/acpi_video0/max_brightness")

Ola,

désolé pour la réponse tardive je n'etais pas chez moi hier soir.
j'ai testé ta commande et ca ne donne rien...en fait il m'affiche juste la valeur que j'ai donnée après le echo mais la luminosité ne bouge pas :-/


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#36 Le 08/02/2008, à 11:30

yleetiny

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

Effectivement les utilisateurs de xbacklight vont avoir quelques problèmes certainements (pas le bon "DISPLAY", faudrait que je modifie mes scripts en conséquences)
pour le moment, il existe déjà une solution logiciel, que j'ai posté dans mon premier post...
En gros ce sont des mini scripts appellant des logiciels permettant de modifier la luminosité de l'affichage de façon software. Ce qui est une solution alternative.
Pour installer/utiliser ces petits srcipts.
1- créer et ouvrir un fichier texte classique:

gedit ~/lumi.sh &

2- copier/coller le texte de script que vous avez trouvé sur mon post... dans ce fichier et le sauvegarder.
3- rendre executable le script créé:

chmod +x ~/lumi.sh

4- executer le code (sans options vous permet d'avoir la syntaxe):

~/lumi.sh

NB: ici j'ai pris le fichier ~/lumi.sh mais vous pouvez l'adapter en fonctions de vos goûts

Je confirmes (recherche passée et sommaire) que d'après ce que j'ai pu lire à droite à gauche que les VAIO "intel" utilisent normalement xbacklight pour régler leur luminosité.

solution temporaire donc...ne dépendant pas de compiz donc...déjà crée et dispo...(implémentation dans le gestionnaire d'énergie pas encore fait par contre)
allez ciao

(Je serai pas mal occupé cette semaine et je suis pas chez moi donc mes posts seront moins fréquents)


Ordinateurs : SONY VAIO C2Z/B & EEEPC 701
Merci de mettre [RESOLU] dans vos postes si le problème est réglé,
et Merci de partager vos expériences

Hors ligne

#37 Le 10/02/2008, à 02:27

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

merci pour ces infos wink

j'ai utilisé le deuxième script, vu que le premier est destiné pour du nVidia.
alors pour ma part cela fonctionne jusqu'ici car j'ai le menu apres avoir fait un :

./lumi.sh

cela m'affiche :

./lumi.sh: line 1: Code: : commande introuvable
Usage ./lumi.sh :
   get         : get current brightness
   set <value> : set current brightness to value (0-20)
   up          : increase current brightness
   down        : decrease current brightness

par contre quand je saisis la commande ./lumi.sh up ou ./lumi.sh down j'ai ca :

./lumi.sh: line 1: Code: : commande introuvable
Xlib:  extension "XFree86-VidModeExtension" missing on display ":1.0".
Unable to que:/ry video extension version

si je fais ./lumi.sh get j'ai ca :

./lumi.sh: line 1: Code: : commande introuvable
Brightness : 20

en fait ma luminosité ne bouge toujours pas, meme si je fais un ./lumi.sh set 15 par exemple hmm

Dernière modification par Tortue Genial 69 (Le 10/02/2008, à 02:29)


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#38 Le 10/02/2008, à 02:40

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@makrook -> tu as installé des drivers pour ta carte Intel ou pas apres l'installation ou tout fonctionnait nickel ?


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#39 Le 10/02/2008, à 03:42

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

vi, j'ai du installer les drivers pour la carte, ca fonctionnait sans, mais pas nickel du tout smile

Hors ligne

#40 Le 10/02/2008, à 07:41

yleetiny

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@tortue geniale 69
euh...je crois savoir d'o๠vient le problème chez toi, quand tu as copié le texte tu as aussi copier le mot "Code" alors qu'il ne fallait pas (je pensais que c'était évident désolé):
le fichier doit se présenter ainsi:

#!/bin/bash
(...)

voili voilou

PS: si cela ne marche toujours pas c'est que peut - être tu n'as pas encore installé le petit programme xgamma :
pour cela:

sudo apt-get install xgamma

Ordinateurs : SONY VAIO C2Z/B & EEEPC 701
Merci de mettre [RESOLU] dans vos postes si le problème est réglé,
et Merci de partager vos expériences

Hors ligne

#41 Le 10/02/2008, à 13:25

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@ makrook -> ah bon, tu les a chopé ou stp ? car moi ca fonctionne sans saccades ni rien donc j'ai pas cherché a installer quoi que ce soit...une erreur de ma part pi etre hmm

@ yleetiny -> autant pour moi c'est ma faute j'ai oublié de retirer le mot code en effet wink

xgamma est bien installé et j'ai toujours le message suivant :

Xlib:  extension "XFree86-VidModeExtension" missing on display ":1.0".
Unable to query video extension version


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#42 Le 10/02/2008, à 22:32

yleetiny

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@tortue geniale
si je cromprends bien tu utilise xserser-xgl....ma question est d'abord pourquoi? (à  ma connaissance il ne sert qu'à  rajouter des trucs pour les cartes graphiques qui ne fonctionnent pas?) => sans on s'en porte bien mieux...(mais bon c'est mon avis).

Si tu as un temps d'essayer sans Xgl


Ordinateurs : SONY VAIO C2Z/B & EEEPC 701
Merci de mettre [RESOLU] dans vos postes si le problème est réglé,
et Merci de partager vos expériences

Hors ligne

#43 Le 11/02/2008, à 00:03

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@yleetiny
dans un autre thread, ou un autre message, sais plus, je t'avais indique que sauf truc que j'ai pas bien fait et/ou compris, compiz ne marche pas sans server-xgl chez nous autres possesseurs de X3100.
moi j'ai vire xserer-xgl et compiz vu que tout ca plantait trop souvent.

Hors ligne

#44 Le 11/02/2008, à 01:04

yleetiny

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

un peu de recherche n'aurait pas fait de mal concernant les x3100...
http://ubuntuforums.org/showthread.php? … ight=x3100
en fait, il est juste dit que compiz ne fonctionne pas out of the box avec et donc ils l'ont blacklistée...tout simplement (c'est souvent une ou deux fonctionnalités qui ne marchent pas mais c'est tout)...
il y a même des solutions de secours en plus...
donc pas besoin d'utiliser xgl qui pourri un peu tout (émulation de l'accélération graphique en quelque sorte, donc encore moins stable)

voili voilou, le lien donné plus haut est celui d'un thread sur Ubuntu forum english..qui traite du pb...vous devriez pouvoir vous en sortir avec cela!


Ordinateurs : SONY VAIO C2Z/B & EEEPC 701
Merci de mettre [RESOLU] dans vos postes si le problème est réglé,
et Merci de partager vos expériences

Hors ligne

#45 Le 11/02/2008, à 01:20

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@yleetiny
oui, me souviens maintenant, j'ai vire xserver-xgl et "deblackliste" la x3100
mais c'etait trop instable.
donc vire compiz, pas besoin de cube qui tourne de toute facon, me console en me disant que c'est du gadget.

Dernière modification par makrook (Le 11/02/2008, à 01:21)

Hors ligne

#46 Le 11/02/2008, à 01:42

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

ola,

alors pour faire un résumé :

@yleetiny -> comme le disais makrook il etait indiqué que compiz ne fonctionnait pas si xserser-xgl n'etait pas installé...vraisemblablement, vu le topic que tu as mis en lien, ca a l'air de tourner sans xserser-xgl... ok je vais tester sans xserser-xgl et je te dirais wink

@makrook -> tu as fais quoi du coup par rapport a ta carte ? install de drivers (si oui ou tu les a chopés stp?) ... la tu fonctionnes avec quoi en gros ? compiz ?  xserser-xgl ?

thx smile


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne

#47 Le 11/02/2008, à 02:19

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

donc
en preambule, me gonfle profondement d'avoir a trifouiller tout ca pour que ca marche, je ne m'interresse pas plus que ca aux entrailles de xserver et de mon driver.ca explique que je ne me souvienne pas de tout ce que j'ai fait.
donc, le driver, il est trouvable par synaptic si je me souviens bien (une recherche sur intel ? j'avais aussi ete le trouver sur la page d'intel, mais je crois que c'est inutile).il est bien possible que de toute maniere il soit deja installe sur ton systeme, j'imagine que si tu trouve un "intel" quelquepart dans xorg.conf ca veut dire oui.ceci dit, je n'ai pas regarde depuis un moment, possible qu'une nouvelle version existe pas sur les depots donc pas installee automatiquement et pas proposee en mise a jour, m'etonnerai, faudrait regarder.
j'ai vire compiz et xserver-xgl car c'etait instable, se passait des trucs bizarres avec l'affichage regulierement, j'aime bien avoir un systeme qui marche (arf, avec le choix entre vista et linux sur un portable recent c'est plus un blague qu'autre chose ce que je viens de dire), donc compiz=>poubelle.
MAIS, effectivement, on peut faire tourner compiz sans xgl, en retirant la X3100 de la "blacklist" quelquepart dans un fichier de config de compiz, je pense que la manip est indiquee dans le lien sur le post d'yleetiny au dessus.et du coup, tu peux avoir ET compiz ET un reglage de luminosite en meme temps (impossible tant que xserver-xgl est la, sauf manip a faire que je ne connais pas).
voila voila.

p.s. quand meme genial l'informatique moderne non ? le nombre de posts et d'energie depensee pour des histoires de touches de clavier que je comprends toujours pas comment sony a fait pour que ce soit le bo**el a chaque nouvelle generation, pour faire un bete reglage de luminosite, pour faire toutes sortes de choses qui DEVRAIENT ALLER DE SOIT histoire qu'on puisse UTILISER nos pcs...
oui, je sais, pas la faute de linux, mais jerefais le constat, vista = beurk, mais linux sur mon portable ben ... au final, PAS de solution satisfaisante, merci le monde marchand j'imagine (oups, derive sur la politique la).

Dernière modification par makrook (Le 11/02/2008, à 02:31)

Hors ligne

#48 Le 11/02/2008, à 08:37

yleetiny

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@makrook
Je partage entièrement ton avis, et je pense que malheureusement c'est ce genre de chose qui est un vrai frein à  l'utilisation des systèmes Linux...
En effet, la majorité des ordinateurs sont maintenant des portables et linux n'est pas forcément adapté pour eux (car les proprio ne fournissent pas des données techniques), et c'est vraiment la misère :
par ex : j'installe chez une amie sur son fixe ancien (>5 ans), et elle a quasiment les mêmes perfs que moi hormis la vitesse de calcul...et tout fonctionne out of the box...
En plus le second gros chantier est à  mon avis une meilleure gestion de l'énergie sur les ordinateurs portables (parce que sur mon VAIO, l'autonomie est équivalente voire plus faible que sur sous vista)
bah en espérant que les choses s'améliorent avec Hardy ....


Ordinateurs : SONY VAIO C2Z/B & EEEPC 701
Merci de mettre [RESOLU] dans vos postes si le problème est réglé,
et Merci de partager vos expériences

Hors ligne

#49 Le 11/02/2008, à 09:55

makrook

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

une note positive tout de meme : a part pour mes cvs (parceque ai eu la flemme d'aller regarder comment pourquoi open office refuse d'importer mes decuments sans les remplir de caracteres ... grecs ???, mais vais le faire au final) et pour telecharger les fichiers du tel de macopine (mais la aussi il y a une solution, je sais), au final, je ne me sers quasiment jamais de ma partition vista.
bon, je rale, mais (et ce notement grace a toi, le coup de la luminosite etait vraiment insupportable), ca fini par marcher tout ca.

Hors ligne

#50 Le 13/02/2008, à 20:01

Tortue Genial 69

Re : [APPEL aux utilisateurs VAIOs ] utilisant smartdimmer ou xbacklight

@makrook -> ok merci pour ces infos...j'ai vérifié et xserver-xorg-video-intel est installé.
ok donc à  la limite faudrait que je teste en virant xserver-xgl, compiz, et compizconfig-settings-manager ...
faudrait que je trouve le fichier ou la X3100 est "blacklisté" .. peut etre que y'a une piste la aussi !


Membre des 5 mousquetaires de l'apéro !!! http://www.toonetcreation.com

Hors ligne