Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#401 Le 15/09/2023, à 19:18

vv221

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Calyp a écrit :

Par contre, je me demandais si je pouvais abuser en postant un retour sur ce jeu, qui plante systématiquement chez moi.

Bien sûr, ce fil est là pour ça wink

Calyp a écrit :

Le terminal retourne ce soucis en s'arrêtant :

moi@moi-MS-xxxx:~$ dragon-age-origins
wine: Unhandled page fault on write access to 00000000 at address 797C5278 (thread 0120), starting debugger...
Killed

Tu devrais pouvoir obtenir des messages plus détaillés en lançant WINE en mode debug, avec :

WINEDEBUG='err+all,fixme+all' dragon-age-origins

Avec le retour complet de cette commande, jusqu’au crash du jeu, on devrait pouvoir trouver des pistes à exploiter.


Jouer sur Ubuntu ? Facile !

Hors ligne

#402 Le 02/10/2023, à 04:23

vv221

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Je ne sais pas encore si ça va tenir sur la durée ou si je vais rapidement m'en lasser, en tous cas ./play.it vient de débarquer dans le Fédiverse : @playit@fediverse.dotslashplay.it.

Ce compte partagera de temps en temps des messages (en anglais et ou français) portant sur les jeux vidéo sans DRM sur Linux, mais les messages postés par le compte lui-même ne concerneront que ./play.it. Donc si vous le suivez attendez vous à une activité plutôt faible, ce n'est clairement pas le genre de compte qui va remplir votre fil d'activité.


Jouer sur Ubuntu ? Facile !

Hors ligne

#403 Le 02/11/2023, à 14:28

vv221

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Ça a demandé pas mal de temps et de boulot (heureusement, j’ai reçu de l’aide efficace pour ça), mais enfin ça y est : la dernière version de ./play.it est de nouveau disponible dans les dépôts d’Ubuntu (24.04). Comme signalé sur le wiki, à partir de cette version le logiciel est séparé en plusieurs paquets, cf. play.it [Wiki ubuntu-fr].

Le paquet play.it est celui qui fournit le cœur du logiciel, et n’est vraiment utile que si on installe en plus un paquet fournissant la prise en charge d’un collection de jeux. play.it-community fournit la prise en charge d’une grande quantité de jeux, plus ou moins maintenue collectivement, et play.it-vv221 fournit la prise en charge d’une collection plus réduite que je maintiens personnellement.


Jouer sur Ubuntu ? Facile !

Hors ligne

#404 Le 17/12/2023, à 14:15

Flo-raspb5

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Bonjour vv221,

merci pour votre message, j'arrive à "sudo apt install play.it"
mais  "sudo apt install play.it-community" ou  "sudo apt install play.it-vv221" ne donnent rien.
(j'utilise un raspberry pi 5 8go).

Auriez-vous une indication à me donner svp ?

Hors ligne

#405 Le 17/12/2023, à 17:56

iznobe

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Bonjour ,sans plus de precision de ce qui a été fait ou pas , ni retour de commande , difficile d' aider .

pour commencer il faut suivre ce qui est indiqué dans la doc ( lien au message #1 ) en fonction du systeme installé ( que tu ne precises meme pas ... ) .


retour COMPLET et utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#406 Le 17/12/2023, à 18:41

Flo-raspb5

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Bonjour,
merci,
j'utilise ubuntu 23.10 pour raspberry pi.

je suis l'aide de la page : https://wiki.ubuntu-fr.org/play.it

j'ai effectué : "Ubuntu 23.10 et versions plus anciennes Installez le paquet play.it"

dans mon dossier téléchargement j'ai le fichier : GOG_Galaxy_Heroes_of_Might_and_Magic_3_Complete.exe

dans un terminal je tape donc : "

flo@flo-raspb:~$ play.it /home/flo/Downloads/GOG_Galaxy_Heroes_of_Might_and_Magic_3_Complete.exe

"
et j'ai comme résultat : "

Erreur :
Impossible de trouver un script pour le fichier GOG_Galaxy_Heroes_of_Might_and_Magic_3_Complete.exe

"

Je lis à nouveau la page https://wiki.ubuntu-fr.org/play.it et je vois que pour la future version 24.04 il faudra ajouter  au moins une collection de scripts de prise en charge de jeux parmi :

play.it-community, une collection maintenue collectivement ;
play.it-vv221, une collection maintenue par l’auteur de ./play.it.

mais je ne parviens pas à le faire, la commande :

flo@flo-raspb:~$ sudo apt install play.it-community
[sudo] Mot de passe de flo : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
E: Impossible de trouver le paquet play.it-community
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « play.it-community »

voila, merci d'avance smile

Dernière modification par Flo-raspb5 (Le 17/12/2023, à 18:50)

Hors ligne

#407 Le 17/12/2023, à 18:44

xubu1957

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Bonjour,

Pour ajouter toi-même les balises code à ton précédent message #406 :             Merci        wink

  • Cliquer sur le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

Balisesmoko138.jpg

comme indiqué dans le : Retour utilisable de commande

Dernière modification par xubu1957 (Le 17/12/2023, à 18:59)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#408 Le 17/12/2023, à 18:54

ylag

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Bonjour,

Les paquets play.it-community et play.it-vv221 ne sont disponibles que pour la prochaine version Ubuntu Noble 24.04, actuellement en développement jusqu'à la fin Avril 2024.
C'est mentionnè au message #403.

On peut le vérifier là : https://packages.ubuntu.com/search?keyw … ection=all

A+

Dernière modification par ylag (Le 17/12/2023, à 18:56)

Hors ligne

#409 Le 17/12/2023, à 18:58

Flo-raspb5

Re : ./play.it, installez facilement vos jeux sur Ubuntu

D'accord merci, rien à faire que d'attendre alors.

Hors ligne

#410 Le 20/12/2023, à 14:39

vv221

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Flo-raspb5 a écrit :

dans mon dossier téléchargement j'ai le fichier : GOG_Galaxy_Heroes_of_Might_and_Magic_3_Complete.exe

Le problème est là, tu t’es fait piéger par GOG qui t’a fait télécharger un installateur pour leur spyware/client Galaxy au lieu d’un installateur pour le jeu. L’installateur correct pour Heroes of Might and Magic 3 en version française est fourni en deux fichiers :

gog-no-galaxy-775141.png


Jouer sur Ubuntu ? Facile !

Hors ligne

#411 Le 20/12/2023, à 19:02

vv221

Re : ./play.it, installez facilement vos jeux sur Ubuntu

ylag a écrit :

Les paquets play.it-community et play.it-vv221 ne sont disponibles que pour la prochaine version Ubuntu Noble 24.04, actuellement en développement jusqu'à la fin Avril 2024.

Pour être totalement clair, ces paquets ne sont pas utiles avant la version 24.04 d’Ubuntu parce qu’avant ça leurs fonctionnalités sont fournis par le paquet de base "play.it". Ce n’est qu’à partir de la version 2.16 de ./play.it qu’on a divisé le logiciel de manière à ce qu’il soit fourni en plusieurs paquets.


Jouer sur Ubuntu ? Facile !

Hors ligne

#412 Le 21/12/2023, à 19:19

Flo-raspb5

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Merci pour ces messages, la formulation de l'aide me faisait bien comprendre que ma version d'ubuntu ne nécessitait PAS ces scripts...

bref, j'ai donc téléchargé les 2 fichiers, puis j'ai fait :

flo@flo-raspb:~$ play.it /home/flo/Downloads/setup_heroes_of_might_and_magic_3_complete_4.0_\(french\)_\(28740\).exe
Utilisation de /home/flo/Downloads/setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740).exe
Calcul de la somme de contrôle de setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740).exe…
Somme de contrôle calculée!
Utilisation de /home/flo/Downloads/setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740)-1.bin
Calcul de la somme de contrôle de setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740)-1.bin…
Somme de contrôle calculée!
Extraction des données de setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740).exe…
/usr/share/games/play.it/games/50_core/play-heroes-of-might-and-magic-3.sh: 2245: innoextract: not found

j'ai tenté d'installer innoextract :

flo@flo-raspb:~$ sudo apt install innoextract
[sudo] Mot de passe de flo : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets supplémentaires suivants seront installés : 
  libboost-program-options1.74.0
Les NOUVEAUX paquets suivants seront installés :
  innoextract libboost-program-options1.74.0
0 mis à jour, 2 nouvellement installés, 0 à enlever et 5 non mis à jour.
Il est nécessaire de prendre 507 ko dans les archives.
Après cette opération, 2889 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://ports.ubuntu.com/ubuntu-ports mantic/main arm64 libboost-program-options1.74.0 arm64 1.74.0+ds1-22ubuntu1 [305 kB]
Réception de :2 http://ports.ubuntu.com/ubuntu-ports mantic/universe arm64 innoextract arm64 1.9-0.1 [203 kB]
507 ko réceptionnés en 0s (1246 ko/s) 
Sélection du paquet libboost-program-options1.74.0:arm64 précédemment désélectio
nné.
(Lecture de la base de données... 152800 fichiers et répertoires déjà installés.
)
Préparation du dépaquetage de .../libboost-program-options1.74.0_1.74.0+ds1-22ub
untu1_arm64.deb ...
Dépaquetage de libboost-program-options1.74.0:arm64 (1.74.0+ds1-22ubuntu1) ...
Sélection du paquet innoextract précédemment désélectionné.
Préparation du dépaquetage de .../innoextract_1.9-0.1_arm64.deb ...
Dépaquetage de innoextract (1.9-0.1) ...
Paramétrage de libboost-program-options1.74.0:arm64 (1.74.0+ds1-22ubuntu1) ...
Paramétrage de innoextract (1.9-0.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.11.2-3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.38-1ubuntu6) ..
.

puis

flo@flo-raspb:~$ play.it /home/flo/Downloads/setup_heroes_of_might_and_magic_3_complete_4.0_\(french\)_\(28740\).exe
Utilisation de /home/flo/Downloads/setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740).exe
Calcul de la somme de contrôle de setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740).exe…
Somme de contrôle calculée!
Utilisation de /home/flo/Downloads/setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740)-1.bin
Calcul de la somme de contrôle de setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740)-1.bin…
Somme de contrôle calculée!
Extraction des données de setup_heroes_of_might_and_magic_3_complete_4.0_(french)_(28740).exe…
Extraction réussie!

Erreur :
Le fichier dʼicône suivant est du type MIME "application/vnd.microsoft.portable-executable", qui nʼest pas pris en charge : /tmp/play.it-flo/heroes-of-might-and-magic-3.VQuyU/heroes-of-might-and-magic-3-wine-fr_4.0-gog28740+20210112.2_i386/usr/local/share/games/heroes-of-might-and-magic-3/heroes3.exe

ensuite rien donc j'ai tenté :

flo@flo-raspb:~$ heroes3
La commande « heroes3 » n'a pas été trouvée, voulez-vous dire :
  commande « heroes » du deb heroes (0.21-18)
Essayez : sudo apt install <nom du deb>
flo@flo-raspb:~$ apt install /home/user/heroes-of-might-and-magic-3-data-fr_4.0-gog28740+20210112.2_all.deb /home/user/heroes-of-might-and-magic-3-vcmi_4.0-gog28740+20210112.2_all.deb
E: Le fichier donné /home/user/heroes-of-might-and-magic-3-data-fr_4.0-gog28740+20210112.2_all.deb n'est pas compris sur la ligne de commande
E: Le fichier donné /home/user/heroes-of-might-and-magic-3-vcmi_4.0-gog28740+20210112.2_all.deb n'est pas compris sur la ligne de commande
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock-frontend - open (13: Permission non accordée)
E: Impossible d'obtenir le verrou de dpkg (/var/lib/dpkg/lock-frontend). Avez-vous les droits du superutilisateur ?
flo@flo-raspb:~$ sudo apt install /home/user/heroes-of-might-and-magic-3-data-fr_4.0-gog28740+20210112.2_all.deb /home/user/heroes-of-might-and-magic-3-vcmi_4.0-gog28740+20210112.2_all.deb
Lecture des listes de paquets... Fait
E: Le fichier donné /home/user/heroes-of-might-and-magic-3-data-fr_4.0-gog28740+20210112.2_all.deb n'est pas compris sur la ligne de commande
E: Le fichier donné /home/user/heroes-of-might-and-magic-3-vcmi_4.0-gog28740+20210112.2_all.deb n'est pas compris sur la ligne de commande

je n'ai pas de nouveau fichier .deb dans mes dossiers.

c'est vraiment difficile, je n'ai pas les bases ni les éléments pour comprendre, ou puis-je apprendre tout cela ?

Hors ligne

#413 Le 22/01/2024, à 18:19

vv221

Re : ./play.it, installez facilement vos jeux sur Ubuntu

Flo-raspb5 a écrit :
flo@flo-raspb:~$ play.it /home/flo/Downloads/setup_heroes_of_might_and_magic_3_complete_4.0_\(french\)_\(28740\).exe
(…)
Erreur :
Le fichier dʼicône suivant est du type MIME "application/vnd.microsoft.portable-executable", qui nʼest pas pris en charge : /tmp/play.it-flo/heroes-of-might-and-magic-3.VQuyU/heroes-of-might-and-magic-3-wine-fr_4.0-gog28740+20210112.2_i386/usr/local/share/games/heroes-of-might-and-magic-3/heroes3.exe

Pour éviter cette erreur il faut utiliser au moins ./play.it 2.20.1, cf. https://forge.dotslashplay.it/play.it/s … ses/2.20.1


Jouer sur Ubuntu ? Facile !

Hors ligne