Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/02/2008, à 19:29

Wolfi

[Post installation 7.10] problème de boot instable (HPdv6510)

Bonjour à  tous,
Avec l'aide précieuse d'un membre de ce forum, Slasher-fun pourne pas le citer, j'ai installé Ubuntu 7.10 sur mon portable.
Le dual boot avec vista fonctionne correctement, mais quand je choisi Ubuntu, j'ai environ un chance sur dix de booter, sinon le chargement reste bloqué au début de la barre.
Si je fais Ctrl + F1, je vois les lignes de test des résolutions, dont la dernière qui marche, et puis plus de changement. Et le disque à  sa led qui tourne.

En changeant la commande de boot et en ajoutant ro quiet noirqart, poll noacpi noapic nolapic nosmp splash  comme indiqué sur internet, cela n'a pas l'air d'avoir des effets.

Quelqu'un à -t-il su remédier à  ce problème autrement ?

D'autre part, quelqu'un sait-il comment éviter le test des résolutions ? ce serait déjà  ce temps là  de gagné !

Merci d'avance

#2 Le 07/02/2008, à 20:28

wolfi

Re : [Post installation 7.10] problème de boot instable (HPdv6510)

Bon, j'ai avancé un peu dans mes tests.

J'ai cherché la serie sur le wiki ubuntu, j'ai testé tout les suffixes conseillés, rien ne marche.

Ce que j'ai appris : quand je mets en mode splash, ça plante, mais pas toujours aux mêmes endroits ( après le check sata, après le check usb, après le check carte réseau ).
De plus, quand ça plante en mode normal, au bout de quelques minutes, il m'ouvre une busybox, et l'erreur qu'il trouve avant c'est : "check root= bootarg cat/proc/modules ls /dev
/disk/by_uuid/LE_UUID_DE_MA_PARTOCH_LINUX does not exist"
J'ai bien vérifé, c'est le bon.

Des conseils ?

#3 Le 07/02/2008, à 20:59

wolfi

Re : [Post installation 7.10] problème de boot instable (HPdv6510)

Bon, on progresse, mais pas beaucoup.
http://www.bonz.org/tech/post/2007/09/1 … -la-maison ressemble à mon problème, mais la marche à suivre n'est pas la même sur Ubuntu.
Une idée ? Quelqu'un ?

#4 Le 11/02/2008, à 00:13

wolfi

Re : [Post installation 7.10] problème de boot instable (HPdv6510)

Je ne peux pas éditer, mais c'est résolu. sans rien faire. Mon ratio de 1 lancement réussi pour 10 est passé  à 1 raté pour 10. Pour info j'ai juste l'option ro.

Si jamais vous avez le même problème, n'hésitez pas à me contacter !

Hors ligne

#5 Le 12/02/2008, à 15:23

DanaKil

Re : [Post installation 7.10] problème de boot instable (HPdv6510)

Bonjour,

après plusieurs mois de galère, je pense enfin avoir résolu le problème en rajoutant "all_generic_ide" dans la ligne de boot. Pour rappel, mon PC ne démarrait qu'une fois sur trois normalement en gros, et il restait bloqué au niveau de la gauge de chargement du splash. Je devais alors le rebooter sauvagement jusqu'à  ce qu'il démarre normalement (je tombais aussi sur la busybox quand j'attendais assez longtemps).

Pour rajouter cette option de ligne de commande :

- Au démarrage, quand l'invite de Grub apparaà®t, appuyez sur Echap pour accéder  aux différents choix de boot.
- Sélectionner la seconde ligne (après "root(0,0)" ou quelque chose de ressemblant) et appuyez sur "e" pour l'éditer.
- rajouter "all_generic_ide" tout à  la fin de la ligne (attention, clavier anglais normalement, donc "a"="q". Pour taper le "_", je crois de mémoire que c'est "shitft"+")" mais je peux me tromper.
- démarrer avec la touche "b" pour booter en utilisant cette ligne de commande modifiée

Vu que le problème survient de manière aléatoire, c'est difficile de jugez si cela change quelque chose, donc si tout se passe bien, on peut modifier de façon permanente notre entrée Grub :

- éditer le fichier /boot/grub/menu.lst
- vers la fin du fichier, on a la liste de nos entrée Grub qui apparaisent au boot
Dans mon cas, j'ai :
-----------------------------------------------------------------
title		Ubuntu 7.10, kernel 2.6.22-14-generic
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=727889d5-e7a6-41f8-83f5-3ba392223b11 ro quiet splash
initrd		/boot/initrd.img-2.6.22-14-generic
quiet
-----------------------------------------------------------------
Modifier la ligne "root=" pour qu'elle ressemble à  ceci :
root=UUID=727889d5-e7a6-41f8-83f5-3ba392223b11 ro quiet splash all_generic_ide

Voilà , chez moi ça a l'air de marcher, par contre je n'ai aucune idée de ce que fait cette commande.

Note: j'ai déjà  posté ma réponse dans ce fil : http://forum.ubuntu-fr.org/viewtopic.php?pid=1531614#p1531614

Hors ligne

#6 Le 18/05/2011, à 13:24

blarger

Re : [Post installation 7.10] problème de boot instable (HPdv6510)

bonjour
j'ai un pb au démarrage. il m'affiche busybox etc. avec initramfs.
j'ai cherché sur les différents forum sans réussir à résoudre mon problème.
je voulais essayer avec cette méthode :mais je n'arrive pas à la résoudre avec ta méthode bloquant à la 1ère étape.
je n'ai pas de "root(0,0)" dans les choix du boot.

mon pC est un acer 1640 datant de mars 2006

je précise qu' il marchait sans problème apparent. Les pb ont commencé il y a deux jours ...
pour précision : J'ai installé ubuntu 10.04 en septembre 2010.
pouvez-vous m'aider.
j'ai l'impression qu'il ne trouve pas certain fichier pour démarrer correctement.
cordialement
blarger

Hors ligne

#7 Le 30/08/2011, à 07:12

Antikam

Re : [Post installation 7.10] problème de boot instable (HPdv6510)

Hors ligne