Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 15/09/2015, à 11:47

Trymy

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

Oui malbo, mon ordi démarre bien sur le menu Grub.

Effectivement des fichiers ne servent à rien, je songerai à les supprimer. ikewdu si tu as un lien qui qui explique la modification des option du Grub je suis preneur (quoique j'ai vu des topics passer la dessus), j'ai des entrées qui ne sont pour l'instant pas utiles.

Hors ligne

#27 Le 15/09/2015, à 12:08

malbo

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

Trymy a écrit :

Oui malbo, mon ordi démarre bien sur le menu Grub.

Si tu ne sélectionnes rien dans le menu Grub et que tu attends plus de 10 secondes afin que ça démarre sur le choix par défaut de Grub, que se passe-t-il ? Est-ce que c'est Windows qui démarre ou bien ?

Hors ligne

#28 Le 15/09/2015, à 13:19

Trymy

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

Hm oui c'est bien Windows qui démarre après 10sec. Du coup ça répond partiellement à ma question, il suffirait de changer ce choix, régler si besoin le temps d'attente ?

Hors ligne

#29 Le 15/09/2015, à 14:50

malbo

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

Dans la partie "/etc/default/grub" de ton Boot-Info, on peut voir cette ligne :

GRUB_DEFAULT="Windows Boot UEFI loader"

Ce qui signifie que ton démarrage par défaut se fait sur cette entrée du fichier de configuration de Grub :

menuentry "Windows Boot UEFI loader" {
search --fs-uuid --no-floppy --set=root BE3E-6714
chainloader (${root})/EFI/Boot/bkpbootx64.efi
}

Comme tu vois, il s'agit du chargeur d'amorçage bkpbootx64.efi donc on peut en déduire que ce fichier sert à quelque chose puisqu'il est fonctionnel pour démarrer Windows.
Si tu souhaites que ce soit Ubuntu qui soit sélectionné par défaut, il suffit de modifier ce paramètre pour qu'il devienne :

GRUB_DEFAULT=0

Ainsi, c'est la première entrée du menu Grub qui sera sélectionnée : celle qui est désignée "Ubuntu"
La procédure pour réaliser cela est détaillée dans la doc : 6.5 Exemple : OS sélectionné par défaut
C'est bien mentionné dans cette doc mais les gens oublient toujours : il faut toujours terminer cette procédure par la commande :

sudo update-grub

Sinon la modif n'est pas prise en compte

EDIT : tu peux en profiter pour régler le temps d'affichage du menu en suivant mes indications de ce post : http://forum.ubuntu-fr.org/viewtopic.ph … #p19459431

Dernière modification par malbo (Le 15/09/2015, à 14:52)

Hors ligne

#30 Le 15/09/2015, à 16:11

ikewdu

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

Re,

malbo a écrit :

Comme tu vois, il s'agit du chargeur d'amorçage bkpbootx64.efi donc on peut en déduire que ce fichier sert à quelque chose puisqu'il est fonctionnel pour démarrer Windows.

C'est l'évidence. C'est même probablement l'original, renommé par boot-repair (je croyais que yannubuntu avait viré cette fonction de renommage).

Quant à la suppression des entrées inutiles, si on s'appuie sur boot-repair, tu dois avoir  (dis-moi si je me trompe):

Ubuntu
advanced option for ubuntu

Windows UEFI bootmgfw.efi
Windows Boot UEFI loader
EFI/ubuntu/MokManager.efi
EFI/toshiba/Boot/bootmgfw.efi
Windows Boot Manager (on /dev/sda2)

Peut-être aussi

System setup

Si ceux que j'ai mis en gras fonctionnent, il n'est pas compliqué de virer tous les autres en rendant inactifs les fichiers /etc/grub.d/25_custom, et éventuellement 30_uefi-firmware en faisant un sudo update-grub.

Dernière modification par ikewdu (Le 15/09/2015, à 16:17)

Hors ligne

#31 Le 15/09/2015, à 23:28

Trymy

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

J'ai suivis vos procédure, c'est du tout bon, exactement ça smile

@ikewdu, j'avais en effet System setup en plus de ces entrées. Merci pour ton aide.

@malbo, merci pour ton aide, ton temps et pour la précision de tes procédures.

Je mets en résolu wink

Hors ligne

#32 Le 16/09/2015, à 04:20

malbo

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

Si un jour tu te retrouves en panne de démarrage, n'utilise pas Boot-Repair parce qu'il va encore te créer des entrées inutiles dans le menu Grub : utilise une LiveUSB SG2D pour démarrer sur Ubuntu et tenter de réparer depuis la session Ubuntu. A cette occasion, tu seras peut-être amené à refaire la manip du post #17.

Dernière modification par malbo (Le 16/09/2015, à 04:23)

Hors ligne

#33 Le 18/09/2015, à 20:29

Trymy

Re : [RESOLU] Pas de boot en dual W8.1 - Ubuntu

C'est noté, encore merci.

Hors ligne