Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/10/2015, à 07:48

malbo

L'install de Wily bloque à "création du système de fichiers ext4..."

EDIT le 2 mars 2016 : j'ai refait des manips sur le sujet et il en ressort que Wily (Ubuntu 15.10) et Vivid (Ubuntu 15.04 qui n'est plus maintenu) sont affectés par ce problème de blocage à "création du système de fichiers ext4..." alors que Ubuntu 14.04.3 et Ubuntu 14.04.4 (et probablement les premières versions de Trusty - 14.04, 14.04.1 et 14.04.2- mais j'ai la flemme de faire les manips) ne sont pas affectés.

Vicieux le truc. En virtualisation avec VMware Player, dans une machine virtuelle fonctionnant en mode non-EFI, si j'utilise le démarrage sur l'ISO de Wily, aucun souci, par contre, si je démarre ma machine virtuelle sur le DVD physique gravé préalablement avec l'ISO de Wily ou bien si je démarre sur une LiveUSB réalisée avec LiLi à partir de ce même ISO, j'ai le problème signalé dans le titre, c'est à dire que l'installation semble fonctionner sauf que la "Création du système de fichiers ext4 pour le point de montage / sur la partition ....." n'avance plus, comme si le formatage de cette partition était impossible :
1444284599.png
Je précise mes conditions de manips : je fais une installation de Wily en écrasant une précédente installation de Wily, c'est pourquoi j'ai sélectionné "Autre chose" à l'étape "Type d'installation" et j'ai coché la case "formater la partition" pour la partition racine puisque je veux une installation toute neuve.

Dans la chronologie, je précise qu'avant de faire ces essais en virtualisation avec VMware, j'ai tenté une installation de Wily dans mon PC Acer (voir dans ma signature) qui m'a donné le même pb (blocage à "Création du système de fichiers ext4") et une installation dans un autre ordi qui m'a donné aussi ce même blocage.
La solution pour parvenir à installer Wily dans ces deux machines : depuis la session live de Wily, lancer Gparted et formater la partition destinée à être la partition racine puis faire l'installation en ne cochant pas la case "formater la partition"(*) pour cette partition racine. L'installateur affiche alors un message pour signaler qu'il va installer dans une partition non formatée :
1444284762.png
mais on s'en fout de ce qu'il peut déblatérer : il faut cliquer sur "Continuer" et l'installation peut se réaliser jusqu'au bout et elle est fonctionnelle.

EDIT : il semblerait que ce soit la même chose que dans le le rapport de bug #1361951 ou le rapport de bug #1447600 (ce serait le même bug dans les deux cas mais il a donné lieu à deux rapports de bug). La solution que j'ai utilisée se trouve être la même que celle décrite dans le commentaire 6 du rapport de bug #1447600.

(*) dans certains cas, on peut quand même cocher la case "formater la partition" à cette étape parce que Gparted à fait le ménage juste avant et qu'il n'y a plus d'obstacle. On peut toujours tenter en cochant la case et si ça continue à bloquer à "Création du système de fichiers ext4", on refait toute la procédure sans cocher cette case.

Dernière modification par malbo (Le 02/03/2016, à 09:19)

Hors ligne

#2 Le 08/10/2015, à 18:00

malbo

Re : L'install de Wily bloque à "création du système de fichiers ext4..."

Mes manips du post #1 étaient fausses. C'est l’enchaînement des essais qui m'avait fait croire que le problème ne se produisait que si j'utilisais un support physique (LiveDVD ou LiveUSB) mais qu'il n'y avait aucun souci si je démarrais sur l'ISO de Wily. J'ai fait un tas d'autres manips et il en ressort que le problème n'est pas là du tout : ce blocage à "Création du système de fichiers ext4" se produit lorsqu'il y a un chargeur d'amorçage de Grub installé dans le secteur de boot de la partition racine comme dans cet extrait du Boot-Info http://paste.ubuntu.com/12715862/ :

sda1: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  Grub2 (v1.99-2.00)
    Boot sector info:  Grub2 (v2.00) is installed in the boot sector of sda1 
                       and looks at sector 21839592 of the same hard drive 
                       for core.img. core.img is at this location and looks 
                       for (,msdos1)/boot/grub.
    Operating System:  Ubuntu Wily Werewolf (development branch) 
    Boot files:        /boot/grub/grub.cfg /etc/fstab 
                       /boot/grub/i386-pc/core.img

On comprend pourquoi ma solution du post #1 fonctionne : quand Gparted formate la partition, il efface ce chargeur d'amorçage du secteur de boot de la partition (extrait Boot-Info http://paste.ubuntu.com/12715963/ ) :

sda1: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

Après cela, l'installation ne bloque plus à "Création du système de fichiers ext4", même si on coche la case "formater la partition" (ce qui ne sert à rien puisque la partition est déjà formatée mais c'est pour dire).

Conclusion :
Pour moi, c'est bien un bug de Ubiquity (l’installateur de Ubuntu) mais je considère que la solution de contournement qui consiste à formater la partition racine avec Gparted avant l'installation est satisfaisante.
EDIT : j'ai oublié de préciser que lors de l'installation dans mon PC Acer et dans l'autre ordi dont j'ai parlé dans le post #1, j'avais bien le chargeur d'amorçage de Grub qui se trouvait dans le secteur de boot de la partition racine dans les deux cas. Cela confirme bien la chose.

Dernière modification par malbo (Le 09/10/2015, à 07:11)

Hors ligne

#3 Le 12/10/2015, à 15:09

malbo

Re : L'install de Wily bloque à "création du système de fichiers ext4..."

Investigations complémentaires à mon post #2 :

1) depuis une installation neuve de Ubuntu 15.10, j'enchaine dans les commandes ci-dessous les actions suivantes : état des lieux dans le premier secteur de la partition racine, installation de Grub dans le secteur de boot de la partition racine, nouvel état des lieux pour montrer que Grub apparaît dans le premier secteur de la partition racine :

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

malbo@malbo-virtual-machine:~$ sudo dd  if=/dev/sda skip=2048 count=1  |  hexdump  -C
Mot de passe [sudo] pour malbo : 
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
1+0 enregistrements lus
1+0 enregistrements écrits
512 octets (512 B) copiés, 0,000634536 s, 807 kB/s
00000200
malbo@malbo-virtual-machine:~$ sudo grub-install --force /dev/sda1
Installation pour la plate-forme i386-pc
grub-install : attention : Le système de fichiers « ext2 » ne prend pas en charge l'embarquage.
grub-install : attention : L'embarquage est impossible. GRUB ne peut être installé sur cette configuration qu'en utilisant les listes de blocs. Cependant, les listes de blocs ne sont PAS fiables et leur utilisation est déconseillée..
Installation terminée, sans erreur.
malbo@malbo-virtual-machine:~$ sudo dd  if=/dev/sda skip=2048 count=1  |  hexdump  -C
1+0 enregistrements lus
1+0 enregistrements écrits
512 octets (512 B) copiés, 0,000562158 s, 911 kB/s
00000000  eb 63 90 00 00 00 00 00  00 00 00 00 00 00 00 00  |.c..............|
00000010  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00000050  00 00 00 00 00 00 00 00  00 00 00 80 f8 5d c5 00  |.............]..|
00000060  00 00 00 00 ff fa 90 90  f6 c2 80 74 05 f6 c2 70  |...........t...p|
00000070  74 02 b2 80 ea 79 7c 00  00 31 c0 8e d8 8e d0 bc  |t....y|..1......|
00000080  00 20 fb a0 64 7c 3c ff  74 02 88 c2 52 bb 17 04  |. ..d|<.t...R...|
00000090  f6 07 03 74 06 be 88 7d  e8 17 01 be 05 7c b4 41  |...t...}.....|.A|
000000a0  bb aa 55 cd 13 5a 52 72  3d 81 fb 55 aa 75 37 83  |..U..ZRr=..U.u7.|
000000b0  e1 01 74 32 31 c0 89 44  04 40 88 44 ff 89 44 02  |..t21..D.@.D..D.|
000000c0  c7 04 10 00 66 8b 1e 5c  7c 66 89 5c 08 66 8b 1e  |....f..\|f.\.f..|
000000d0  60 7c 66 89 5c 0c c7 44  06 00 70 b4 42 cd 13 72  |`|f.\..D..p.B..r|
000000e0  05 bb 00 70 eb 76 b4 08  cd 13 73 0d 5a 84 d2 0f  |...p.v....s.Z...|
000000f0  83 d0 00 be 93 7d e9 82  00 66 0f b6 c6 88 64 ff  |.....}...f....d.|
00000100  40 66 89 44 04 0f b6 d1  c1 e2 02 88 e8 88 f4 40  |@f.D...........@|
00000110  89 44 08 0f b6 c2 c0 e8  02 66 89 04 66 a1 60 7c  |.D.......f..f.`||
00000120  66 09 c0 75 4e 66 a1 5c  7c 66 31 d2 66 f7 34 88  |f..uNf.\|f1.f.4.|
00000130  d1 31 d2 66 f7 74 04 3b  44 08 7d 37 fe c1 88 c5  |.1.f.t.;D.}7....|
00000140  30 c0 c1 e8 02 08 c1 88  d0 5a 88 c6 bb 00 70 8e  |0........Z....p.|
00000150  c3 31 db b8 01 02 cd 13  72 1e 8c c3 60 1e b9 00  |.1......r...`...|
00000160  01 8e db 31 f6 bf 00 80  8e c6 fc f3 a5 1f 61 ff  |...1..........a.|
00000170  26 5a 7c be 8e 7d eb 03  be 9d 7d e8 34 00 be a2  |&Z|..}....}.4...|
00000180  7d e8 2e 00 cd 18 eb fe  47 52 55 42 20 00 47 65  |}.......GRUB .Ge|
00000190  6f 6d 00 48 61 72 64 20  44 69 73 6b 00 52 65 61  |om.Hard Disk.Rea|
000001a0  64 00 20 45 72 72 6f 72  0d 0a 00 bb 01 00 b4 0e  |d. Error........|
000001b0  cd 10 ac 3c 00 75 f4 c3  00 00 00 00 00 00 00 00  |...<.u..........|
000001c0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|
00000200
malbo@malbo-virtual-machine:~$ 

2) démarrage d'une session live Ubuntu 15.10 et tentative d'installation avec formatage de la partition racine : ça bloque comme on peut s'y attendre à "création du système de fichiers ext4" :
1444655838.png
Je clique sur le bouton "Quitter" pour sortir de l'installation.

3) sans redémarrer (depuis la même session live), j’enchaîne les actions suivantes : état des lieux du secteur de boot de la partition racine (pour vérifier que ça n'a pas bougé), mise à zéro de tous les octets du premier secteur de la partition racine puis nouvel état des lieux pour vérifier que tout a bien été mis à zéro :

ubuntu@ubuntu:~$ sudo dd  if=/dev/sda skip=2048 count=1  |  hexdump  -C
1+0 records in
1+0 records out
512 bytes (512 B) copied, 0,000729647 s, 702 kB/s
00000000  eb 63 90 00 00 00 00 00  00 00 00 00 00 00 00 00  |.c..............|
00000010  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00000050  00 00 00 00 00 00 00 00  00 00 00 80 f8 5d c5 00  |.............]..|
00000060  00 00 00 00 ff fa 90 90  f6 c2 80 74 05 f6 c2 70  |...........t...p|
00000070  74 02 b2 80 ea 79 7c 00  00 31 c0 8e d8 8e d0 bc  |t....y|..1......|
00000080  00 20 fb a0 64 7c 3c ff  74 02 88 c2 52 bb 17 04  |. ..d|<.t...R...|
00000090  f6 07 03 74 06 be 88 7d  e8 17 01 be 05 7c b4 41  |...t...}.....|.A|
000000a0  bb aa 55 cd 13 5a 52 72  3d 81 fb 55 aa 75 37 83  |..U..ZRr=..U.u7.|
000000b0  e1 01 74 32 31 c0 89 44  04 40 88 44 ff 89 44 02  |..t21..D.@.D..D.|
000000c0  c7 04 10 00 66 8b 1e 5c  7c 66 89 5c 08 66 8b 1e  |....f..\|f.\.f..|
000000d0  60 7c 66 89 5c 0c c7 44  06 00 70 b4 42 cd 13 72  |`|f.\..D..p.B..r|
000000e0  05 bb 00 70 eb 76 b4 08  cd 13 73 0d 5a 84 d2 0f  |...p.v....s.Z...|
000000f0  83 d0 00 be 93 7d e9 82  00 66 0f b6 c6 88 64 ff  |.....}...f....d.|
00000100  40 66 89 44 04 0f b6 d1  c1 e2 02 88 e8 88 f4 40  |@f.D...........@|
00000110  89 44 08 0f b6 c2 c0 e8  02 66 89 04 66 a1 60 7c  |.D.......f..f.`||
00000120  66 09 c0 75 4e 66 a1 5c  7c 66 31 d2 66 f7 34 88  |f..uNf.\|f1.f.4.|
00000130  d1 31 d2 66 f7 74 04 3b  44 08 7d 37 fe c1 88 c5  |.1.f.t.;D.}7....|
00000140  30 c0 c1 e8 02 08 c1 88  d0 5a 88 c6 bb 00 70 8e  |0........Z....p.|
00000150  c3 31 db b8 01 02 cd 13  72 1e 8c c3 60 1e b9 00  |.1......r...`...|
00000160  01 8e db 31 f6 bf 00 80  8e c6 fc f3 a5 1f 61 ff  |...1..........a.|
00000170  26 5a 7c be 8e 7d eb 03  be 9d 7d e8 34 00 be a2  |&Z|..}....}.4...|
00000180  7d e8 2e 00 cd 18 eb fe  47 52 55 42 20 00 47 65  |}.......GRUB .Ge|
00000190  6f 6d 00 48 61 72 64 20  44 69 73 6b 00 52 65 61  |om.Hard Disk.Rea|
000001a0  64 00 20 45 72 72 6f 72  0d 0a 00 bb 01 00 b4 0e  |d. Error........|
000001b0  cd 10 ac 3c 00 75 f4 c3  00 00 00 00 00 00 00 00  |...<.u..........|
000001c0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|
00000200
ubuntu@ubuntu:~$ sudo dd if=/dev/zero of=/dev/sda seek=2048 count=1
1+0 records in
1+0 records out
512 bytes (512 B) copied, 0,156844 s, 3,3 kB/s
ubuntu@ubuntu:~$ sudo dd  if=/dev/sda skip=2048 count=1  |  hexdump  -C
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
1+0 records in
1+0 records out
512 bytes (512 B) copied, 0,00118458 s, 432 kB/s
00000200
ubuntu@ubuntu:~$ 

4) toujours sans redémarrer (depuis la même session live), je retente l'installation et cette fois-ci, ça passe :
1444656681.png

Pour être sûr qu'il n'y avait pas une blague un peu plus loin, j'ai poursuivi l'install (mot de passe, etc...) et j'ai laissé l'installation s'accomplir jusqu'au bout et tout s'est bien passé.

Conclusion partielle :
Il semblerait que ce soit le contenu du premier secteur de la partition racine qui peut causer le blocage à "création du système de fichiers ext4...". Dans ces derniers essais, il a suffi que je remette à zéro tous les octets du premier secteur de la partition racine pour supprimer le blocage.

EDIT_1 : encore plus simple. Avec ghex, je modifie seulement les deux derniers octets de la ligne 1F0 (55 aa) comme on peut voir là :

ubuntu@ubuntu:~$ sudo dd  if=/dev/sda skip=2048 count=1  |  hexdump  -C
1+0 records in
1+0 records out
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|
512 bytes (512 B) copied, 0,000780488 s, 656 kB/s
00000200

Et ça entraîne le blocage à "création du système de fichiers ext4...". On peut penser que l'installateur se contente de surveiller l'état de ces deux octets et s'il voit "55 aa" (*), il se bloque...
EDIT_2 : j'ai fait la contre-manip, c'est à dire que je suis parti d'une installation de Ubuntu avec Grub dans le secteur de boot de la partition racine, j'ai vérifié que ça bloquait l'installation à "création du système de fichiers ext4...", puis avec l'aide de ghex j'ai seulement modifié les deux octets en question pour qu'ils deviennent "00 00" au lieu de "55 aa". Après ça, j'ai pu faire l'installation sans qu'il y ait le blocage à "création du système de fichiers ext4..."

(*) j'ai vu dans ce doc, que c'est appelé "Boot record Signature AA55". Ailleurs, j'ai pu voir qu'on appelait ça aussi "Signature du secteur d'amorçage"

Dernière modification par malbo (Le 17/11/2015, à 18:37)

Hors ligne

#4 Le 17/10/2015, à 14:18

domi301

Re : L'install de Wily bloque à "création du système de fichiers ext4..."

merci malbo

tres utile ce compte rendu


Lubuntu / Xubuntu-Voyager ==> redonner vie à des machines abandonnées
en cas de besoin => http://forum.ubuntu-fr.org/viewtopic.php?id=1069631

Hors ligne