Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 23/11/2015, à 21:46

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

thecheshirecat a écrit :

C'est pas possible de désactiver le truc au démarrage et de le réactiver après ?

C'est ce que je me demande aussi, non pas par le bios, mais par un script qui se déclenche au login pour activer le réseau et un script qui se déclenche au logout pour désactiver l'interface réseau ?

J'ai fait un test, j'arrive à booter quand je désactive le réseau dans ubuntu au préalable.
Mais il "plante" après quelques secondes, par exemple quand je veux activer le wifi pour me connecter.

Cela n'a pas l'air très stable comme solution en tout cas ^^

Hors ligne

#27 Le 23/11/2015, à 22:00

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

thecheshirecat a écrit :

Dongle externe ?

Comme ça par exemple : http://www.amazon.fr/Asus-USB-N10-Adapt … B-N10+Nano

En désactivant l'interface réseau du bios cela passerait quand même par l'usb ?
^^

Hors ligne

#28 Le 23/11/2015, à 22:47

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Autre solution de contournement pour finir la soirée et qui a l'air fiable (marche sur le mien sans bug après quelques tests):
Passer par le bios avant de booter sur ubuntu.
Au démarrage, je bascule sur le bios et j'enregistre avant de quitter, ensuite, en bootant sur ubuntu, aucun problème même avec le wifi...

Hors ligne

#29 Le 24/11/2015, à 16:35

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Quelle manipulation fait tu exactement ? Ca ne semble pas fonctionner chez moi, le coup du BIOS...
Sinon, quelqu'un aurait une idée pour désactiver / réactiver la carte réseau ? Peut on modifier les vérifications faites par Linux au démarrage ?

Hors ligne

#30 Le 24/11/2015, à 20:20

inakoll

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

@maki78 @thecheshlrecat

Je compte également acheter cette petite merveille (Asus e202sa) et remplacer le HDD par un SSD comme a pu le faire maki78.
Je porte donc un intérêt particulier à cette discution. Merci de continuer à partager les résultats de vos essais :)

Si j'en crois cette discution, il s'agirait d'un problème lié à l'ACPI.
Cet article, explique ce qu'est l'ACPI et les problèmes associés et comment changer les paramètres ACPI dans Grub.

Puisque le problème semble être lié à l'ACPI (Advanced Configuration and Power Interface) et à l'alimentation/consomation d'énergie, je pense que si vous trouvez comment configurer l'ACPI de Grub vous devriez régler votre problème.
Ces paramètres d'ACPI semblent être intiment liés au couple versions de BIOS/kernel donc il n'y a pas de solution universelle suivant le BIOS...

Paramètre à tester dans /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

si non concluant :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

Après avoir changé les paramètres de grub, exécuter la commande suivante puis redémarrer:

update-grub2

Avec "acpi=off", vous devriez perdre l'utilisation des touches spéciales (Fn, luminosité de l'écran, controle du volume, etc...) mais avec un peu de chance le reste devrait fonctionner :D

Hors ligne

#31 Le 24/11/2015, à 23:29

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Chez moi aucune de ces deux options ne fonctionnent (par contre pas de soucis, ca me nique bien les touches Fn !)
Qu'en est il pour toi maki ?

Hors ligne

#32 Le 25/11/2015, à 00:05

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

De mon côté ça ne fonctionne pas, en tout cas la 1ère option.
Pour la 2ème option, ça boot bien mais je n'ai ni souris ni wifi.

Hors ligne

#33 Le 25/11/2015, à 00:07

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

thecheshirecat a écrit :

Quelle manipulation fait tu exactement ? Ca ne semble pas fonctionner chez moi, le coup du BIOS...
Sinon, quelqu'un aurait une idée pour désactiver / réactiver la carte réseau ? Peut on modifier les vérifications faites par Linux au démarrage ?

Quand tu allumes le pc, tu presses echap pour entrer dans le BIOS.
Ensuite, sans rien modifier, tu va dans la dernière partie "Save & EXIT" et tu valides sur "Save changes and Exit" (confirmer ensuite par Yes").
Et là ça marche sans problème, allez savoir pourquoi lol

Dernière modification par maki78 (Le 25/11/2015, à 00:08)

Hors ligne

#34 Le 25/11/2015, à 15:00

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Bon, bah ça ne fonctionne pas pour moi.
Je viens de m'apercevoir, par contre, que le changement d'état de la batterie n'est pas détecté :
> Si j'ai démarré sur le secteur et que je débranche, il me dit toujours "En charge"
> Si j'ai réussi à démarrer sur batterie et que je branche, il me dit toujours "Truc:Truc restant"

Peut être une piste ???

Hors ligne

#35 Le 25/11/2015, à 16:17

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

(Au fait, le problème est similaire sur Fedora)

Hors ligne

#36 Le 25/11/2015, à 17:23

inakoll

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Quelques autres pistes à explorer :
1) Dans le BIOS désactiver l'option "Secure Boot Control" (onglet "Security")
2) Dans le BIOS désactiver l'option "Fast Boot" (onglet "Boot")
3) Rebooter, Réinstaller Ubuntu

Sinon, du côté des paramètres de boot (dans grub) qui pourraient jouer sur la consommation d'énergie, les 3 paramètres suivants lorsque positionné à 1 sont censés diminuer la consommation d'énergie :
i915.i915_enable_rc6=1  # Ce paramètre devrait déjà être à 1 par défaut sur les versions récentes d'Ubuntu ==> Il faudrait essayer de le passer à 0 malgré tout pour voir big_smile
i915.i915_enable_fbc=1  # Paramètre à 0 par défaut ==> Il faudrait essayer en le passant à 1
i915.lvds_downclock=1  # Paramètre à 0 par défaut ==> Il faudrait essayer en le passant à 1

Hors ligne

#37 Le 25/11/2015, à 21:29

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

@inakoll
Dans quel fichier on peut modifier ces paramètres ?
Je ne les ai pas dans mon fichier /etc/default/grub

Hors ligne

#38 Le 25/11/2015, à 22:06

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Ayant installé un ssd, j'ai mis en place ceci :

Changez dynamiquement le programmateur 'I/O disks'

The default I/O scheduler is CFQ .
Le programmateur d'entrée-sortie par défaut est CFQ.
De meilleures performances de lecture/écriture pour les disques SSD ont planificateur noop.
Vous pouvez automatiser le processus de programmation d'entrée-sortie de disque, selon que le disque tourne (HDD) ou pas (SSD).
Créez un nouveau dossier:

sudo gedit /etc/udev/rules.d/60-schedulers.rules

Collez-lui ce code:

# set deadline scheduler for non-rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="noop"
# set cfq scheduler for rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="1", ATTR{queue/scheduler}="cfq"
Enregistrez les modifications. Redémarrez l'ordinateur.

Source : Lien

Et au redémarrage ça a sacrément accélérer le boot de Ubuntu. Il reste à peine une seconde sur l'écran graphique de boot.
Sur la batterie, je vais plus loin grâce à ce paramétrage : au boot, j'arrive jusqu'à l'écran de login mais ça se fige quand je veux faire une action.
En enlevant "quiet et splash" ça me permet d'utiliser quelque fois la souris mais l'écran se fige...

Hors ligne

#39 Le 25/11/2015, à 22:34

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Aucune chance que ca marche avec le disque par défaut ?

Hors ligne

#40 Le 25/11/2015, à 22:40

maki78

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

thecheshirecat a écrit :

Aucune chance que ca marche avec le disque par défaut ?

Aucune, car c'est une optimisation pour disque ssd.

Hors ligne

#41 Le 27/11/2015, à 14:06

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Je me permet un petit up sur cette discussion, ça serait super cool de trouver une solution parce que c'est quand même handicapant.
Je dirais qu'il faut creuser du côté de l'ACPI ...

Hors ligne

#42 Le 27/11/2015, à 20:48

inakoll

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Bonsoir,

@thecheshirecat, en ce qui concerne les paramètres de boot proposés dans mon message #36, il s'agit des paramètres de ligne de commande du noyau à placer dans la variable GRUB_CMDLINE_LINUX_DEFAULT dans le fichier  /etc/default/grub ou a éditer dans le menu de boot de GRUB en appuyant sur "e" et en les ajoutant à la ligne fin de la ligne "linux...".

Pour en revenir à la description de vos problèmes je trouve étrange que thecheshirecat ait ce problème même sans avoir changé de disque.

@thecheshirecat, si tu ne reproduis pas exactement le même problème avec/sans le cordon d'alimentation ? Ton PC boot correctement avec le cordon branché ?
Sinon,le problème de l'indicateur de batterie ne me semble pas être nécessairement lié. Je pense qu'il s'agit d'autre chose. @maki, as tu le même soucis concernant l'indicateur de charge ?
Dans tous les cas ce ci problème serait plutôt lié à l'ACPI.

Pour essayer de faire avancer les choses @thecheshirecat, pourrais tu reproduire le soft lock up au démarrage et poster une capture d'écran  complète du message d'erreur (avec la stack) comme l'a fait maki en #9 ?

Sinon, j'ai peut être une autre piste, que retourne la commande suivante chez vous ?

lspci | grep -i wireless

Si votre carte wifi utilise un chipset realteck 8821AE il se peut que vous rencontriez un problème décrit ici et .
Le problème est assez récent et je ne crois pas que le correctif soit déjà remonté dans le kernel 4.4-rc2 (sorti 22 Nov 2015...), dans tous les cas mettre à jour en 4.4-rc2 ne me parraitrait pas être une si mauvaise idée.
Avant ça essayez de reproduire le problème avec le paramètre "pci=nomsi" dans la ligne de commande de lancement du noyau linux. D'après ce que j'ai compris c'est censé contourner le problème.

Sinon, je suis un peu à court d'idée. S'il ne s'agit pas d'un bug mais d'un problème d'alimentation, il faudrait continuer d'essayer de réduire la consomation d'énergie au maximum : installation de l'outil "tlp", optimisation des paramètres du noyaux pour diminuer la consomation, downclocker le CPU (limiter la fréquence maximale possible quand la batterie est utilisée)...

Dernière modification par inakoll (Le 27/11/2015, à 20:51)

Hors ligne

#43 Le 27/11/2015, à 21:59

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

YOUPI ! Alors inakoll, je te dois une fière chandelle, parce que l'astuce du pci=nomsi FONCTIONNE big_smile
Je suis effectivement l'heureux détenteur d'un chipset realteck 8821AE !
C'est fantastique, je commençais à désespérer ! après 5 boots en batterie, il semblerait bien que ce fix me convienne !
A voir si cela fonctionne du côté de maki aussi !
Est ce nécessaire que je poste les lignes CPU etc du coup ? On devrait peut être rajouter ce détail dans le wiki des ordis Asus, non ?

ENCORE MERCI !!!!

Hors ligne

#44 Le 27/11/2015, à 23:16

inakoll

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

C'était facile! ;)
Par contre, c'est Google qui a trouvé la solution.
Tout ce que j'ai fait c'est étudier une bonne dizaine de rapports de bug plus ou moins récents.

Ce bug avec le pilote de la puce Realteck 8821AE semblait bien correspondre avec le fait que lorsque vous désactiviez la carte wifi dans le BIOS le boot se déroulait normalement.
Je savais que le ASUS e202sa avait du 802.11ac (la norme la plus récente de wifi) et quand j'ai compris que le 8821AE était un controleur 802.11ac je me suis dit que ca collait plutôt bien.

Cependant, je n'explique toujours pas pourquoi le bug survient uniquement sur batterie chez maki.
En attendant la correction dans une prochaine version du noyau, j'espère que ca réglera également ce problème pour maki78!

Hors ligne

#45 Le 28/11/2015, à 00:47

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Note : on attend également la nouvelle version des noyaux pour avoir un touchpad qui supporte le multitouche.

Hors ligne

#46 Le 28/11/2015, à 09:22

manuelv

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Salut,

même machine que maki (asus E202SA, mais d'origine, sans SSD) et mêmes problèmes: boot sur batterie impossible (nmi watchdog : BUG: soft lockup...).

L'ajout de pci=nomsi a aussi fonctionné chez moi, merci inakoll!

Hors ligne

#47 Le 28/11/2015, à 12:23

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Wiki modifié, je ne sais pas si j'ai fait ca bien par contre tongue allez modifier si ca vous semble douteux

Hors ligne

#48 Le 29/11/2015, à 17:31

Toineuh

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Bonjour,
J'ai exactement le même souci. Pour ma part, je n'ai pas touché à la configuration d'origine du E202SA, j'ai juste immédiatement installé ubuntu à la place de windows.
Je viens demander plus de détail pour résoudre le problème.

inakoll a écrit :

Avant ça essayez de reproduire le problème avec le paramètre "pci=nomsi" dans la ligne de commande de lancement du noyau linux. D'après ce que j'ai compris c'est censé contourner le problème.

Quel est la ligne de commande de lancement du noyau et comment vais-je la modifier ?
Merci beaucoup !

Hors ligne

#49 Le 29/11/2015, à 18:20

Toineuh

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

J'ai fais quelques recherches et pour résumer :

sudo cp /etc/default/grub /etc/default/grub.bak
sudo gedit /etc/default/grub

et ensuite remplez :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
par :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"
sauvegardez puis faites :

sudo update-grub
sudo reboot

ça marche très bien maintenant, merci beaucoup !

Il ne reste plus qu'à trouver comment faire marcher le pavé tactile correctement sur mon E202SA hmm

Hors ligne

#50 Le 29/11/2015, à 18:20

thecheshirecat

Re : [Résolu] Asus e202sa démarrage sur batterie qui bloque

Alors, méthodologie :
-> Ouvres un terminal : [Ctrl] + [Alt] + [ T ]
-> Tapes la ligne de commande suivante :

sudo gedit /etc/default/grub

-> On va te demander ton mot de passe : tu le tapes et tu valides par Entrée (aucun caractère ne s'affiche, c'est normal)
-> Ca va t'ouvrir un fichier dans un éditeur de texte : ici, tu vas voir une ligne : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
-> Il faut que tu remplaces "quiet splash" par "quiet splash pci=nomsi"
-> Sauvegardes le fichier ([Ctrl] + [ S ]) puis ferme le logiciel
-> Dans le terminal, tapes la ligne suivante :

sudo update-grub2

-> Si besoin, retapes le mot de passe : laisses le tourner jusqu'à ce qu'il s'arrête de lui même.

En théorie, ca devrait résoudre le problême. Si besoin, reviens ici pour qu'on t'aide !
Edit : ah grillé tongue pas bête de faire une sauvegarde du fichier grub avant

Dernière modification par thecheshirecat (Le 29/11/2015, à 18:23)

Hors ligne