Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#126 Le 24/10/2016, à 11:27

Titee52

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour,

J'ai essayé d'installer Linux sur un asus T100TAF qui n'est pas à moi, en suivant les indications fournies dans le message de "brainWreck" du groupe google dédié au sujet.
Le T100TAF concerné est un achat récent affligé d'un Windows 10 (tm) surement très récent aussi.
L'amorçage et le fonctionnement à partir de la clé USB fabriquée avec "la dernière ISO" (noyau 4.7.1 etc.) fournie sur le groupe google semble fonctionner.

Malheureusement, une fois l'installation terminée, le redémarrage n'aboutit pas.
La partition 'SYSTEM' de Windaube10 a bien été préservée lors de l'installation comme cela est recommandé dans le tuto .pdf fourni sur le groupe google par "BrainWreck" et je n'ai pas vu de message d'erreur lorsque l'installateur met en place Grub (efi32).

Au redémarrage du T100TAF après l'installation de ubuntu 16.04, j'obtiens le message suivant :

WINDOWS BOOT MANAGER
(blablablabla ...) 
[...]
File \EFI\Microsoft\Boot\BCD
Status 0xc0000225
The Boot Configuration Data for your PC is missing or contains errors.

WINDOWS_KEY=UEFI  Firmware Settings

Note : le lien pour récupérer le "MagicStick" du forum "xda..." est mort et je n'ai pas vu de lien alternatif pour récupérer ce "MagicStick".

Merci pour votre aide.

Dernière modification par Titee52 (Le 24/10/2016, à 11:32)

Hors ligne

#127 Le 16/11/2016, à 21:03

joh07

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour,
Je suis nouveau sur le forum donc je fais vite fais une présentation: J'ai trois PC, un sous Lubuntu en lecteur Hifi: au top ! Un sous Win10 qui sert pour le boulot et qui va passer sous Ubuntu (test au live CD OK) et cette saleté de T100 qui ne fait rien comme je veux.
Je ne suis pas calé en info, je n'y connais rien en code mais je comprend les principes de base et de fonctionnement en général.

Je voulais passer le T100 sous Ubuntu car je n'ai pas confiance en Win10 et il "brille" trop à mon gout. Malheureusement, ça m'a l'air bien complexe maintenant que le lien magic stick est mort. (Dans l'idéal j'aurai bien mis Qubes mais je ne maitrise pas assez le sujet...)

J'ai eu une idée et j'aimerai savoir si cela est réalisable.
Le T100 boote en live sur une clé USB Ubuntu sans pb (faite avec Rufus). Le port USB sur lequel le boot se fait est celui du clavier, pas le mini usb de la tablette.

Du coup je me demande si je ne pourrai pas:
Mettre le DD de 500 Go qui est dans le clavier dans un boitier externe, créer une partition en FAT32 de qq giga, la rendre bootable avec un logiciel type Rufus puis replacer le disque dans le PC l’utiliser tel quel ? (Je ne l'utilise jamais en tablette seule)

Ce qui m'amène à une seconde question: Est-ce que cette utilisation "live" permanente me laisserai la possibilité de rajouter les drivers de la carte Wifi (qui ne fonctionne pas de base).

Merci.


Asus R752L - i7-5500u - 2.40 GHz - Ram: 4Go -SSD Kingston 120 Go - Ubuntu 16.04.1 LTS
Asus eeepc 1215B - AMD E-450 APU 1.6 GHz Radeon HD graphic - Ram: 2Go - Ata Ghost SSD 120 - Lubuntu 16.04.1 LTS
Asus T100TAM -   Bay Trail-T Quad Core Z3775 1.46 GHz - Ram: 4 Go - 64 Go Avec 500 Go HDD  - Ubuntu 16.04.1 LTS

Hors ligne

#128 Le 17/11/2016, à 09:16

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Titee52 a écrit :

Au redémarrage du T100TAF après l'installation de ubuntu 16.04, j'obtiens le message suivant :

WINDOWS BOOT MANAGER
(blablablabla ...) 
[...]
File \EFI\Microsoft\Boot\BCD
Status 0xc0000225
The Boot Configuration Data for your PC is missing or contains errors.

WINDOWS_KEY=UEFI  Firmware Settings

Salut,

Apparemment, il semble que tu n'ailles eu aucun problème lors de l'installation d'Ubuntu 16.04 sur ta machine, ainsi que le GRUB.
Est-ce que l'entrée "grub" apparaît dans le menu du BOOT au démarrage de ta machine dans l'UEFI  ? A côté de "Windows Boot Manager"
Si c'est le cas, il te suffira de booter dessus et de vérifier si tout fonctionne, et ensuite de définir cette entrée comme la principale de manière automatique.
Si elle n’apparaît pas, tu peux toujours essayer de formater toutes les partitions de ta T100, d'installer Ubuntu 15.04 MagicStick depuis ce lien, et ensuite recommencer la manipulation avec la 16.04.

P.S : je viens de me rendre compte que je ne possédais pas de copie du ZIP de la MagicStick sur le LaunchPad, je suis entrain de recréer une archive avec les fichiers de la MagicStick présent sur ma clé USB de secours pour ma T100, j'espère que ça marchera sur vos machines ! wink

Dernière modification par Li@nel (Le 17/11/2016, à 11:32)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#129 Le 17/11/2016, à 09:26

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

joh07 a écrit :

Du coup je me demande si je ne pourrai pas:
Mettre le DD de 500 Go qui est dans le clavier dans un boitier externe, créer une partition en FAT32 de qq giga, la rendre bootable avec un logiciel type Rufus puis replacer le disque dans le PC l’utiliser tel quel ? (Je ne l'utilise jamais en tablette seule)

Ce qui m'amène à une seconde question: Est-ce que cette utilisation "live" permanente me laisserai la possibilité de rajouter les drivers de la carte Wifi (qui ne fonctionne pas de base)..

Salut,

Tout d'abord, bienvenue à toi ici alors ! wink
Je te conseille de renseigner la config de tes trois machines dans ta signature, cela nous permettra de garder toujours un œil sur ça.

Je pense qu'il serait tout à fait possible de graver l'image ISO de la communauté sur ton disque dur et d'ensuite booter dessus, si le BIOS nous le permet car s'il permet de booter avec une clé USB sur un port USB 3.0, je ne sais pas si c'est possible avec le port du dock clavier pour accéder au disque dur inclus dedans.
Je sais d'ors et déjà que booter sur une carte microSD est impossible.
Il est possible d'utiliser une session live d'Ubuntu pour travailler dessus, mais je ne vois pas trop l'intérêt si tu peux l'installer sur ton disque dur ou sur le SSD de la T100 et mettre la partition /home sur le disque dur par exemple pour une question de place.
Tout dépend si tu comptes beaucoup encore utiliser le W10 présent dessus.
Je ne te conseille pas de toucher aux drivers wifi, ceux présent sur l'image ISO 64 bits de la communauté fonctionnement plus ou moins correctement.
Personnellement, j'utilise un dock USB/Wifi pour palier ce problème le temps que l'équipe de développeur trouve les bons drivers.

Si tu as d'autres questions à ce sujet, hésite surtout pas.
Le lien du MagicStick depuis le LaunchPad est ici

Dernière modification par Li@nel (Le 17/11/2016, à 11:33)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#130 Le 17/11/2016, à 21:26

joh07

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour,

Li@nel a écrit :

Il est possible d'utiliser une session live d'Ubuntu pour travailler dessus, mais je ne vois pas trop l'intérêt si tu peux l'installer sur ton disque dur ou sur le SSD de la T100 et mettre la partition /home sur le disque dur par exemple pour une question de place.
Tout dépend si tu comptes beaucoup encore utiliser le W10 présent dessus.

Non je ne compte plus utiliser windows. De toute façon il a crashé, il ne boote même plus et la réinstallation ou réparation avec un CD de Windows plante elle aussi. C'est réglé.
En fait je cherchais une "magouille" à faire car sans lien vers la magic stick je ne voyais pas comment réaliser l'installation complète. Je te remercie pour ton lien et je vais me pencher dessus.

Li@nel a écrit :

Je ne te conseille pas de toucher aux drivers wifi, ceux présent sur l'image ISO 64 bits de la communauté fonctionnement plus ou moins correctement.
Personnellement, j'utilise un dock USB/Wifi pour palier ce problème le temps que l'équipe de développeur trouve les bons drivers.

En fait je parle des drivers car quand j'utilise la live USB d'Ubuntu tout semble fonctionner sauf le wifi... Mais bon, chaque problème en son temps. Pour l'instant je doit réussir l’installation.

Sinon j'ai bien une autre question. J'ai lu les pages précédentes, et très honnêtement je suis largué  en ce qui concerne les histoires de Kernel et Kernel patché. J'ai une vague idée de ce qu'est un Kernel (une sorte de programme "chef d'orchestre" qui s’intercale entre le bios et l'OS !? ).
Ai-je quelque chose à faire à ce sujet avant de lancer l'installation avec la Magic Stick ou est-ce que cela se fait automatiquement comme n’importe quelle installation ?

Merci.


Asus R752L - i7-5500u - 2.40 GHz - Ram: 4Go -SSD Kingston 120 Go - Ubuntu 16.04.1 LTS
Asus eeepc 1215B - AMD E-450 APU 1.6 GHz Radeon HD graphic - Ram: 2Go - Ata Ghost SSD 120 - Lubuntu 16.04.1 LTS
Asus T100TAM -   Bay Trail-T Quad Core Z3775 1.46 GHz - Ram: 4 Go - 64 Go Avec 500 Go HDD  - Ubuntu 16.04.1 LTS

Hors ligne

#131 Le 19/11/2016, à 19:00

joh07

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bon après avoir un peu galéré, j'ai finalement réussi mon installation:

Au début je l'ai faite avec la magic stick, grub ne s'installe pas, j'ai essayé plein de choses mais rien à faire (j'ai supprimé de longs messages détaillés que j'avais posté et qui sont bien inutiles au final).

En définitive, il faut juste faire une live USB de la dernière version en date (16.04 pour moi), rajouter le fichier bootia32 (disponible dans le lien magic stick fourni plus haut: merci !) dans le dossier EFI/BOOT/ de la clé et faire l'installation. Tout se passe bien, le PC boote sur Ubuntu sans problème.

Par contre je n'ai pas de wifi... a voir.


Asus R752L - i7-5500u - 2.40 GHz - Ram: 4Go -SSD Kingston 120 Go - Ubuntu 16.04.1 LTS
Asus eeepc 1215B - AMD E-450 APU 1.6 GHz Radeon HD graphic - Ram: 2Go - Ata Ghost SSD 120 - Lubuntu 16.04.1 LTS
Asus T100TAM -   Bay Trail-T Quad Core Z3775 1.46 GHz - Ram: 4 Go - 64 Go Avec 500 Go HDD  - Ubuntu 16.04.1 LTS

Hors ligne

#132 Le 19/11/2016, à 19:37

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

joh07 a écrit :

]Sinon j'ai bien une autre question. J'ai lu les pages précédentes, et très honnêtement je suis largué  en ce qui concerne les histoires de Kernel et Kernel patché. J'ai une vague idée de ce qu'est un Kernel (une sorte de programme "chef d'orchestre" qui s’intercale entre le bios et l'OS !? ).
Ai-je quelque chose à faire à ce sujet avant de lancer l'installation avec la Magic Stick ou est-ce que cela se fait automatiquement comme n’importe quelle installation ?.

Alors pour répondre à tes questions, le kernel ou noyau sous Linux c'est le cerveau de ton ordinateur
C'est le système qui permet de lier l'hardware avec le software, je m'explique, celui qui va recevoir toutes les informations des composants physiques (clavier, souris/TouchPad, écran tactile) et les intégrer avec ton système d'exploitation
Ça fonctionne aussi dans l'autre sens (pour écouter du son par exemple)
C'est une particularité des systèmes UNIX comme Linux ou macOS, tu ne trouveras pas ça sous l'environnement Windows qui fonctionne en librairies.
Le kernel ne s'intercale pas entre le BIOS et l'OS, pas du tout.
Le BIOS ou UEFI est le chargeur d'amorcage, c'est un micrologiciel implanté dans ta carte mère qui te permet de dire quel périphérique va se lancer au démarrage (disque dur ou clé USB), il gère aussi quelques fonctions de base mais c'est tout
Le kernel est lancé au démarrage de Linux par contre, au moment du GRUB qui est le chargeur d'amorcage, c'est lui qui te permet de choisir sur quel kernel démarré.
Un kernel patché, c'est un kernel qui a été patché, c'est à dire qu'on y a intégré des fichiers systèmes spécifiques propre à une machine afin de pouvoir utiliser des drivers ou certains bouton du clavier ou de la machine (touche du volume par exemple)
J'espère avoir été assez clair^^

Par contre je n'ai pas de wifi... a voir.

Je viens de me renseigner, et il me semble que la version TAM de ta machine n'est peut-être pas compatible avec le wifi hmm (question posée ici)
Néanmoins je te conseille d'installer un kernel patché de la communauté afin de tester la compatibilité de ton matériel
Voici une liste de kernels, il faut choisir celui en fonction de ton architecture, 64 ou 32 bits
Le 4.7.5.13 et 4.8.8.8.4 fonctionnent assez bien et ne bug quasi pas, à condition d'avoir rentré les bons arguments dans le GRUB (tu l'as déjà fais ? )

Dernière modification par Li@nel (Le 19/11/2016, à 19:50)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#133 Le 19/11/2016, à 20:23

joh07

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Merci pour tes réponses

Li@nel a écrit :

Je viens de me renseigner, et il me semble que la version TAM de ta machine n'est peut-être pas compatible avec le wifi hmm (question posée ici)

Pour ce qui est du wifi, c'est bon mon problème est résolu (le lien que j'ai fourni plus haut explique ça en anglais). Au cas ou un autre dans le même cas passe dans le coin il faut, une fois l'installation faite, taper dans un terminal:

sudo cp /sys/firmware/efi/efivars/nvram-XXXXXX /lib/firmware/brcm/brcmfmac43241b4-sdio.txt 

sudo modprobe -r brcmfmac

sudo modprobe brcmfma

A la place de nvram-XXXXXX, il faut mettre le bon nom de fichier, pour cela, on va voir dans le disque ou est fait l'installation, puis dans sys/firmware/efi/efivar. On relève le nom du fichier "nvram-etc..." et on le met dans la commande. Ensuite c'est tout bon.

Le 4.7.5.13 et 4.8.8.8.4 fonctionnent assez bien et ne bug quasi pas, à condition d'avoir rentré les bons arguments dans le GRUB (tu l'as déjà fais ? )

Je n'ai rentré aucun arguments dans le GRUB... j'ai juste copié sur une clé tous les fichiers du CD Ubuntu que j'ai gravé dans le but de l'installer sur mon Asus R752L (une version 64 bits), j'ai rajouté "bootia32" dans le dossier EFI/BOOT/ puis j'ai fais l'installation comme si de rien n’était.
Je n'y croyais pas trop mais ça a fonctionné... big_smile

Dernière modification par joh07 (Le 19/11/2016, à 20:26)


Asus R752L - i7-5500u - 2.40 GHz - Ram: 4Go -SSD Kingston 120 Go - Ubuntu 16.04.1 LTS
Asus eeepc 1215B - AMD E-450 APU 1.6 GHz Radeon HD graphic - Ram: 2Go - Ata Ghost SSD 120 - Lubuntu 16.04.1 LTS
Asus T100TAM -   Bay Trail-T Quad Core Z3775 1.46 GHz - Ram: 4 Go - 64 Go Avec 500 Go HDD  - Ubuntu 16.04.1 LTS

Hors ligne

#134 Le 15/12/2016, à 09:53

set

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

bonjour a tous,

je me suis lancé a mon tour dans la migration totale de ma petite machine t100. je rencontre des soucis tel que la non reconnaissance du disque dur dans la liste de demarrage du bios.
Une cle boot repair pourrait etre utilisée pour tenter de réparer mon probleme ?
merci d'avance.


ubuntustudio 16.04LTS (xubuntu 4.12-)
ASUS P5Q pro // core 2 duo E75004//4g mem DDR2 // RADEON HD4670//M-Audio delta 44

Asus T100 TAF32gb (Ubuntu 16-4 /64bit sans son)

Hors ligne

#135 Le 15/12/2016, à 10:02

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

set a écrit :

je me suis lancé a mon tour dans la migration totale de ma petite machine t100. je rencontre des soucis tel que la non reconnaissance du disque dur dans la liste de demarrage du bios.
Une cle boot repair pourrait etre utilisée pour tenter de réparer mon probleme ?

Salut,

Je pense que ton problème de non reconnaissance du disque dur comme tu dis est plutôt une non reconnaissance du GRUB dans le BIOS, ou tout simplement la mauvaise installation du GRUB sur ta machine, ce qui t'empêche de démarrer ton Ubuntu.
La réparation avec BootRepair ne t'aidera pas ici, comment as-tu installé Ubuntu sur ta machine ?

Si tu as procédé à un reformatage complet avec le dernier ISO, je te conseille de repasser avec l'ISO du MagicStick pour réinstaller proprement le GRUB, et ensuite installer la 16.04.1 avec le dernier ISO wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#136 Le 15/12/2016, à 10:57

set

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Li@nel a écrit :

je te conseille de repasser avec l'ISO du MagicStick pour réinstaller proprement le GRUB, et ensuite installer la 16.04.1 avec le dernier ISO ;)

J'ai simplement tenté une réinstallation mais tjr avec le même resultat : mon disque dur n'apparait pas dans la liste d'option de boot du bios. Je n'avais pas bien compris me faut il faire l'install en deux temps soit reinstaller le grub et seulement ensuite installer ubuntu ..??

J'ai tenté une 2nde install avec la derniere image iso + ajout dans le dossier efi. => j'ai eu le message suivant lors du processus d'installation  :
le paquet grub-efi-ia32 n'a pas pu etre installé dans /target/ ....le systeme installé ne pourra pas démarrer

autre tentative avec magic stick... en cours mais galère. Mon principal souci pour l'heure est de creer une cle bootable avec les fichiers recuperés via le lien de la magic stick. Je copie colle les elements du dossier sur une cle usb formaté en fat32.... rien. Un passage par ISOmaster pour reconditionner les paquets et le rendre utilisable avec unetbootin. Et enfin grub fait son job. :)
Mais voila bloqué face a une ubuntu 15.04 sans wifi. Je n'ai pas reussi a reinstaller la 16.04.01 sans endommager le grub et donc retour a chaque fois a la reinstallation de la 15.04 magicstick.

Vous serait il possible de me re aiguiller vers les etapes suivantes ? Aurai je "zappé" une procedure ?commande ?

Merci d'avance.

Dernière modification par set (Le 17/12/2016, à 00:32)


ubuntustudio 16.04LTS (xubuntu 4.12-)
ASUS P5Q pro // core 2 duo E75004//4g mem DDR2 // RADEON HD4670//M-Audio delta 44

Asus T100 TAF32gb (Ubuntu 16-4 /64bit sans son)

Hors ligne

#137 Le 20/12/2016, à 20:57

set

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

bon... mon T100 fonctionne sous ubuntu 16-4 mais je dois passer par deux grub et il demarre une fois sur Trois. Et je ne sais meme pas pourquoi.


ubuntustudio 16.04LTS (xubuntu 4.12-)
ASUS P5Q pro // core 2 duo E75004//4g mem DDR2 // RADEON HD4670//M-Audio delta 44

Asus T100 TAF32gb (Ubuntu 16-4 /64bit sans son)

Hors ligne

#138 Le 23/12/2016, à 13:19

remio7

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour à tous!
Une amie m'a laissé son Asus T100H pour que je lui réinstalle correctement ubuntu. Il y a déjà une version installé dessus mais pas de son, wifi, il ne sort pas de veille, etc. . J'ai fait une clé bootable avec mkusb (cela ne marchait pas au démarrage avec Multisystem) mais elle n'est pas reconnue par le pc. J'ai utilisé l'iso du Drive (de 1.8Go), il n'est pas reconnu par le créateur de disque de de démarrage...
Je n'arrive pas à tout comprendre pour une réinstall correct, je précise que je n'ai pas windose pour faire un clé avec Rufus.
Merci pour votre aide possible...
Rémi

Hors ligne

#139 Le 24/12/2016, à 10:44

stefberni

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Au cas ou un autre dans le même cas passe dans le coin il faut, une fois l'installation faite, taper dans un terminal:

sudo cp /sys/firmware/efi/efivars/nvram-XXXXXX /lib/firmware/brcm/brcmfmac43241b4-sdio.txt 

sudo modprobe -r brcmfmac

sudo modprobe brcmfma

A la place de nvram-XXXXXX, il faut mettre le bon nom de fichier, pour cela, on va voir dans le disque ou est fait l'installation, puis dans sys/firmware/efi/efivar. On relève le nom du fichier "nvram-etc..." et on le met dans la commande. Ensuite c'est tout bon.


Bonjour,
J'ai réalisé l'installation en dual boot d'Ubuntu avec plusieurs essais infructueux. C'est une vidéo tutoriel qui m'a aidé à finaliser l'installation.. Merci ubuntuto.

Toutefois j'ai maintenant le problème de wifi.
J'ai essayé de rentrer dans le terminal la ligne de commande citée plus haut, et lorsque je fais entrée, on me demande mon mot de passe... Sauf que je n'arrive pas à écrire quoi que ce soit dans la fenêtre du terminal..
Quelqu'un peut il m'aider s'il vous plaît?

Hors ligne

#140 Le 06/01/2017, à 15:40

fakbill

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour,
J'ai une T100 avec un windows10 dans un état lamentable (impossible de le mettre à jour...).
Bref, je voudrais mettre une 16.10 dessus.
Je vois qu'il y a beaucoup de doc disponible mais aussi pas mal de doc qui date (de 2013 par exemple).
Bref, que faut il commencer parlire pour installer un ubuntu qui boote correctement sur une T100? Je ne veux pas de dualboot.
Je connais bien linux donc aucun problème s'il y a des choses à faire en ligne de commande pour faire marcher tel ou tel périphérique.
L'essentiel est d'avoir une distrib qui boot...

Hors ligne

#141 Le 08/01/2017, à 13:35

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

set a écrit :

J'ai simplement tenté une réinstallation mais tjr avec le même resultat : mon disque dur n'apparait pas dans la liste d'option de boot du bios. Je n'avais pas bien compris me faut il faire l'install en deux temps soit reinstaller le grub et seulement ensuite installer ubuntu ..??

Tu as quoi comme modèle de T100 ? Tu as un disque dur dans le dock clavier ?
Non non, le GRUB s'installe en même temps qu'Ubuntu, ne t'inquiète pas pour ça.
Après, si tu as formé ton disque dur et que tu es pas arrivé à installé un OS dessus, normal qu'il n' "apparaît" pas dans le BIOS, car le BIOS te liste les partitions pouvant être bootée, c'est à dire ayant un OS capable de démarrer.
J'espère que je suis pas trop confus^^

set a écrit :

J'ai tenté une 2nde install avec la derniere image iso + ajout dans le dossier efi. => j'ai eu le message suivant lors du processus d'installation  :
le paquet grub-efi-ia32 n'a pas pu etre installé dans /target/ ....le systeme installé ne pourra pas démarrer

Tu parles de la dernière ISO d'Ubunut ou celle de la communauté ?
Si tu as tout formaté, le plus simple je pense est de repasser par une installation complète avec la version du MagicStick, puis avec l'ISO 16.04.1 de la communauté sans toucher à la partition EFI alors !

set a écrit :

Vous serait il possible de me re aiguiller vers les etapes suivantes ? Aurai je "zappé" une procedure ?commande ?

Retélécharge la dernière version du MagicStick ici .
T'inquiète pas, c'est une version dite beta, mais c'est parce qu'ils ont modifié la version d'Android je pense, pour Ubuntu ils ont rien touchés.
Réinstaller Ubuntu 15.04 donc complètement en choisissant l'option "automatique" lors de l'installation.
Retélécharge l'ISO de la communauté ici, et installe le en choisissant le paramétrage manuel de tes partitions pour ne pas toucher à la partition EFI. Il faut surtout plus y toucher pour ne pas supprimer le GRUB.
Et après ça devrait fonctionner^^

Revient vers moi si ça fonctionne toujours pas wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#142 Le 08/01/2017, à 13:39

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

remio7 a écrit :

Une amie m'a laissé son Asus T100H pour que je lui réinstalle correctement ubuntu. Il y a déjà une version installé dessus mais pas de son, wifi, il ne sort pas de veille, etc. . J'ai fait une clé bootable avec mkusb (cela ne marchait pas au démarrage avec Multisystem) mais elle n'est pas reconnue par le pc. J'ai utilisé l'iso du Drive (de 1.8Go), il n'est pas reconnu par le créateur de disque de de démarrage...
Je n'arrive pas à tout comprendre pour une réinstall correct, je précise que je n'ai pas Windows pour faire un clé avec Rufus.

Quelle version état déjà installée sur la machine ? La 15.04 ?
Tape cette commande pour le savoir :

lsb_release -a

Je te conseille de télécharger l'ISO de la 16.04.1 pour la T100 ici, et ensuite d'utiliser UnetbootIn pour décompresser l'ISO sur ta clé.
Lors de l'installation, n'utilise pas l'installation automatique, mais partitionne toi-même ton disque dur en ne touchant pas à la partition EFI surtout. Ca rendrait ton système impossible à booter !

Bon courage !


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#143 Le 08/01/2017, à 13:41

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Toutefois j'ai maintenant le problème de wifi.
J'ai essayé de rentrer dans le terminal la ligne de commande citée plus haut, et lorsque je fais entrée, on me demande mon mot de passe... Sauf que je n'arrive pas à écrire quoi que ce soit dans la fenêtre du terminal..
Quelqu'un peut il m'aider s'il vous plaît?

Tu ne peux même pas le taper et il apparaît masquer par des * ?
Petite capture d'écran pour mieux comprendre non ? wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#144 Le 08/01/2017, à 13:44

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

fakbill a écrit :

Bref, que faut il commencer parlire pour installer un ubuntu qui boote correctement sur une T100? Je ne veux pas de dualboot.
Je connais bien linux donc aucun problème s'il y a des choses à faire en ligne de commande pour faire marcher tel ou tel périphérique.
L'essentiel est d'avoir une distrib qui boot...

Heureux de savoir qu'il y a encore des gens prêt à installer Ubuntu sur leurs T100 ! smile
Je peux te conseiller cette doc pour installer la 16.04.1 de la communauté.
Ensuite, tu peux télécharger l'ISO et le décompresser avec UnetBootin sur ta clé et lancer l'installation.

Voilà voilà wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#145 Le 09/01/2017, à 09:01

stefberni

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

bonjour à tous,
pour faire suite à mon et vos derniers messages :
- j'ai bien installé la 16.04 et rencontré des pb de WIFI déjà identifiés par d'autres auparavant
- pour le WIFI j'ai débloqué la situation en faisant la manip citée plus haut .
- pour le mot de passe qui est nécessaire pour valider  l'étape du wifi, c'est normal si rien n'est inscrit dans le terminal au moment du mot de passe , car c'est une sécurité. "penser à taper entrée" à la fin du mot de passe.
- maintenant j'ai des pb d'audio, j'ai plus de son , mais j'ai vu que ça aussi c'était connu.....donc je vais suivre la procédure un jour...et je vous tiendrai au courant.

à plus

Hors ligne

#146 Le 09/01/2017, à 17:21

set

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour Lionel,

Li@nel a écrit :

Réinstaller Ubuntu 15.04 donc complètement en choisissant l'option "automatique" lors de l'installation.

pour ca c'est ok.. j'ai la version15.04 qui fonctionne correctement a part le WIFI malheureusement... sans quoi je serai resté sur cette version.

Li@nel a écrit :

Retélécharge l'ISO de la communauté ici, et installe le en choisissant le paramétrage manuel de tes partitions pour ne pas toucher à la partition EFI. Il faut surtout plus y toucher pour ne pas supprimer le GRUB.
Et après ça devrait fonctionner^^

Revient vers moi si ça fonctionne toujours pas wink

Et bien, je n'arrive pas a trouver la methode de reinstallation de la version 16.04 sans que cela interfere sur le grub mis en place lors de l'installation de la version 15.04. Je n'arrive pas a trouver le bon protocole de reinstallation. Je suis vraiment desolé. J'aurai besoin de la procedure pas à pas.

un grand merci d'avance.


ubuntustudio 16.04LTS (xubuntu 4.12-)
ASUS P5Q pro // core 2 duo E75004//4g mem DDR2 // RADEON HD4670//M-Audio delta 44

Asus T100 TAF32gb (Ubuntu 16-4 /64bit sans son)

Hors ligne

#147 Le 10/01/2017, à 12:40

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

stefberni a écrit :

- j'ai bien installé la 16.04 et rencontré des pb de WIFI déjà identifiés par d'autres auparavant

Une "solution" pour améliorer la stabilité du Wi-Fi est sortie depuis quelque temps sur le groupe Google.
Voici un rapide tuto :

his avoids "brcmf_escan_timeout: timer expired" which is apparently caused by sdio entering power-saving mode.

1)  Create /etc/modprobe.d/brcmfmac.conf

2) paste the following in the file

install brcmfmac echo on > /sys/bus/platform/drivers/sdhci-acpi/INT33BB:00/power/control; modprobe --ignore-install brcmfmac

replace the INT33BB:00 with your ACPI ID of the wireless card, not sure if this differs on the TAF, CHI, etc...

save and reboot, should help with the frequent disconnects

- maintenant j'ai des pb d'audio, j'ai plus de son , mais j'ai vu que ça aussi c'était connu.....donc je vais suivre la procédure un jour...et je vous tiendrai au courant.

As-tu essayé sur d'autres noyaux plus ancien ?
Tu n'as pas touché à la config son depuis l'installation ?
Il se peut que le son ne fonctionne plus avec une config depuis quelques noyaux récents, si tu as des difficultés, hésite pas à venir me trouver si tu veux de l'aide.


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#148 Le 10/01/2017, à 12:48

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Et bien, je n'arrive pas a trouver la methode de reinstallation de la version 16.04 sans que cela interfere sur le grub mis en place lors de l'installation de la version 15.04. Je n'arrive pas a trouver le bon protocole de reinstallation. Je suis vraiment desolé. J'aurai besoin de la procedure pas à pas.

Quand tu installes la 15.04 :

Après avoir choisis ta langue lors du premier écran d'installation, on te demandera de choisir l'installation avec l'installation des mises à jours et l'installation ou pas des logiciels tiers.
Après cet écran, tu pourras véritablement choisir le mode d'installation d'Ubuntu sur ta machine.
Là, tu devras choisir le premier choix, celui par défaut si ma mémoire ne se plante pas, c'est à dire "écraser le disque et installer Ubuntu".
C'est Ubuntu qui va lui même allouer la taille de tes partitions EFI et home.
Après ça, tu devrais pouvoir démarrer sans problème avec le GRUB installé comme il faut.

Pour Ubuntu 16.04:
Même procédure, sauf qu'il ne te faudra plus choisir d' "écraser le disque et d'installer Ubuntu", mais tu devras cocher le dernier choix, c'est à dire "Quelque chose d'autre" ou partitionnement toi-même ton disque.
Cette étape est très important car elle te permettra de ne pas toucher à ta partition EFI, et donc de garder ton GRUB intact.
Après tu pourras ou non scinder ton home avec ton système et faire ce que tu veux.
Surtout ne pas toucher sur l'endroit ou s'installera le programme de démarrage !

Voilà, j'espère que ça va t'aider !

Pour tous ceux qui ont installé la 16.04 et reformant l'intégralité du disque et en laissant Ubunut le repartitionner automatiquement, il vous faudra repasser par la 15.04 pour avoir le GRUB fonctionnel et pouvoir booter.
J'espère que ce sera corrigé dans un prochain ISO de la communauté pour ne plus devoir passer par ça.

Dernière modification par Li@nel (Le 10/01/2017, à 12:48)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#149 Le 10/01/2017, à 16:18

set

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

bonjour Lionel,

Li@nel a écrit :

Je peux te conseiller cette doc pour installer la 16.04.1 de la communauté

Ce lien me laisse esperer une reinstall... j'en suis a ma 4ieme tentative infructueuse mais j'y crois ... ))

J'espere egalement qu'une "fusion" entre l'install de la version 15.04 et 16.04 verra le jour. Nos petites machines meritent de ne pas tomber dans l'oubli ou la poubelle à cause d'un seul homme et de sa pseudo "fenetre" ... de Windobs quoi !!!


LIBEREZ LES MACHINES

Dernière modification par set (Le 10/01/2017, à 16:18)


ubuntustudio 16.04LTS (xubuntu 4.12-)
ASUS P5Q pro // core 2 duo E75004//4g mem DDR2 // RADEON HD4670//M-Audio delta 44

Asus T100 TAF32gb (Ubuntu 16-4 /64bit sans son)

Hors ligne

#150 Le 11/01/2017, à 22:35

richtouille

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonsoir à tous,

Qu'advient-il du son sur cette tablette T 100 d'ASUS. C'est très problématique. Je ne trouve toujours pas de solution. D'autre part avez vous une solution pour voir des vidéos sur internet (ex: youtube) quelque soit le navigateur ce n'est pas possible. Je pense que ça vient de la carte graphique. Confirmez vous ou non mon hypothèse à ce sujet s'il vous plaît.

cdt,

Richtouille

Hors ligne