Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/08/2016, à 00:17

herodote k210

message de mise à jours de sécurité[réglé]

J'ai reçu alors que je suis sous ubuntu 14.04, un message de mise à jour inhabituel dans sa forme:
qui m'indique:
"new important  security and hardware support update

warning security update for your current hardware enablement

Stack ended on  2016-08-04
*http://wiki.ubuntu/14.04_HWE_EOL"

Cela me paraît suspect, d'autant que les mises à jour touchent les logiciels et non le matériel (hardware)
et proviennent du gestionnaire de mise à jour sous une autre forme.

ici en lien:
http://i35.servimg.com/u/f35/16/27/68/87/captur10.png


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Dernière modification par herodote k210 (Le 21/08/2016, à 16:22)

Hors ligne

#2 Le 20/08/2016, à 01:21

Bougron

Re : message de mise à jours de sécurité[réglé]

Bonjour
Je pense qu'il y a rien d'anormal. => https://wiki.ubuntu.com/1404_HWE_EOL   et https://doc.ubuntu-fr.org/versions
Tu disposes d'un logiciel qui n'est plus maintenu depuis le 4 aout 2016.
On te propose gentiment d'accélérer la migration par upgrade en 16.04.1
Plus sérieusement je te suggère d'installer la 16.04.1 à coté de ta version 14.04 et voir si elle fonctionne bien. https://doc.ubuntu-fr.org/migration

Dernière modification par Bougron (Le 20/08/2016, à 01:22)

Hors ligne

#3 Le 20/08/2016, à 02:32

cqfd93

Re : message de mise à jours de sécurité[réglé]

Bonjour,

Bougron a écrit :

On te propose gentiment d'accélérer la migration par upgrade en 16.04.1

Non, ça n'est pas une migration par upgrade en 16.04.1, c'est le passage à 14.04.5 qui utilise les noyaux de la 16.04. C'est très différent mais ça peut présenter des risques avec du matériel un peu ancien qui risque de ne pas supperter ces noyaux.

Plus sérieusement je te suggère d'installer la 16.04.1 à coté de ta version 14.04 et voir si elle fonctionne bien. https://doc.ubuntu-fr.org/migration

à mon avis, aucune raison d'installer une 16.04.


cqfd93

Hors ligne

#4 Le 20/08/2016, à 07:56

Arioch91

Re : message de mise à jours de sécurité[réglé]

Bonjour.

Je m'immisce dans la discussion car je rencontre le même message depuis hier soir.

Le retour de la commande uname -r m'indique que j'utilise le noyau 3.19.0-66-generic et, après lecture de la page wiki, je suis concerné par cette mise à jour.

Bien que mon matériel soit très récent, je n'ose pas installer ce "patch".

Y a-t-il moyen de le désactiver ?

Comme herodote_k210, je suis surpris par la forme du message qui est assez inhabituelle par rapport à ce qu'affiche généralement le gestionnaire de mise à jour.

En gros : peur de faire une connerie sur un système qui me va à ravir et qui ne plante jamais.


8 Go RAM - SSD 120 Go + SATA 1 To - Ubuntu 14.04 LTS

Hors ligne

#5 Le 20/08/2016, à 08:09

xubu1957

Re : message de mise à jours de sécurité[réglé]

Bonjour,

Vous êtes utilisateurs du : ltsenablementstack

Voir la Doc : gestionnaire_de_mises_a_jour au § 4.5

Choisir jamais au choix :
"Me prévenir lorsqu'une nouvelle version d'Ubuntu est disponible"

choix réversible à volonté par l'utilisateur !

A partir d'août 2016, les versions 14.04.2,14.04.3 et 14.04.4, ne sont plus supportées !

Dernière modification par xubu1957 (Le 20/08/2016, à 21:43)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 20/08/2016, à 10:40

herodote k210

Re : message de mise à jours de sécurité[réglé]

@bongron.
Donc ce qui est proposé est licite.
J'ai cru d'abord à un hameçonnage.
J'ai de l'espace de libre sur mon disque dur en partition .

@arioch91
Sinon après un certains temps le passage à 16.04 est nécessaire il ne sera plus soutenue.

@cqfd93
Donc le message que nous avons reçu tient compte de notre matériel il est vrai que le mien est ancien il date des jo de 2008.
!
Donc avec un noyau de 14.04 un problème se sécurité se pose?

Merci à tous pour votre aide.

Hors ligne

#7 Le 20/08/2016, à 12:38

jplemoine

Re : message de mise à jours de sécurité[réglé]

Ce n'est pas tout à fait ça : en fait, soit tu as une "vraie" 14.04
soit, et c'est ton cas, tu as une 14.04 + HWE (lstenablemenstack) : c'est une 14.04 mais avec les noyaux des version intermédiaires.
Donc, il faut suivre ces versions intermédiaires aux niveau des noyaux.
Le problème, c'est que la version n+1 peut ne pas supporter des vieux matériels (mais 2008, je ne pense pas que ce soit si vieux).
J'ai des PC qui date de début des années 2000 qui tournent avec une 16.04.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#8 Le 20/08/2016, à 17:37

herodote k210

Re : message de mise à jours de sécurité[réglé]

Donc jplemoine, je nettoie le noyau avec kclean et ensuite je fais la mise à jour  proposée.
Quels sont les incovénients d'une telle mise à jours du kernel?

De ce que j'ai lu, sans comprendre ce que signifie xenial, le noyau de U14.04 n'est plus maintenue en tant
que tel et une évolution vers u14.04.5 s'impose.

c'est le hwe support c'est à dire c'est ce qui permet de faire fonctionner la machine pilotes,.....

Par contre qu'est ce que le "graphic stack"?

Donc 16.04 Xenial HWE Stack (v4.4. Kernel)  c'(est ubuntu quel différences par rapport à ubuntu lts?

Hors ligne

#9 Le 20/08/2016, à 17:39

herodote k210

Re : message de mise à jours de sécurité[réglé]

xubu1957 a écrit :

Bonjour,

Vous êtes utilisateurs du : ltsenablementstack

Voir la Doc : gestionnaire_de_mises_a_jour au § 4.5

Choisir jamais au choix :
"Me prévenir lorsqu'une nouvelle version d'Ubuntu est disponible"

choix réversible à volonté par l'utilisateur !


Si j'ai bien compris vu que je n'ai pas fait la mis à niveau de u14.04 mon système d'exploitation
est passé de 14.04lts à tsenblemtstack

Hors ligne

#10 Le 20/08/2016, à 17:43

herodote k210

Re : message de mise à jours de sécurité[réglé]

xenial xerus c'est juste un nom et pas vraiment quelque chose de signifiant en fait.

Hors ligne

#11 Le 20/08/2016, à 17:52

xubu1957

Re : message de mise à jours de sécurité[réglé]

herodote k210 a écrit :

xenial xerus c'est juste un nom et pas vraiment quelque chose de signifiant en fait.

xenial identifie une version d'Ubuntu soit la 16.04

Toutes les : versions ont un nom ( voir au § 4 : Historique des versions !

Pour les utilisateurs confirmés, cela peut aider !

Dernière modification par xubu1957 (Le 20/08/2016, à 17:53)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#12 Le 20/08/2016, à 18:22

jplemoine

Re : message de mise à jours de sécurité[réglé]

La 14.04 s'appelle The Trusty Tahr (Trusty pour les intimes) : c'est une LTS avec un noyau 3.13
La 16.04 s'appelle The Xenial Xerus (Xenial pour les intimes) : c'est aussi une LTS avec un noyau 4.4
Le but de HWE est d'avoir un 14.04 (Trusty) mais avec les noyaux supérieurs à la 3.13.
Ce que l'on te propose est juste de passer à la version supérieure du noyau pour avoir une 14.04 avec un noyau de la 16.04.
C'est pour cela que je préfère installer les versions de base (ou les .1) et rester sur le noyau historique.
En installer les versions .2, .3,.. tu as le HWE qui augmente les versions de noyaux.
Lis les liens fournis pour le détail.
NB : Dans ton cas, je réinstallerai une 16.04 (histoire de partir propre) en dual-boot avec ma version actuelle en ne gardant pas le /home.
Le plus simple que j'ai trouvé est de suffixer l'utilisateur par la version : si mon utilisateur est toto, je crée un toto-16. Comme ça, je peux tranquillement récupérer mes documents.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#13 Le 20/08/2016, à 18:28

moko138

Re : message de mise à jours de sécurité[réglé]

Vous êtes utilisateurs du : ltsenablementstack

Exact.
  - -

Voir la Doc : gestionnaire_de_mises_a_jour au § 4.5

Choisir jamais au choix :
"Me prévenir lorsqu'une nouvelle version d'Ubuntu est disponible"

choix réversible à volonté par l'utilisateur !

Non, ce n'est pas cela.
herodotek210 utilise 14.04 (dont le noyau normal est un 3.13), mais il l'utilise avec ltsenablementstack (dont la fonction est de fournir, quand c'est indispensable, un noyau intermédiaire).
Ce noyau n'est plus supporté.
Donc pas question de bloquer en l'état la version de noyau.

La suite la plus logique est dans la Doc ltsenablementstack :
passer à une version suivante de ltsenablementstack
(vers wily ou vers xenial, je n'en sais rien - je n'ai jamais eu besoin d'utiliser HWE-S).
  Si c'est vers wily, chercher dans la page de la Doc la ligne :

Pour passer au HWE stack de Wily (équipé du noyau 4.2.0-x)

  Si c'est vers xenial, puisque la Doc n'est pas à jour, demander ici.
  - -


Et à l'avenir, si on vise un système stable et sans souci,
se souvenir de n'utiliser HWE-S que si c'est indispensable.  smile


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#14 Le 20/08/2016, à 18:35

jplemoine

Re : message de mise à jours de sécurité[réglé]

moko138 a écrit :

herodotek210 utilise 14.04 (dont le noyau normal est un 3.13), mais il l'utilise avec ltsenablementstack (dont la fonction est de fournir, quand c'est indispensable, un noyau intermédiaire).

Pas d'accord, je pense que tu prends le noyau supérieur et basta !
herodotek210, quel est la retour de

uname -r 

Pas contre, oui, il FAUT faire la mise à jour de HWE.
Mais, s'il a installé au départ une version >= 14.04.2, c'est HWE obligatoire (on peut peut-être le supprimer mais je ne sais pas comment).
C'est pour cela que je garde les versions xxx ou xxx.1 et que je n'utilise pas les versions supérieures.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#15 Le 20/08/2016, à 18:41

moko138

Re : message de mise à jours de sécurité[réglé]

jplemoine a écrit :

oui, il FAUT faire la mise à jour de HWE.
Mais, s'il a installé au départ une version >= 14.04.2, c'est HWE obligatoire (on peut peut-être le supprimer mais je ne sais pas comment).
C'est pour cela que je garde les versions xxx ou xxx.1 et que je n'utilise pas les versions supérieures.

En effet, je n'avais pas pensé aux 14.4.2 (ou .3) installées d'emblée.
Donc je suis d'accord avec toi.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#16 Le 20/08/2016, à 19:53

xubu1957

Re : message de mise à jours de sécurité[réglé]

@ jplemoine et moko138

le message invite bien à passer en 14.04.5 ?
(edit)
On peut bloquer ce choix, restant sauf, le fait de toujours continuer à faire les mises à jours des noyaux :

Les versions:

-  14.04.2 (noyaux 3.16)
-  14.04.3 (noyaux 3.19)
-  14.04.4 (noyaux 4.2)

ne sont plus soutenues à partir depuis le 04 août 2016 !

(edit) source : https://wiki.ubuntu.com/1404_HWE_EOL

Dernière modification par xubu1957 (Le 21/08/2016, à 22:38)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#17 Le 20/08/2016, à 20:10

jplemoine

Re : message de mise à jours de sécurité[réglé]

Justement, il FAUT passer en 14.04.5 : sauf erreur de ma part, c'est le seule version 14.04 avec HWE qui soit supportée.
Voir le 1er lien du post #13.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#18 Le 20/08/2016, à 20:19

xubu1957

Re : message de mise à jours de sécurité[réglé]

OK , j'édite le # 16 !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#19 Le 20/08/2016, à 21:22

herodote k210

Re : message de mise à jours de sécurité[réglé]

Bonsoir jplemoine
voici le retour:

jean-marc@gargantua:~$ uname -r 
4.4.0-34-generic

J'ai fait la mise à jour hwe stack et cela fonctionne.
Je vois en quoi cela consiste et même l'intérêt de la chose mais plus profondément est ce que cela a un rapport avec le maintient d'un noyau apte à se servir du matériel cartes...ou le serveur graphique.

Ou bien c'est autre chose car dans la doc il est indiqué que si le matériel est déjà reconnu cela importe peu
de le faire, ici au 1er §.

ici en §2 est indiqué le moyen de supprimé les lts enablement stack:
https://doc.ubuntu-fr.org/ltsenablementstack

Si quelqu'un a la définition de stack dans le contexte ubuntu cela m'intéresse.

jplemoine a écrit :

L
C'est pour cela que je préfère installer les versions de base (ou les .1) et rester sur le noyau historique.
En installer les versions .2, .3,.. tu as le HWE qui augmente les versions de noyaux.

Mais normalement même pour une lts on a des noyaux qui s'accumulent et que l'on doit supprimer pour les inutiles  par kclean.

Donc en quoi le hwe augmente les versions du noyau sur l'ordi?

A moins que ce soit pour le choix en général de la version de 14.04 à choisir, ce qui pourrait poser problème?

Là j'ai fait une mise à jour quasiement comme pour une mise jour du kernel pour lts et avec Kclean j'ai supprimé les anciennes.

Comme l'indique xubu je suis à un momment passé de lts à  ltsenablementstack mais je ne l'avais par remarqué et je ne sais même pas quand en tout cas c'est ce qui a permis un mise à jour avec hwe s.

Hors ligne

#20 Le 20/08/2016, à 22:16

jplemoine

Re : message de mise à jours de sécurité[réglé]

Le fait de supprimer les noyaux ne change pas : il faut le faire dans tous les cas.
C'est juste un problème de noyau :
- Si tu installes une 14.04 ou une 14.04.1, tu auras ce que j'appelle une "vraie lts" avec le noyau historique 3.13.x. (par exemple : 3.13.0-93-generic aujourd'hui). Ce dernier est maintenu 5 ans.
- Si tu installes une 14.04.2 et au-delà (ou si tu installes volontairement HWE) : tu aura une 14.04 mais avec le noyau des versions intermédiaires : la partie HWE n'est supportée que jusqu'au mois d’août (donc le mois courant) sauf pour la version qui correspond au noyau de la 16.04.
Regardes le schéma sur la page que l'on t'a mis en lien ci-dessus (et que je remets) : ltsenablementstack


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#21 Le 20/08/2016, à 22:24

herodote k210

Re : message de mise à jours de sécurité[réglé]

Tout à fait jplemoine, et d'ailleurs en relisant la doc its j'ai compris que c'est pour le matériel futur qu'il faut mettre à jour avec une version 14.04.05 donc le noyau du 16.04 pour que matériel (soit encore soutenu pour le nouveau du moins).

Mais ce qui surprend c'est que je ne pense pas avoir fait volontairement de mise à jour vers 14.04.02 ou....
voir même    ltsenablementstack.

Hors ligne

#22 Le 20/08/2016, à 22:48

jplemoine

Re : message de mise à jours de sécurité[réglé]

Tu confonds 2 choses :
- la version installée : c'est celle qui est sur le DVD / Clé USB qui a servit à installer le système.
- la version courante (qui doit être 14.04.5 dans tous les cas : HWE ou pas)

Dans tous les cas, on fait les mises à jour et on a la même version (14.04.5 aujourd'hui) mais on n'a pas la même version du noyau.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#23 Le 21/08/2016, à 22:46

xubu1957

Re : message de mise à jours de sécurité[réglé]

Bonjour,

Les versions :

14.04.2 Ubuntu 14.10 Utopic HWE Stack (v3.16 kernel)

14.04.3 Ubuntu 15.04 Vivid HWE Stack (v3.19 kernel)

14.04.4 Ubuntu 15.10 Wily HWE Stack (v4.2 kernel)

ne sont plus supportées depuis le 04/08/2016.


Lien : https://wiki.ubuntu.com/1404_HWE_EOL

What to do if I'm affected?
You have the following options:

Update to the Ubuntu 16.04 Xenial HWE Stack (v4.4. Kernel)
Upgrade to Ubuntu 16.04 LTS
Fresh install of Ubuntu 16.04 LTS

Traduction a écrit :

Que faire si je suis affecté?
Vous avez les options suivantes:

Mise à jour du Ubuntu 16.04 Xenial HWE Stack (v4.4. Kernel)
Mise à niveau vers Ubuntu 16.04 LTS
Nouvelle installation d'Ubuntu 16.04 LTS

Dernière modification par xubu1957 (Le 22/08/2016, à 07:25)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#24 Le 22/08/2016, à 14:17

herodote k210

Re : message de mise à jours de sécurité[réglé]

@ xubu une chose m'intrigue pourquoi la mise à niveau ce fait  vers 16.04 Hwe alors que cette dénomination ne semble réservée que pour version antérieure qui a reçu un noyau de 16.04 elle devrait s'appeler 16.04lts est ce que  cela dénote quelque chose de particulier?

Hors ligne

#25 Le 22/08/2016, à 14:38

xubu1957

Re : message de mise à jours de sécurité[réglé]

Il y a 3 choix possibles :

Mise à jour du Ubuntu 16.04 Xenial HWE Stack (v4.4. Kernel)
Mise à niveau vers Ubuntu 16.04 LTS
Nouvelle installation d'Ubuntu 16.04 LTS

En HWE : tous les 6 mois, changement des noyaux dupliqués de ceux des futures versions intermédiaires (16.10, 17.04, 17.10 ...)

J'ai opté pour la mise à niveau vers la version 16.04.1  à partir d'une version 14.04.4,  mes ordinateurs étant anciens !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne