Contenu | Rechercher | Menus

Annonce

T-shirt Disco Dingo : Série limitée

Ubuntu 19.04
T-shirt Ubuntu-FR « Disco Dingo » en série limitée !
Prix spécial pré-vente (15€) jusqu'au 21 avril 2019.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/11/2016, à 22:43

Noxinnes

Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Salutations!
Alors, avant tout je tiens à vous dire que c'est la première fois que je communique sur un forum en temps normal je me contente de lire mais étant donné que je n'ai trouvé qu'une seule discutions non résolu car plus personne n'y écrit depuis quelques jours je me suis dit que j'allais relancé une discutions sur le meme sujet (en espérant avoir bien fait).

Mon problème: Suite à mon passage  d'ubuntu 14.04 à la version 16.04 je ne peut plus installer de paquet. À chaque fois je suis les procédures pour installer les paquets et a la fin des installations je reçois toujours le meme message:

N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable

Je ne comprends pas pourquoi ce message s'affiche tout ce que je sais c'est qu'il est apparu depuis que je suis passé sous la version 16.04

Si des âmes charitables pouvaient m'apporter leur aides j'en vous serez très reconnaissant.

Si vous avez besoin de n’importe qu’elle information faites le  moi savoir

Je vous remercie d'avance  pour m'offrir un peu de  votre temps en espérant ne pas le vous faire perdre  inutilement

Cordialement

Dernière modification par cqfd93 (Le 10/11/2016, à 16:35)

Hors ligne

#2 Le 03/11/2016, à 22:45

jplemoine

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Quel est le contenu de /etc/apt/apt.conf.d/  ?
A priori, il y a au moins 1 fichier "50unattended-upgrades.ucf-dist" . Quel est son contenu ?


Compte volontairement inactif
Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre) et de ALDI4 (Atelier Libre d'Informatique du 4ième)

Hors ligne

#3 Le 04/11/2016, à 00:13

Noxinnes

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Je sais pas comment  faire pour  vous montrer le contenu du dossier :x
Mais en effet  il y a bien un dossier nommé: 50unattended-upgrades

Dernière modification par Noxinnes (Le 04/11/2016, à 00:19)

Hors ligne

#4 Le 06/11/2016, à 17:22

cdomi

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonjour,
J'ai le même souci.
J'ai regardé dans apt-conf.d, voici les paquets ignorés

// List of packages to not update (regexp are supported)
Unattended-Upgrade::Package-Blacklist {
//    "vim";
//    "libc6";
//    "libc6-dev";
//    "libc6-i686";
};

PS pour Noxinnes, pour voir le contenu du fichier, la commande est  :

cat /etc/apt/apt.conf.d/50unattended-upgrades.ucf-dist

ou si gedit installé

gedit /etc/apt/apt.conf.d/50unattended-upgrades.ucf-dist

J'ai pensé à réinstaller les paquets mais  c'est vraiment au pif alors dans le doute, je m'abstiens.
J'attends un retour d'une bonne âme sur le forum smile
Cordialement
Domi

Dernière modification par cdomi (Le 06/11/2016, à 17:23)

Hors ligne

#5 Le 06/11/2016, à 21:45

cdomi

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Pour faire avancer le sujet, j'ai trouvé ce lien

Quelle solution ? dé-commenter les paquets "blacklistés" ???

Dernière modification par cdomi (Le 06/11/2016, à 21:47)

Hors ligne

#6 Le 06/11/2016, à 22:02

tuxmarc

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonsoir.
Je n'ai pas la solution miracle, j'ai regardé ce qu'il y avait dans /etc/apt/aptconf.d chez moi sur une 16.04 qui marche bien.
J'ai découvert un truc ce soir : l'existence d'un fichier 50unattended-upgrades !
Dans mon répertoire il n'y a pas de "ucf-dist".
On dirait que ce "ucf-dist" hérisse le poil de la bécane.
Je suggère de modifier le nom de ce "50unattended-upgrades.ucf-dist" pour lui virer son ".ucf-dist" en lançant en console le navigateur en root pour pouvoir bricoler au niveau système en faisant

sudo nemo

ou

sudo nautilus

ou le nom du navigateur de fichiers.
Ça va ouvrir le navigateur, il faudra chercher /etc puis /apt, puis aptconf.d et le coupable est dedans.
Clic droit, renommer en virant l'extension, on ferme le navigateur et ensuite mise à jour.


Vive Richard Stalmann, Linus Torvalds, et tous les fondus de Linux.
De l'Ordinosaure fait à 90% de récup, à un portable LDLC, une tour, neufs sans système,un serveur et une carte mère sans boitier, tous libres !!
Parrain Linux sur www.parrain-linux.com et www.parrains.linux.free.fr

Hors ligne

#7 Le 07/11/2016, à 18:34

cdomi

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonsoir,
En fait, j'ai 2 fichiers "50unattended-upgrades", l'un sans extension, l'autre avec l'extension *.ufc-dist
Et le même contenu.

-rw-r--r-- 1 root root 2,3K - 22:52 mer. 02 avril 2014 - 50unattended-upgrades
-rw-r--r-- 1 root root 2,4K - 16:42 dim. 06 nov.  2016 - 50unattended-upgrades.ucf-dist

J'ai déplacé le fichier avec l'extension *.ufc-dist dans un autre répertoire (dans mon /home).
Ensuite "apt-get update"
Plus de message d'erreur.
Idem avec "apt-get upgrade"

Le système ne supportait pas la présence des 2 fichiers sans doute !

PS pour Noxinnes :
Indique-nous si tu as besoin d'une aide pour faire les manipulations depuis la console.

Dernière modification par cdomi (Le 07/11/2016, à 18:38)

Hors ligne

#8 Le 07/11/2016, à 18:48

tuxmarc

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonsoir !

cdomi a écrit :

Le système ne supportait pas la présence des 2 fichiers sans doute !

On dirait bien smile
Content que ça se termine bien pour toi et j'espère que pour Noxinnes, ce sera le même cas smile


Vive Richard Stalmann, Linus Torvalds, et tous les fondus de Linux.
De l'Ordinosaure fait à 90% de récup, à un portable LDLC, une tour, neufs sans système,un serveur et une carte mère sans boitier, tous libres !!
Parrain Linux sur www.parrain-linux.com et www.parrains.linux.free.fr

Hors ligne

#9 Le 08/11/2016, à 13:19

Noxinnes

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Merci de vos réponses et de vos informations.

En effet je pense que Domi a trouvé la solution mais seul petit problème pour déplacé ou supprimé le fichier en question il faut avoir le droit de root dont je ne dispose pas étant donné que c'est un ordinateur qui a été donné par la région.
(je ne sais pas si vous avez déjà entendu parler du plan POP qui consiste a donné des ordinateurs a tout élèves entrant de seconde dans un lycée général, ces ordinateurs sont livrés sous ubuntu et pour le rester la région nous prive des droits de root.Pour y avoir accès il faudrait que j'ouvre mon ordi pour effacer la mémoire du BIOS...)
Bref je pense que je vais devoir me débrouillé à moins que l'un d'entre vous sache comment faire pour déplacer/ effacer ce fichier sans les droits de root.
Si ce n'est pas le cas merci quand même de votre aide tongue

Dernière modification par Noxinnes (Le 08/11/2016, à 13:21)

Hors ligne

#10 Le 08/11/2016, à 13:34

cqfd93

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonjour,

Noxinnes a écrit :

En effet je pense que Domi a trouvé la solution mais seul petit problème pour déplacé ou supprimé le fichier en question il faut avoir le droit de root dont je ne dispose pas étant donné que c'est un ordinateur qui a été donné par la région.
(je ne sais pas si vous avez déjà entendu parler du plan POP qui consiste a donné des ordinateurs a tout élèves entrant de seconde dans un lycée général, ces ordinateurs sont livrés sous ubuntu et pour le rester la région nous prive des droits de root.Pour y avoir accès il faudrait que j'ouvre mon ordi pour effacer la mémoire du BIOS...)

Alors comment as-tu fait pour passer de 14.04 à 16.04 comme tu le dis dans ton premier message ? Il me semble que pour lancer une telle commande, il faut utiliser sudo dans le terminal ou donner le mot de passe administrateur si on le fait en graphique.

Que tu ne puisses pas démarrer un DVD ou un live USB, effectivement, puisque le BIOS est verrouillé par un mot de passe mais je serais bien étonnée que l'utilisateur principal n'ait pas de droits sudo ne serait-ce que pour faire des mises à jour de la distribution installée.


cqfd93

Hors ligne

#11 Le 08/11/2016, à 15:01

Noxinnes

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonjour big_smile

Je n'ai pas eu a entré de commande pour changer mes version d'ubuntu ( à la base j'étais sous ubuntu 12.04) je suis juste passé par le gestionnaire de mis à jour et les mis à jours se sont faites naturellement.
Je dispose des  droit sudo mais pour pouvoir déplacer/effacer/modifier le fichier en question il me faut les droits de root mes droit de sudo ne sont pas  suffisant

noxinnes@201200009:~$ apt-get remove 50unattended-upgrades.ucf-dist
N: « 50unattended-upgrades.ucf-dist » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?

Dernière modification par Noxinnes (Le 08/11/2016, à 16:36)

Hors ligne

#12 Le 08/11/2016, à 18:01

tuxmarc

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonjour Noxinnes

Je vois que tu n'utilises pas la bonne méthode, car, le gêneur "50unattended-upgrades.ucf-dist" c'est un fichier et non pas un programme.
Je te recommande ce que j'ai indiqué au post nr 6.
Si tu ne connais pas le nom de ton navigateur de fichiers, un petit truc :
- tu l'ouvres tout simplement
-  tu cliques sur "aide" puis "à propos" et tu verras le nom du navigateur et sa version.

Ensuite, en console, tu tapes

sudo le_nom_de_ton_navigateur

La bécane va bien entendu te demander ton mot de passe et le navigateur va s'ouvrir avec les droits maxis.
Tu peux aller partout, alors attention, pas de bêtises tongue

Tu modifies le nom comme j'ai indiqué dans /etc/apt/aptconf.d, tu fermes.
Ensuite tu peux taper en console

sudo apt-get update

et je croise les doigts pour que tout se passe bien smile

Je suis devenu méfiant avec les migrations, des fois l'usine à gaz part en sucette.
J'avais eu beaucoup de chance en tentant de passer de 12.04 à 14.04, ça s'était arrêté en remettant tout comme avant. Ouf !!!
D'autres membres du forum n'avaient pas eu cette chance.


Vive Richard Stalmann, Linus Torvalds, et tous les fondus de Linux.
De l'Ordinosaure fait à 90% de récup, à un portable LDLC, une tour, neufs sans système,un serveur et une carte mère sans boitier, tous libres !!
Parrain Linux sur www.parrain-linux.com et www.parrains.linux.free.fr

Hors ligne

#13 Le 10/11/2016, à 10:18

Noxinnes

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonjour!

En effet  Tuxmarc tu avais raison j'ai suivi tes conseils et tout fonctionne parfaitement merci beaucoup de ton aide <3 big_smile

Hors ligne

#14 Le 10/11/2016, à 12:22

tuxmarc

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonjour smile
Je suis content, j'ai trouvé smile
Tu m'avais bien aidé en copiant les lignes bizzarroïdales.

Maintenant, tu peux modifier le titre de ton premier message et ajouter "RESOLU".
Au plaisir de te rencontrer à nouveau sur le forum smile


Vive Richard Stalmann, Linus Torvalds, et tous les fondus de Linux.
De l'Ordinosaure fait à 90% de récup, à un portable LDLC, une tour, neufs sans système,un serveur et une carte mère sans boitier, tous libres !!
Parrain Linux sur www.parrain-linux.com et www.parrains.linux.free.fr

Hors ligne

#15 Le 10/11/2016, à 16:30

Noxinnes

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

tuxmarc a écrit :

Bonjour smile
Je suis content, j'ai trouvé smile
Tu m'avais bien aidé en copiant les lignes bizzarroïdales.

Maintenant, tu peux modifier le titre de ton premier message et ajouter "RESOLU".
Au plaisir de te rencontrer à nouveau sur le forum smile

C'est toi qui m'a bien aidé ahah j'ai modifié le titre malgrès que le "16.04" ai disparu car le titre était trop long..
Merci encore de ton aide et de celui de tout les autres personnes big_smile

Hors ligne

#16 Le 10/11/2016, à 16:37

cqfd93

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

Bonjour,

Noxinnes a écrit :

j'ai modifié le titre malgrès que le "16.04" ai disparu car le titre était trop long..

J'ai modifié le titre wink


cqfd93

Hors ligne

#17 Le 10/11/2016, à 18:05

tuxmarc

Re : Installation de paquet impossible depuis passage 14.04 →16.04 [Résolu]

cqfd93 a écrit :

J'ai modifié le titre wink

Merci Sylvie smile


Vive Richard Stalmann, Linus Torvalds, et tous les fondus de Linux.
De l'Ordinosaure fait à 90% de récup, à un portable LDLC, une tour, neufs sans système,un serveur et une carte mère sans boitier, tous libres !!
Parrain Linux sur www.parrain-linux.com et www.parrains.linux.free.fr

Hors ligne