Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 27/11/2016, à 08:23

CRIMA

[RESOLU] Supprimer définitivement "nomodeset"

Bonjour

Lors de l'installation de Lubuntu 16.04 sur un ordinateur, j'ai dû faire l'installation avec l'option "Nomodeset".

J'ai changé d'ordinateur et mon disque dur est maintenant dans un ordinateur qui ne démarre pas en "nomodeset".

Comment faire pour modifier le fichier de Grub afin de supprimer de façon définitive cette option "Nomodeset" sans tout réinstaller ?

Merci de votre aide

Salutations

Dernière modification par CRIMA (Le 27/11/2016, à 15:53)

Hors ligne

#2 Le 27/11/2016, à 09:47

malbo

Re : [RESOLU] Supprimer définitivement "nomodeset"

Il faut suivre la procédure de ce post : https://forum.ubuntu-fr.org/viewtopic.p … #p16502491
Sauf qu'il faut supprimer nomodeset, c'est à dire que la ligne :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
doit devenir :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Ne pas oublier de passer la commande suivante en fin de procédure (c'est pourtant bien mentionné dans le post mais les gens trop pressés ont tendance à sauter cette dernière étape) :

sudo update-grub

Dernière modification par malbo (Le 27/11/2016, à 09:50)

Hors ligne

#3 Le 27/11/2016, à 10:41

CRIMA

Re : [RESOLU] Supprimer définitivement "nomodeset"

malbo a écrit :

Il faut suivre la procédure de ce post : https://forum.ubuntu-fr.org/viewtopic.p … #p16502491
Sauf qu'il faut supprimer nomodeset, c'est à dire que la ligne :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
doit devenir :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Ne pas oublier de passer la commande suivante en fin de procédure (c'est pourtant bien mentionné dans le post mais les gens trop pressés ont tendance à sauter cette dernière étape) :

sudo update-grub

Merci beaucoup pour votre réponse.

Cependant, le fichier ne s'ouvre pas.

macri@macri-IMEDIA-MC-9667-FR:~$ gksudo gedit /etc/default/grub
macri@macri-IMEDIA-MC-9667-FR:~$ gksudo gedit /etc/default/grub
macri@macri-IMEDIA-MC-9667-FR:~$ sudo gedit /etc/default/grub
[sudo] password for macri: 
sudo: gedit: command not found
macri@macri-IMEDIA-MC-9667-FR:~$ 

Quel fichier je pourrais éditer et modifier pour régler le problème ?

Merci d'avance

Salutations

Hors ligne

#4 Le 27/11/2016, à 10:51

biloute_c

Re : [RESOLU] Supprimer définitivement "nomodeset"

bonjour,
est tu sûr que sous lubuntu ce soit gedit  ?.......

un indice..... leafpad

Dernière modification par biloute_c (Le 27/11/2016, à 10:52)

Hors ligne

#5 Le 27/11/2016, à 11:29

malbo

Re : [RESOLU] Supprimer définitivement "nomodeset"

Merci biloute_c.
Effectivement, la commande avec gedit ne fonctionne pas sous Lubuntu. Il doit falloir utiliser l'éditeur de texte leafpad.
1) D'abord, installer gksu en vue d'utiliser gksudo : https://forum.ubuntu-fr.org/viewtopic.p … #p19459481
2) puis passer la commande :

gksudo leafpad /etc/default/grub

Et faire les modifs prévues

Dernière modification par malbo (Le 27/11/2016, à 11:30)

Hors ligne

#6 Le 27/11/2016, à 11:29

grandtoubab

Re : [RESOLU] Supprimer définitivement "nomodeset"

salut
ça doit se savoir avec la commande

update-alternatives --list editor

Après avoir installé gedit si on veut en faire son premier choix

sudo update-alternatives --install /usr/bin/editor editor /usr/bin/gedit 1

pour vérifier

update-alternatives --config editor

Dernière modification par grandtoubab (Le 27/11/2016, à 11:35)


Linux tout seul sur HP Pavilion DV7 et Acer aspire T650
Debian 10 Buster XFCE/Gnome3 sur sda1
Canon MG3650 en wifi

Hors ligne

#7 Le 27/11/2016, à 12:13

Bougron

Re : [RESOLU] Supprimer définitivement "nomodeset"

CRIMA a écrit :

Bonjour

Lors de l'installation de Lubuntu 16.04 sur un ordinateur, j'ai dû faire l'installation avec l'option "Nomodeset".

J'ai changé d'ordinateur et mon disque dur est maintenant dans un ordinateur qui ne démarre pas en "nomodeset"

Salutations

Bonjour.
Comment as-tu diagnostiqué que c'était l'option nomodeset qui était la responsable?
car je n'y crois pas un seul instant. Elle est mise par defaut sur pas mal d'autres OS que ubuntu Elle est aussi mise dans ubuntu uniquement dans les sessions de recovery qu'on est sensé utiliser lorsque ubuntu ne met pas en route.

Dernière modification par Bougron (Le 27/11/2016, à 12:21)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne

#8 Le 27/11/2016, à 12:52

grandtoubab

Re : [RESOLU] Supprimer définitivement "nomodeset"

ça dépends essentiellement de la carte graphique et du driver utilisé.
nomodeset est souvent utile pour les cartes nvidia avec le driver nouveau pour ne pas laisser le noyau gérer trop tôt la configuration graphique

Dernière modification par grandtoubab (Le 27/11/2016, à 12:53)


Linux tout seul sur HP Pavilion DV7 et Acer aspire T650
Debian 10 Buster XFCE/Gnome3 sur sda1
Canon MG3650 en wifi

Hors ligne

#9 Le 27/11/2016, à 13:55

CRIMA

Re : [RESOLU] Supprimer définitivement "nomodeset"

Merci à tous.

Je suis le procédure de Malbo et vous tiens informés

Le PC d'origine avait une carte graphique NVIDIA et n'acceptait qu'une installation "nomodeset". Le PC est à présent muni d'une carte Intel Intégrée.

A bientôt

Dernière modification par CRIMA (Le 27/11/2016, à 13:59)

Hors ligne

#10 Le 27/11/2016, à 15:53

CRIMA

Re : [RESOLU] Supprimer définitivement "nomodeset"

Bonjour

Me voilà de retour.

"Nomodeset" ne semblant pas être à l'origine du défaut de démarrage, j'ai tout compte fait réinstallé SANS formater. J'ai ainsi préservé l'essentiel de mes fichiers et applications et j'ai réinstallé ce qui manquait.
Tout est donc rentré dans l'ordre.

Merci à tous ceux qui m'ont aidé.

Je passe en résolu

Salutations

Hors ligne