Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/05/2017, à 09:56

dezix

[RESOLU] Réparation erreur installation - option acpi, noapic, nolapic

Bonjour,

Je viens d'installer : Xubuntu 16.04 LTS 32bit
sur : ASUS X71SL

Le Live-CD ne bootant pas directement,
j'ai utilisé les options [F6]

acpi=off
noapic
nolapic

pour obtenir le boot

J'ai fait mon installation avec ces options.

Le résultat => une multitude de problèmes (prévisibles) dont :

L'arrêt électrique ne se fait pas (normal)
Les touches [Fn]+... ne fonctionnent pas
La résolution avec le pilote libre "Nouveau" est mal configurée et n'est pas réglable (le pilote Nvidia 340 règle ça)
...

Alors que je tente de réparer tout cela,

je lis (un peu tard ;-/ )  dans :   https://doc.ubuntu-fr.org/liste_portables_asus

ubuntu-fr a écrit :

"....  aller dans le BIOS : Bios > Security > I/O interface security > option New card interface —> mettre en statut LOCKED au lieu de UNLOCKED  "

J'ai fait un test du Live-CD avec ce réglage du BIOS => Tout semble bien fonctionner

Oui, c'est ballot sad

---------------------------------------------------------------------------------------------
Ma Question :

Est-il (assez) facilement possible de remettre les choses en bon ordre ?

Ou vaut-il mieux refaire une installation complète ?... 

J'ai déjà installé pas mal de logiciels, si je pouvais éviter de tout perdre ....

---------------------------------------------------------------------------------------------

Merci de votre attention.

À bientôt

Dernière modification par dezix (Le 08/05/2017, à 21:00)

Hors ligne

#2 Le 08/05/2017, à 10:51

carabao

Re : [RESOLU] Réparation erreur installation - option acpi, noapic, nolapic

Bonjour

As tu essayé les options suivantes pour le boot

acpi_osi=Linux pci=nomsi au lieu de acpi=off noapic nolapic


1° PC portable MSI 17": Intel Core i5-7300HQ, 8gb, GPU Nvidia GTX 1050Ti GDDR5, SSD 256 Go + HDD 1 To avec kubuntu 17.10
2° PC portable LDLC 15": Intel Core i5, 8Gb ram, carte intel HD4600 - 1 SSD (système) et 1 HDD (répertoire perso) avec kubuntu 17.04

Hors ligne

#3 Le 08/05/2017, à 12:05

dezix

Re : [RESOLU] Réparation erreur installation - option acpi, noapic, nolapic

Non, je n'ai pas testé

Comment passe-t-on ces options ?

quel fichier doit-on éditer?

Hors ligne

#4 Le 08/05/2017, à 13:08

dezix

Re : [RESOLU] Réparation erreur installation - option acpi, noapic, nolapic

Comme le DVD d'installation fonctionne bien en Live,
Comment pourrais-je voir quelles sont les options de boot qu'il utilise et les recopier sur mon système ?
Enfin si cela peut se faire... j
.... je pensais que ces options influençaient plus profondément l'installation du système (dans sa structure-même)

Hors ligne

#5 Le 08/05/2017, à 20:55

dezix

Re : [RESOLU] Réparation erreur installation - option acpi, noapic, nolapic

carabao a écrit :

acpi_osi=Linux pci=nomsi au lieu de acpi=off noapic nolapic

Cette piste était la bonne .... du moins l'idée big_smile

Une petite recherche sur " acpi=off " ,
je me doutais que ça se trouvait, soit dans /boot, soit dans /etc

donc :

$ cd /etc
$ sudo find . | xargs grep 'acpi=off' -sl		
./default/grub

(sudo pour les permissions sur certains fichiers)


$ less /etc/default/grub

pour voir où le mal se tient :

GRUB_CMDLINE_LINUX="acpi=off noapic nolapic" 

           (ligne 12 pour moi)

À ce stade j'ai redémarré mon système sur le Live-CD d'installation
et je suis allé voir le paramètre équivalent :

GRUB_CMDLINE_LINUX=""  

c'est à dire sans option particulière

Remarque :
Introduire le CD/DVD dans le lecteur pour parcourir son contenu ne permet pas d'obtenir l'information recherchée ;
c'est dans les "Fichiers Système" en cours d'exécution qu'il faut chercher.

Il ne me restait plus qu'à revenir sur mon système installé (redémarrage normal)
et corriger le paramètre ;

Donc :

Se placer dans le bon répertoire,

$ cd /etc/default

Faire une copie du fichier original (au cas où)

$ sudo cp grub grub.orig



Éditer le fichier de configuration de GRUB
 

avec :

$ sudo nano grub

     remplacement de :
               
               

GRUB_CMDLINE_LINUX="acpi=off noapic nolapic"

               
    par :
               
               

GRUB_CMDLINE_LINUX="" 

                          ( inspiré du fichier du Live-CD )


Mettre GRUB à jour pour appliquer la modification :

$ sudo update-grub
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.8.0-49-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.8.0-49-generic
Image Linux trouvée : /boot/vmlinuz-4.8.0-36-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.8.0-36-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-75-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-75-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
Windows Recovery Environment (loader) trouvé sur /dev/sda1
Windows Vista (loader) trouvé sur /dev/sda2
fait
$ sudo reboot

en espérant que cela continue de fonctionner....

.... Bingo !  ça marche !

Merci à carabao pour m'avoir mis sur le bonne piste...  cool

... encore un petit truc d'appris. 

En espérant que cela soit utile à d'autres étourdis  roll ... comme moi.

@ bientôt.

Hors ligne