Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/03/2008, à 06:47

laurent111

[Résolu]Problème d'install webcam Philips Toucam

Bonjour,

J'ai un souci avec ma webcam une philips toucam. A priori elle ne fonctionne pas avec amsn ainsi que mercury. J'ai installé easycam2 ainsi que easypwc. Dans mercury en allant dans option->généraux->webcam->paramètres->assistant JMF j'ai les messages suivant :

VidConf-libs.jar in classpath: Passed
JavaLibs-linux.jar in classpath.: Passed
Native library files for Linux found: Passed
Copy libjmutil.so: Failed

Pour info voici ce que j'ai avec dmesg si ça peut aider

[11522.380932] usb 3-2: new full speed USB device using uhci_hcd and address 2
[11522.678541] usb 3-2: configuration #1 chosen from 1 choice
[11522.820595] Linux video capture interface: v2.00
[11522.846616] pwc: Philips webcam module version 10.0.13 loaded.
[11522.846623] pwc: Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 & PCVC830/840.
[11522.846626] pwc: Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10 and MPC-C30,
[11522.846628] pwc: the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite VCS-UC300 and VCS-UM100.
[11522.848248] pwc: Philips PCVC740K (ToUCam Pro)/PCVC840 (ToUCam II) USB webcam detected.
[11523.077956] pwc: Registered as /dev/video0.
[11523.080777] usbcore: registered new interface driver Philips webcam
[11523.182893] usbcore: registered new interface driver snd-usb-audio
[14428.768599] cdrom: sr0: mrw address space DMA selected
[14428.817665] cdrom: sr0: mrw address space DMA selected
[14428.943091] UDF-fs: No VRS found
[14429.013223] ISO 9660 Extensions: Microsoft Joliet Level 3
[14429.115411] ISO 9660 Extensions: RRIP_1991A
[14715.452042] usb 3-2: USB disconnect, address 2
[14721.385848] usb 3-1: new full speed USB device using uhci_hcd and address 3
[14721.685087] usb 3-1: configuration #1 chosen from 1 choice
[14721.688018] pwc: Philips PCVC740K (ToUCam Pro)/PCVC840 (ToUCam II) USB webcam detected.
[14722.084344] pwc: Registered as /dev/video0.

Pour amsn c'est simple, il me dit que je n'ai pas de cam.

Je précise que la lumière rouge sur ma cam est toujours allumée.

Si quelqu'un pouvait m'aider se serait sympa car là je séche.

Pour easycam2, il n'apparait pas dans le menu système->administration->EasyCam2  comme indiqué dans la doc http://doc.ubuntu-fr.org/easycam.

Merci.

Dernière modification par laurent111 (Le 24/03/2008, à 05:36)


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#2 Le 21/03/2008, à 17:10

laurent111

Re : [Résolu]Problème d'install webcam Philips Toucam

smile Bonjour,

Personne pour m'aider ? j'ai l'impression que c'est un point très sensible l'installation d'une webcam sous ubuntu et linux en général.


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#3 Le 21/03/2008, à 18:11

vogia

Re : [Résolu]Problème d'install webcam Philips Toucam

ben moi j'ai bien ça aussi:

[   14.996000] uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:2640)
[   14.996000] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).

comme tu vois, t'es pas le seul. wink

je pense qu'il faut passer par ndiswrapper avec les pilotes windows.
je vais voir ça...

#4 Le 21/03/2008, à 18:20

laurent111

Re : [Résolu]Problème d'install webcam Philips Toucam

vogia a écrit :

ben moi j'ai bien ça aussi:

[   14.996000] uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:2640)
[   14.996000] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).

comme tu vois, t'es pas le seul. wink

je pense qu'il faut passer par ndiswrapper avec les pilotes windows.
je vais voir ça...

Oh la c'est du obscur pour moi ta manip cool qu'est ce donc que ndiswrapper ?

Pour infos quand le fais un lsusb j'ai bien ma cam qui est reconnu

Bus 005 Device 005: ID 054c:01bd Sony Corp.
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 002 Device 009: ID 10eb:0001 
Bus 002 Device 003: ID 05e3:0604 Genesys Logic, Inc. USB 1.1 Hub
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 004: ID 07b3:0001 Plustek, Inc. OpticPro 1212U Scanner
Bus 001 Device 001: ID 0000:0000 
Bus 003 Device 006: ID 0471:0311 Philips PCVC740K ToUcam Pro [pwc]
Bus 003 Device 001: ID 0000:0000

C'est un peu dommage je n'ai plus que ma cam qui ne fonctionne pas sous ubuntu sinon tout le reste c'est ok


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#5 Le 22/03/2008, à 00:16

laurent111

Re : [Résolu]Problème d'install webcam Philips Toucam

personne n'a jamais eu de soucis avec sa cam ? big_smile


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#6 Le 22/03/2008, à 17:59

Clarinette.

Re : [Résolu]Problème d'install webcam Philips Toucam

Pour que le JMF puisse copier le fichier il faut utiliser Mercury en mode super utilisateur. Allez donc dans le terminal et tapez "gksudo mercury". Ensuite allez dans les paramètres, webcam, assistant JMF 'ouvrir'. Voilà moi j'me suis arrêté là, je ne sais pas quoi faire ensuite ^^

#7 Le 23/03/2008, à 05:54

laurent111

Re : [Résolu]Problème d'install webcam Philips Toucam

Merci Clarinette pour tes infos

Effectivement j'ai fait la manip il y a bien ma web cam maintenant lorsque je vais dans JMF
voici le statut :
VidConf-libs.jar in classpath: Passed
JavaLibs-linux.jar in classpath.: Passed
Native library files for Linux found: Passed

lorsque je fais suivant j'arrive sur vidéo device et voici ce que j'ai :

Present video capture devices:
v4l:Philips 740 webcam:1
1: YUV encoding, 160 x 120
2: YUV encoding, 320 x 240
3: YUV encoding, 640 x 480
4: YUV encoding, 176 x 144
5: YUV encoding, 352 x 288

Ensuite en cliquant sur suivant j'arrive sur "choisir une source vidéo mais je n'ai pas le choix il me propose qu'une solution à savoir pour le device :  v4l:Philips 740 webcam:1 bon mais ça me parait normal ensuite l'encoding je n'ai que YUV

Ensuite je fais suivant et là j'arrive sur le test de la source vidéo et il m'indique déconnecté alors que ma cam est branché lumière rouge allumé.

Donc je ne comprends toujours pas.

Est-ce que toutes les web cam ont le même problème c'est à dire que tout simplement ça ne fonctionne pas encore sous linux ? j'ai une très forte impression que c'est le cas malheureusement.

C'est un peu dommage je commencé à aimer linux mais je vais revoir ma copie et sans doute songer à regret de revenir sous windows malheureusement.

L'histoire était trop belle lolll tant pis


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#8 Le 23/03/2008, à 21:16

laurent111

Re : [Résolu]Problème d'install webcam Philips Toucam

je remonte mon post quelqu'un aurait il une solution ou un début de solution ?

après lecture sur différent forum il faut pwc je l'ai bien installé

Camorama ne fonctionne pas il me dit : Could not connect to vidéo device (dev/video0) please check connection

J'ai bien relu également un article dans un magasine linux pour l'installation des web cam, j'ai bien suivi les procédures mais je ne comprends pas pourquoi ça ne fonctionne pas du tout.

Pour info pwc et un module pour gérer les web cam Philips.

Je me demande si mon problème ne vient pas tout simplement de la distribution ubuntu qui pose problème sans doute par ça jeunesse. Peut-être devrais je changer de distrib et migrer vers une distrib prenant en charge les périphériques d'une façon plus efficace.

Bonne fête de Pâque

Dernière modification par laurent111 (Le 23/03/2008, à 21:20)


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#9 Le 24/03/2008, à 02:27

laurent111

Re : [Résolu]Problème d'install webcam Philips Toucam

laurent111 a écrit :

je remonte mon post quelqu'un aurait il une solution ou un début de solution ?

après lecture sur différent forum il faut pwc je l'ai bien installé

Camorama ne fonctionne pas il me dit : Could not connect to vidéo device (dev/video0) please check connection

J'ai bien relu également un article dans un magasine linux pour l'installation des web cam, j'ai bien suivi les procédures mais je ne comprends pas pourquoi ça ne fonctionne pas du tout.

Pour info pwc et un module pour gérer les web cam Philips.

Je me demande si mon problème ne vient pas tout simplement de la distribution ubuntu qui pose problème sans doute par ça jeunesse. Peut-être devrais je changer de distrib et migrer vers une distrib prenant en charge les périphériques d'une façon plus efficace.

Bonne fête de Pâque

Alors un début de solution pour ce qui est de

Could not connect to vidéo device (dev/video0) please check connection

il suffit de mettre :

sudo chmod 666 /dev/video0

et là camorama fonctionne

J'attends toujours de l'aide ou des infos pour le reste du moins un début de piste serait déjà pas mal


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#10 Le 24/03/2008, à 05:14

ReZiNuX

Re : [Résolu]Problème d'install webcam Philips Toucam

lol changer de distrib ne résoudra pas le problème car j'ai une Philips Toucam pro II et sur toutes les distro que j'ai eu le plaisir d'utiliser (Mandriva 2005 2006, Suse 9, Fedora 7 et actuellement Ubuntu 7.10) je n'ai jamais réussi à l'installer donc reste sous Ubuntu ça sera un soucis en moins.

Cependant l'idée d'utiliser ndiswrapper et assez étonnante puisqu'il s'agit d'un programme gérant les pilotes Windows sans fil.

Encore une chose, il faut ouvrir certains ports pour qu' aMsn puisse envoyer les images de la webcam. Ils l'expliquent très bien ici (en anglais tongue)
http://amsn.sourceforge.net/devwiki/tik … am+In+aMSN

j'essaye quelques trucs de mon coté et je te tiens au courant (je te promet rien ^^)

Dernière modification par ReZiNuX (Le 24/03/2008, à 05:14)

Hors ligne

#11 Le 24/03/2008, à 05:34

laurent111

Re : [Résolu]Problème d'install webcam Philips Toucam

ReZiNuX a écrit :

lol changer de distrib ne résoudra pas le problème car j'ai une Philips Toucam pro II et sur toutes les distro que j'ai eu le plaisir d'utiliser (Mandriva 2005 2006, Suse 9, Fedora 7 et actuellement Ubuntu 7.10) je n'ai jamais réussi à l'installer donc reste sous Ubuntu ça sera un soucis en moins.

Cependant l'idée d'utiliser ndiswrapper et assez étonnante puisqu'il s'agit d'un programme gérant les pilotes Windows sans fil.

Encore une chose, il faut ouvrir certains ports pour qu' aMsn puisse envoyer les images de la webcam. Ils l'expliquent très bien ici (en anglais tongue)
http://amsn.sourceforge.net/devwiki/tik … am+In+aMSN

j'essaye quelques trucs de mon coté et je te tiens au courant (je te promet rien ^^)

J'ai trouvé la solution c'est tout bête en fait vérifiez que vous êtes bien dans le groupe vidéo donc :

1- editer le fichier etc/group

sudo gedit /etc/group

chercher la ligne

video:x:44:

là, mette si ça n'est déjà fait, votre compte user exp

video:x:44:moncompte

attention si vous avez +++ compte les séparer par une virgule.

Ensuite redémarrer et voilà la philips est reconnu et tous fonctionne.

Ne pas oublier de mettre le chmod à 666 pour /dev/video0. Si j'ai un peu de temps je ferais bien un petit tuto pour la philips toucam. en revanche je ne sais pas comment l'on procède pour créer une doc ici.

Si quelqu'un peut me dire la marche à suivre et les règles à respecter.

Une doc sur cette webcam serait à mon sens utile et bénéfique pour tous. Finalement après deux jours de bidouillage ça fonctionne alors que les manips demandent moins de 10 min.

Voilà ReZiNuX on garde le contact si tu veux j'apprécie que tu essaies d'apporter une contrib constructive alors si on peu s'aider mutuellement dans la mesure de nos connaissances bien entendu. Je précise que je suis débutant sur linux mais pas en informatique.

Dernière modification par laurent111 (Le 24/03/2008, à 05:34)


Je refuse d'avoir une bataille d'esprits avec une personne non armée.

Kubuntu 8.10 - KDE4.1.0 - FF 3.0.4

Hors ligne

#12 Le 24/03/2008, à 23:38

philou1209

Re : [Résolu]Problème d'install webcam Philips Toucam

Moi aussi j'ai une toucam...

Faut-il la jeter au rebut ou existe t il  une solution?

Dernière modification par philou1209 (Le 24/03/2008, à 23:49)

Hors ligne

#13 Le 25/03/2008, à 23:48

ReZiNuX

Re : [Résolu]Problème d'install webcam Philips Toucam

Laurent111 je suis plus que ravis de ta proposition et bien sûr no problem restons en contact ^^

sinon de mon coter toujours pas de webcam détectée par aMsn mais elle l'est avec "lsusb" donc je pense que cela pourrait venir d' aMsn ou du module pwc que je vais réinstaller, j'ai tous les linux-headers donc ça vient pas de là.

et puis vu par ci par là qu'il faudrait patcher pwc selon la version du kernel je me penche sur le sujet

Pour répondre à Philou1209 non ne la jette pas lol
- Elle est reconnue via la commande lsusb ???
- Si oui vérifie si le module pwc et les linux-headers sont installés (via ton gestionnaire de packages tu devrais pouvoir le vérifier normalement)
- S'ils le sont pas installe les grace à ton gestionnaire de packages (Synaptic pour Ubuntu)
voilà bonne chance (si t'as des erreurs poste les)


c'est un plaisir de participer à ce post ^^

Dernière modification par ReZiNuX (Le 26/03/2008, à 00:06)

Hors ligne

#14 Le 05/05/2008, à 23:26

philou1209

Re : [Résolu]Problème d'install webcam Philips Toucam

Merci pour ta réponse! ;-)

Ok, maintenant j'ai ceci

Bus 007 Device 001: ID 0000:0000 
Bus 008 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 
Bus 006 Device 001: ID 0000:0000 
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 003: ID 05a9:0518 OmniVision Technologies, Inc. OV518 WebCam
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 001 Device 003: ID 046d:c512 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000 

Ensuite, que dois-je faire?

Hors ligne

#15 Le 12/05/2008, à 12:23

bihorece

Re : [Résolu]Problème d'install webcam Philips Toucam

Hello,

J'ai moi aussi une toucam 740.
J'essaie justement de l'installer sous Hardy.

Coup de chance, pas besoin de faire les manips de laurent111 concernant les droits de /dev/video0 et les groups.
J'ai donc bien l'image.

Gros bémol : pas de son. Je n'arrive pas a faire en sorte que le peripherique de capture soit la webcam.

Avez vous ce probleme ?
J'ai fait le test avec Skype et Kopete.

Merci pour vos réponses

Hors ligne

#16 Le 17/05/2008, à 20:29

ReZiNuX

Re : [Résolu]Problème d'install webcam Philips Toucam

Bonjour, Bihorece
pour te répondre franchement...
je n'ai pas la solution software,
mais heureusement...
j'ai la solution hardware : y'a des micros vraiment pas cher, environ 1.50€, dans les espaces culturels (Leclerc).

voilà tout ce que je peux te répondre

Hors ligne

#17 Le 17/05/2008, à 21:35

ginovanelli

Re : [Résolu]Problème d'install webcam Philips Toucam

avec n'importe quelle distribution que j'ai essayé que ce soit Mandriva , Ubuntu , Suse , ma Toucam Pro II est toujours reconnu sans faire aucune manip , donc je ne comprends vraiment pas ou se trouve votre problème

Hors ligne

#18 Le 15/06/2008, à 17:32

costakarl

Re : [Résolu]Problème d'install webcam Philips Toucam

Bonjour!

Pas de probleme avec mon Toucam sous Hardy/AMD64.  lsusb me donne:

Bus 003 Device 005: ID 15a9:0004 
Bus 003 Device 004: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 007: ID 0471:0311 Philips PCVC740K ToUcam Pro [pwc]
Bus 002 Device 005: ID 0c0b:27cb Dura Micro, Inc. (Acomdata) 6-in-1 Flash Reader and Writer
Bus 002 Device 004: ID 04a9:2204 Canon, Inc. CanoScan FB630U
Bus 002 Device 003: ID 04a9:1056 Canon, Inc. BJC-2110 Color Printer
Bus 002 Device 002: ID 0451:2046 Texas Instruments, Inc. TUSB2046 Hub
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 001: ID 0000:0000

et lsmod  me donne:
Module                  Size  Used by
snd_usb_audio         100384  1
snd_usb_lib            21120  1 snd_usb_audio
snd_hwdep              12552  1 snd_usb_audio
pwc                    92224  0
compat_ioctl32         11136  1 pwc
videodev               30720  1 pwc
v4l2_common            21888  2 compat_ioctl32,videodev
v4l1_compat            15492  1 videodev
ipv6                  311720  17
af_packet              27272  2
rfcomm                 47392  2
l2cap                  28800  13 rfcomm
bluetooth              67748  4 rfcomm,l2cap
ppdev                  11400  0

Parcontre j'ai eu bcp de misere avec un camera creative qui demande le OV511.