Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 27/02/2018, à 20:53

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Dommage, si tu connais des personnes qui peuvent m'apporter leurs aident n'hésite pas s'il te plaît !


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#27 Le 27/02/2018, à 22:44

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Complète déjà ton titre de discussion, en rajoutant  X206H.

Pas de son sur mon Notebook X206H

Pour éditer ta discussion et rajouter cette info, il faut utiliser le bouton Modifier au bas de ton premier message.

(edit=messages regroupés)

_ _ _

Quoique :

Le 20/08/2017, Etaif a écrit :

Merci xubu1957,

je viens de jouer le script et ca marche !

(edit=titre discussion actualisé) > [Résolu]carte son non prise en compte Asus x206h


ou alors :

Le 02/07/2016, Le_Menhir_n a écrit :

j'ai trouvé une alternative , j'ai emprunté une enceinte Bluetooth ( Phillips BT3010 ) et j'ai du son  via cette enceinte

mais toujours pas via les Haut-parleurs du pc , n'y la sortie casque .

si quelqu'un a une solution a me proposer je suis preneur

merci

> carte son non prise en compte Asus x206h

Dernière modification par xubu1957 (Le 22/04/2018, à 15:02)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#28 Le 27/02/2018, à 23:06

Nuliel

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Bonjour,

Quelques infos: j'ai remarqué dans le script https://github.com/Grippentech/Asus-E20 … h_sound.sh ce nom: chtcx2072x . Cela pourrait être utile pour faire des recherches.

Peux tu démarrer sur le noyau avec lequel tu as exécuté le script et donner le retour de

ls /usr/share/alsa/ucm/

afin de savoir si le script a fait son boulot?
Tu l'as testé sur quel noyau?

D'après https://github.com/Grippentech/Asus-E20 … all-Script , ce script n'est plus maintenu, il fonctionne pas après certaines versions du noyau. Notamment, d'après https://github.com/Grippentech/Asus-E20 … t/releases , le script sur le noyau 4.13, ça passe pas. Il est indiqué que ce script va sûrement arriver dans le noyau, je ne sais pas si c'est le cas.

Sinon, au cas où tu peux tenter le 1 de https://forum.ubuntu-fr.org/viewtopic.p … #p21874250
Edit: j'ai pas pensé à détailler ce dernier point, donc les commandes sont

echo "blacklist snd_hdmi_lpe_audio" | sudo tee /etc/modprobe.d/blacklist_snd_hdmi_lpe_audio.conf

et redémarrer

Dernière modification par Nuliel (Le 27/02/2018, à 23:16)


[ poster un retour de commande ] [ poster une photo ]
Thinkpad x220, Dell latitude E7270 (i7 6600U, 16 Go de RAM, ...), Thinkstation E32 modifié: i5-4570, GTX 1060 6 Gb, 16 Gb de RAM, ...
Mon nouveau blog: nuliel.fr

Hors ligne

#29 Le 28/02/2018, à 01:59

LeoMajor

Re : [Non Résolu] Pas de son sur mon Notebook X206H

bonjour,

lspci -nnk | sed -n '/\[04..\]/,/driver/p'

si c' est du snd_hda_intel, regarde de ce côté. D'habitude, je déconseille les PPA, mais à situation exceptionnelle ...

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt install oem-audio-hda-daily-lts-xenial-dkms

Hors ligne

#30 Le 28/02/2018, à 09:42

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Bonjour Naziel,

Voici un retour de ta 1ere commande :

minitux@minitux-E200HA:~$ ls /usr/share/alsa/ucm/
apq8064-tabla-snd-card  DB410c                      PandaBoard     tegraalc5632
broadwell-rt286         GoogleNyan                  PandaBoardES   tegra-rt5640
chtcx2072x              Manta-I2S                   PAZ00          Tuna
chtrt5645               Manta-SPDIF                 SDP4430        VEYRON-I2S
DAISY-I2S               msm8974-taiko-mtp-snd-card  skylake-rt286

Je l'ai essayé (je crois) sur le noyau 4.13 et 4.15 à vérifier car je l'ai indiqué plus haut dans les posts je débute sous Linux ! Et si on downgrade le noyau genre passe sur un noyau inférieur c'est grave ? Je viens de mettre la commande dans mon terminal et il répond ceci :

minitux@minitux-E200HA:~$ echo "blacklist snd_hdmi_lpe_audio" | sudo tee /etc/modprobe.d/blacklist_snd_hdmi_lpe_audio.conf
[sudo] Mot de passe de minitux : 
blacklist snd_hdmi_lpe_audio

Je vais redémarrer la machine et je te tiens au courant !

Edit : Le PC a redémarré, l'icone son n'est plus grisé MAIS toujours pas de son ... En revanche on avance surment car je peux monter et descendre le son...

Dernière modification par Minitux93 (Le 28/02/2018, à 09:46)


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#31 Le 28/02/2018, à 09:43

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Bonjour,

Naziel a écrit :

j'ai remarqué dans le script Grippentech/Asus, ce nom: chtcx2072x . Cela pourrait être utile pour faire des recherches.

@ Naziel

> bugs.launchpad.net/ubuntu/+source/linux No sound on Asus e200ha, intel sst with cx2072x codec.

et > how-to-build-the-driver-for-cx2072x-codec

Dernière modification par xubu1957 (Le 28/02/2018, à 09:46)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#32 Le 28/02/2018, à 09:46

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

xubu1957 a écrit :

Bonjour,

Naziel a écrit :

j'ai remarqué dans le script Grippentech/Asus, ce nom: chtcx2072x . Cela pourrait être utile pour faire des recherches.

@ Naziel

> bugs.launchpad.net/ubuntu/+source/linux No sound on Asus e200ha, intel sst with cx2072x codec.

et > how-to-build-the-driver-for-cx2072x-codec

Hello xubu1957,

Qu'est-ce que cela signifie ?


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#33 Le 28/02/2018, à 09:51

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Salut LeoMajor,

La première commande ne répond rien :

minitux@minitux-E200HA:~$ lspci -nnk | sed -n '/\[04..\]/,/driver/p'
minitux@minitux-E200HA:~$ 

Pour la seconde partie j'ai suivi les commandes et la réponse du terminal :

minitux@minitux-E200HA:~$ sudo apt install oem-audio-hda-daily-lts-xenial-dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet oem-audio-hda-daily-lts-xenial-dkms

Une solution à proposer ?


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#34 Le 28/02/2018, à 09:51

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

J'interpelle Naziel, je lui signale le bug connu pour le codec cx2072x et une piste de solution.

Naziel a des connaissances techniques, que je n'ai pas.

J'aide avec du prêt-à-porter, mais ne suis pas capable de faire du sur-mesure.

Il faut attendre son avis.

Dernière modification par xubu1957 (Le 28/02/2018, à 09:56)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#35 Le 28/02/2018, à 09:59

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

No problème xubu1957 j'essaye de comprendre en même temps mais je fais entièrement confiance aux gens de cette communauté, malheureusement si on ne trouve pas une solution mon PC va devoir retourner sous Windows car je ne peux pas me passer de son et que j'en ai rapidement besoin pour mes cours... Je trouvais l'idée et le concept de Linux assez génial, enfin une alternative à M$ et à ces logiciels hors de prix que l'on finit par télécharger illégalement. J'aime également pouvoir me dire que je peux personnaliser de A à Z mon système comme bon me semble et enfin j'ai réellement l'impression d'avoir pour la 1ere fois la main sur mon ordinateur. Il ne s'autorise pas des choses seul sans que je lui en commande l'action.
Donc même si on ne trouve pas, je suis contente de voir que des alternatives existent dommage que mon PC soit si capricieux...


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#36 Le 28/02/2018, à 10:06

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

J'avais trouvé chez nos confrères (pour des pilotes wifi) : https://wiki.debian.org/fr/WiFi, les informations suivantes :

Ce sont les sociétés qui refusent - ou sont incapables - de coopérer avec la communauté des logiciels libres qui produisent des pilotes ou des firmwares non-libres. Avec les pilotes ou les firmwares non-libres la prise en charge des périphériques n'est pas toujours disponible ou alors sévèrement restreinte. Par exemple toutes les fonctionnalités ne sont pas toujours disponibles, les bogues ne sont pas corrigés et ce qui est pris en charge par le fabricant est fugace.
(...)

Si ASUS ne fournit pas les informations aux développeurs Linux, on retrouve la même difficulté, pour les pilotes des cartes sons.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#37 Le 28/02/2018, à 10:07

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Là j'essaye de donwgrade mon noyau je passe de 4.15.5 à 4.11.0 nous verrons bien si le son apparaît.


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#38 Le 28/02/2018, à 10:09

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

xubu1957 a écrit :

J'avais trouvé chez nos confrères (pour des pilotes wifi) : https://wiki.debian.org/fr/WiFi, les informations suivantes :

Ce sont les sociétés qui refusent - ou sont incapables - de coopérer avec la communauté des logiciels libres qui produisent des pilotes ou des firmwares non-libres. Avec les pilotes ou les firmwares non-libres la prise en charge des périphériques n'est pas toujours disponible ou alors sévèrement restreinte. Par exemple toutes les fonctionnalités ne sont pas toujours disponibles, les bogues ne sont pas corrigés et ce qui est pris en charge par le fabricant est fugace.
(...)

Si ASUS ne fournit pas les informations aux développeurs Linux, on retrouve la même difficulté, pour les pilotes des cartes sons.

Ouais mais tu es bien d'accord avec moi ça devient dramatique et il faut clairement boycotter les marques qui font ça ! Nous sommes en droit de refuser d'utiliser Windows. Si demain pour une raison X ou Y Microsoft ne me correspond plus je suis en droit d'aller voir ailleurs. En revanche je paie la marque pour acheter son matériel, elle a un contrat moral avec le client et doit lui apporter une certaine garantie et sécurité...


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#39 Le 28/02/2018, à 10:18

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Tu as un ordi moderne, je suis venu sur Linux pour continuer à faire marcher des machines qui tournaient auparavant sur XP !

J'aide en section Wifi, et je galère avec les nouveaux pilotes wifi.

En revanche je paie la marque pour acheter son matériel, elle a un contrat moral avec le client

Le fabricant, ne se préoccupe pas toujours d'une compatibilité Linux, si l'ordi est vendu avec une licence W$.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#40 Le 28/02/2018, à 10:26

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Je viens de changer le noyau cela ne change rien à mon problème toujours pas de son ... Pour le fabricant c'est de la connerie total, je fais bien ce que je veux de mon ordinateur... Il devrait y avoir des programmes pour obliger les constructeurs de machine à communiquer sur leurs matériels...


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#41 Le 28/02/2018, à 10:31

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

C'est des histoires de gros sous.

Ton ordi fonctionne en W$, le fabricant a rempli son contrat.

Tes choix personnels ne sont pas un impératif, pour des marchands.

because :

peripetie a écrit :

Pas vraiment une blague mais vécu aujourd'hui chez Darty ou j'ai été chercher une souris. Il y avait une cliente casse-pied déterminée qui ramenait l'ultra portable qu'elle avait reçu à Noël. Elle ne comprenait visiblement rien à Windows 8, avait quand même un peu cherché sur Google et s'était forgé son idée: c'était l'OS qui n'était pas bon.
Le pauvre vendeur déployait des trésors de patience et de gentillesse pour lui expliquer comment ça marchait, ou trouver le bureau, lui montrait ou étaient les applications, mais elle ne voulait en démordre, l'interrompait sans cesse, l'enguirlandait, etc... À un moment elle lui sort tout de go:
"Mais puisque je vous dit que c'est l'OS ! C'est quand même pas dur à comprendre ? J'en veux un autre ! Vendez-moi un meilleur OS !"
Et là le vendeur visiblement excédé intérieurement:
"Un meilleur OS ? Ah oui ça existe mais c'est gratuit !"
Pas pu m'empêcher d'éclater de rire...

> [VOTRE topic] Toutes vos blagues sur Microsoft/Windows. Lâchez-vous !

Dernière modification par xubu1957 (Le 28/02/2018, à 10:41)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#42 Le 28/02/2018, à 10:42

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

xubu1957 a écrit :

C'est des histoires de gros sous.

Ton ordi fonctionne en W$, le fabricant a rempli son contrat.

Tes choix personnels ne sont pas un impératif, pour des marchands.

Il y a des marques qui sont plus tolérante et qui travaillent avec Linux ou du moins qui partagent leurs infos sur le matériel pour que celui-ci soit compatible avec Linux ?

Je sais maintenant que je vais arrêter d'acheter ASUS. Mon copain vient de prendre un LENOVO il n'a aucun problème tout est parfaitement reconnu j'en jalouse presque ^^'


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#43 Le 28/02/2018, à 10:44

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

J'ai édité le #42. wink

Il y des discussions sur le forum où l'on conseille d'acheter d'occasion, des ordinateurs professionnels reconditionnés.

Dernière modification par xubu1957 (Le 28/02/2018, à 10:47)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#44 Le 28/02/2018, à 10:57

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Je viens de voir smile

Acheter d'occasion ici en Belgique ce n'est pas le top. Il n'y a pas vraiment de personnes spécialisés c'est HappyCash ou CashConverters qui s'occupe de ça et franchement le service est peu convaincant ...


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#45 Le 28/02/2018, à 11:00

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Et par correspondance ?

Le 16/10/2017, Caribou22 a écrit :

Bonjour smile

Je suis tombé sur cette liste depuis l'accueil du site, qui liste les revendeurs de PC sous Ubuntu et autres distributions Linux : https://doc.ubuntu-fr.org/ordinateur_vendu_avec_ubuntu

Je pensais la compléter par les revendeurs d'ordinateurs reconditionnés qui proposent Ubuntu et autres distributions. Beaucoup d'entre eux le font big_smile

Voici une liste non-exhaustive de ces revendeurs : https://debian-facile.org/viewtopic.php?id=14562
Une fois un tri fait de ceux qui proposent Ubuntu, est-ce que leur intégration à la liste serait possible ? smile


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#46 Le 28/02/2018, à 11:06

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Oui à la limite par correspondance mais bon pour le moment j'ai celui-ci tout neuf et franchement j'aimerai le faire fonctionner... Il n'y a vraiment aucune solution pour résoudre ce tout petit problème :x ?

Edit : L'enceinte en Bluetooth ou le casque en Bluetooth ne fonctionnent pas non plus... Je commence à désespérer !

Dernière modification par Minitux93 (Le 28/02/2018, à 11:07)


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#47 Le 28/02/2018, à 11:11

xubu1957

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Je n'ai pas de solution immédiate, attends des réponses d'autres intervenants, tu as posté hier à 17 heures.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#48 Le 28/02/2018, à 11:47

Nuliel

Re : [Non Résolu] Pas de son sur mon Notebook X206H

D'après le premier retour, le script a visiblement été bien lancé, donc c'est déjà une bonne chose.
Peux tu aller dans alsamixer et dire ce qui apparaît comme carte (je t'ai fait blacklister celle en rapport avec l'HDMI, donc elle n'apparaîtra plus normalement). Et toujours dans alsamixer, tu peux faire F6 (ou touche windows+F6 si F6 est une touche associée à une action comme couper le son) afin de voir la liste des cartes proposées.

La carte son n'est pas listée dans lspci et je pense pas dans lsusb car elle n'est ni branchée en pci, ni en usb. J'ai l'impression que c'est la nouvelle mode chez les constructeurs d'utiliser des ports jusqu'à ce jour inconnus... (une carte wifi sur un port SD amélioré, ...).

Et  tu peux donner le retour de

dmesg | grep intel_sst_acpi

Edit: et tu peux faire tes mises à jour, redémarrer et réessayer https://forum.ubuntu-fr.org/viewtopic.php?id=2013441 . Pourquoi pas tester un noyau plus ancien, mais je préfèrerais plutôt passer par les dépôts que par ukuu.

Dernière modification par Nuliel (Le 28/02/2018, à 11:50)


[ poster un retour de commande ] [ poster une photo ]
Thinkpad x220, Dell latitude E7270 (i7 6600U, 16 Go de RAM, ...), Thinkstation E32 modifié: i5-4570, GTX 1060 6 Gb, 16 Gb de RAM, ...
Mon nouveau blog: nuliel.fr

Hors ligne

#49 Le 28/02/2018, à 14:58

Minitux93

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Re Naziel;

Commande retour concernant alsamixer :

minitux@minitux-E200HA:~$ alsamixer
le mixeur ne peut pas être ouvert: Aucun fichier ou dossier de ce type

Voici pour la seconde commande :

minitux@minitux-E200HA:~$ dmesg | grep intel_sst_acpi
[    6.446003] intel_sst_acpi 808622A8:00: No matching machine driver found

J'ai déjà testé la procédure de ton lien, ça n'a rien donné ! Et changer de noyau j'y est déjà pensé se matin je l'ai fait et toujours rien. Regarde les messages plus haut tu verras les traces de se qui a été fait.


- Actuellement sous (x)Ubuntu 17.10 Windows 10

Hors ligne

#50 Le 28/02/2018, à 15:02

Nuliel

Re : [Non Résolu] Pas de son sur mon Notebook X206H

Tu peux donner le retour

dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t

afin de savoir quels sont les noyaux installés (et donc essayés)

Dernière modification par Nuliel (Le 28/02/2018, à 15:09)


[ poster un retour de commande ] [ poster une photo ]
Thinkpad x220, Dell latitude E7270 (i7 6600U, 16 Go de RAM, ...), Thinkstation E32 modifié: i5-4570, GTX 1060 6 Gb, 16 Gb de RAM, ...
Mon nouveau blog: nuliel.fr

Hors ligne