Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 12/06/2019, à 17:03

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Salut,

cqfd93 a écrit :

Bonjour,

fazpedro a écrit :
…et 24 non mis à jour.

Il faudrait peut-être faire les mises à jour…

++1

Hors ligne

#27 Le 12/06/2019, à 18:09

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

La mise à jour est à priori cassée ?
Que faire ?
Merci

$ sudo apt-get update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu disco InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu disco-updates InRelease                                        
Atteint :3 http://fr.archive.ubuntu.com/ubuntu disco-backports InRelease                                      
Ign :4 http://ppa.launchpad.net/deluge-team/ppa/ubuntu disco InRelease                                        
Err :5 http://ppa.launchpad.net/deluge-team/ppa/ubuntu disco Release                                          
  404  Not Found [IP :]
Réception de :6 http://security.ubuntu.com/ubuntu disco-security InRelease [97,5 kB]
Lecture des listes de paquets... Fait                         
E: Le dépôt http://ppa.launchpad.net/deluge-team/ppa/ubuntu disco Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

Dernière modification par fazpedro (Le 12/06/2019, à 18:10)

Hors ligne

#28 Le 12/06/2019, à 19:57

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Salut,

Le ppa deluge-team ne fournit pas de paquets pour la 19.04, et en plus ne semble plus mis à jour depuis un an déjà ?

Il faut le retirer de tes sources.

La commande suivante devrait le faire:

sudo add-apt-repository --remove ppa:deluge-team/ppa

La doc sur la gestion des ppa: ppa

A+

Dernière modification par ylag (Le 12/06/2019, à 20:19)

Hors ligne

#29 Le 12/06/2019, à 20:31

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

C'est fait... à priori pas de changement ?
Merci

$ sudo add-apt-repository --remove ppa:deluge-team/ppa
 Deluge Stable Release Packages
This repository contains packages for the latest stable releases of Deluge and stable libtorrent releases.
For more information, visit http://deluge-torrent.org
As the maintainer of this PPA, you can now support me on Patreon: https://www.patreon.com/deluge_cas
 Plus d’info : https://launchpad.net/~deluge-team/+archive/ubuntu/ppa
Appuyez sur [ENTRÉE] pour continuer ou sur Ctrl-c pour annuler la suppression.
$ sudo apt-get update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu disco InRelease
Réception de :2 http://fr.archive.ubuntu.com/ubuntu disco-updates InRelease [97,5 kB]
Atteint :3 http://fr.archive.ubuntu.com/ubuntu disco-backports InRelease
Réception de :4 http://security.ubuntu.com/ubuntu disco-security InRelease [97,5 kB]
Réception de :5 http://fr.archive.ubuntu.com/ubuntu disco-updates/main amd64 Packages [158 kB]
Réception de :6 http://fr.archive.ubuntu.com/ubuntu disco-updates/main i386 Packages [142 kB]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu disco-updates/universe i386 Packages [207 kB]
Réception de :8 http://fr.archive.ubuntu.com/ubuntu disco-updates/universe amd64 Packages [208 kB]
909 ko réceptionnés en 1s (971 ko/s)                     
Lecture des listes de paquets... Fait
$ sudo sane-find-scanner
  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.
  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.
found USB scanner (vendor=0x04a9 [Canon], product=0x1795 [G2000 series]) at libusb:002:003
found USB scanner (vendor=0x0bda [Generic], product=0x0129 [USB2.0-CRW]) at libusb:001:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
  # Not checking for parallel port scanners.
  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
$ sudo scanimage -L
Error my backend :	out of memory
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
$ 

Hors ligne

#30 Le 12/06/2019, à 21:41

xubu1957

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#31 Le 12/06/2019, à 22:18

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

@xubu1957:

Salut,

Tu penses à une règle udev ?
Je l'aurais suggéré si l'appareil avait été détecté par la commande:

sudo scanimage -L

C'est peut-être quand-même une piste à suivre...

A+

Hors ligne

#32 Le 12/06/2019, à 22:21

xubu1957

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Dans le #1,il ressortait :

:~$ sudo sane-find-scanner -q
found USB scanner (vendor=0x04a9 [Canon], product=0x1795 [G2000 series]) at libusb:002:003
found USB scanner (vendor=0x0bda [Generic], product=0x0129 [USB2.0-CRW]) at libusb:001:004
:~$ sudo gedit /lib/udev/rules.d/60-libsane.rules

Les règles udev étaient vides !

_ _ _

Et vu la Doc > scanner#probleme_connu, c'est pas simple !

Dernière modification par xubu1957 (Le 12/06/2019, à 22:26)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#33 Le 12/06/2019, à 22:29

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Salut,

xubu1957 a écrit :

Les règles udev étaient vides !

smile Pas nécessairement: Vu que @fazpedro a ouvert le fichier dans gedit (par un sudo gedit -> sad ) le contenu éventuel se serait affiché dans une fenêtre graphique gedit et non dans le terminal.

Une règle udev qui pourrait faire l'affaire pour cet appareil:

SUBSYSTEM=="usb", ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="1795", MODE="0666", GROUP="scanner", ENV{libsane_matched}="yes"

...que je mettrais dans: /etc/udev/rules.d/79-g2510.rules, par exemple ?

Note: Je ne suis pas certain que les entrées SUBSYSTEM, MODE et GROUP soient correctes ou même nécessaires.

Passer ensuite cette commande pour recharger les règles udev: (ou redémarrer)

sudo udevadm control --reload-rules && udevadm trigger

A+

Dernière modification par ylag (Le 03/08/2019, à 17:28)

Hors ligne

#34 Le 12/06/2019, à 22:58

xubu1957

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

@ylag

En théorie, le scanner devrait fonctionner d'après les échanges dans cette discussion > [Résolu] Multifonction Canon MG3650.

Mais entre la théorie et la pratique ! roll


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#35 Le 13/06/2019, à 12:35

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

@fazpedro:

Salut,

xubu1957, au #32 a écrit :

Et vu la Doc > scanner#probleme_connu, c'est pas simple !

Faudrait voir le retour complet de:

ls -l /usr/lib/sane/libsane-*

...et de:

ls -l /usr/lib/x86_64-linux-gnu/libsane-*

...pour voir s'il n'y aurait pas lieu de créer des liens symboliques de /usr/lib/sane vers /usr/lib/x86_64-linux-gnu/sane, si c'est encore pertinent sur la 19.04 ?

A+

Dernière modification par ylag (Le 13/06/2019, à 14:52)

Hors ligne

#36 Le 13/06/2019, à 17:24

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Voici :

$ ls -l /usr/lib/sane/libsane-*
ls: impossible d'accéder à '/usr/lib/sane/libsane-*': Aucun fichier ou dossier de ce type
$ ls -l /usr/lib/x86_64-linux-gnu/libsane-*
ls: impossible d'accéder à '/usr/lib/x86_64-linux-gnu/libsane-*': Aucun fichier ou dossier de ce type
$ sudo udevadm control --reload-rules && udevadm trigger
$ sudo scanimage -L
Error my backend :	out of memory
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
$ 

Hors ligne

#37 Le 13/06/2019, à 17:50

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Salut,

Après le passage à la 19.04, il faut sûrement avant toutes choses installer un pilote pour le scanner ?

A+

Dernière modification par ylag (Le 13/06/2019, à 18:01)

Hors ligne

#38 Le 13/06/2019, à 17:55

LeoMajor

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

bonjour,

sudo add-apt-repository ppa:thierry-f/fork-michael-gruz
:~$  aptitude search '~Ofork-michael-gruz (pixma|~dpixma|~d2[0-9]{3}|2[0-9]{3}) ~ramd64'
p   cnijfilter-ip2800series                                                              - IJ Printer Driver for Linux.                                                                  
p   cnijfilter-mg2100series                                                              - IJ Printer Driver for Linux.                                                                  
p   cnijfilter-mg2200series                                                              - IJ Printer Driver for Linux.                                                                  
p   cnijfilter-mg2400series                                                              - IJ Printer Driver for Linux.                                                                  
p   cnijfilter-mg2500series                                                              - IJ Printer Driver for Linux.                                                                  
p   scangearmp-mg2100series                                                              - ScanGear MP for Linux.                                                                        
p   scangearmp-mg2200series                                                              - ScanGear MP for Linux.                                                                        
p   scangearmp-mg2400series                                                              - ScanGear MP for Linux.                                                                        
p   scangearmp-mg2500series                                                              - ScanGear MP for Linux.  
sudo apt/aptitude install cnijfilter-mg2500series scangearmp-mg2500series

Hors ligne

#39 Le 13/06/2019, à 20:38

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Voila :

$ sudo add-apt-repository ppa:thierry-f/fork-michael-gruz
 Fork of the PPA : https://launchpad.net/~michael-gruz/+archive/ubuntu/canon-trunk
To make it available for new distributions.

Official drivers of Canon printers and multifunction devices, included versions 2.20 and newer (2.4, 2.5, 2.6, 2.7, 2.8, 2.9, 3.0, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8)
 Plus d’info : https://launchpad.net/~thierry-f/+archive/ubuntu/fork-michael-gruz
Appuyez sur [ENTRÉE] pour continuer ou sur Ctrl-c pour annuler l'ajout.

Atteint :1 http://fr.archive.ubuntu.com/ubuntu disco InRelease
Réception de :2 http://fr.archive.ubuntu.com/ubuntu disco-updates InRelease [97,5 kB]                         
Atteint :3 http://fr.archive.ubuntu.com/ubuntu disco-backports InRelease                                      
Réception de :4 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco InRelease [15,9 kB]         
Réception de :5 http://security.ubuntu.com/ubuntu disco-security InRelease [97,5 kB]                          
Réception de :6 http://fr.archive.ubuntu.com/ubuntu disco-updates/main i386 Packages [145 kB]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu disco-updates/main amd64 Packages [162 kB]
Réception de :8 http://fr.archive.ubuntu.com/ubuntu disco-updates/main Translation-en [64,0 kB]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu disco-updates/universe amd64 Packages [214 kB]
Réception de :10 http://fr.archive.ubuntu.com/ubuntu disco-updates/universe i386 Packages [214 kB]
Réception de :11 http://fr.archive.ubuntu.com/ubuntu disco-updates/universe Translation-en [54,8 kB]
Réception de :12 http://fr.archive.ubuntu.com/ubuntu disco-updates/multiverse i386 Packages [1340 B]
Réception de :13 http://fr.archive.ubuntu.com/ubuntu disco-updates/multiverse amd64 Packages [1172 B]
Réception de :14 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco/main amd64 Packages [11,9 kB]
Réception de :15 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco/main i386 Packages [20,7 kB]
Réception de :16 http://security.ubuntu.com/ubuntu disco-security/multiverse i386 Packages [1340 B]         
Réception de :17 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco/main Translation-en [1404 B]
Réception de :18 http://security.ubuntu.com/ubuntu disco-security/multiverse amd64 Packages [1172 B]
1103 ko réceptionnés en 1s (919 ko/s)     
Lecture des listes de paquets... Fait
$ aptitude search '~Ofork-michael-gruz (pixma|~dpixma|~d2[0-9]{3}|2[0-9]{3}) ~ramd64'

La commande « aptitude » n'a pas été trouvée, mais peut être installée avec :

sudo apt install aptitude

$ sudo apt install aptitude
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  aptitude-common libcwidget3v5 libxapian30
Paquets suggérés :
  aptitude-doc-en | aptitude-doc apt-xapian-index debtags tasksel libcwidget-dev xapian-tools
Les NOUVEAUX paquets suivants seront installés :
  aptitude aptitude-common libcwidget3v5 libxapian30
0 mis à jour, 4 nouvellement installés, 0 à enlever et 27 non mis à jour.
Il est nécessaire de prendre 4020 ko dans les archives.
Après cette opération, 18,3 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de :1 http://fr.archive.ubuntu.com/ubuntu disco/universe amd64 aptitude-common all 0.8.11-3ubuntu1 [1710 kB]
Réception de :2 http://fr.archive.ubuntu.com/ubuntu disco/universe amd64 libcwidget3v5 amd64 0.5.17-11 [303 kB]
Réception de :3 http://fr.archive.ubuntu.com/ubuntu disco/universe amd64 libxapian30 amd64 1.4.10-1 [672 kB]
Réception de :4 http://fr.archive.ubuntu.com/ubuntu disco/universe amd64 aptitude amd64 0.8.11-3ubuntu1 [1335 kB]
4020 ko réceptionnés en 0s (9785 ko/s)
Sélection du paquet aptitude-common précédemment désélectionné.
(Lecture de la base de données... 209356 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../aptitude-common_0.8.11-3ubuntu1_all.deb ...
Dépaquetage de aptitude-common (0.8.11-3ubuntu1) ...
Sélection du paquet libcwidget3v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libcwidget3v5_0.5.17-11_amd64.deb ...
Dépaquetage de libcwidget3v5:amd64 (0.5.17-11) ...
Sélection du paquet libxapian30:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libxapian30_1.4.10-1_amd64.deb ...
Dépaquetage de libxapian30:amd64 (1.4.10-1) ...
Sélection du paquet aptitude précédemment désélectionné.
Préparation du dépaquetage de .../aptitude_0.8.11-3ubuntu1_amd64.deb ...
Dépaquetage de aptitude (0.8.11-3ubuntu1) ...
Paramétrage de libcwidget3v5:amd64 (0.5.17-11) ...
Paramétrage de libxapian30:amd64 (1.4.10-1) ...
Paramétrage de aptitude-common (0.8.11-3ubuntu1) ...
Paramétrage de aptitude (0.8.11-3ubuntu1) ...
update-alternatives: utilisation de « /usr/bin/aptitude-curses » pour fournir « /usr/bin/aptitude » (aptitude) en mode automatique
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.29-0ubuntu2) ...
$ aptitude search '~Ofork-michael-gruz (pixma|~dpixma|~d2[0-9]{3}|2[0-9]{3}) ~ramd64'
p   cnijfilter-ip2800series                                                                                                         - IJ Printer Driver for Linux.                                                                                                             
p   cnijfilter-mg2100series                                                                                                         - IJ Printer Driver for Linux.                                                                                                             
p   cnijfilter-mg2200series                                                                                                         - IJ Printer Driver for Linux.                                                                                                             
p   cnijfilter-mg2400series                                                                                                         - IJ Printer Driver for Linux.                                                                                                             
p   cnijfilter-mg2500series                                                                                                         - IJ Printer Driver for Linux.                                                                                                             
p   scangearmp-mg2100series                                                                                                         - ScanGear MP for Linux.                                                                                                                   
p   scangearmp-mg2200series                                                                                                         - ScanGear MP for Linux.                                                                                                                   
p   scangearmp-mg2400series                                                                                                         - ScanGear MP for Linux.                                                                                                                   
p   scangearmp-mg2500series                                                                                                         - ScanGear MP for Linux.                                                                                                                   
$ sudo apt/aptitude install cnijfilter-mg2500series scangearmp-mg2500series
sudo: apt/aptitude : commande introuvable
$ sudo aptitude install cnijfilter-mg2500series scangearmp-mg2500series
Les NOUVEAUX paquets suivants vont être installés :     
  cnijfilter-common{a} cnijfilter-mg2500series scangearmp-common{a} scangearmp-mg2500series 
0 paquets mis à jour, 4 nouvellement installés, 0 à enlever et 27 non mis à jour.
Il est nécessaire de télécharger 1188 ko d'archives. Après dépaquetage, 4481 ko seront utilisés.
Voulez-vous continuer ? [Y/n/?] Y
Prendre :  1 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco/main amd64 cnijfilter-common amd64 4.10+3.5.4-1904ubuntu1 [149 kB]
Prendre :  2 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco/main amd64 cnijfilter-mg2500series amd64 4.10+3.5.4-1904ubuntu1 [483 kB]
Prendre :  3 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco/main amd64 scangearmp-common amd64 2.30.1-1904+1ubuntu3 [326 kB]
Prendre :  4 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu disco/main amd64 scangearmp-mg2500series amd64 2.30.1-1904+1ubuntu3 [230 kB]
 1188 ko téléchargés en 1s (1990 ko/s)         
Sélection du paquet cnijfilter-common précédemment désélectionné.
(Lecture de la base de données... 209535 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../cnijfilter-common_4.10+3.5.4-1904ubuntu1_amd64.deb ...
Dépaquetage de cnijfilter-common (4.10+3.5.4-1904ubuntu1) ...
Sélection du paquet cnijfilter-mg2500series précédemment désélectionné.
Préparation du dépaquetage de .../cnijfilter-mg2500series_4.10+3.5.4-1904ubuntu1_amd64.deb ...
Dépaquetage de cnijfilter-mg2500series (4.10+3.5.4-1904ubuntu1) ...
Sélection du paquet scangearmp-common précédemment désélectionné.
Préparation du dépaquetage de .../scangearmp-common_2.30.1-1904+1ubuntu3_amd64.deb ...
Dépaquetage de scangearmp-common (2.30.1-1904+1ubuntu3) ...
Sélection du paquet scangearmp-mg2500series précédemment désélectionné.
Préparation du dépaquetage de .../scangearmp-mg2500series_2.30.1-1904+1ubuntu3_amd64.deb ...
Dépaquetage de scangearmp-mg2500series (2.30.1-1904+1ubuntu3) ...
Paramétrage de scangearmp-common (2.30.1-1904+1ubuntu3) ...
Paramétrage de scangearmp-mg2500series (2.30.1-1904+1ubuntu3) ...
Paramétrage de cnijfilter-common (4.10+3.5.4-1904ubuntu1) ...
Paramétrage de cnijfilter-mg2500series (4.10+3.5.4-1904ubuntu1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.32.0-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.29-0ubuntu2) ...
                                                        
$ sudo scanimage -L
Error my backend :	out of memory

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
$ scangearmp2
$ 

Dernière modification par fazpedro (Le 13/06/2019, à 20:38)

Hors ligne

#40 Le 13/06/2019, à 20:52

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Salut,

Vu au comentaire #1:

found USB scanner (vendor=0x04a9 [Canon], product=0x1795 [G2000 series]) at libusb:002:003

Est-ce que le paquet scangearmp-mg2500series est compatible avec cet appareil?

D'après ce site: SANE supported devices

Extrait du site cité plus haut:

PIXMA G2000     USB     0x04a9/0x1795     Complete     All resolutions supported (up to 600DPI).     pixma
(0.23.0)     sane-pixma

...la machine devrait être supportée  par sane via le "backend" pixma ?

Dans cette discussion: [sane-devel] Canon Pixma G2000 support, il est suggéré de renseigner l'appareil dans le fichier /etc/sane.d/pixma.conf; cette commande devrait le faire:

echo "usb 0x04a9 0x1795" | sudo tee -a /etc/sane.d/pixma.conf

Ensuite vérifier qu'il y ait une ligne non-commentée avec le mot pixma dans le fichier /etc/sane.d/dll.conf; je crois que c'est le cas dans le fichier par défaut, mais ça ne fait pas de mal de vérifier. Peut-être suivre d'un redémarrage et voir si simple-scan et/ou xsane reconnaissent alors l'appareil ?

Si ça ne fonctionne toujours pas, retire la ligne ajoutée dans /etc/sane.d/pixma.conf.

A+

Dernière modification par ylag (Le 13/06/2019, à 22:41)

Hors ligne

#41 Le 16/06/2019, à 14:55

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

hélas cela n'a rien changé après le redémarrage... et pourtant il y a bien pixma non commentée dans le fichier dll.conf...

$ echo "usb 0x04a9 0x1795" | sudo tee -a /etc/sane.d/pixma.conf
usb 0x04a9 0x1795
$ sudo scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
$ 

Hors ligne

#42 Le 02/08/2019, à 22:26

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Up

Hors ligne

#43 Le 02/08/2019, à 23:04

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Bonsoir,

Si ce retour de lsusb est toujours pertinent:

Bus 002 Device 003: ID 04a9:1795 Canon, Inc.

....pourrais-tu donner le retour de:

ls -l /dev/bus/usb/002/003

Ça pourrait donner des indications pour la création d'une règle udev appropriée, voir ce tuto: scanner-udev-rule

A+

Dernière modification par ylag (Le 02/08/2019, à 23:08)

Hors ligne

#44 Le 03/08/2019, à 15:54

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Bonjour ylag,

voici :
merci d'avance,

$ ls -l /dev/bus/usb/002/003
crw-rw-rw-+ 1 root lp 189, 130 août   3 15:51 /dev/bus/usb/002/003

Hors ligne

#45 Le 03/08/2019, à 16:10

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Salut,

Si pas déjà fait, efface le fichier suggéré au commentaire #33:

sudo rm /etc/udev/rules.d/79-g2510.rules

Pour le remplacer avec un autre que tu pourrais nommer: /etc/udev/rules.d/99-g2510.rules, avec pour contenu:

SUBSYSTEMS=="usb", ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1795", GROUP="lp", MODE="0666"

...redémarre ensuite pour s'assurer que tout soit pris en compte.

Vérifie que ton utilisateur fasse partie du groupe lp

Si ça ne marche toujours pas, efface ce fichier.
Je n'aurai alors pas d'autres propositions à faire et il te faudra attendre d'autres intervenant(e)s, désolé...

Ajout: Il y a ce retour généré par la commande scanimage -L qui me semble fort énigmatique:

$ sudo scanimage -L
Error my backend :	out of memory

...je ne trouve rien concernant ce message, hmm

A+

Dernière modification par ylag (Le 03/08/2019, à 19:07)

Hors ligne

#46 Le 03/08/2019, à 19:24

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Bonsoir,

Est-ce que le paquet libtiff4 serait encore requis sous la 19.04 ?
Voir là: problemes_de_dependances_libtiff4
Ajout: Ce lien a été proposé par @xubu1957 au commentaire #2.

A+

Dernière modification par ylag (Le 03/08/2019, à 21:54)

Hors ligne

#47 Le 03/08/2019, à 22:17

fazpedro

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

ça fonctionne toujours pas :

$sudo sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1795 [G2000 series]) at libusb:002:003
found USB scanner (vendor=0x0bda [Generic], product=0x0129 [USB2.0-CRW]) at libusb:001:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
$ sudo scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
$ 

Hors ligne

#48 Le 03/08/2019, à 22:40

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Bonsoir,

As-tu installé le paquet libtiff4 ?

Donne aussi le retour de:

sudo find / -name libsane-canon*

A+

Hors ligne

#49 Le 03/08/2019, à 22:45

xubu1957

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

Bonjour,

@ylag

Au #21 :

scangearmp2 est déjà la version la plus récente (3.40-1).

dans cette discussion de janvier 2018 > Imprimante Canon TS3100 on voit :

ii  scangearmp2                                3.50-1                                       amd64        ScanGear MP for Linux.

Comment récupérer une version récente ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#50 Le 03/08/2019, à 23:02

ylag

Re : [RESOLU] Canon Pixma G2510 et ubuntu 19.04

@xubu1957:

Bonsoir,

Peut-être via un ppa ?  Thierry Ordissimo

Est-ce pertinent de le faire ?

A+

Dernière modification par ylag (Le 03/08/2019, à 23:03)

Hors ligne