Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/09/2019, à 12:08

Tinou44

Témoignage Snap, Flatpak, paquets Deb avec Gimp

Bonjour,
Je voulais témoigner de ma découverte, pour le moins désagréable et déconcertante , des méthodes Snap et Flatpak pour l'installation de logiciels.

Je suis sous Xubuntu 18.04 et voulais simplement installer Gimp. Je résume d'abord ce à quoi je suis arrivée avant d'expliquer le comment:

- Installation via Snap:  gimp 2.10 avec impossibilité d'accéder à mes deux disques durs supplémentaires (sdb, sdc) là où j'ai justement mon répertoire photos...

- Installation via Flatpak: gimp 2.10, l'accès aux disques est ok mais le lanceur ne trouve pas Gimp dans la liste des logiciels et il faut lancer à la main dans un terminal "$ flatpak run org.gimp.GIMP//stable" sad

- Installation via les dépots "classiques" ($ apt-get install gimp): gimp 2.8 . Tout marche nickel mais avec une "vieille" version.

Au départ, j'utilise logiciels pour installer Gimp. Bizarrement je vois  deux fois Gimp dans la liste proposée. Comme pour l'un, le descriptif est en anglais, je choisis celui en français. L'install se passe sans soucis mais quand je veux l'utiliser, je m'aperçois qu'il ne voit pas mes deux disques supplémentaires (/dev/sdb et /dev/sdc). Après beaucoup de recherches, je tombe sur un fil où il est question de Snap (dont je découvre l'existence) et de difficulté d'accès sur disque externe. Je soupçonne que j'approche du problème. J'essaye d'abord de comprendre ce qu'est Snap (donc encore pas mal de temps sur des forums...) et finit par comprendre que sur les deux logiciels proposés dans ma liste , il s'agit pour l'un d'une méthode d'install avec Snap, et pour l'autre avec les dépôts. Je désinstalle la version via snap et réinstalle Gimp classiquement avec les dépôts. Là c'est ok pour mes disques, sauf que je suis en 2.8. Personnellement, je n'ai pas spécialement besoin de la 2.10 mais mon compagnon débute et aime autant démarrer sur la dernière version. Et de plus j'aime bien comprendre. En lisant la doc sur Snap, j'ai évidemment découvert aussi Flatpak. Du coup j'essaye une install avec Flatpak. j'installe d'abord flatpak puis Gimp. Et là, étonnement, je ne trouve pas Gimp dans la liste des logicels. C'est un bug qui est déjà recensé mais évidemment que je découvre quand je tombe dessus... Il faut lancer Gimp dans un terminal "$ flatpak run org.gimp.GIMP//stable".

Y'a des fois, le libre c'est fatiguant...

Personnellement je vais simplement réinstaller Gimp avec les dépôts et travailler avec la 2.8. Mais je tenais à témoigner pour tous ceux qui veulent passer au libre et qui trouvent cela compliqué. Je sais très bien qu'avec Windows, ce n'est pas toujours simple non plus, mais en général c'est plus facile et rapide de trouver de l'aide. Les moyens de Microsoft, Google et compagnie ne sont pas les mêmes...

Sinon je fais partie d'une association (www.lesordislibres.fr) qui essaye de promouvoir le Libre via une exposition, des vidéos... Le but est d'être pédagogique. C'est notre petite pierre à l'édifice.

Bonne journée à toutes et tous

Hors ligne

#2 Le 16/09/2019, à 12:22

Christophe C

Re : Témoignage Snap, Flatpak, paquets Deb avec Gimp

Les distributions majoritaires (à part celles en rolling-release comme l'excellente manjarro) joue le jeux de la stabilité : une version tous les 2 ans tous les 6 mois pour les versions intermédiaires), et entre temps rien ne change, sauf le noyeau et ses pilotes, les correctifs de (gros) bugs et les navigateurs web. Avantage : stabilité. Inconvénient : des logiciels pouvant avoir jusqu'à 2 ans de retard.

Les paquets universels snap et flatpak sont supposés contourner ce problème (ils embarquent leur propres librairies et n’abîment pas le système). Ensuite snap est à mon sens un peu jeune, et plus orienté industrie, avec des règles de sécurité parfois trop strictes.

Flatpak est bien plus mature, plus rapide, plus grand public. Surpris de ton bug, j'utilise aussi gimp 2.10 en version flatpak, et aucun problème.

le vrai problème, c'est que la présentation faite par Ubuntu est incompréhensible, puisque on se retrouve en parallèle avec les versions deb et les version snap, sans aucune explication.

Beaucoup râle, non pas tant de la techno (encore que les snap soit très leeeents) que de la présentation pas claire du tout des choix.

Pour les autres membres du forum : pitié, pas 50 posts de troll, tout a déjà été dis et redis smile

Dernière modification par Christophe C (Le 16/09/2019, à 12:24)


https://salt.bountysource.com/teams/xfce - Faite un petit don, ponctuel ou récurent, pour soutenir le développement de XFCE.

Hors ligne

#3 Le 16/09/2019, à 12:58

GammaDraconis

Re : Témoignage Snap, Flatpak, paquets Deb avec Gimp

Tinou44 a écrit :

Installation via Snap:  gimp 2.10 avec impossibilité d'accéder à mes deux disques durs supplémentaires (sdb, sdc) là où j'ai justement mon répertoire photos...

Si tu peux, tu peux désactiver le confinement pour pouvoir accéder à n'importe quel répertoire ou sinon pour les autres lecteurs, tu peux utiliser le paramètre "removable-media" pour pouvoir les utiliser depuis Gimp

Tinou44 a écrit :

Installation via Flatpak: gimp 2.10, l'accès aux disques est ok mais le lanceur ne trouve pas Gimp dans la liste des logiciels

Pour avoir déjà testé Gimp depuis Flatpak, j'avais bien le raccourci par contre parfois il faut redémarrer la session pour avoir effectivement l'icone. Ton problème peux venir aussi du fait que tu as laissé plusieurs versions de Gimp installé en même temps (par exemple version classique via apt + la version snap + la version flatpak) et là effectivement il est possible que tu ne retrouve pas les 3 icones Gimp. Mais si tu déinstalles toutes les versions de Gimp et tu réinstalles uniquement la version flatpak + reboot, à mon avis tu auras un icone de ton Gimp flatpak.

Tinou44 a écrit :

Installation via les dépots "classiques" ($ apt-get install gimp): gimp 2.8 . Tout marche nickel mais avec une "vieille" version.

Exact mais de toute façon tu auras la dernière version de Gimp avec les nouvelles versions d'Ubuntu dont la nouvelle LTS (20.04) qui sortira en Avril 2020


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#4 Le 16/09/2019, à 13:31

kamaris

Re : Témoignage Snap, Flatpak, paquets Deb avec Gimp

Tinou44 a écrit :

Je suis sous Xubuntu 18.04 et voulais simplement installer Gimp. Je résume d'abord ce à quoi je suis arrivée avant d'expliquer le comment:

- Installation via Snap:  gimp 2.10 avec impossibilité d'accéder à mes deux disques durs supplémentaires (sdb, sdc) là où j'ai justement mon répertoire photos...

- Installation via Flatpak: gimp 2.10, l'accès aux disques est ok mais le lanceur ne trouve pas Gimp dans la liste des logiciels et il faut lancer à la main dans un terminal "$ flatpak run org.gimp.GIMP//stable" sad

- Installation via les dépots "classiques" ($ apt-get install gimp): gimp 2.8 . Tout marche nickel mais avec une "vieille" version.

C'est pourquoi, contrairement à ce qui est la plupart du temps conseillé sur ce forum, je trouve qu'utiliser les version intermédiaires d'Ubuntu (en ce moment 19.04, bientôt 19.10) n'est pas un si mauvais compromis que ça.
- Ces versions intermédiaires ne sont pas instables contrairement à ce qui est souvent dit, encore moins expérimentales, il s'agit bien de releases et non d'alpha ou beta.
- Il est tout à fait possible de passer par la procédure d'upgrade, sans réinstaller tous les 6 mois, quitte à faire une clean install tous les deux ans à l'occasion de la nouvelle LTS.
- Les logiciels sont significativement plus à jour que sur les LTS, on peut donc davantage rester sur les dépôts, sans s'embêter avec snap / flatpak (gimp est en version 2.10.8 sur disco en ce moment : https://packages.ubuntu.com/disco/gimp).

Par contre, ça ne règle évidemment pas le problème de la cacophonie logicielle que tu décris au niveau du magasin d'applications. Pour cela, il existe une solution « simple » : ne plus utiliser ce magasin d'applications, mais passer par apt en ligne de commande.

Hors ligne

#5 Le 16/09/2019, à 14:37

katian

Re : Témoignage Snap, Flatpak, paquets Deb avec Gimp

kamaris a écrit :

Par contre, ça ne règle évidemment pas le problème de la cacophonie logicielle que tu décris au niveau du magasin d'applications. Pour cela, il existe une solution « simple » : ne plus utiliser ce magasin d'applications, mais passer par apt en ligne de commande.

+1

personnellement, j'ai toujours été très satisfait des version intermédiaires d'Ubuntu et ce depuis mes débuts (2008) donc +1 là aussi

EDIT : en serveur je favorise la LTS tout de même wink

Dernière modification par katian (Le 16/09/2019, à 16:10)


dhamma.free.fr
monnaie libre
serveur minecraft : exoplanet.xyz

Hors ligne

#6 Le 16/09/2019, à 17:43

serged

Re : Témoignage Snap, Flatpak, paquets Deb avec Gimp

Gimp 2.10 avec flatpak : Impossible de scanner une image depuis Gimp. Donc -> poubelle et retour au gimp classique.


Linux-Mint 20.0 ulyana (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU et diverses machines en 19.3

Hors ligne

#7 Le 17/09/2019, à 08:08

Motux

Re : Témoignage Snap, Flatpak, paquets Deb avec Gimp

Bonjour,

J'ai fait l'installation de Gimp à partir des PPA. J'ai la version 2.10 et l'accès au média amovible ne pose pas de problème.
Bonne journée
Maurice

Hors ligne

#8 Le 17/09/2019, à 08:24

serged

Re : Témoignage Snap, Flatpak, paquets Deb avec Gimp

Motux a écrit :

Bonjour,

J'ai fait l'installation de Gimp à partir des PPA. J'ai la version 2.10 et l'accès au média amovible ne pose pas de problème.
Bonne journée
Maurice

... Ainsi que l'accès au scanner. Merci de cette suggestion !


Linux-Mint 20.0 ulyana (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU et diverses machines en 19.3

Hors ligne