Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 31/08/2020, à 17:06

csat18

probleme avec libffi8ubuntu1 RÉSOLU

Bonjour a tous

J'ai un problème depuis un bon moment avec libffi8ubuntu1
Son installation est forcée et je veux la désélectionner il va ma retirer tout mate etc....
Donc je ne peux plus mettre a jour les autres programmes

Auriez vous une idée ?
Amicalement

Richard

richard06@richard06-System-Product-Name:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libgirepository-1.0-1 : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 libglib-object-introspection-perl : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 libglib2.0-0 : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 libllvm10 : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 libpython3.8-stdlib : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 libwayland-client0 : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 libwayland-server0 : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 python3-cffi-backend : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
 python3-gi : Dépend: libffi8ubuntu1 (>= 3.4~20200819) mais il n'est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Dernière modification par csat18 (Le 07/09/2020, à 10:05)

Hors ligne

#2 Le 31/08/2020, à 17:12

inbox

Re : probleme avec libffi8ubuntu1 RÉSOLU

Salut,

Tu as installé une version en cours de développement. Il est normal de rencontrer ce genre de problème.

Tu as donc plusieurs solutions :
1/ Ne plus utiliser de version en cours de développement
2/ Attendre que le problème de paquets soit réglé
3/ Si tu en as la capacité, les connaissances et si la chose est possible, tenter de corriger ce problème de dépendances.

A+

[Edit] En l'occurrence, le paquet libffi8ubuntu1 n'existe dans aucun dépôt. La solution 2 est la plus probable.

Dernière modification par inbox (Le 31/08/2020, à 17:14)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#3 Le 31/08/2020, à 17:18

csat18

Re : probleme avec libffi8ubuntu1 RÉSOLU

Salut

Ok Je vais t’écouter mais ça fait déjà une bonne semaine que cela me bloque tout

Hors ligne

#4 Le 31/08/2020, à 17:26

inbox

Re : probleme avec libffi8ubuntu1 RÉSOLU

Je te répète que tu as installé une version en cours de développement. Il est normal de rencontrer ce genre de problème. D'ailleurs, une version de dév, ne peut servir qu'à deux choses : participer au test de la distribution pour en rapporter les bugs ou vérifier qu'un ou plusieurs logiciels non fournis par la distribution fonctionnent avec la nouvelle version de système.

Cette version ne peut actuellement être utilisée comme une version finie.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#5 Le 07/09/2020, à 10:04

csat18

Re : probleme avec libffi8ubuntu1 RÉSOLU

Bonjour

J'ai résolu en faisant une nouvelle installation (toujours avec la version pending mate groovy)
Et tout fonctionne correctement


Merci a tous


Richard

Hors ligne