Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 14/10/2020, à 23:03

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Ensuite, retour de :

sudo apt-get remove -s --purge command-not-found-data cpp-5 dconf-tools evolution-data-server-online-accounts g++-5 gcc-5-base gcc-5 gcc-6-base geoclue-ubuntu-geoip geoclue gir1.2-gnomekeyring-1.0 gstreamer1.0-fluendo-mp3 libasan2 libboost-date-time1.58.0 libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-system1.58.0 libbrlapi0.6 libbsapi libcamel-1.2-61 libebook-contacts-1.2-2 libecal-1.2-19 libedataserver-1.2-23 libevent-core-2.1-6 libexempi3 libffi6 libfreerdp-primitives1.1 libgcc-5-dev libgdbm5 libgeoclue0 libgnome-keyring-common libgnome-keyring0 libgutenprint2 libhdf5-100 libhogweed4 libhunspell-1.3-0 libicu55 libicu60 libilmbase12 libisl15 libllvm4.0 libminiupnpc10 libmpx0 libnetcdf13 libnettle6 libnih-dbus1 libnih1 libnm-glib-vpn1 libnm-glib4 libnm-gtk0 libnm-util2 libopenexr22 libperl5.26 libplymouth4 libpng12-0 libpoppler58 librarian0 libsndio6.1 libssl1.0.0 libstdc++-5-dev libunity-action-qt1 libusbmuxd4 libwinpr-dsparse0.1 libwinpr-handle0.1 libwinpr-input0.1 libwinpr-library0.1 libwinpr-rpc0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 master-pdf-editor multiarch-support oracle-java8-installer oracle-java8-set-default perl-modules-5.26 paper-icon-theme php-gettext php-php-gettext plainbox-provider-resource-generic plainbox-secure-policy python-glade2 python-gtk2 python-libuser python-netcdf4 python-retrying python-smbc python-talloc python3-checkbox-support qtcore4-l10n qtdeclarative5-qtquick2-plugin qtdeclarative5-test-plugin qtdeclarative5-unity-action-plugin rarian-compat system-config-samba transfig unity-scope-chromiumbookmarks unity-scope-firefoxbookmarks unity-scope-texdoc unity-scope-yelp ureadahead xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-video-ati-hwe-16.04 xserver-xorg-video-fbdev-hwe-16.04 xserver-xorg-video-intel-hwe-16.04 xserver-xorg-video-nouveau-hwe-16.04 xserver-xorg-video-radeon-hwe-16.04 xserver-xorg-video-vmware-hwe-16.04

C'est une simulation, ça ne va rien supprimer, c'est d'abord pour vérifier que ça ne vire pas de paquets importants.

Dernière modification par abelthorne (Le 14/10/2020, à 23:03)

Hors ligne

#27 Le 14/10/2020, à 23:06

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

toto:~$ sudo apt-get remove -s --purge command-not-found-data cpp-5 dconf-tools evolution-data-server-online-accounts g++-5 gcc-5-base gcc-5 gcc-6-base geoclue-ubuntu-geoip geoclue gir1.2-gnomekeyring-1.0 gstreamer1.0-fluendo-mp3 libasan2 libboost-date-time1.58.0 libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-system1.58.0 libbrlapi0.6 libbsapi libcamel-1.2-61 libebook-contacts-1.2-2 libecal-1.2-19 libedataserver-1.2-23 libevent-core-2.1-6 libexempi3 libffi6 libfreerdp-primitives1.1 libgcc-5-dev libgdbm5 libgeoclue0 libgnome-keyring-common libgnome-keyring0 libgutenprint2 libhdf5-100 libhogweed4 libhunspell-1.3-0 libicu55 libicu60 libilmbase12 libisl15 libllvm4.0 libminiupnpc10 libmpx0 libnetcdf13 libnettle6 libnih-dbus1 libnih1 libnm-glib-vpn1 libnm-glib4 libnm-gtk0 libnm-util2 libopenexr22 libperl5.26 libplymouth4 libpng12-0 libpoppler58 librarian0 libsndio6.1 libssl1.0.0 libstdc++-5-dev libunity-action-qt1 libusbmuxd4 libwinpr-dsparse0.1 libwinpr-handle0.1 libwinpr-input0.1 libwinpr-library0.1 libwinpr-rpc0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 master-pdf-editor multiarch-support oracle-java8-installer oracle-java8-set-default perl-modules-5.26 paper-icon-theme php-gettext php-php-gettext plainbox-provider-resource-generic plainbox-secure-policy python-glade2 python-gtk2 python-libuser python-netcdf4 python-retrying python-smbc python-talloc python3-checkbox-support qtcore4-l10n qtdeclarative5-qtquick2-plugin qtdeclarative5-test-plugin qtdeclarative5-unity-action-plugin rarian-compat system-config-samba transfig unity-scope-chromiumbookmarks unity-scope-firefoxbookmarks unity-scope-texdoc unity-scope-yelp ureadahead xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-video-ati-hwe-16.04 xserver-xorg-video-fbdev-hwe-16.04 xserver-xorg-video-intel-hwe-16.04 xserver-xorg-video-nouveau-hwe-16.04 xserver-xorg-video-radeon-hwe-16.04 xserver-xorg-video-vmware-hwe-16.04
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  dconf-editor gsfonts-x11 libaec0 libgfortran4 libglade2-0 libsz2 libuser1 python-atomicwrites python-attr python-cairo python-configparser python-contextlib2
  python-funcsigs python-gobject-2 python-importlib-metadata python-mock python-more-itertools python-numpy python-packaging python-pathlib2 python-pbr python-pluggy
  python-py python-pyparsing python-pytest python-scandir python-six python-wcwidth python-zipp
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  command-not-found-data* cpp-5* dconf-tools* evolution-data-server-online-accounts* g++-5* gcc-5* gcc-5-base* gcc-6-base* geoclue* geoclue-ubuntu-geoip*
  gir1.2-gnomekeyring-1.0* gstreamer1.0-fluendo-mp3* libasan2* libboost-date-time1.58.0* libboost-filesystem1.58.0* libboost-iostreams1.58.0* libboost-system1.58.0*
  libbrlapi0.6* libbsapi* libcamel-1.2-61* libebook-contacts-1.2-2* libecal-1.2-19* libedataserver-1.2-23* libevent-core-2.1-6* libexempi3* libffi6* libfreerdp-primitives1.1*
  libgcc-5-dev* libgdbm5* libgeoclue0* libgnome-keyring-common* libgnome-keyring0* libgutenprint2* libhdf5-100* libhogweed4* libhunspell-1.3-0* libicu55* libicu60*
  libilmbase12* libisl15* libllvm4.0* libminiupnpc10* libmpx0* libnetcdf13* libnettle6* libnih-dbus1* libnih1* libnm-glib-vpn1* libnm-glib4* libnm-gtk0* libnm-util2*
  libopenexr22* libperl5.26* libplymouth4* libpng12-0* libpoppler58* librarian0* libsndio6.1* libssl1.0.0* libstdc++-5-dev* libunity-action-qt1* libusbmuxd4*
  libwinpr-dsparse0.1* libwinpr-handle0.1* libwinpr-input0.1* libwinpr-library0.1* libwinpr-rpc0.1* libwinpr-sysinfo0.1* libwinpr-thread0.1* master-pdf-editor*
  multiarch-support* oracle-java8-installer* oracle-java8-set-default* paper-icon-theme* perl-modules-5.26* php-gettext* php-php-gettext* plainbox-provider-resource-generic*
  plainbox-secure-policy* python-glade2* python-gtk2* python-libuser* python-netcdf4* python-retrying* python-smbc* python-talloc* python3-checkbox-support* qtcore4-l10n*
  qtdeclarative5-qtquick2-plugin* qtdeclarative5-test-plugin* qtdeclarative5-unity-action-plugin* rarian-compat* system-config-samba* transfig* unity-scope-chromiumbookmarks*
  unity-scope-firefoxbookmarks* unity-scope-texdoc* unity-scope-yelp* ureadahead* xserver-xorg-hwe-16.04* xserver-xorg-input-all-hwe-16.04* xserver-xorg-video-all-hwe-16.04*
  xserver-xorg-video-ati-hwe-16.04* xserver-xorg-video-fbdev-hwe-16.04* xserver-xorg-video-intel-hwe-16.04* xserver-xorg-video-nouveau-hwe-16.04*
  xserver-xorg-video-radeon-hwe-16.04* xserver-xorg-video-vmware-hwe-16.04*
0 mis à jour, 0 nouvellement installés, 108 à enlever et 0 non mis à jour.
Purg command-not-found-data [18.04.5]
Purg g++-5 [5.5.0-12ubuntu1]
Purg gcc-5 [5.5.0-12ubuntu1]
Purg cpp-5 [5.5.0-12ubuntu1]
Purg dconf-tools [0.26.0-2ubuntu3]
Purg evolution-data-server-online-accounts [3.28.5-0ubuntu0.18.04.3]
Purg libstdc++-5-dev [5.5.0-12ubuntu1]
Purg libgcc-5-dev [5.5.0-12ubuntu1]
Purg libmpx0 [5.5.0-12ubuntu1]
Purg gcc-5-base [5.5.0-12ubuntu1] [libasan2:amd64 ]
Purg gcc-6-base [6.5.0-2ubuntu1~18.04] [libasan2:amd64 ]
Purg geoclue-ubuntu-geoip [1.0.2+18.04.20180223-0ubuntu1] [libasan2:amd64 ]
Purg geoclue [0.12.99-4ubuntu2] [libasan2:amd64 ]
Purg gir1.2-gnomekeyring-1.0 [3.12.0-1build1] [libasan2:amd64 ]
Purg gstreamer1.0-fluendo-mp3 [0.10.32.debian-1] [libasan2:amd64 ]
Purg libasan2 [5.5.0-12ubuntu1]
Purg libboost-date-time1.58.0 [1.58.0+dfsg-5ubuntu3.1]
Purg libboost-filesystem1.58.0 [1.58.0+dfsg-5ubuntu3.1]
Purg libboost-iostreams1.58.0 [1.58.0+dfsg-5ubuntu3.1]
Purg libboost-system1.58.0 [1.58.0+dfsg-5ubuntu3.1]
Purg libbrlapi0.6 [5.5-4ubuntu2.0.1]
Purg libbsapi [4.3~rc1+build4.3.291+dfsg2-0ppa1]
Purg libebook-contacts-1.2-2 [3.28.5-0ubuntu0.18.04.3]
Purg libecal-1.2-19 [3.28.5-0ubuntu0.18.04.3]
Purg libedataserver-1.2-23 [3.28.5-0ubuntu0.18.04.3]
Purg libcamel-1.2-61 [3.28.5-0ubuntu0.18.04.3]
Purg libevent-core-2.1-6 [2.1.8-stable-4build1]
Purg libexempi3 [2.4.5-2]
Purg libllvm4.0 [1:4.0.1-10]
Purg libffi6 [3.2.1-8]
Purg libfreerdp-primitives1.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg libperl5.26 [5.26.1-6ubuntu0.3]
Purg libgdbm5 [1.14.1-6]
Purg libgeoclue0 [0.12.99-4ubuntu2]
Purg libgnome-keyring0 [3.12.0-1build1]
Purg libgnome-keyring-common [3.12.0-1build1]
Purg libgutenprint2 [5.2.13-2]
Purg python-netcdf4 [1.3.1-1]
Purg libnetcdf13 [1:4.6.0-2build1]
Purg libhdf5-100 [1.10.0-patch1+docs-4]
Purg libhogweed4 [3.4-1]
Purg libhunspell-1.3-0 [1.3.3-4ubuntu1]
Purg libicu55 [55.1-7ubuntu0.4]
Purg libicu60 [60.2-3ubuntu3.1]
Purg libopenexr22 [2.2.0-11.1ubuntu1.3]
Purg libilmbase12 [2.2.0-11ubuntu2]
Purg libisl15 [0.18-4]
Purg libminiupnpc10 [1.9.20140610-4ubuntu2]
Purg libnettle6 [3.4-1]
Purg libnih-dbus1 [1.0.3-6ubuntu2]
Purg ureadahead [0.100.0-21]
Purg libnih1 [1.0.3-6ubuntu2]
Purg libnm-glib-vpn1 [1.10.14-0ubuntu2]
Purg libnm-gtk0 [1.8.10-2ubuntu3]
Purg libnm-glib4 [1.10.14-0ubuntu2]
Purg libnm-util2 [1.10.14-0ubuntu2]
Purg libplymouth4 [0.9.3-1ubuntu7.18.04.2]
Purg libpoppler58 [0.41.0-0ubuntu1.7]
Purg libpng12-0 [1.2.54-1ubuntu1.1]
Purg rarian-compat [0.8.1-6build1]
Purg librarian0 [0.8.1-6build1]
Purg libsndio6.1 [1.1.0-3]
Purg libwinpr-rpc0.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg libssl1.0.0 [1.0.2n-1ubuntu5.4]
Purg qtdeclarative5-unity-action-plugin [1.1.0+17.04.20170405-0ubuntu1]
Purg libunity-action-qt1 [1.1.0+17.04.20170405-0ubuntu1]
Purg libusbmuxd4 [1.1.0~git20171206.c724e70f-0.1]
Purg libwinpr-dsparse0.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg libwinpr-handle0.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg libwinpr-input0.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg libwinpr-library0.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg libwinpr-sysinfo0.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg libwinpr-thread0.1 [1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1]
Purg master-pdf-editor [5.4.38]
Purg multiarch-support [2.27-3ubuntu1.2]
Purg oracle-java8-set-default [8u201-1~webupd8~1]
Purg oracle-java8-installer [8u201-1~webupd8~1]
Purg paper-icon-theme [1.4+r696~daily~ubuntu16.04.1]
Purg perl-modules-5.26 [5.26.1-6ubuntu0.3]
Purg php-gettext [1.0.12-0.1]
Purg php-php-gettext [1.0.12-0.1]
Purg plainbox-provider-resource-generic [0.23-1.1]
Purg plainbox-secure-policy [0.25-1]
Purg system-config-samba [1.2.63-0ubuntu6]
Purg python-glade2 [2.24.0-5.1ubuntu2]
Purg python-gtk2 [2.24.0-5.1ubuntu2]
Purg python-libuser [1:0.62~dfsg-0.1ubuntu2]
Purg python-retrying [1.3.3-3]
Purg python-smbc [1.0.15.6-1build2]
Purg python-talloc [2.1.10-2ubuntu1]
Purg python3-checkbox-support [0.22-1]
Purg qtcore4-l10n [4:4.8.7+dfsg-7ubuntu1]
Purg qtdeclarative5-qtquick2-plugin [5.9.5-0ubuntu1.1]
Purg qtdeclarative5-test-plugin [5.9.5-0ubuntu1.1]
Purg transfig [1:3.2.6a-6ubuntu1]
Purg unity-scope-chromiumbookmarks [0.1+13.10.20130723-0ubuntu1]
Purg unity-scope-firefoxbookmarks [0.1+13.10.20130809.1-0ubuntu1]
Purg unity-scope-texdoc [0.1+14.04.20140328-0ubuntu1]
Purg unity-scope-yelp [0.1+13.10.20130723-0ubuntu1]
Purg xserver-xorg-hwe-16.04 [3:14.1]
Purg xserver-xorg-input-all-hwe-16.04 [3:14.1]
Purg xserver-xorg-video-all-hwe-16.04 [3:14.1]
Purg xserver-xorg-video-ati-hwe-16.04 [3:14.1]
Purg xserver-xorg-video-fbdev-hwe-16.04 [3:14.1]
Purg xserver-xorg-video-intel-hwe-16.04 [3:14.1]
Purg xserver-xorg-video-nouveau-hwe-16.04 [3:14.1]
Purg xserver-xorg-video-radeon-hwe-16.04 [3:14.1]
Purg xserver-xorg-video-vmware-hwe-16.04 [3:14.1]
toto:~$

Hors ligne

#28 Le 14/10/2020, à 23:11

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Ça a l'air ok à première vue. Relance la commande sans l'option -s (et supprime les paquets) :

sudo apt-get remove --purge command-not-found-data cpp-5 dconf-tools evolution-data-server-online-accounts g++-5 gcc-5-base gcc-5 gcc-6-base geoclue-ubuntu-geoip geoclue gir1.2-gnomekeyring-1.0 gstreamer1.0-fluendo-mp3 libasan2 libboost-date-time1.58.0 libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-system1.58.0 libbrlapi0.6 libbsapi libcamel-1.2-61 libebook-contacts-1.2-2 libecal-1.2-19 libedataserver-1.2-23 libevent-core-2.1-6 libexempi3 libffi6 libfreerdp-primitives1.1 libgcc-5-dev libgdbm5 libgeoclue0 libgnome-keyring-common libgnome-keyring0 libgutenprint2 libhdf5-100 libhogweed4 libhunspell-1.3-0 libicu55 libicu60 libilmbase12 libisl15 libllvm4.0 libminiupnpc10 libmpx0 libnetcdf13 libnettle6 libnih-dbus1 libnih1 libnm-glib-vpn1 libnm-glib4 libnm-gtk0 libnm-util2 libopenexr22 libperl5.26 libplymouth4 libpng12-0 libpoppler58 librarian0 libsndio6.1 libssl1.0.0 libstdc++-5-dev libunity-action-qt1 libusbmuxd4 libwinpr-dsparse0.1 libwinpr-handle0.1 libwinpr-input0.1 libwinpr-library0.1 libwinpr-rpc0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 master-pdf-editor multiarch-support oracle-java8-installer oracle-java8-set-default perl-modules-5.26 paper-icon-theme php-gettext php-php-gettext plainbox-provider-resource-generic plainbox-secure-policy python-glade2 python-gtk2 python-libuser python-netcdf4 python-retrying python-smbc python-talloc python3-checkbox-support qtcore4-l10n qtdeclarative5-qtquick2-plugin qtdeclarative5-test-plugin qtdeclarative5-unity-action-plugin rarian-compat system-config-samba transfig unity-scope-chromiumbookmarks unity-scope-firefoxbookmarks unity-scope-texdoc unity-scope-yelp ureadahead xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-video-ati-hwe-16.04 xserver-xorg-video-fbdev-hwe-16.04 xserver-xorg-video-intel-hwe-16.04 xserver-xorg-video-nouveau-hwe-16.04 xserver-xorg-video-radeon-hwe-16.04 xserver-xorg-video-vmware-hwe-16.04

Ensuite, nouveau nettoyage des dépendances inutiles :

sudo apt-get autoremove --purge

Puis on va vérifier les noyaux :

uname -a
dpkg -l | grep linux-

Hors ligne

#29 Le 14/10/2020, à 23:16

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Voilà j'ai nettoyé.

toto:~$ uname -a
Linux toto-ThinkPad-T440s 5.4.0-51-generic #56-Ubuntu SMP Mon Oct 5 14:28:49 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
toto:~$ dpkg -l | grep linux-
ii  binutils-x86-64-linux-gnu                  2.34-6ubuntu1                               amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  liblinux-epoll-perl                        0.017-1                                     amd64        perl epoll module for O(1) multiplexing
ii  linux-base                                 4.5ubuntu3.1                                all          Linux image base package
ii  linux-firmware                             1.187.3                                     all          Firmware for Linux kernel drivers
ii  linux-generic                              5.4.0.51.54                                 amd64        Complete Generic Linux kernel and headers
ii  linux-generic-hwe-16.04                    4.15.0.118.105                              amd64        Complete Generic Linux kernel and headers (dummy transitional package)
ii  linux-headers-5.4.0-48                     5.4.0-48.52                                 all          Header files related to Linux kernel version 5.4.0
ii  linux-headers-5.4.0-48-generic             5.4.0-48.52                                 amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-5.4.0-51                     5.4.0-51.56                                 all          Header files related to Linux kernel version 5.4.0
ii  linux-headers-5.4.0-51-generic             5.4.0-51.56                                 amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-generic                      5.4.0.51.54                                 amd64        Generic Linux kernel headers
rc  linux-image-4.15.0-118-generic             4.15.0-118.119                              amd64        Signed kernel image generic
ii  linux-image-5.4.0-48-generic               5.4.0-48.52                                 amd64        Signed kernel image generic
ii  linux-image-5.4.0-51-generic               5.4.0-51.56                                 amd64        Signed kernel image generic
ii  linux-image-generic                        5.4.0.51.54                                 amd64        Generic Linux kernel image
ii  linux-libc-dev:amd64                       5.4.0-51.56                                 amd64        Linux Kernel Headers for development
rc  linux-modules-4.15.0-118-generic           4.15.0-118.119                              amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-48-generic             5.4.0-48.52                                 amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-51-generic             5.4.0-51.56                                 amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-118-generic     4.15.0-118.119                              amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.4.0-48-generic       5.4.0-48.52                                 amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.4.0-51-generic       5.4.0-51.56                                 amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-signed-generic                       4.15.0.118.105                              amd64        Complete Signed Generic Linux kernel and headers (dummy transitional package)
ii  linux-signed-generic-hwe-16.04             4.15.0.118.105                              amd64        Complete Signed Generic Linux kernel and headers (dummy transitional package)
ii  linux-sound-base                           1.0.25+dfsg-0ubuntu5                        all          base package for ALSA and OSS sound systems
ii  syslinux-common                            3:6.04~git20190206.bf6db5b4+dfsg1-2         all          collection of bootloaders (common)
ii  syslinux-legacy                            2:3.63+dfsg-2ubuntu9                        amd64        Bootloader for Linux/i386 using MS-DOS floppies
toto:~$

Hors ligne

#30 Le 14/10/2020, à 23:19

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Question annexe : Sais-tu pourquoi quand je fais 'snap-store', ça m'ouvre "Ubuntu Software" ? Quand je venais d'installer 20.04, j'avais une icône Snap Store.

Hors ligne

#31 Le 14/10/2020, à 23:22

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Je n'utilise pas GNOME, je n'ai pas vraiment suivi les choix de Canonical sur le sujet mais je sais que la Logithèque dans Ubuntu 20.04 est maintenant la Boutique des snaps (Snap Store). Tu as deux logithèques différentes dans ta liste d'applications ?

Pour les noyaux, donne le retour de :

sudo apt-get remove -s --purge linux-generic-hwe-16.04 linux-image-4.15.0-118-generic linux-modules-4.15.0-118-generic linux-modules-extra-4.15.0-118-generic linux-signed-generic linux-signed-generic-hwe-16.04

Hors ligne

#32 Le 14/10/2020, à 23:30

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Oui j'ai "Logiciel" et "Ubuntu Software". Avant j'avais "Snap Store" aussi. Je crois que j'ai fait quelque chose comme 'sudo apt-get install gnome-software', ce qui m'a permis d'avoir accès à "Logiciel", mais "Snap Store" s'est transformé en "Ubuntu Software". Enfin, je suis pas tout à fait sûr, mais je trouve que c'est un peu le bazar. Enfin, c'est pas bien grave, je chercherai comment régler ça une prochaine fois.

toto:~$ sudo apt-get remove -s --purge linux-generic-hwe-16.04 linux-image-4.15.0-118-generic linux-modules-4.15.0-118-generic linux-modules-extra-4.15.0-118-generic linux-signed-generic linux-signed-generic-hwe-16.04
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  linux-generic-hwe-16.04* linux-image-4.15.0-118-generic* linux-modules-4.15.0-118-generic* linux-modules-extra-4.15.0-118-generic* linux-signed-generic*
  linux-signed-generic-hwe-16.04*
0 mis à jour, 0 nouvellement installés, 6 à enlever et 0 non mis à jour.
Purg linux-generic-hwe-16.04 [4.15.0.118.105]
Purg linux-image-4.15.0-118-generic
Purg linux-modules-4.15.0-118-generic
Purg linux-modules-extra-4.15.0-118-generic
Purg linux-signed-generic-hwe-16.04 [4.15.0.118.105]
Purg linux-signed-generic [4.15.0.118.105]
toto:~$ 

Hors ligne

#33 Le 14/10/2020, à 23:35

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

En fait, le Snap Store est une version modifiée de GNOME Software et quand il est installé, il met en place des bidouilles au niveau des lanceurs pour n'afficher qu'un élément. Pour résoudre la situation, il faudrait peut-être supprimer GNOME Software puis réinstaller le Snap Store. On essaiera de voir ça après le reste.

Pour les noyaux, c'est bon, tu peux relancer la commande sans la simu :

sudo apt-get remove --purge linux-generic-hwe-16.04 linux-image-4.15.0-118-generic linux-modules-4.15.0-118-generic linux-modules-extra-4.15.0-118-generic linux-signed-generic linux-signed-generic-hwe-16.04

Une fois que c'est fait, redonne la liste des paquets orphelins :

apt list | grep "installé, local"

Hors ligne

#34 Le 14/10/2020, à 23:36

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Fait.

toto:~$ apt list | grep "installé, local"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

djvu2pdf/now 0.9.2-1 all  [installé, local]
jitsi/now 2.10.5550-1 amd64  [installé, local]
zoom/now 5.2.454870.0831 amd64  [installé, local]
toto:~$

EDIT : zoom semble être sur snap et jitsi sur flatpak. Ne vaudrait-il pas mieux les récupérer là-bas plutôt que de laisser ces paquets orphelins ?

Dernière modification par TVG (Le 14/10/2020, à 23:42)

Hors ligne

#35 Le 14/10/2020, à 23:41

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Il reste le problème de jitsi et là, je suis un peu coi. Si je vais voir sur download.jitsi.org et que je sélectionne la version Ubuntu, il y a plein de paquets jitsi-meet-* mais pas de jitsi tout court. Est-ce que tu sais si tu avais ajouté le dépôt toi-même ou tu avais installé un paquet qui l'a rajouté ?

À tout hasard, qu'est-ce que ça donne pour ça ?

apt-cache policy jitsi*

Hors ligne

#36 Le 14/10/2020, à 23:45

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

J'ai peut-être ajouté le dépôt moi-même, je ne sais plus neutral.

toto:~$ apt-cache policy jitsi*
jitsi-meet-turnserver:
  Installé : (aucun)
  Candidat : 1.0.4466-1
 Table de version :
     1.0.4466-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4428-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4425-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4370-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4289-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4127-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4074-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4073-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4025-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3992-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3969-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3962-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3928-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi-videobridge2:
  Installé : (aucun)
  Candidat : 2.1-376-g9f12bfe2-1
 Table de version :
     2.1-376-g9f12bfe2-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-351-g0bfaac1c-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-304-g8488f77d-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-273-g072dd44b-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-202-g5f9377b9-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-197-g38256192-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-183-gdbddd169-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-169-ga28eb88e-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-164-gfdce823f-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-163-g63d2f9da-1 500
        500 https://download.jitsi.org stable/ Packages
     2.1-157-g389b69ff-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi-meet-web:
  Installé : (aucun)
  Candidat : 1.0.4466-1
 Table de version :
     1.0.4466-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4428-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4425-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4370-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4289-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4127-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4074-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4073-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4025-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3992-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3969-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3962-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3928-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3729-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3577-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3387-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3216-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3186-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3081-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3036-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2942-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2866-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2740-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2579-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2441-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2301-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1967-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1592-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1575-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi-meet:
  Installé : (aucun)
  Candidat : 2.0.5142-1
 Table de version :
     2.0.5142-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.5076-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.5073-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4966-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4857-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4627-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4548-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4546-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4468-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4416-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4384-1 500
        500 https://download.jitsi.org stable/ Packages
     2.0.4376-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4335-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4101-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3936-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3734-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3548-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3547-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3508-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3383-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3344-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3229-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3135-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2988-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2794-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2635-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2467-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2098-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1622-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1595-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1465-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1338-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1294-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1217-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1108-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1072-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi-videobridge:
  Installé : (aucun)
  Candidat : 1126-1
 Table de version :
     1126-1 500
        500 https://download.jitsi.org stable/ Packages
     1124-1 500
        500 https://download.jitsi.org stable/ Packages
     1116-1 500
        500 https://download.jitsi.org stable/ Packages
     1109-1 500
        500 https://download.jitsi.org stable/ Packages
     1104-1 500
        500 https://download.jitsi.org stable/ Packages
     1093-1 500
        500 https://download.jitsi.org stable/ Packages
     1087-1 500
        500 https://download.jitsi.org stable/ Packages
     1077-1 500
        500 https://download.jitsi.org stable/ Packages
     1066-1 500
        500 https://download.jitsi.org stable/ Packages
     1055-1 500
        500 https://download.jitsi.org stable/ Packages
     1030-1 500
        500 https://download.jitsi.org stable/ Packages
     1011-1 500
        500 https://download.jitsi.org stable/ Packages
     995-1 500
        500 https://download.jitsi.org stable/ Packages
     953-1 500
        500 https://download.jitsi.org stable/ Packages
     879-1 500
        500 https://download.jitsi.org stable/ Packages
     869-1 500
        500 https://download.jitsi.org stable/ Packages
     840-1 500
        500 https://download.jitsi.org stable/ Packages
     820-1 500
        500 https://download.jitsi.org stable/ Packages
     808-1 500
        500 https://download.jitsi.org stable/ Packages
     801-1 500
        500 https://download.jitsi.org stable/ Packages
     757-1 500
        500 https://download.jitsi.org stable/ Packages
     750-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi-meet-web-config:
  Installé : (aucun)
  Candidat : 1.0.4466-1
 Table de version :
     1.0.4466-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4428-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4425-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4370-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4289-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4127-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4074-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4073-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4025-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3992-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3969-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3962-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3928-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3729-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3577-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3387-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3216-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3186-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3081-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3036-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2942-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2866-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2740-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2579-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2441-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2301-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1967-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1592-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1575-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi-meet-tokens:
  Installé : (aucun)
  Candidat : 1.0.4466-1
 Table de version :
     1.0.4466-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4428-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4425-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4370-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4289-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4127-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4074-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4073-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4025-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3992-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3969-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3962-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3928-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3729-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3577-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3387-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3216-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3186-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3081-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3036-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2942-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2866-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2740-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2579-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2441-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2301-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1967-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1592-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1575-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1465-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1338-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1294-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1217-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1108-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1072-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi:
  Installé : 2.10.5550-1
  Candidat : 2.10.5550-1
 Table de version :
 *** 2.10.5550-1 100
        100 /var/lib/dpkg/status
jitsi-archive-keyring:
  Installé : 1.0.1
  Candidat : 1.0.1
 Table de version :
 *** 1.0.1 500
        500 https://download.jitsi.org stable/ Packages
        100 /var/lib/dpkg/status
jitsi-upload-integrations:
  Installé : (aucun)
  Candidat : 0.15.15-1
 Table de version :
     0.15.15-1 500
        500 https://download.jitsi.org stable/ Packages
     0.13.13-1 500
        500 https://download.jitsi.org stable/ Packages
jitsi-meet-prosody:
  Installé : (aucun)
  Candidat : 1.0.4466-1
 Table de version :
     1.0.4466-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4428-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4425-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4370-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4289-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4127-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4074-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4073-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.4025-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3992-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3969-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3962-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3928-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3729-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3577-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3387-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3216-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3186-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3081-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.3036-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2942-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2866-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2740-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2579-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2441-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.2301-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1967-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1592-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1575-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1465-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1338-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1294-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1217-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1108-1 500
        500 https://download.jitsi.org stable/ Packages
     1.0.1072-1 500
        500 https://download.jitsi.org stable/ Packages
toto:~$

As-tu vu mon EDIT dans mon message précédent ?

Hors ligne

#37 Le 14/10/2020, à 23:54

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Ah, effectivement, si zoom et jitsi sont dispo en snap/flatpak, c'est probablement plus simple de les installer comme ça.

Pour ce qui est de la version deb, le dépôt est valide, il héberge plein de paquets. Je pense qu'à un moment ils ont changé le paquet et que tu es censé remplacer le jitsi par un autre (jeetsi-meet-quelque chose) mais je ne saurais pas te dire lequel, je ne connais pas du tout ce soft.

Je te propose de supprimer le paquet :

sudo apt-get remove --purge jitsi
sudo apt-get autoremove --purge

(La deuxième commande, c'est au cas où il y ait des dépendances inutiles après la suppression du paquet, il n'y aura peut-être rien.)

Ensuite, installe-le en snap ou flatpak et vérifie s'il fonctionne correctement. Si c'est le cas, on pourra supprimer le dépôt.

Même chose pour le paquet zoom (sauf qu'il n'y aura pas de dépôt à supprimer).

Pour le reste, il y a éventuellement OBS que tu peux installer en snap si tu veux l'avoir à jour sans devoir gérer un dépôt tiers. Idem pour Skype, sachant que c'est apparemment déjà le cas, il est installé en snap et pas en deb. S'il fonctionne comme il faut, on pourra supprimer le dépôt.
Il y a éventuellement Inkscape que tu peux installer en snap de la même façon. Concernant LibreOffice, je le laisserais en deb : si tu le supprimes, ça risque de virer le méta-paquet du bureau (problèmes potentiels lors de futures mises à niveau) et si tu le gardes, tu en auras deux dans tes applis si tu l'installes en plus en snap.

Hors ligne

#38 Le 15/10/2020, à 09:49

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Bonjour abelthorne,

Pour info, ce matin, j'ai obtenu ça :

toto:~$ sudo apt update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease                      
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease
Atteint :4 http://ppa.launchpad.net/inkscape.dev/stable/ubuntu focal InRelease                                                                            
Atteint :5 http://ppa.launchpad.net/libreoffice/ppa/ubuntu focal InRelease                                                                                
Réception de :6 https://mega.nz/linux/MEGAsync/xUbuntu_20.04 ./ InRelease [2,441 B]                                                                       
Atteint :7 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu focal InRelease                                                                          
Atteint :8 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu focal InRelease                                                                    
Atteint :9 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal InRelease                                                                         
Atteint :10 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                        
Atteint :11 http://archive.canonical.com/ubuntu focal InRelease                                                                                           
Atteint :13 https://download.jitsi.org stable/ InRelease                                                                                                  
Atteint :12 https://github.com/retorquere/zotero-deb/releases/download/apt-get ./ InRelease                                                               
Err :14 https://repo.skype.com/deb stable InRelease                                                                                                       
  Erreur temporaire de résolution de « repo.skype.com »
Err :15 http://linux.teamviewer.com/deb stable InRelease                                                                                                  
  Erreur temporaire de résolution de « linux.teamviewer.com »
Atteint :16 http://security.ubuntu.com/ubuntu focal-security InRelease                                                                                    
Atteint :17 https://packages.microsoft.com/repos/ms-teams stable InRelease                                                                                
2,441 o réceptionnés en 21s (117 o/s)                                                                                                                     
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.
W: Impossible de récupérer https://repo.skype.com/deb/dists/stable/InRelease  Erreur temporaire de résolution de « repo.skype.com »
W: Impossible de récupérer http://linux.teamviewer.com/deb/dists/stable/InRelease  Erreur temporaire de résolution de « linux.teamviewer.com »
W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
toto:~$

J'ai supprimé jitsi. Comme je m'en servais plus dernièrement, j'ai bien envie de ne pas le réinstaller pour l'instant. Est-ce que sa suppression à aussi automatiquement supprimé le dépôt ? Car je ne le vois plus sous /etc/apt/sources.list.d/.

J'ai supprimé zoom, Inkscape et OBS et les ai réinstallés en snap. Ça fonctionne. Les dépôts inkscape et OBS sont toujours là.
Lorsque je supprime un paquet, il apparaît toujours comme "installé" dans les "logithèques" (par exemple je vois 2 OBS (ppa et snap) installés). Y a-t-il une commande pour mettre à jour ?

Skype (snap) fonctionne. On peut supprimer le dépôt.

Je veux bien garder LibreOffice en deb, mais pourquoi y a-t-il un dépôt spécifique 'libreoffice-ubuntu-ppa-xenial.list' ? LibreOffice ne fait pas partie des dépôts officiels ?!

Merci.

Hors ligne

#39 Le 15/10/2020, à 10:37

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

1) Normalement, non : quand on supprime un paquet, ça ne supprime pas le dépôt associé sauf cas particulier.

2) Installer un paquet en snap ne le supprime pas en deb (et inversement), il faut le faire manuellement. Si tu veux supprimer Inkscape et OBS :

sudo apt-get remove --purge inkscape obs-studio
sudo apt-get autoremove --purge

3) Suppression du dépôt Slype :

sudo rm /etc/apt/sources.list.d/skype-stable.list /etc/apt/sources.list.d/skype-stable.list.save
sudo apt-get update

4) LibreOffice est dans les dépôts Ubuntu, oui. Mais comme la plupart des logiciels, il ne sera pas mis à jour pendant la durée de vie d'Ubuntu. Par exemple, Bionic (18.04) a la version 6.0.7, Focal (20.04) a la 6.4.6, Groovy (20.10) a la 7.0.2. Ces versions n'évolueront pas. C'est pour ça qu'il y a des dépôts tiers : pour pouvoir installer des versions plus récentes, ou proposer des logiciels qui ne sont pas dans les dépôts de base.

Au point où on en est (on a plus ou moins fini), redonne la liste des dépôts et des paquets snap/flatpak :

ls /etc/apt/sources.list.d
snap list
flatpak list

Hors ligne

#40 Le 15/10/2020, à 11:04

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Pour répondre aux points 1) et 2), j'avais bien supprimé les deb d'où mon étonnement de les voir toujours dans la liste des APT ou dans les "logithèques". Voici une copie de mon terminal pour inkscape :

toto:~$ sudo apt-get remove --purge inkscape 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgdl-3-5 libgdl-3-common libimage-magick-perl libimage-magick-q16-perl libpotrace0 perlmagick
  python3-scour
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  inkscape*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 163 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [Y/n] 
(Lecture de la base de données... 522195 fichiers et répertoires déjà installés.)
Suppression de inkscape (1.0.1+r73~ubuntu20.04.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) ...
Rebuilding /usr/share/applications/bamf-2.index...

toto:~$ sudo apt-get autoremove --purge
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  libgdl-3-5* libgdl-3-common* libimage-magick-perl* libimage-magick-q16-perl* libpotrace0* perlmagick*
  python3-scour*
0 mis à jour, 0 nouvellement installés, 7 à enlever et 0 non mis à jour.
Après cette opération, 2,107 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [Y/n] 
(Lecture de la base de données... 519350 fichiers et répertoires déjà installés.)
Suppression de libgdl-3-5:amd64 (3.34.0-1) ...
Suppression de libgdl-3-common (3.34.0-1) ...
Suppression de perlmagick (8:6.9.10.23+dfsg-2.1ubuntu11.1) ...
Suppression de libimage-magick-perl (8:6.9.10.23+dfsg-2.1ubuntu11.1) ...
Suppression de libimage-magick-q16-perl (8:6.9.10.23+dfsg-2.1ubuntu11.1) ...
Suppression de libpotrace0:amd64 (1.16-2) ...
Suppression de python3-scour (0.37-4build1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9.1) ...
(Lecture de la base de données... 519193 fichiers et répertoires déjà installés.)
Purge des fichiers de configuration de perlmagick (8:6.9.10.23+dfsg-2.1ubuntu11.1) ...
Purge des fichiers de configuration de libimage-magick-perl (8:6.9.10.23+dfsg-2.1ubuntu11.1) ...

toto:~$ apt list | grep inkscape

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

inkscape-open-symbols/focal,focal 1.2.1-1 all
inkscape-speleo/focal,focal 1.8-4 all
inkscape-survex-export/focal,focal 1.0-3 all
inkscape-trunk-data/focal,focal 1.0rc1+100~ubuntu20.04.1 all
inkscape-trunk/focal 1.0rc1+100~ubuntu20.04.1 amd64
inkscape-tutorials/focal-updates,focal-updates 0.92.5-1ubuntu1.1 all
inkscape/focal 1.0.1+r73~ubuntu20.04.1 amd64
inkscape/focal-updates 0.92.5-1ubuntu1.1 i386
toto:~$

Voici les retours :

toto:~$ ls -l /etc/apt/sources.list.d
total 40
-rw-r--r-- 1 root root  189 Oct 14 20:28 google-chrome.list
-rw-r--r-- 1 root root  140 Oct 14 20:28 inkscape_dev-ubuntu-stable-bionic.list
-rw-r--r-- 1 root root  132 Oct 14 20:28 libreoffice-ubuntu-ppa-xenial.list
-rw-r--r-- 1 root root   53 Oct 14 22:04 megasync.list
-rw-r--r-- 1 root root  144 Oct 14 20:29 obsproject-ubuntu-obs-studio-bionic.list
-rw-r--r-- 1 root root  196 Oct 14 20:30 teams.list
-rw-r--r-- 1 root root 1198 Oct 14 20:30 teamviewer.list
-rw-r--r-- 1 root root  156 Oct 14 20:31 thierry-f-ubuntu-fork-michael-gruz-bionic.list
-rw-r--r-- 1 root root  146 Oct 12 14:28 yannubuntu-ubuntu-boot-repair-focal.list
-rw-r--r-- 1 root root   75 Oct 14 20:31 zotero.list

toto:~$ snap list
Nom                      Version                      Révision  Suivi            Éditeur       Notes
core                     16-2.47                      10126     latest/stable    canonical✓    core
core18                   20200724                     1885      latest/stable    canonical✓    base
gnome-3-28-1804          3.28.0-19-g98f9e67.98f9e67   145       latest/stable    canonical✓    -
gnome-3-34-1804          0+git.3556cb3                60        latest/stable/…  canonical✓    -
gtk-common-themes        0.1-36-gc75f853              1506      latest/stable/…  canonical✓    -
inkscape                 1.0.1-3bc2e813f5-2020-09-07  7947      latest/stable    inkscape✓     -
kde-frameworks-5-core18  5.61.0                       32        latest/stable    kde✓          -
obs-studio               26.0.2                       1141      latest/stable    snapcrafters  -
shotcut                  20.09.27                     71        latest/stable    meltytech✓    classic
skype                    8.65.0.78                    156       latest/stable    skype✓        classic
snap-store               3.36.0-82-g80486d0           481       latest/stable/…  canonical✓    -
sublime-text             3211                         85        latest/stable    snapcrafters  classic
zoom-client              5.3.469451.0927              101       latest/stable    ogra          -

toto:~$ flatpak list
Name                                        Application ID                                  Version    Branch    Origin     Installation
Nuvola Apps Service                         eu.tiliado.Nuvola                                          stable    nuvola     system
Deezer • Nuvola App                         eu.tiliado.NuvolaAppDeezer                                 stable    nuvola     system
default                                     org.freedesktop.Platform.GL.default                        20.08     flathub    system
nvidia-450-80-02                            org.freedesktop.Platform.GL.nvidia-450-80-02               1.4       flathub    system
Intel                                       org.freedesktop.Platform.VAAPI.Intel                       20.08     flathub    system
openh264                                    org.freedesktop.Platform.openh264               2.1.0      2.0       flathub    system
GNOME Application Platform version 3.38     org.gnome.Platform                                         3.38      flathub    system
Yaru Gtk Theme                              org.gtk.Gtk3theme.Yaru                                     3.22      flathub    system
toto:~$ 

Si j'ai bien compris, on peut maintenant virer 'inkscape_dev-ubuntu-stable-bionic.list' et 'obsproject-ubuntu-obs-studio-bionic.list' ?

Est-il nécessaire de garder 'thierry-f-ubuntu-fork-michael-gruz-bionic.list' ? J'avais finalement téléchargé les drivers de l'imprimante depuis le site de Canon donc je pense que ce dépôt et les paquets associés sont inutiles.
Est-ce que des drivers ça se met à jour comme des paquets ?

Dernière modification par TVG (Le 15/10/2020, à 14:45)

Hors ligne

#41 Le 15/10/2020, à 11:57

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

apt list va montrer tous les paquets disponibles via apt. Si tu filtres sur le terme "inkscape", ça va te montrer tous les paquets disponibles avec ce terme dans leur nom, pas nécessairement ceux qui sont installés.

Effectivement, tu peux supprimer les deux .list (Inkscape et OBS). Pense à supprimer aussi les .list.save correspondants si apt les a recréés.

Pour les drivers, ça dépend de la façon dont ils ont été installés, si ce sont des paquets deb ou non, etc. Accessoirement, si tu avais installé manuellement les pilotes du site de Canon sans avoir désinstallé les paquets venant du PPA, c'était pas vraiment une bonne idée : dans le cas où un script installe directement les fichiers, il pourrait remplacer les mêmes gérés par le deb du PPA et ça peut poser de gros problèmes quand on manipule le paquet en question ; en revanche, si Canon fournit des debs, il suffit qu'ils ne soient pas empaquetés de la même façon que ceux du PPA pour que ça mette la zone aussi.

En règle générale, hormis pour le cas des snaps/flatpaks/appimages qui ne s'installent pas dans les dossiers système habituels, il faut absolument éviter de multiplier les sources ou méthodes d'installations pour les mêmes logiciels.

Concernant ton imprimante, comme il n'y a ni dépôt Canon "officiel" dans tes sources ni de deb correspondant dans les paquets orphelins (sui aurait été installé manuellement), on peut en déduire que le pilote installé depuis le site officiel l'a été via un script qui copie directement les fichiers au bon endroit.

Avant de supprimer le PPA, il vaudrait donc mieux vérifier si des paquets installés viennent de lui :

dpkg -l | grep cncups
dpkg -l | grep cnijfilter
dpkg -l | grep cnrcups
dpkg -l | grep cque
dpkg -l | grep cupsys
dpkg -l | grep libcanon
dpkg -l | grep scangear

Hors ligne

#42 Le 15/10/2020, à 13:17

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Ah oui merci. En effet si je fais 'apt list --installed | grep obs' ou 'apt list --installed | grep inkscape', je ne trouve pas Inkscape ni OBS. En revanche, les "logithèques" ne sont pas à jour. Tu peux voir sur cette capture d'écran à gauche "Logiciel" qui montre le PPA et le snap et à droite "Ubuntu Software" (même chose que "Snap Store" chez moi a priori) qui montre le PPA uniquement (alors que je n'ai que le snap d'installé) : https://cjoint.com/c/JJplfDYPfmv. Est-ce que je peux en conclure qu'il faut éviter d'utiliser ces interfaces graphiques ?

Pour les pilotes d'imprimante et de scanner, j'ai récupéré les debian Packagearchives ici. Dedans, il y a un fichier install.sh à exécuter.

toto:~$ dpkg -l | grep cncups
toto:~$ dpkg -l | grep cnijfilter
ii  cnijfilter2                                5.90-1+2004+1ubuntu1                        amd64        IJ Printer Driver for Linux.
toto:~$ dpkg -l | grep cnrcups
toto:~$ dpkg -l | grep cque
toto:~$ dpkg -l | grep cupsys
toto:~$ dpkg -l | grep libcanon
ii  libcanon-proprio-bin                       0.2+3.90-2004ubuntu1                        amd64        libs for ScanGear MP for Linux.
toto:~$ dpkg -l | grep scangear
ii  scangearmp2                                3.90-1+2004+1ubuntu1                        amd64        ScanGear MP for Linux.
toto:~$

Merci pour les conseils !

Hors ligne

#43 Le 15/10/2020, à 13:28

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

C'est possible que GNOME Software (Logiciel) et/ou Ubuntu Software n'aient pas rechargé la liste des logiciels, ou que ce soit un petit bug. En théorie, il n'y a pas spécialement de problèmes à les utiliser. En revanche, dans Ubuntu Software (partie droite), tu es sûr que c'est la version deb et pas le snap qu'il te montre ?

Pour ton imprimante, on va vérifier les versions de ces paquets :

apt-cache policy cnijfilter2 libcanon-proprio-bin scangearmp2

EDIT : avant que j'oublie, dans les dépôts obsolètes supprimés au début, il y en avait un pour Avidemux. Si tu as encore besoin du soft, il est disponible en flatpak.

Dernière modification par abelthorne (Le 15/10/2020, à 13:31)

Hors ligne

#44 Le 15/10/2020, à 13:34

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Oui pratiquement sûr : https://cjoint.com/c/JJplFL0M6ov.

toto:~$ apt-cache policy cnijfilter2 libcanon-proprio-bin scangearmp2
cnijfilter2:
  Installé : 5.90-1+2004+1ubuntu1
  Candidat : 5.90-1+2004+1ubuntu1
 Table de version :
 *** 5.90-1+2004+1ubuntu1 500
        500 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
libcanon-proprio-bin:
  Installé : 0.2+3.90-2004ubuntu1
  Candidat : 0.2+3.90-2004ubuntu1
 Table de version :
 *** 0.2+3.90-2004ubuntu1 500
        500 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
scangearmp2:
  Installé : 3.90-1+2004+1ubuntu1
  Candidat : 3.90-1+2004+1ubuntu1
 Table de version :
 *** 3.90-1+2004+1ubuntu1 500
        500 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status
toto:~$ 

Ah ben y a le dépôt qui apparaît... Est-ce que ça veut dire que les drivers seront mis à jour si y a du changement dans ce dépôt ?

Hors ligne

#45 Le 15/10/2020, à 13:35

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

abelthorne a écrit :

EDIT : avant que j'oublie, dans les dépôts obsolètes supprimés au début, il y en avait un pour Avidemux. Si tu as encore besoin du soft, il est disponible en flatpak.

Merci. Non je n'en ai plus besoin.

Hors ligne

#46 Le 15/10/2020, à 13:52

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

C'est normal que le dépôt apparaisse, étant donné qu'il est actif. Ce que je voulais vérifier, c'est si ces paquets étaient aussi dans les dépôts Ubuntu mais ce n'est pas le cas. Quant aux mises à jour des pilotes : la réponse aurait été oui si tu utilisais cette version du pilote mais comme tu l'as installé en plus manuellement... Là, je ne sais pas si tu as deux pilotes installés, si tu en as un seul mais dont tu as remplacé des fichiers, etc. La seule chose de sûre, c'est que le pilote installé manuellement ne se mettra pas à jour tout seul.

On va essayer de le supprimer proprement :

sudo ppa-purge ppa:thierry-f/fork-michael-gruz

(Si ppa-purge n'est pas installé, il est dans les dépôts : sudo apt-get install ppa-purge)

Dernière modification par abelthorne (Le 15/10/2020, à 13:54)

Hors ligne

#47 Le 15/10/2020, à 14:02

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

abelthorne a écrit :

C'est normal que le dépôt apparaisse, étant donné qu'il est actif. Ce que je voulais vérifier, c'est si ces paquets étaient aussi dans les dépôts Ubuntu mais ce n'est pas le cas. Quant aux mises à jour des pilotes : la réponse aurait été oui si tu utilisais cette version du pilote mais comme tu l'as installé en plus manuellement... Là, je ne sais pas si tu as deux pilotes installés, si tu en as un seul mais dont tu as remplacé des fichiers, etc. La seule chose de sûre, c'est que le pilote installé manuellement ne se mettra pas à jour tout seul.

Je ne suis pas sûr de comprendre. Si le dépôt apparaît, c'est bien que les paquets s'y trouvent ? Donc 'cnijfilter2' et 'scangearmp2', que j'ai a priori installés à partir d'archives téléchargées sur le site de Canon (c'est bien les pilotes ces deux machins ?), se trouvent aussi dans http://ppa.launchpad.net/thierry-f/fork … ruz/ubuntu ? Est-ce que donc si on laisse ce dépôt, 'cnijfilter2' et 'scangearmp2' seront mis automatiquement à jour ?

Merci.

Hors ligne

#48 Le 15/10/2020, à 14:05

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

abelthorne a écrit :

C'est possible que GNOME Software (Logiciel) et/ou Ubuntu Software n'aient pas rechargé la liste des logiciels, ou que ce soit un petit bug.

J'ai rebooté. C'est à jour maintenant.

Hors ligne

#49 Le 15/10/2020, à 14:06

abelthorne

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

J'ai peut-être mal compris mais ce que tu as téléchargé sur le site de Canon, c'est un script d'installation, non (qui copie des fichiers sans passer par des paquets) ? ou bien ce sont des paquets deb qui correspondent à ceux du PPA (cnijfilter2, etc.) ?

Si on est dans le cas n° 2, alors ceux du PPA ont remplacé ceux que tu avais installés manuellement et du coup, il faudrait le garder. Auquel cas, les paquets seront effectivement maintenus à jour (à condition qu'il y ait effectivement des mises à jour et que le type qui gère le PPA s'en occupe).

Dernière modification par abelthorne (Le 15/10/2020, à 14:07)

Hors ligne

#50 Le 15/10/2020, à 14:10

TVG

Re : [Résolu] Ubuntu 20.04 : dépôts désactivés pour la MAJ vers focal

Voilà ce qu'on trouve dans l'archive téléchargée sur le site de Canon pour cnijfilter: https://cjoint.com/c/JJpmi4oKDnv.

Hors ligne