Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/06/2021, à 14:02

arvernes

[Résolu] passage 16.4 LTS vers 20.4 LTS

Bonjour,
Je voudrais passer sur mon portable de ma version 16.04 LTS, vers la 20.04 LTS. Il me semblait que lors d'une mise à jour des paquets, il me disait qu'une nouvelle version était dispo et il me proposait de faire l'upgrade. Là, il ne me propose pas ça. Sans doute parce que je n'ai pas fait l'upgrade vers la 18.04 LTS d'abord.
Comment puis faire l'upgrade tout en automatique maintenant.

Je pose la question, car j'ai les messages suivants :
do-release-upgrade -V
do-release-upgrade: version 16.04.32

et :
do-release-upgrade -c
Recherche d'une nouvelle version d'Ubuntu
Aucune nouvelle version n'a été trouvée.

donc ça m'étonne. Merci.

Dernière modification par arvernes (Le 07/06/2021, à 18:38)

Hors ligne

#2 Le 05/06/2021, à 14:15

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

En passant par le gestionnaire de mises à jour, on ne peut pas sauter de versions pour la mise à niveau, on ne peut passer que d'une version à la suivante ou d'une LTS à la LTS suivante. Donc, il faudrait effectivement passer d'abord à la 18.04, puis passer de la 18.04 à la 20.04.

Après, c'est possible de bidouiller en changeant manuellement les dépôts puis en faisant une grosse mise à jour mais les chances que ça se passe mal sont assez élevées, d'autant qu'il y a eu des changements majeurs entre la 16.04 et la 18.04 si tu es sur la variante principale d'Ubuntu (passage d'Unity à GNOME 3). Je ne le recommanderais pas.

Quoi qu'il en soit, il devrait toujours te proposer le passage en 18.04. Si ce n'est pas le cas, il y a potentiellement un problème de paramètres. Dans Logiciels et mises à jour, c'est bien réglé pour te proposer la mise à niveau pour les LTS (ou à la limite pour toutes les versions) ?

Dernière modification par abelthorne (Le 05/06/2021, à 14:16)

Hors ligne

#3 Le 05/06/2021, à 15:42

jplemoine

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

abelthorne a écrit :

Quoi qu'il en soit, il devrait toujours te proposer le passage en 18.04.

Sauf s'il n'y a plus les dépôts en ligne... Le support s'est arrêté en Avril dernier.

Je pense qu'il faut faire ce que je fais :
- faire un dual-boot entre les deux versions avec une partition /home séparé
- le user est suffixé par la version. --> Si l’utilisateur actuel est toto, le nouveau sera toto_18
- une fois installée, il suffit de copier les documents personnels d'un home à l'autre tout à sachant que UID sera le même (1000) --> Donc, pas de problème de droit.

S'il y a un problème, on  peut revenir en arrière facilement.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#4 Le 05/06/2021, à 15:44

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Bien vu ;-( Dans logiciels et mise à jour, j'avais le paramètre "me prévenir lorsqu'une nouvelle version d'ubuntu est disponible" à "Jamais". Je l'ai changé bien sûr, et là le gestionnaire de mise à jour me propose de migrer vers 18.04.05 LTS. J'espère que tout va bien se passer .... je croise les doigts. Merci pour la réponse.

Hors ligne

#5 Le 05/06/2021, à 16:43

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

jplemoine a écrit :

Sauf s'il n'y a plus les dépôts en ligne... Le support s'est arrêté en Avril dernier.

C'est le support de la 16.04 qui s'est arrêté en avril, la 18.04 est supportée encore deux ans. Normalement, du moment que les dépôts de la version vers laquelle on fait la mise à niveau sont en ligne, elle est possible, même si ceux de la version actuelle ne le sont plus.

arvernes a écrit :

Bien vu ;-( Dans logiciels et mise à jour, j'avais le paramètre "me prévenir lorsqu'une nouvelle version d'ubuntu est disponible" à "Jamais". Je l'ai changé bien sûr, et là le gestionnaire de mise à jour me propose de migrer vers 18.04.05 LTS. J'espère que tout va bien se passer .... je croise les doigts. Merci pour la réponse.

Une fois en 18.04, si la mise à niveau se fait sans problème, ce serait probablement une bonne idée de faire un peu de nettoyage (vérification des dépôts, nettoyage des paquets orphelins, du noyau...) avant de lancer celle vers la 20.04.

Dernière modification par abelthorne (Le 05/06/2021, à 16:46)

Hors ligne

#6 Le 05/06/2021, à 17:26

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Une fois en 18.04, si la mise à niveau se fait sans problème, ce serait probablement une bonne idée de faire un peu de nettoyage (vérification des dépôts, nettoyage des paquets orphelins, du noyau...) avant de lancer celle vers la 20.04.

OK, bonne idée. Comment je fais ça en ligne de commande ? Et faut-il que je fasse tourner un peu la 18.04 avant de continuer l'upgrade?
J'ai fait un "do-release-upgrade --sandbox" mais il me dit :
Please install all available updates for your release before upgrading.
Pourtant le gestionnaire de mise ne me donne pas d'updates. Il me dit que je suis à jour. Merci pour vos réponses.

Dernière modification par arvernes (Le 05/06/2021, à 17:30)

Hors ligne

#7 Le 05/06/2021, à 17:43

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

T'en es où, là ? Toujours en 16.04 ou tu as fait la mise à niveau en 18.04 ?

Je ne connais pas l'option --sandbox, je suggérerais de passer par le gestionnaire de mises à jour si tu es encore en 16.04 et de me dire quand c'est fait. Si c'est la mise à niveau en 18.04 qui te donne des messages d'erreur, on va faire un tour des dépôts/paquets. Commence par donner le retour de :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
cat /etc/apt/sources.list.d/*.list

Hors ligne

#8 Le 05/06/2021, à 17:46

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Pour le moment j 'attendais ta réponse. Je vais lancer le gestionnaire de fichiers. Ca risque d'être un peu long car mon ordi portable n'est pas de la première jeunesse (comme son proprio d'ailleurs ;-) ). Je lance la mise à niveau vers 18.04

Hors ligne

#9 Le 05/06/2021, à 18:00

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Là, s'il te dit qu'il y a des mises à jour à faire, c'est qu'il y a peut-être un problème de dépôts ou de paquets orphelins. Dans le doute, lance d'abord une mise à jour (en supposant que les dépôts sont encore en ligne malgré l'arrêt du support − généralement ils sont encore dispo pendant quelques mois)  :

sudo apt-get update && sudo apt-get dist-upgrade

Et s'il n'y a rien à faire, que tu as des erreurs ou que le gestionnaire de mises à jour ne peut pas lancer la mise à niveau, donne le retour des commandes demandées en #7.

Dernière modification par abelthorne (Le 05/06/2021, à 18:01)

Hors ligne

#10 Le 05/06/2021, à 18:23

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Le résultat de la commande que tu me donnes est la suivante :

sudo apt-get update && sudo apt-get dist-upgrade
Atteint :1 http://archive.canonical.com/ubuntu xenial InRelease
Atteint :2 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease   
Atteint :3 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                
Atteint :4 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease        
Atteint :5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease
Atteint :6 http://security.ubuntu.com/ubuntu xenial-security InRelease
Atteint :7 http://download.virtualbox.org/virtualbox/debian xenial InRelease
Atteint :8 https://linux.teamviewer.com/deb stable InRelease
Atteint :9 https://repo.skype.com/deb stable InRelease
Réception de :10 https://esm.ubuntu.com/infra/ubuntu xenial-infra-security InRelease [7 500 B]
Réception de :11 https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates InRelease [7 475 B]
15,0 ko réceptionnés en 1s (8 251 o/s)                          
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libllvm4.0 libllvm5.0 python3-notify2 snapd-login-service
Veuillez utiliser « sudo apt autoremove » pour les supprimer.

*The following packages could receive security updates with
 UA Infra: ESM service enabled:
  libpam0g libdjvulibre-text exim4-base gstreamer1.0-alsa linux-headers-generic linux-libc-dev gstreamer1.0-plugins-base-apps libpam-modules linux-image-generic-hwe-16.04 linux-image-generic libdjvulibre-dev linux-generic-hwe-16.04 exim4-daemon-light gstreamer1.0-plugins-base libpam-runtime isc-dhcp-common libx11-6 apport exim4-config python3-apport liblz4-1 libgstreamer-plugins-base1.0-0 gstreamer1.0-x gir1.2-gst-plugins-base-1.0 libpam-modules-bin libx11-data libx11-dev libx11-doc exim4 libdjvulibre21 apport-gtk linux-headers-generic-hwe-16.04 libexiv2-14 isc-dhcp-client linux-generic python3-problem-report libx11-xcb1
Learn more about UA Infra: ESM service at https://ubuntu.com/esm

0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Ensuite :

 cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
ls /etc/apt/sources.list.d/
total 28
-rw-r--r-- 1 root root  136 oct.  18  2017 webupd8team-ubuntu-java-xenial.list
-rw-r--r-- 1 root root   68 oct.  19  2017 virtualbox.list
-rw-r--r-- 1 root root   56 févr.  2 09:58 skype-stable.list
-rw-r--r-- 1 root root  315 mai    1 06:19 ubuntu-esm-infra.list
-rw-r--r-- 1 root root 1201 mai   28 10:56 teamviewer.list
drwxr-xr-x 2 root root 4096 juin   2 10:42 ./
drwxr-xr-x 7 root root 4096 juin   2 10:42 ../
cat /etc/apt/sources.list.d/*.list
deb [arch=amd64] https://repo.skype.com/deb stable main
###   TeamViewer DEB repository list

### NOTE: Manual changes to this file
###        - prevent it from being updated by TeamViewer package updates
###        - will be lost after using the 'teamviewer repo' command
###       The original file can be restored with this command:
###       cp /opt/teamviewer/tv_bin/script/teamviewer.list /etc/apt/sources.list.d/teamviewer.list
###       which has the same effect as 'teamviewer repo default'

### NOTE: It is preferred to use the following commands to edit this file:
###       teamviewer repo                - show current repository configuration
###       teamviewer repo default        - restore default configuration
###       teamviewer repo disable        - disable the repository
###       teamviewer repo stable         - make all regular TeamViewer packages available (default)
###       teamviewer repo preview        - additionally, make feature preview packages available
###       teamviewer repo development    - additionally, make the latest development packages available


deb https://linux.teamviewer.com/deb stable main

# deb https://linux.teamviewer.com/deb preview main
# deb https://linux.teamviewer.com/deb development main
# Written by ubuntu-advantage-tools
deb https://esm.ubuntu.com/infra/ubuntu xenial-infra-security main
# deb-src https://esm.ubuntu.com/infra/ubuntu xenial-infra-security main

deb https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates main
# deb-src https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates main
deb http://download.virtualbox.org/virtualbox/debian xenial contrib
deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main

Hors ligne

#11 Le 05/06/2021, à 18:31

geole

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

jplemoine a écrit :
abelthorne a écrit :

Quoi qu'il en soit, il devrait toujours te proposer le passage en 18.04.

Sauf s'il n'y a plus les dépôts en ligne... Le support s'est arrêté en Avril dernier.

Je viens d'installer

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.7 LTS"

sudo apt update 
Atteint :1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease                                              
Atteint :3 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease                                            
Atteint :4 http://security.ubuntu.com/ubuntu xenial-security InRelease             
Lecture des listes de paquets... Fait                         
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
183 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.

sudo apt list --upgradable
En train de lister... Fait
accountsservice/xenial-updates,xenial-security 0.6.40-2ubuntu11.6 amd64 [pouvant être mis à jour depuis : 0.6.40-2ubuntu11.3]
apport/xenial-updates,xenial-updates,xenial-security,xenial-security 2.20.1-0ubuntu2.30 all [pouvant être mis à jour depuis : 2.20.1-0ubuntu2.24]
apport-gtk/xenial-updates,xenial-updates,xenial-security,xenial-security 2.20.1-0ubuntu2.30 all [pouvant être mis à jour depuis : 2.20.1-0ubuntu2.24]
apt/xenial-updates 1.2.35 amd64 [pouvant être mis à jour depuis : 1.2.32ubuntu0.1]
apt-transport-https/xenial-updates 1.2.35 amd64 [pouvant être mis à jour depuis : 1.2.32ubuntu0.1]
apt-utils/xenial-updates 1.2.35 amd64 [pouvant être mis à jour depuis : 1.2.32ubuntu0.1]
aptdaemon/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1+bzr982-0ubuntu14.5 all [pouvant être mis à jour depuis : 1.1.1+bzr982-0ubuntu14.3]
aptdaemon-data/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1+bzr982-0ubuntu14.5 all [pouvant être mis à jour depuis : 1.1.1+bzr982-0ubuntu14.3]
base-files/xenial-updates 9.4ubuntu4.13 amd64 [pouvant être mis à jour depuis : 9.4ubuntu4.12]
bind9-host/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
ca-certificates/xenial-updates,xenial-updates,xenial-security,xenial-security 20210119~16.04.1 all [pouvant être mis à jour depuis : 20190110~16.04.1]
distro-info-data/xenial-updates,xenial-updates,xenial-security,xenial-security 0.28ubuntu0.17 all [pouvant être mis à jour depuis : 0.28ubuntu0.14]
dnsmasq-base/xenial-updates,xenial-security 2.75-1ubuntu0.16.04.10 amd64 [pouvant être mis à jour depuis : 2.75-1ubuntu0.16.04.5]
dnsutils/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
dpkg/xenial-updates 1.18.4ubuntu1.7 amd64 [pouvant être mis à jour depuis : 1.18.4ubuntu1.6]
dpkg-dev/xenial-updates,xenial-updates 1.18.4ubuntu1.7 all [pouvant être mis à jour depuis : 1.18.4ubuntu1.6]
file-roller/xenial-updates,xenial-security 3.16.5-0ubuntu1.5 amd64 [pouvant être mis à jour depuis : 3.16.5-0ubuntu1.4]
firefox/xenial-updates,xenial-security 88.0+build2-0ubuntu0.16.04.1 amd64 [pouvant être mis à jour depuis : 79.0+build1-0ubuntu0.16.04.2]
ghostscript/xenial-updates,xenial-security 9.26~dfsg+0-0ubuntu0.16.04.14 amd64 [pouvant être mis à jour depuis : 9.26~dfsg+0-0ubuntu0.16.04.12]
ghostscript-x/xenial-updates,xenial-security 9.26~dfsg+0-0ubuntu0.16.04.14 amd64 [pouvant être mis à jour depuis : 9.26~dfsg+0-0ubuntu0.16.04.12]
gir1.2-packagekitglib-1.0/xenial-updates,xenial-security 0.8.17-4ubuntu6~gcc5.4ubuntu1.5 amd64 [pouvant être mis à jour depuis : 0.8.17-4ubuntu6~gcc5.4ubuntu1.4]
grub-common/xenial-updates 2.02~beta2-36ubuntu3.32 amd64 [pouvant être mis à jour depuis : 2.02~beta2-36ubuntu3.27]
grub-pc/xenial-updates 2.02~beta2-36ubuntu3.32 amd64 [pouvant être mis à jour depuis : 2.02~beta2-36ubuntu3.27]
grub-pc-bin/xenial-updates 2.02~beta2-36ubuntu3.32 amd64 [pouvant être mis à jour depuis : 2.02~beta2-36ubuntu3.27]
grub2-common/xenial-updates 2.02~beta2-36ubuntu3.32 amd64 [pouvant être mis à jour depuis : 2.02~beta2-36ubuntu3.27]
gstreamer1.0-plugins-good/xenial-updates,xenial-security 1.8.3-1ubuntu0.5 amd64 [pouvant être mis à jour depuis : 1.8.3-1ubuntu0.4]
gstreamer1.0-pulseaudio/xenial-updates,xenial-security 1.8.3-1ubuntu0.5 amd64 [pouvant être mis à jour depuis : 1.8.3-1ubuntu0.4]
imagemagick/xenial-updates,xenial-security 8:6.8.9.9-7ubuntu5.16 amd64 [pouvant être mis à jour depuis : 8:6.8.9.9-7ubuntu5.15]
imagemagick-6.q16/xenial-updates,xenial-security 8:6.8.9.9-7ubuntu5.16 amd64 [pouvant être mis à jour depuis : 8:6.8.9.9-7ubuntu5.15]
imagemagick-common/xenial-updates,xenial-updates,xenial-security,xenial-security 8:6.8.9.9-7ubuntu5.16 all [pouvant être mis à jour depuis : 8:6.8.9.9-7ubuntu5.15]
initramfs-tools/xenial-updates,xenial-updates 0.122ubuntu8.17 all [pouvant être mis à jour depuis : 0.122ubuntu8.16]
initramfs-tools-bin/xenial-updates 0.122ubuntu8.17 amd64 [pouvant être mis à jour depuis : 0.122ubuntu8.16]
initramfs-tools-core/xenial-updates,xenial-updates 0.122ubuntu8.17 all [pouvant être mis à jour depuis : 0.122ubuntu8.16]
intel-microcode/xenial-updates,xenial-security 3.20210216.0ubuntu0.16.04.1 amd64 [pouvant être mis à jour depuis : 3.20200609.0ubuntu0.16.04.1]
krb5-locales/xenial-updates,xenial-updates,xenial-security,xenial-security 1.13.2+dfsg-5ubuntu2.2 all [pouvant être mis à jour depuis : 1.13.2+dfsg-5ubuntu2.1]
libaccountsservice0/xenial-updates,xenial-security 0.6.40-2ubuntu11.6 amd64 [pouvant être mis à jour depuis : 0.6.40-2ubuntu11.3]
libapt-inst2.0/xenial-updates 1.2.35 amd64 [pouvant être mis à jour depuis : 1.2.32ubuntu0.1]
libapt-pkg5.0/xenial-updates 1.2.35 amd64 [pouvant être mis à jour depuis : 1.2.32ubuntu0.1]
libbind9-140/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libc-bin/xenial-updates,xenial-security 2.23-0ubuntu11.3 amd64 [pouvant être mis à jour depuis : 2.23-0ubuntu11.2]
libc-dev-bin/xenial-updates,xenial-security 2.23-0ubuntu11.3 amd64 [pouvant être mis à jour depuis : 2.23-0ubuntu11.2]
libc6/xenial-updates,xenial-security 2.23-0ubuntu11.3 amd64 [pouvant être mis à jour depuis : 2.23-0ubuntu11.2]
libc6-dbg/xenial-updates,xenial-security 2.23-0ubuntu11.3 amd64 [pouvant être mis à jour depuis : 2.23-0ubuntu11.2]
libc6-dev/xenial-updates,xenial-security 2.23-0ubuntu11.3 amd64 [pouvant être mis à jour depuis : 2.23-0ubuntu11.2]
libcaca0/xenial-updates,xenial-security 0.99.beta19-2ubuntu0.16.04.2 amd64 [pouvant être mis à jour depuis : 0.99.beta19-2ubuntu0.16.04.1]
libcurl3/xenial-updates,xenial-security 7.47.0-1ubuntu2.19 amd64 [pouvant être mis à jour depuis : 7.47.0-1ubuntu2.15]
libcurl3-gnutls/xenial-updates,xenial-security 7.47.0-1ubuntu2.19 amd64 [pouvant être mis à jour depuis : 7.47.0-1ubuntu2.15]
libdns-export162/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libdns162/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libdpkg-perl/xenial-updates,xenial-updates 1.18.4ubuntu1.7 all [pouvant être mis à jour depuis : 1.18.4ubuntu1.6]
libexif12/xenial-updates,xenial-security 0.6.21-2ubuntu0.6 amd64 [pouvant être mis à jour depuis : 0.6.21-2ubuntu0.5]
libfreetype6/xenial-updates,xenial-security 2.6.1-0.1ubuntu2.5 amd64 [pouvant être mis à jour depuis : 2.6.1-0.1ubuntu2.4]
libglib2.0-0/xenial-updates,xenial-security 2.48.2-0ubuntu4.8 amd64 [pouvant être mis à jour depuis : 2.48.2-0ubuntu4.6]
libglib2.0-bin/xenial-updates,xenial-security 2.48.2-0ubuntu4.8 amd64 [pouvant être mis à jour depuis : 2.48.2-0ubuntu4.6]
libglib2.0-data/xenial-updates,xenial-updates,xenial-security,xenial-security 2.48.2-0ubuntu4.8 all [pouvant être mis à jour depuis : 2.48.2-0ubuntu4.6]
libgs9/xenial-updates,xenial-security 9.26~dfsg+0-0ubuntu0.16.04.14 amd64 [pouvant être mis à jour depuis : 9.26~dfsg+0-0ubuntu0.16.04.12]
libgs9-common/xenial-updates,xenial-updates,xenial-security,xenial-security 9.26~dfsg+0-0ubuntu0.16.04.14 all [pouvant être mis à jour depuis : 9.26~dfsg+0-0ubuntu0.16.04.12]
libgssapi-krb5-2/xenial-updates,xenial-security 1.13.2+dfsg-5ubuntu2.2 amd64 [pouvant être mis à jour depuis : 1.13.2+dfsg-5ubuntu2.1]
libgstreamer-plugins-good1.0-0/xenial-updates,xenial-security 1.8.3-1ubuntu0.5 amd64 [pouvant être mis à jour depuis : 1.8.3-1ubuntu0.4]
libhogweed4/xenial-updates,xenial-security 3.2-1ubuntu0.16.04.2 amd64 [pouvant être mis à jour depuis : 3.2-1ubuntu0.16.04.1]
libisc-export160/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libisc160/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libisccc140/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libisccfg140/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libjasper1/xenial-updates,xenial-security 1.900.1-debian1-2.4ubuntu1.3 amd64 [pouvant être mis à jour depuis : 1.900.1-debian1-2.4ubuntu1.2]
libk5crypto3/xenial-updates,xenial-security 1.13.2+dfsg-5ubuntu2.2 amd64 [pouvant être mis à jour depuis : 1.13.2+dfsg-5ubuntu2.1]
libkrb5-3/xenial-updates,xenial-security 1.13.2+dfsg-5ubuntu2.2 amd64 [pouvant être mis à jour depuis : 1.13.2+dfsg-5ubuntu2.1]
libkrb5support0/xenial-updates,xenial-security 1.13.2+dfsg-5ubuntu2.2 amd64 [pouvant être mis à jour depuis : 1.13.2+dfsg-5ubuntu2.1]
libldap-2.4-2/xenial-updates,xenial-security 2.4.42+dfsg-2ubuntu3.13 amd64 [pouvant être mis à jour depuis : 2.4.42+dfsg-2ubuntu3.9]
libldb1/xenial-updates,xenial-security 2:1.1.24-1ubuntu3.2 amd64 [pouvant être mis à jour depuis : 2:1.1.24-1ubuntu3.1]
liblwres141/xenial-updates,xenial-security 1:9.10.3.dfsg.P4-8ubuntu1.19 amd64 [pouvant être mis à jour depuis : 1:9.10.3.dfsg.P4-8ubuntu1.16]
libmagickcore-6.q16-2/xenial-updates,xenial-security 8:6.8.9.9-7ubuntu5.16 amd64 [pouvant être mis à jour depuis : 8:6.8.9.9-7ubuntu5.15]
libmagickcore-6.q16-2-extra/xenial-updates,xenial-security 8:6.8.9.9-7ubuntu5.16 amd64 [pouvant être mis à jour depuis : 8:6.8.9.9-7ubuntu5.15]
libmagickwand-6.q16-2/xenial-updates,xenial-security 8:6.8.9.9-7ubuntu5.16 amd64 [pouvant être mis à jour depuis : 8:6.8.9.9-7ubuntu5.15]
libnettle6/xenial-updates,xenial-security 3.2-1ubuntu0.16.04.2 amd64 [pouvant être mis à jour depuis : 3.2-1ubuntu0.16.04.1]
libnss3/xenial-updates,xenial-security 2:3.28.4-0ubuntu0.16.04.14 amd64 [pouvant être mis à jour depuis : 2:3.28.4-0ubuntu0.16.04.12]
libnss3-nssdb/xenial-updates,xenial-updates,xenial-security,xenial-security 2:3.28.4-0ubuntu0.16.04.14 all [pouvant être mis à jour depuis : 2:3.28.4-0ubuntu0.16.04.12]
libopenexr22/xenial-updates,xenial-security 2.2.0-10ubuntu2.6 amd64 [pouvant être mis à jour depuis : 2.2.0-10ubuntu2.3]
libp11-kit0/xenial-updates,xenial-security 0.23.2-5~ubuntu16.04.2 amd64 [pouvant être mis à jour depuis : 0.23.2-5~ubuntu16.04.1]
libpackagekit-glib2-16/xenial-updates,xenial-security 0.8.17-4ubuntu6~gcc5.4ubuntu1.5 amd64 [pouvant être mis à jour depuis : 0.8.17-4ubuntu6~gcc5.4ubuntu1.4]
libpam-modules/xenial-updates 1.1.8-3.2ubuntu2.3 amd64 [pouvant être mis à jour depuis : 1.1.8-3.2ubuntu2.1]
libpam-modules-bin/xenial-updates 1.1.8-3.2ubuntu2.3 amd64 [pouvant être mis à jour depuis : 1.1.8-3.2ubuntu2.1]
libpam-runtime/xenial-updates,xenial-updates 1.1.8-3.2ubuntu2.3 all [pouvant être mis à jour depuis : 1.1.8-3.2ubuntu2.1]
libpam-systemd/xenial-updates 229-4ubuntu21.31 amd64 [pouvant être mis à jour depuis : 229-4ubuntu21.28]
libpam0g/xenial-updates 1.1.8-3.2ubuntu2.3 amd64 [pouvant être mis à jour depuis : 1.1.8-3.2ubuntu2.1]
libperl5.22/xenial-updates,xenial-security 5.22.1-9ubuntu0.9 amd64 [pouvant être mis à jour depuis : 5.22.1-9ubuntu0.6]
libpoppler-glib8/xenial-updates,xenial-security 0.41.0-0ubuntu1.16 amd64 [pouvant être mis à jour depuis : 0.41.0-0ubuntu1.14]
libpoppler58/xenial-updates,xenial-security 0.41.0-0ubuntu1.16 amd64 [pouvant être mis à jour depuis : 0.41.0-0ubuntu1.14]
libproxy1-plugin-gsettings/xenial-updates,xenial-security 0.4.11-5ubuntu1.2 amd64 [pouvant être mis à jour depuis : 0.4.11-5ubuntu1]
libproxy1-plugin-networkmanager/xenial-updates,xenial-security 0.4.11-5ubuntu1.2 amd64 [pouvant être mis à jour depuis : 0.4.11-5ubuntu1]
libproxy1v5/xenial-updates,xenial-security 0.4.11-5ubuntu1.2 amd64 [pouvant être mis à jour depuis : 0.4.11-5ubuntu1]
libpulse-mainloop-glib0/xenial-updates,xenial-security 1:8.0-0ubuntu3.15 amd64 [pouvant être mis à jour depuis : 1:8.0-0ubuntu3.12]
libpulse0/xenial-updates,xenial-security 1:8.0-0ubuntu3.15 amd64 [pouvant être mis à jour depuis : 1:8.0-0ubuntu3.12]
libpulsedsp/xenial-updates,xenial-security 1:8.0-0ubuntu3.15 amd64 [pouvant être mis à jour depuis : 1:8.0-0ubuntu3.12]
libpython2.7/xenial-updates,xenial-security 2.7.12-1ubuntu0~16.04.18 amd64 [pouvant être mis à jour depuis : 2.7.12-1ubuntu0~16.04.12]
libpython2.7-minimal/xenial-updates,xenial-security 2.7.12-1ubuntu0~16.04.18 amd64 [pouvant être mis à jour depuis : 2.7.12-1ubuntu0~16.04.12]
libpython2.7-stdlib/xenial-updates,xenial-security 2.7.12-1ubuntu0~16.04.18 amd64 [pouvant être mis à jour depuis : 2.7.12-1ubuntu0~16.04.12]
libpython3.5/xenial-updates,xenial-security 3.5.2-2ubuntu0~16.04.13 amd64 [pouvant être mis à jour depuis : 3.5.2-2ubuntu0~16.04.11]
libpython3.5-minimal/xenial-updates,xenial-security 3.5.2-2ubuntu0~16.04.13 amd64 [pouvant être mis à jour depuis : 3.5.2-2ubuntu0~16.04.11]
libpython3.5-stdlib/xenial-updates,xenial-security 3.5.2-2ubuntu0~16.04.13 amd64 [pouvant être mis à jour depuis : 3.5.2-2ubuntu0~16.04.11]
libraptor2-0/xenial-updates,xenial-security 2.0.14-1ubuntu0.16.04.1 amd64 [pouvant être mis à jour depuis : 2.0.14-1]
libsane/xenial-updates,xenial-security 1.0.25+git20150528-1ubuntu2.16.04.3 amd64 [pouvant être mis à jour depuis : 1.0.25+git20150528-1ubuntu2.16.04.1]
libsane-common/xenial-updates,xenial-updates,xenial-security,xenial-security 1.0.25+git20150528-1ubuntu2.16.04.3 all [pouvant être mis à jour depuis : 1.0.25+git20150528-1ubuntu2.16.04.1]
libseccomp2/xenial-updates 2.5.1-1ubuntu1~16.04.1 amd64 [pouvant être mis à jour depuis : 2.4.3-1ubuntu3.16.04.3]
libsmbclient/xenial-updates,xenial-security 2:4.3.11+dfsg-0ubuntu0.16.04.34 amd64 [pouvant être mis à jour depuis : 2:4.3.11+dfsg-0ubuntu0.16.04.28]
libsndfile1/xenial-updates,xenial-security 1.0.25-10ubuntu0.16.04.3 amd64 [pouvant être mis à jour depuis : 1.0.25-10ubuntu0.16.04.2]
libsnmp-base/xenial-updates,xenial-updates,xenial-security,xenial-security 5.7.3+dfsg-1ubuntu4.6 all [pouvant être mis à jour depuis : 5.7.3+dfsg-1ubuntu4.4]
libsnmp30/xenial-updates,xenial-security 5.7.3+dfsg-1ubuntu4.6 amd64 [pouvant être mis à jour depuis : 5.7.3+dfsg-1ubuntu4.4]
libssl1.0.0/xenial-updates,xenial-security 1.0.2g-1ubuntu4.19 amd64 [pouvant être mis à jour depuis : 1.0.2g-1ubuntu4.16]
libsystemd0/xenial-updates 229-4ubuntu21.31 amd64 [pouvant être mis à jour depuis : 229-4ubuntu21.28]
libtiff5/xenial-updates,xenial-security 4.0.6-1ubuntu0.8 amd64 [pouvant être mis à jour depuis : 4.0.6-1ubuntu0.7]
libudev1/xenial-updates 229-4ubuntu21.31 amd64 [pouvant être mis à jour depuis : 229-4ubuntu21.28]
libvncclient1/xenial-updates,xenial-security 0.9.10+dfsg-3ubuntu0.16.04.6 amd64 [pouvant être mis à jour depuis : 0.9.10+dfsg-3ubuntu0.16.04.5]
libwbclient0/xenial-updates,xenial-security 2:4.3.11+dfsg-0ubuntu0.16.04.34 amd64 [pouvant être mis à jour depuis : 2:4.3.11+dfsg-0ubuntu0.16.04.28]
libx11-6/xenial-updates,xenial-security 2:1.6.3-1ubuntu2.2 amd64 [pouvant être mis à jour depuis : 2:1.6.3-1ubuntu2.1]
libx11-data/xenial-updates,xenial-updates,xenial-security,xenial-security 2:1.6.3-1ubuntu2.2 all [pouvant être mis à jour depuis : 2:1.6.3-1ubuntu2.1]
libx11-xcb1/xenial-updates,xenial-security 2:1.6.3-1ubuntu2.2 amd64 [pouvant être mis à jour depuis : 2:1.6.3-1ubuntu2.1]
linux-libc-dev/xenial-updates,xenial-security 4.4.0-210.242 amd64 [pouvant être mis à jour depuis : 4.4.0-186.216]
locales/xenial-updates,xenial-updates,xenial-security,xenial-security 2.23-0ubuntu11.3 all [pouvant être mis à jour depuis : 2.23-0ubuntu11.2]
multiarch-support/xenial-updates,xenial-security 2.23-0ubuntu11.3 amd64 [pouvant être mis à jour depuis : 2.23-0ubuntu11.2]
openssl/xenial-updates,xenial-security 1.0.2g-1ubuntu4.19 amd64 [pouvant être mis à jour depuis : 1.0.2g-1ubuntu4.16]
p11-kit/xenial-updates,xenial-security 0.23.2-5~ubuntu16.04.2 amd64 [pouvant être mis à jour depuis : 0.23.2-5~ubuntu16.04.1]
p11-kit-modules/xenial-updates,xenial-security 0.23.2-5~ubuntu16.04.2 amd64 [pouvant être mis à jour depuis : 0.23.2-5~ubuntu16.04.1]
perl/xenial-updates,xenial-security 5.22.1-9ubuntu0.9 amd64 [pouvant être mis à jour depuis : 5.22.1-9ubuntu0.6]
perl-base/xenial-updates,xenial-security 5.22.1-9ubuntu0.9 amd64 [pouvant être mis à jour depuis : 5.22.1-9ubuntu0.6]
perl-modules-5.22/xenial-updates,xenial-updates,xenial-security,xenial-security 5.22.1-9ubuntu0.9 all [pouvant être mis à jour depuis : 5.22.1-9ubuntu0.6]
poppler-utils/xenial-updates,xenial-security 0.41.0-0ubuntu1.16 amd64 [pouvant être mis à jour depuis : 0.41.0-0ubuntu1.14]
pulseaudio/xenial-updates,xenial-security 1:8.0-0ubuntu3.15 amd64 [pouvant être mis à jour depuis : 1:8.0-0ubuntu3.12]
pulseaudio-module-bluetooth/xenial-updates,xenial-security 1:8.0-0ubuntu3.15 amd64 [pouvant être mis à jour depuis : 1:8.0-0ubuntu3.12]
pulseaudio-module-x11/xenial-updates,xenial-security 1:8.0-0ubuntu3.15 amd64 [pouvant être mis à jour depuis : 1:8.0-0ubuntu3.12]
pulseaudio-utils/xenial-updates,xenial-security 1:8.0-0ubuntu3.15 amd64 [pouvant être mis à jour depuis : 1:8.0-0ubuntu3.12]
python-apt-common/xenial-updates,xenial-updates 1.1.0~beta1ubuntu0.16.04.12 all [pouvant être mis à jour depuis : 1.1.0~beta1ubuntu0.16.04.9]
python2.7/xenial-updates,xenial-security 2.7.12-1ubuntu0~16.04.18 amd64 [pouvant être mis à jour depuis : 2.7.12-1ubuntu0~16.04.12]
python2.7-minimal/xenial-updates,xenial-security 2.7.12-1ubuntu0~16.04.18 amd64 [pouvant être mis à jour depuis : 2.7.12-1ubuntu0~16.04.12]
python3-apport/xenial-updates,xenial-updates,xenial-security,xenial-security 2.20.1-0ubuntu2.30 all [pouvant être mis à jour depuis : 2.20.1-0ubuntu2.24]
python3-apt/xenial-updates 1.1.0~beta1ubuntu0.16.04.12 amd64 [pouvant être mis à jour depuis : 1.1.0~beta1ubuntu0.16.04.9]
python3-aptdaemon/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1+bzr982-0ubuntu14.5 all [pouvant être mis à jour depuis : 1.1.1+bzr982-0ubuntu14.3]
python3-aptdaemon.gtk3widgets/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1+bzr982-0ubuntu14.5 all [pouvant être mis à jour depuis : 1.1.1+bzr982-0ubuntu14.3]
python3-aptdaemon.pkcompat/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1+bzr982-0ubuntu14.5 all [pouvant être mis à jour depuis : 1.1.1+bzr982-0ubuntu14.3]
python3-cryptography/xenial-updates,xenial-security 1.2.3-1ubuntu0.3 amd64 [pouvant être mis à jour depuis : 1.2.3-1ubuntu0.2]
python3-distupgrade/xenial-updates,xenial-updates 1:16.04.32 all [pouvant être mis à jour depuis : 1:16.04.30]
python3-lxml/xenial-updates,xenial-security 3.5.0-1ubuntu0.4 amd64 [pouvant être mis à jour depuis : 3.5.0-1ubuntu0.1]
python3-pil/xenial-updates,xenial-security 3.1.2-0ubuntu1.6 amd64 [pouvant être mis à jour depuis : 3.1.2-0ubuntu1.4]
python3-problem-report/xenial-updates,xenial-updates,xenial-security,xenial-security 2.20.1-0ubuntu2.30 all [pouvant être mis à jour depuis : 2.20.1-0ubuntu2.24]
python3-pyparsing/xenial-updates,xenial-updates,xenial-security,xenial-security 2.0.3+dfsg1-1ubuntu0.2 all [pouvant être mis à jour depuis : 2.0.3+dfsg1-1ubuntu0.1]
python3-software-properties/xenial-updates,xenial-updates,xenial-security,xenial-security 0.96.20.10 all [pouvant être mis à jour depuis : 0.96.20.9]
python3-urllib3/xenial-updates,xenial-updates,xenial-security,xenial-security 1.13.1-2ubuntu0.16.04.4 all [pouvant être mis à jour depuis : 1.13.1-2ubuntu0.16.04.3]
python3-xdg/xenial-updates,xenial-updates,xenial-security,xenial-security 0.25-4ubuntu0.16.04.1 all [pouvant être mis à jour depuis : 0.25-4]
python3.5/xenial-updates,xenial-security 3.5.2-2ubuntu0~16.04.13 amd64 [pouvant être mis à jour depuis : 3.5.2-2ubuntu0~16.04.11]
python3.5-minimal/xenial-updates,xenial-security 3.5.2-2ubuntu0~16.04.13 amd64 [pouvant être mis à jour depuis : 3.5.2-2ubuntu0~16.04.11]
samba-libs/xenial-updates,xenial-security 2:4.3.11+dfsg-0ubuntu0.16.04.34 amd64 [pouvant être mis à jour depuis : 2:4.3.11+dfsg-0ubuntu0.16.04.28]
sane-utils/xenial-updates,xenial-security 1.0.25+git20150528-1ubuntu2.16.04.3 amd64 [pouvant être mis à jour depuis : 1.0.25+git20150528-1ubuntu2.16.04.1]
sbsigntool/xenial-updates,xenial-security 0.6-0ubuntu10.2 amd64 [pouvant être mis à jour depuis : 0.6-0ubuntu10.1]
snapd/xenial-updates,xenial-security 2.48.3 amd64 [pouvant être mis à jour depuis : 2.45.1ubuntu0.2]
software-properties-common/xenial-updates,xenial-updates,xenial-security,xenial-security 0.96.20.10 all [pouvant être mis à jour depuis : 0.96.20.9]
software-properties-gtk/xenial-updates,xenial-updates,xenial-security,xenial-security 0.96.20.10 all [pouvant être mis à jour depuis : 0.96.20.9]
sudo/xenial-updates,xenial-security 1.8.16-0ubuntu1.10 amd64 [pouvant être mis à jour depuis : 1.8.16-0ubuntu1.9]
systemd/xenial-updates 229-4ubuntu21.31 amd64 [pouvant être mis à jour depuis : 229-4ubuntu21.28]
systemd-sysv/xenial-updates 229-4ubuntu21.31 amd64 [pouvant être mis à jour depuis : 229-4ubuntu21.28]
tar/xenial-updates,xenial-security 1.28-2.1ubuntu0.2 amd64 [pouvant être mis à jour depuis : 1.28-2.1ubuntu0.1]
tzdata/xenial-updates,xenial-updates,xenial-security,xenial-security 2021a-0ubuntu0.16.04 all [pouvant être mis à jour depuis : 2020a-0ubuntu0.16.04]
ubuntu-advantage-tools/xenial-updates 27.0~16.04.1 all [pouvant être mis à jour depuis : 10ubuntu0.16.04.1]
ubuntu-core-launcher/xenial-updates,xenial-security 2.48.3 amd64 [pouvant être mis à jour depuis : 2.45.1ubuntu0.2]
ubuntu-desktop/xenial-updates 1.361.6 amd64 [pouvant être mis à jour depuis : 1.361.4]
ubuntu-minimal/xenial-updates 1.361.6 amd64 [pouvant être mis à jour depuis : 1.361.4]
ubuntu-release-upgrader-core/xenial-updates,xenial-updates 1:16.04.32 all [pouvant être mis à jour depuis : 1:16.04.30]
ubuntu-release-upgrader-gtk/xenial-updates,xenial-updates 1:16.04.32 all [pouvant être mis à jour depuis : 1:16.04.30]
ubuntu-standard/xenial-updates 1.361.6 amd64 [pouvant être mis à jour depuis : 1.361.4]
udev/xenial-updates 229-4ubuntu21.31 amd64 [pouvant être mis à jour depuis : 229-4ubuntu21.28]
unattended-upgrades/xenial-updates,xenial-updates 1.1ubuntu1.18.04.7~16.04.7 all [pouvant être mis à jour depuis : 1.1ubuntu1.18.04.7~16.04.6]
unzip/xenial-updates,xenial-security 6.0-20ubuntu1.1 amd64 [pouvant être mis à jour depuis : 6.0-20ubuntu1]
update-notifier/xenial-updates 3.168.14 amd64 [pouvant être mis à jour depuis : 3.168.10]
update-notifier-common/xenial-updates,xenial-updates 3.168.14 all [pouvant être mis à jour depuis : 3.168.10]
vim-common/xenial-updates,xenial-security 2:7.4.1689-3ubuntu1.5 amd64 [pouvant être mis à jour depuis : 2:7.4.1689-3ubuntu1.4]
vim-tiny/xenial-updates,xenial-security 2:7.4.1689-3ubuntu1.5 amd64 [pouvant être mis à jour depuis : 2:7.4.1689-3ubuntu1.4]
vino/xenial-updates,xenial-security 3.8.1-0ubuntu9.4 amd64 [pouvant être mis à jour depuis : 3.8.1-0ubuntu9.2]
wireless-regdb/xenial-updates,xenial-updates,xenial-security,xenial-security 2020.11.20-0ubuntu1~16.04.2 all [pouvant être mis à jour depuis : 2018.05.09-0ubuntu1~16.04.1]
wpasupplicant/xenial-updates,xenial-security 2.4-0ubuntu6.8 amd64 [pouvant être mis à jour depuis : 2.4-0ubuntu6.6]
xdg-utils/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1-1ubuntu1.16.04.5 all [pouvant être mis à jour depuis : 1.1.1-1ubuntu1.16.04.3]
xserver-common/xenial-updates,xenial-updates,xenial-security,xenial-security 2:1.18.4-0ubuntu0.12 all [pouvant être mis à jour depuis : 2:1.18.4-0ubuntu0.8]
xserver-xorg-core-hwe-16.04/xenial-updates,xenial-security 2:1.19.6-1ubuntu4.1~16.04.6 amd64 [pouvant être mis à jour depuis : 2:1.19.6-1ubuntu4.1~16.04.2]
xserver-xorg-legacy-hwe-16.04/xenial-updates,xenial-security 2:1.19.6-1ubuntu4.1~16.04.6 amd64 [pouvant être mis à jour depuis : 2:1.19.6-1ubuntu4.1~16.04.2]
xterm/xenial-updates,xenial-security 322-1ubuntu1.2 amd64 [pouvant être mis à jour depuis : 322-1ubuntu1]

sudo apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  distro-info libzstd1 python3-distro-info python3-yaml
Les paquets suivants seront mis à jour :
  accountsservice apport apport-gtk apt apt-transport-https apt-utils aptdaemon aptdaemon-data base-files bind9-host ca-certificates distro-info-data dnsmasq-base
  dnsutils dpkg dpkg-dev file-roller firefox ghostscript ghostscript-x gir1.2-packagekitglib-1.0 grub-common grub-pc grub-pc-bin grub2-common gstreamer1.0-plugins-good
  gstreamer1.0-pulseaudio imagemagick imagemagick-6.q16 imagemagick-common initramfs-tools initramfs-tools-bin initramfs-tools-core intel-microcode krb5-locales
  libaccountsservice0 libapt-inst2.0 libapt-pkg5.0 libbind9-140 libc-bin libc-dev-bin libc6 libc6-dbg libc6-dev libcaca0 libcurl3 libcurl3-gnutls libdns-export162
  libdns162 libdpkg-perl libexif12 libfreetype6 libglib2.0-0 libglib2.0-bin libglib2.0-data libgs9 libgs9-common libgssapi-krb5-2 libgstreamer-plugins-good1.0-0
  libhogweed4 libisc-export160 libisc160 libisccc140 libisccfg140 libjasper1 libk5crypto3 libkrb5-3 libkrb5support0 libldap-2.4-2 libldb1 liblwres141
  libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra libmagickwand-6.q16-2 libnettle6 libnss3 libnss3-nssdb libopenexr22 libp11-kit0 libpackagekit-glib2-16
  libpam-modules libpam-modules-bin libpam-runtime libpam-systemd libpam0g libperl5.22 libpoppler-glib8 libpoppler58 libproxy1-plugin-gsettings
  libproxy1-plugin-networkmanager libproxy1v5 libpulse-mainloop-glib0 libpulse0 libpulsedsp libpython2.7 libpython2.7-minimal libpython2.7-stdlib libpython3.5
  libpython3.5-minimal libpython3.5-stdlib libraptor2-0 libsane libsane-common libseccomp2 libsmbclient libsndfile1 libsnmp-base libsnmp30 libssl1.0.0 libsystemd0
  libtiff5 libudev1 libvncclient1 libwbclient0 libx11-6 libx11-data libx11-xcb1 linux-libc-dev locales multiarch-support openssl p11-kit p11-kit-modules perl perl-base
  perl-modules-5.22 poppler-utils pulseaudio pulseaudio-module-bluetooth pulseaudio-module-x11 pulseaudio-utils python-apt-common python2.7 python2.7-minimal
  python3-apport python3-apt python3-aptdaemon python3-aptdaemon.gtk3widgets python3-aptdaemon.pkcompat python3-cryptography python3-distupgrade python3-lxml
  python3-pil python3-problem-report python3-pyparsing python3-software-properties python3-urllib3 python3-xdg python3.5 python3.5-minimal samba-libs sane-utils
  sbsigntool snapd software-properties-common software-properties-gtk sudo systemd systemd-sysv tar tzdata ubuntu-advantage-tools ubuntu-core-launcher ubuntu-desktop
  ubuntu-minimal ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk ubuntu-standard udev unattended-upgrades unzip update-notifier update-notifier-common
  vim-common vim-tiny vino wireless-regdb wpasupplicant xdg-utils xserver-common xserver-xorg-core-hwe-16.04 xserver-xorg-legacy-hwe-16.04 xterm
183 mis à jour, 4 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 169 Mo dans les archives.
Après cette opération, 22,9 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 

Le but va être de vérifier si passage en automatique en version 20.04

La première étape est faite...

a@a:~$ sudo apt update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Réception de :2 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]                                
Réception de :3 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]                                 
Réception de :4 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]       
Réception de :5 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [2 049 kB]
Réception de :6 https://esm.ubuntu.com/infra/ubuntu xenial-infra-security InRelease [7 500 B] 
Réception de :7 https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates InRelease [7 475 B]    
Réception de :8 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [93,7 kB]                             
Réception de :9 https://esm.ubuntu.com/infra/ubuntu xenial-infra-security/main amd64 Packages [76,9 kB]
Réception de :10 https://esm.ubuntu.com/infra/ubuntu xenial-infra-security/main i386 Packages [30,0 kB]      
Réception de :11 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [130 kB]
Réception de :12 https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates/main amd64 Packages [4 746 B]         
Réception de :13 https://esm.ubuntu.com/infra/ubuntu xenial-infra-updates/main i386 Packages [4 750 B]            
Réception de :14 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [2 468 B]     
Réception de :15 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [1 525 kB]
Réception de :16 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [327 kB]
Réception de :17 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [281 kB]
Réception de :18 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5 976 B]
Réception de :19 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3 328 B]
Réception de :20 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [6 612 B]
4 880 ko réceptionnés en 4s (1 092 ko/s)                                   
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.

sudo do-release-upgrade appelle les paquets bionic donc 18.04!!!!!!!!

54 paquets installés ne sont plus maintenus par Canonical. Vous 
pouvez toujours obtenir une assistance de la part de la communauté. 

40 paquets vont être supprimés. 408 nouveaux paquets vont être 
installés. 1518 paquets vont être mis à jour.

Dernière modification par geole (Le 05/06/2021, à 19:10)

Hors ligne

#12 Le 05/06/2021, à 18:40

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Tout a l'air ok pour les dépôts. Donne maintenant le retour de :

apt list | grep "installé, local"

Il y a juste un truc qui peut potentiellement être à l'origine du problème : tu as apparemment un dépôt pour le support étendu (ESM) et il te dit qu'il y a quelques paquets qui pourraient être mis à jour avec. Sauf qu'il ne le fait pas tout seul, donc je suppose qu'il faut activer un truc quelque part. Et ça, je connais pas du tout. Si ce sont effectivement ces mises à jour potentielles qui posent problème pour la mise à niveau, il va falloir creuser. Peut-être que simplement désactiver le dépôt ESM suffirait, on va voir ça.

Hors ligne

#13 Le 05/06/2021, à 18:41

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

geole, je viens de faire la même manip que toi et ça me donne ça :

sudo apt list --upgradable
En train de lister... Fait
skypeforlinux/stable 8.72.0.94 amd64 [pouvant être mis à jour depuis : 8.68.0.100]
N: Il y a des versions supplémentaires 4. Veuillez utiliser l'opérande « -a » pour les voir.

comment je fais pour mettre à jour ce skypeforlinux ?

Hors ligne

#14 Le 05/06/2021, à 18:42

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Voilà le résultat :

apt list | grep "installé, local"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

anydesk/now 4.0.1-1 amd64  [installé, local]
brmfc7840wlpr/now 2.0.2-1 i386  [installé, local]
brother-udev-rule-type1/now 1.0.0-1 all  [installé, local]
brscan-skey/now 0.2.4-1 amd64  [installé, local]
brscan3/now 0.2.13-1 amd64  [installé, local]
cupswrappermfc7840w/now 2.0.2-1 i386  [installé, local]
libdvdcss-dev/now 1.4.0-1~local amd64  [installé, local]
libdvdcss2/now 1.4.0-1~local amd64  [installé, local]
oracle-java8-installer/now 8u201-1~webupd8~1 all  [installé, local]
oracle-java8-set-default/now 8u201-1~webupd8~1 all  [installé, local]

Hors ligne

#15 Le 05/06/2021, à 18:43

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Skype devrait être mis à jour automatiquement, tu as un dépôt actif pour lui.

Jette un coup d'œil à mon message précédent si tu l'as zappé (on a posté en même temps).

EDIT : rien de particulier dans les paquets orphelins, du moins rien qui soit a priori problématique pour la mise à niveau. Que donne le retour de cette commande ?

sudo apt list --upgradable -a

Dernière modification par abelthorne (Le 05/06/2021, à 18:44)

Hors ligne

#16 Le 05/06/2021, à 18:45

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Voilà le résultat :

sudo apt list --upgradable -a
En train de lister... Fait
skypeforlinux/stable 8.72.0.94 amd64 [pouvant être mis à jour depuis : 8.68.0.100]
skypeforlinux/stable 8.72.0.82 amd64
skypeforlinux/stable 8.71.0.36 amd64
skypeforlinux/stable 8.69.0.77 amd64
skypeforlinux/stable,now 8.68.0.100 amd64 [installé, pouvant être mis à jour vers : 8.72.0.94]

Hors ligne

#17 Le 05/06/2021, à 18:48

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

C'est bizarre que Skype ne se mette pas à jour. Si c'est lui qui bloque tout, on a deux possibilités :
1) On le supprime et on le réinstallera plus tard, après la mise à niveau.
2) On essaie de le mettre à jour.

Si tu veux le supprimer (ce serait le plus simple) :

sudo apt-get remove --purge skypeforlinux
sudo apt-get autoremove --purge

Ensuite, retente la mise à niveau.

Si tu veux qu'on creuse, donne le retour de :

apt-cache policy skypeforlinux

Dernière modification par abelthorne (Le 05/06/2021, à 18:49)

Hors ligne

#18 Le 05/06/2021, à 18:50

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Pour info, j'ai voulu faire une mise à jour de skypeforlinux par le biais de synaptics, ben il n'a pas voulu. Résultat, j'ai sucré skypeforlinux comme ça il ne va pas m'embêter

Hors ligne

#19 Le 05/06/2021, à 18:52

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Question : est-ce qu'il faut mieux que je fasse la mise à jour par le gestionnaire de mise à jour ou en ligne de commande. Si en ligne de commande, je lance quoi ? Merci

Hors ligne

#20 Le 05/06/2021, à 18:55

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

J'ai fait ce que tu m'as dit à savoir

apt-get autoremove --purge

il m'a sucré quatre trucs, donc ça doit être bon.

Hors ligne

#21 Le 05/06/2021, à 18:56

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Si tu as supprimé Skype, supprime quand même les dépendances inutiles avant de lancer la mise à niveau :

sudo apt-get autoremove --purge

Et pendant qu'on y est, on sait jamais, vérifie que le méta-paquet du bureau est bien en place. Si tu es sur Ubuntu (Unity) :

dpkg -l | grep ubuntu-desktop

Ça devrait lister ubuntu-desktop avec ii au début de la ligne.

Pour la mise à niveau, c'est comme tu préfères. Je trouve que c'est plus pratique en graphique via le gestionnaire de mises à jour mais si tu veux la lancer en ligne de commande :

sudo do-release-upgrade

Dernière modification par abelthorne (Le 05/06/2021, à 18:57)

Hors ligne

#22 Le 05/06/2021, à 18:58

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

voilà le résultat :

dpkg -l | grep ubuntu-desktop
ii  ubuntu-desktop                                1.361.6                                         amd64        The Ubuntu desktop system

C'est bon ??

Hors ligne

#23 Le 05/06/2021, à 19:08

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Oui, c'est bon, tu peux tenter la mise à niveau.

Hors ligne

#24 Le 05/06/2021, à 21:51

arvernes

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Et bien voilà, il est 21h48 et ça vient de rebooter. Je suis donc maintenant sous 18.04. Il m'a demandé trois ou quatre fois si je voulais écraser certains fichiers de configuration, je me souviens qu'il y avait /etc/bash.bashrc, les trois autres, je ne m'en souviens plus. A chaque fois j'ai dit que je voulais conserver mon fichier originel. Ai-je bien fait ? ce sont des fichiers dans lesquels j'avais fait des modifs, il y a surement plusieurs années.
Bon maintenant, vu le temps que ça a mis pour passer en 18.04, j'attends vos conseils et demain pour faire la migration vers 20.04, mais avant . repos du guerrier....

Hors ligne

#25 Le 05/06/2021, à 22:00

abelthorne

Re : [Résolu] passage 16.4 LTS vers 20.4 LTS

Généralement, on fait plutôt les modifs dans les fichiers locaux mais c'est possible que tu aies modifié des fichiers système. Tu peux de toute façon afficher les différences entre le fichier actuel et la nouvelle version pendant la mise à niveau, ça permet de voir si ce sont des modifs perso à garder ou des changements dus à une nouvelle version d'un soft.

Avant le passage en 20.04, je propose de faire une vérif des dépôts/paquets. Pour ça, mêmes commandes que précédemment, avec deux pour les noyaux en plus :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
cat /etc/apt/sources.list.d/*.list
uname -a
dpkg -l | grep linux-

L'idée, c'est de remettre les dépôts tiers à la nouvelle version (18.04), faire les mises à jour éventuelles, vérifier les paquets orphelins puis, une fois que tout est propre, faire la mise à niveau 20.04. Une fois qu'elle sera faite, rebelote une dernière fois.

Dernière modification par abelthorne (Le 05/06/2021, à 22:00)

Hors ligne