Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/09/2021, à 19:52

Logoden

Difficulté a installer CyberGhost sous 20.04

Bonjour, je n'arrive pas a finaliser l’installation du logiciel CyberGhost.
Merci pour un coup de pouce car l’équipe de CyberGhost est réactive mais ne semble pas trouver de solution par méconnaissance d''Ubuntu. Voici la copie de mon terminal:

mathieu@MatLinux:~$ cd Bureau/cyberghost
mathieu@MatLinux:~/Bureau/cyberghost$ sudo  bash install.sh
[sudo] Mot de passe de mathieu : 

CyberGhost Installer ...

No LSB modules are available.
No LSB modules are available.
Checking if glibc version is compatible
The glibc version is compatible, continue...
Check if "curl" package is already installed ... Yes
Check if "openvpn" package is already installed ... Yes
Checking OpenVPN version ... Latest ...
Check if "resolvconf" package is already installed ... Yes
Check if "wireguard" package is already installed ... Yes
Continue ...
Installing application ...
cp: impossible d'évaluer 'cyberghost/*': Aucun fichier ou dossier de ce type
Create symlinks ...
install.sh: ligne 262: cyberghostvpn : commande introuvable
mathieu@MatLinux:~/Bureau/cyberghost$ 

Merci


Logoden 20.04.1 LTS

Hors ligne

#2 Le 21/09/2021, à 20:00

xubu1957

Re : Difficulté a installer CyberGhost sous 20.04

Bonjour,

Si tu vois une idée > dans ce fil


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 21/09/2021, à 21:49

Logoden

Re : Difficulté a installer CyberGhost sous 20.04

Merci xubu1957
Avant de poster ma question je suis tomber sur la discutions que tu me proposes mais je n'y vois pas de réponse. Je ne comprend pas la réponse 3 de l'Alsacien: il dit qu'il a été aidé par le support de CyberGhost mais il ne dit pas comment. Je vais déterrer ce sujet pour voir si il ce souvient de la procédure qui a débloqué son installation.
Je te tiens au courant


Logoden 20.04.1 LTS

Hors ligne

#4 Le 21/09/2021, à 21:59

xubu1957

Re : Difficulté a installer CyberGhost sous 20.04

Tu avais installé > lsb-core ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 21/09/2021, à 22:26

Logoden

Re : Difficulté a installer CyberGhost sous 20.04

Non mais je viens de le faire et j'ai relancer un

sudo bash install.sh

On progresse, je n'ai plus les deux première ligne disant:

No LSB modules are available.
No LSB modules are available.

Mais la procédure n'aboutit toujours pas

mathieu@MatLinux:~/Bureau/cyberghost$ sudo bash install.sh

CyberGhost Installer ...

Checking if glibc version is compatible
The glibc version is compatible, continue...
Check if "curl" package is already installed ... Yes
Check if "openvpn" package is already installed ... Yes
Checking OpenVPN version ... Latest ...
Check if "resolvconf" package is already installed ... Yes
Check if "wireguard" package is already installed ... Yes
Continue ...
Installing application ...
cp: impossible d'évaluer 'cyberghost/*': Aucun fichier ou dossier de ce type
Create symlinks ...
install.sh: ligne 262: cyberghostvpn : commande introuvable
mathieu@MatLinux:~/Bureau/cyberghost$ 

Logoden 20.04.1 LTS

Hors ligne

#6 Le 21/09/2021, à 22:57

xubu1957

Re : Difficulté a installer CyberGhost sous 20.04

nany a écrit :

Bien, donne les retours de :

dpkg -l wireguard*
apt policy wireguard-modules wireguard-dkms wireguard-tools

Je pique dans un fil de Lucie-1985


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#7 Le 22/09/2021, à 05:18

nany

Re : Difficulté a installer CyberGhost sous 20.04

Bonjour,


Je ne pense pas que le problème vienne de wireguard.
Il faudrait voir ce que contient le script (dont la ligne 262) pour pouvoir comprendre.
Pour ce faire, donne le retour de :

cat -n ~/Bureau/cyberghost/install.sh

En ligne

#8 Le 22/09/2021, à 07:52

Logoden

Re : Difficulté a installer CyberGhost sous 20.04

xubu1957 a écrit :
nany a écrit :

Bien, donne les retours de :

dpkg -l wireguard*
apt policy wireguard-modules wireguard-dkms wireguard-tools
mathieu@MatLinux:~$ dpkg -l wireguard*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=att>
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom               Version                Architecture Description
+++-=================-======================-============-=====================>
ii  wireguard         1.0.20200513-1~20.04.2 all          fast, modern, secure >
un  wireguard-dkms    <aucune>               <aucune>     (aucune description n>
un  wireguard-modules <aucune>               <aucune>     (aucune description n>
ii  wireguard-tools   1.0.20200513-1~20.04.2 amd64        fast, modern, secure >
lines 1-9/9 (END)
mathieu@MatLinux:~$ apt policy wireguard-modules wireguard-dkms wireguard-tools
wireguard-modules:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
wireguard-dkms:
  Installé : (aucun)
  Candidat : 1.0.20201112-1~20.04.1
 Table de version :
     1.0.20201112-1~20.04.1 500
        500 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages
     1.0.20200413-1 500
        500 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu focal/universe i386 Packages
wireguard-tools:
  Installé : 1.0.20200513-1~20.04.2
  Candidat : 1.0.20200513-1~20.04.2
 Table de version :
 *** 1.0.20200513-1~20.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.0.20200319-1ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 Packages

Logoden 20.04.1 LTS

Hors ligne

#9 Le 22/09/2021, à 07:55

Logoden

Re : Difficulté a installer CyberGhost sous 20.04

Bonjour
Pour  nany

mathieu@MatLinux:~$ cat -n ~/Bureau/cyberghost/install.sh
     1	#!/bin/bash
     2	
     3		# if user is not running the command as root
     4		if [ "$UID" -ne 0 ]; then
     5	
     6			# output message
     7			echo "Please run the installer with SUDO!"
     8	
     9			# stop script
    10			exit
    11		fi
    12	
    13		# check update
    14		apt update > /dev/null 2>&1
    15	
    16		# output message
    17		echo -e "\nCyberGhost Installer ...\n"
    18	
    19		# get GLIBC version
    20		glibcVersion=$(ldd --version | grep -i ldd | awk -F' ' {'print $5'})
    21		
    22		# get distribution version
    23		ubuntuDistroVersion=$(lsb_release -sr)
    24		distroName=$(lsb_release -a | grep -i "Distributor ID:" | awk -F' ' {'print $3'})
    25		distroVersion=$(lsb_release -a | grep -i "Release:" | awk -F' ' {'print $2'})	
    26	
    27		echo "Checking if glibc version is compatible"
    28		
    29	
    30		# check if GLIBC version is compatible
    31		if [ "$ubuntuDistroVersion" == "16.04" ]; then
    32				
    33			if [ "$glibcVersion" == "2.23" ] ; then
    34	
    35				echo "The glibc version is compatible, continue..."
    36	
    37			else
    38	
    39				echo "THe glibc version is incompatible, exiting setup..."
    40				exit
    41	
    42			fi
    43	
    44		elif [ "$ubuntuDistroVersion" == "18.04" ] || [ "$distroName" == "LinuxMint" ]; then
    45			
    46			if [ "$glibcVersion" == "2.27" ]; then
    47			
    48				echo "The glibc version is compatible, continue..."
    49			
    50			else
    51			
    52				echo "The glibc version is incompatible, exiting setup..."
    53				exit
    54	
    55			fi
    56	
    57		elif [ "$ubuntuDistroVersion" == "19.10" ]; then
    58	
    59			if [ "$glibcVersion" == "2.30" ]; then
    60	
    61				echo "The glibc version is compatible, continue..."
    62	
    63			else
    64	
    65				echo "The glibc version is incompatible, exiting setup..."
    66				exit
    67			fi
    68	
    69		elif [ "$distroName" == "Kali" ] || [ "$ubuntuDistroVersion" == "19.04" ] || [ "$ubuntuDistroVersion" == "20.04" ]; then
    70	
    71			if [ "$glibcVersion" == "2.29" ] || [ "$glibcVersion" == "2.31" ] || [ "$glibcVersion" == "2.30" ]; then
    72	
    73				echo "The glibc version is compatible, continue..."
    74			
    75			else
    76	
    77				echo "The glibc version is incompatible, exiting setup..."
    78				exit
    79			
    80			fi
    81	
    82		elif [ "$distroName" == "Linuxmint" ] && [ "$distroVersion" == "20" ]; then
    83			
    84			if [ "$glibcVersion" == "2.31" ]; then
    85				echo "The glibc version is compatible, continue..."
    86			else
    87				echo "The glibc version is incompatible, exiting setup..."
    88				exit
    89			fi
    90	
    91		else
    92	
    93			echo "Couldn't detect a valid version of your distribution."
    94			echo "Make sure you have downloaded the correct install package for your distribution"
    95			echo "Note: We support only the following distributions for Debian based OS:"
    96			echo ""
    97			echo "-Ubuntu 16.04 "
    98			echo "-Ubuntu 18.04 "
    99			echo "-Ubuntu 19.04 "
   100			echo "-Ubuntu 19.10 "
   101			echo "-Ubuntu 20.04 "
   102			echo "-Linux Mint 19.2 "
   103			echo "-Linux Mint 20"
   104			echo "-PopOS 19.10 "
   105			echo "-Kali 2019/2020 (glibc version should be 2.29/2.30/2.31 in order to work) "
   106			exit
   107	
   108		fi			
   109	
   110	
   111		# define required packages
   112	    requiredPackages=(curl openvpn resolvconf wireguard)
   113	
   114		# loop through packages
   115	    for package in "${requiredPackages[@]}"; do
   116	
   117			# set package
   118			p="$package"
   119	
   120			# if package is opwireguardenvpn
   121			if [ "$package" == "wireguard" ]; then
   122	
   123				# check if wireguard ppa exist
   124				responseCode=$(grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/* | grep -c wireguard)
   125	
   126				# if ppa does not exist
   127				if [ "$responseCode" == "0" ]; then
   128	
   129					# install wireguard ppa
   130					add-apt-repository -y ppa:wireguard/wireguard > /dev/null 2>&1
   131					apt update > /dev/null 2>&1
   132				fi
   133	
   134				# change package name
   135				p="wg"
   136			fi
   137	
   138			# check if package is installed and get exit code
   139	        responseCode=$(which "$p" > /dev/null 2>&1; echo "$?")
   140	
   141			# output message
   142			echo -n "Check if \"$package\" package is already installed ... "
   143	
   144			# if package is installed
   145	        if [ "$responseCode" == "0" ]; then
   146	
   147				# output message
   148				echo "Yes"
   149	
   150				# if package is openvpn
   151				if [ "$package" == "openvpn" ]; then
   152	
   153					# get openvpn version
   154					openvpnVersion=$(openvpn --version | head -n 1 | awk '{print $2}')
   155	
   156					# get major version
   157					majorVersion=$(echo "$openvpnVersion" | awk -F. '{print $1}')
   158	
   159					# get minor version
   160					minorVersion=$(echo "$openvpnVersion" | awk -F. '{print $2}')
   161	
   162					# output message
   163					echo -n "Checking OpenVPN version ... "
   164	
   165					if [ $majorVersion -ge 2 ] && [ $minorVersion -gt 3 ]; then
   166	
   167						# output message
   168						echo "Latest ..."
   169					else
   170	
   171						# output message
   172						echo "The OpenVPN version is too old ... "
   173						echo "Removing old package ... "
   174	
   175						# uninstall package
   176						apt remove "$package" -y > /dev/null 2>&1
   177	
   178						# output message
   179						echo -n "Installing new package ... "
   180						curl -s https://swupdate.openvpn.net/repos/repo-public.gpg | apt-key add -
   181						echo "deb http://build.openvpn.net/debian/openvpn/stable xenial main" > /etc/apt/sources.list.d/openvpn-aptrepo.list
   182						apt update > /dev/null 2>&1
   183						apt install "$package" -y > /dev/null 2>&1
   184	
   185						# output message
   186						echo "Done."
   187					fi
   188				fi
   189	        else
   190	
   191				# output message
   192	            echo -n "No, installing ... "
   193	
   194				if [ "$package" == "openvpn" ]; then
   195	
   196					# get openvpn version from apt
   197					openvpnVersion=$(apt show openvpn|grep "Version:" | awk '{ print $2 }')
   198					version=$(echo "$openvpnVersion"| awk -F'-' '{print $1}')
   199					
   200					# get major version
   201					majorVersion=$(echo "$version" | awk -F. '{print $1}')
   202	
   203					# get minor version
   204					minorVersion=$(echo "$version" | awk -F. '{print $2}')
   205	
   206					# if version is lower then 2.4
   207					if [ $majorVersion -ge 2 ] && [ $minorVersion -lt 4 ]; then
   208						curl -s https://swupdate.openvpn.net/repos/repo-public.gpg | apt-key add -
   209						echo "deb http://build.openvpn.net/debian/openvpn/stable xenial main" > /etc/apt/sources.list.d/openvpn-aptrepo.list
   210						apt update > /dev/null 2>&1
   211					fi
   212				fi
   213	
   214	
   215				# install package
   216	            apt install "$package" -y > /dev/null 2>&1
   217	
   218				# output message
   219	            echo "Done."
   220	        fi
   221	    done
   222	
   223		# output message
   224		echo "Continue ..."
   225	
   226		# if directory exist
   227		if [ -d /usr/local/cyberghost ]; then
   228	
   229			# remove directory
   230			rm -rf /usr/local/cyberghost
   231		fi
   232	
   233		echo "Installing application ..."
   234	
   235		# if logs directory does not exist
   236		if [ ! -d /usr/local/cyberghost ]; then
   237	
   238			# create logs directory if not exist
   239			mkdir /usr/local/cyberghost
   240		fi
   241	
   242		# copy certificates to local directory
   243		cp -r cyberghost/* /usr/local/cyberghost
   244	
   245		# change directory permissions
   246		chmod -R 755 /usr/local/cyberghost
   247	
   248		# output message
   249		echo "Create symlinks ..."
   250	
   251		# if symlink exist
   252		if [ -L /usr/bin/cyberghostvpn ]; then
   253	
   254			# remove old symlink
   255			rm /usr/bin/cyberghostvpn
   256		fi
   257	
   258		# create symlink
   259		ln -sf /usr/local/cyberghost/cyberghostvpn /usr/bin/cyberghostvpn
   260	
   261		# setup application
   262		cyberghostvpn --setup

Logoden 20.04.1 LTS

Hors ligne

#10 Le 22/09/2021, à 07:55

Logoden

Re : Difficulté a installer CyberGhost sous 20.04

Bonjour
Pour  nany

mathieu@MatLinux:~$ cat -n ~/Bureau/cyberghost/install.sh
     1	#!/bin/bash
     2	
     3		# if user is not running the command as root
     4		if [ "$UID" -ne 0 ]; then
     5	
     6			# output message
     7			echo "Please run the installer with SUDO!"
     8	
     9			# stop script
    10			exit
    11		fi
    12	
    13		# check update
    14		apt update > /dev/null 2>&1
    15	
    16		# output message
    17		echo -e "\nCyberGhost Installer ...\n"
    18	
    19		# get GLIBC version
    20		glibcVersion=$(ldd --version | grep -i ldd | awk -F' ' {'print $5'})
    21		
    22		# get distribution version
    23		ubuntuDistroVersion=$(lsb_release -sr)
    24		distroName=$(lsb_release -a | grep -i "Distributor ID:" | awk -F' ' {'print $3'})
    25		distroVersion=$(lsb_release -a | grep -i "Release:" | awk -F' ' {'print $2'})	
    26	
    27		echo "Checking if glibc version is compatible"
    28		
    29	
    30		# check if GLIBC version is compatible
    31		if [ "$ubuntuDistroVersion" == "16.04" ]; then
    32				
    33			if [ "$glibcVersion" == "2.23" ] ; then
    34	
    35				echo "The glibc version is compatible, continue..."
    36	
    37			else
    38	
    39				echo "THe glibc version is incompatible, exiting setup..."
    40				exit
    41	
    42			fi
    43	
    44		elif [ "$ubuntuDistroVersion" == "18.04" ] || [ "$distroName" == "LinuxMint" ]; then
    45			
    46			if [ "$glibcVersion" == "2.27" ]; then
    47			
    48				echo "The glibc version is compatible, continue..."
    49			
    50			else
    51			
    52				echo "The glibc version is incompatible, exiting setup..."
    53				exit
    54	
    55			fi
    56	
    57		elif [ "$ubuntuDistroVersion" == "19.10" ]; then
    58	
    59			if [ "$glibcVersion" == "2.30" ]; then
    60	
    61				echo "The glibc version is compatible, continue..."
    62	
    63			else
    64	
    65				echo "The glibc version is incompatible, exiting setup..."
    66				exit
    67			fi
    68	
    69		elif [ "$distroName" == "Kali" ] || [ "$ubuntuDistroVersion" == "19.04" ] || [ "$ubuntuDistroVersion" == "20.04" ]; then
    70	
    71			if [ "$glibcVersion" == "2.29" ] || [ "$glibcVersion" == "2.31" ] || [ "$glibcVersion" == "2.30" ]; then
    72	
    73				echo "The glibc version is compatible, continue..."
    74			
    75			else
    76	
    77				echo "The glibc version is incompatible, exiting setup..."
    78				exit
    79			
    80			fi
    81	
    82		elif [ "$distroName" == "Linuxmint" ] && [ "$distroVersion" == "20" ]; then
    83			
    84			if [ "$glibcVersion" == "2.31" ]; then
    85				echo "The glibc version is compatible, continue..."
    86			else
    87				echo "The glibc version is incompatible, exiting setup..."
    88				exit
    89			fi
    90	
    91		else
    92	
    93			echo "Couldn't detect a valid version of your distribution."
    94			echo "Make sure you have downloaded the correct install package for your distribution"
    95			echo "Note: We support only the following distributions for Debian based OS:"
    96			echo ""
    97			echo "-Ubuntu 16.04 "
    98			echo "-Ubuntu 18.04 "
    99			echo "-Ubuntu 19.04 "
   100			echo "-Ubuntu 19.10 "
   101			echo "-Ubuntu 20.04 "
   102			echo "-Linux Mint 19.2 "
   103			echo "-Linux Mint 20"
   104			echo "-PopOS 19.10 "
   105			echo "-Kali 2019/2020 (glibc version should be 2.29/2.30/2.31 in order to work) "
   106			exit
   107	
   108		fi			
   109	
   110	
   111		# define required packages
   112	    requiredPackages=(curl openvpn resolvconf wireguard)
   113	
   114		# loop through packages
   115	    for package in "${requiredPackages[@]}"; do
   116	
   117			# set package
   118			p="$package"
   119	
   120			# if package is opwireguardenvpn
   121			if [ "$package" == "wireguard" ]; then
   122	
   123				# check if wireguard ppa exist
   124				responseCode=$(grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/* | grep -c wireguard)
   125	
   126				# if ppa does not exist
   127				if [ "$responseCode" == "0" ]; then
   128	
   129					# install wireguard ppa
   130					add-apt-repository -y ppa:wireguard/wireguard > /dev/null 2>&1
   131					apt update > /dev/null 2>&1
   132				fi
   133	
   134				# change package name
   135				p="wg"
   136			fi
   137	
   138			# check if package is installed and get exit code
   139	        responseCode=$(which "$p" > /dev/null 2>&1; echo "$?")
   140	
   141			# output message
   142			echo -n "Check if \"$package\" package is already installed ... "
   143	
   144			# if package is installed
   145	        if [ "$responseCode" == "0" ]; then
   146	
   147				# output message
   148				echo "Yes"
   149	
   150				# if package is openvpn
   151				if [ "$package" == "openvpn" ]; then
   152	
   153					# get openvpn version
   154					openvpnVersion=$(openvpn --version | head -n 1 | awk '{print $2}')
   155	
   156					# get major version
   157					majorVersion=$(echo "$openvpnVersion" | awk -F. '{print $1}')
   158	
   159					# get minor version
   160					minorVersion=$(echo "$openvpnVersion" | awk -F. '{print $2}')
   161	
   162					# output message
   163					echo -n "Checking OpenVPN version ... "
   164	
   165					if [ $majorVersion -ge 2 ] && [ $minorVersion -gt 3 ]; then
   166	
   167						# output message
   168						echo "Latest ..."
   169					else
   170	
   171						# output message
   172						echo "The OpenVPN version is too old ... "
   173						echo "Removing old package ... "
   174	
   175						# uninstall package
   176						apt remove "$package" -y > /dev/null 2>&1
   177	
   178						# output message
   179						echo -n "Installing new package ... "
   180						curl -s https://swupdate.openvpn.net/repos/repo-public.gpg | apt-key add -
   181						echo "deb http://build.openvpn.net/debian/openvpn/stable xenial main" > /etc/apt/sources.list.d/openvpn-aptrepo.list
   182						apt update > /dev/null 2>&1
   183						apt install "$package" -y > /dev/null 2>&1
   184	
   185						# output message
   186						echo "Done."
   187					fi
   188				fi
   189	        else
   190	
   191				# output message
   192	            echo -n "No, installing ... "
   193	
   194				if [ "$package" == "openvpn" ]; then
   195	
   196					# get openvpn version from apt
   197					openvpnVersion=$(apt show openvpn|grep "Version:" | awk '{ print $2 }')
   198					version=$(echo "$openvpnVersion"| awk -F'-' '{print $1}')
   199					
   200					# get major version
   201					majorVersion=$(echo "$version" | awk -F. '{print $1}')
   202	
   203					# get minor version
   204					minorVersion=$(echo "$version" | awk -F. '{print $2}')
   205	
   206					# if version is lower then 2.4
   207					if [ $majorVersion -ge 2 ] && [ $minorVersion -lt 4 ]; then
   208						curl -s https://swupdate.openvpn.net/repos/repo-public.gpg | apt-key add -
   209						echo "deb http://build.openvpn.net/debian/openvpn/stable xenial main" > /etc/apt/sources.list.d/openvpn-aptrepo.list
   210						apt update > /dev/null 2>&1
   211					fi
   212				fi
   213	
   214	
   215				# install package
   216	            apt install "$package" -y > /dev/null 2>&1
   217	
   218				# output message
   219	            echo "Done."
   220	        fi
   221	    done
   222	
   223		# output message
   224		echo "Continue ..."
   225	
   226		# if directory exist
   227		if [ -d /usr/local/cyberghost ]; then
   228	
   229			# remove directory
   230			rm -rf /usr/local/cyberghost
   231		fi
   232	
   233		echo "Installing application ..."
   234	
   235		# if logs directory does not exist
   236		if [ ! -d /usr/local/cyberghost ]; then
   237	
   238			# create logs directory if not exist
   239			mkdir /usr/local/cyberghost
   240		fi
   241	
   242		# copy certificates to local directory
   243		cp -r cyberghost/* /usr/local/cyberghost
   244	
   245		# change directory permissions
   246		chmod -R 755 /usr/local/cyberghost
   247	
   248		# output message
   249		echo "Create symlinks ..."
   250	
   251		# if symlink exist
   252		if [ -L /usr/bin/cyberghostvpn ]; then
   253	
   254			# remove old symlink
   255			rm /usr/bin/cyberghostvpn
   256		fi
   257	
   258		# create symlink
   259		ln -sf /usr/local/cyberghost/cyberghostvpn /usr/bin/cyberghostvpn
   260	
   261		# setup application
   262		cyberghostvpn --setup

Logoden 20.04.1 LTS

Hors ligne

#11 Le 22/09/2021, à 19:54

Logoden

Re : Difficulté a installer CyberGhost sous 20.04

J'ai réussi à finaliser l'installation. Je vous fait un petit récap des manipulations que j'ai faites. Demain. merci


Logoden 20.04.1 LTS

Hors ligne