Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/04/2022, à 18:04

antartic7100

problème installation de eid-archive (lecteur de carte identité Belg

Bonjour,

Je suis récemment passé à Ubuntu 22.04 (réinstallation)
Tour fonctionne impeccablement...hormis l'installation du package eid-archive detiné à permettre la lecture d'une carte d'identité belge.

J'ai téléchargé le pacquer .deb "eid-archive_2022.3_all.deb" et ai tenté de l'installaer dde diverses manières.

La commande "sudo dpkg -i eid-archive_2022.3_all.deb" donne le retiur suivant :

   Sélection du paquet eid-archive précédemment désélectionné.
(Lecture de la base de données... 206289 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de eid-archive_2022.3_all.deb ...
Dépaquetage de eid-archive (2022.3) ...
Paramétrage de eid-archive (2022.3) ...

Creating config file /etc/apt/sources.list.d/eid.list with new version
Repository enabled, keys installed. Please run "apt-get update" followed by
"apt-get install eid-mw eid-viewer" to install the middleware and the viewer, respectively.
    

Je tends à penser alors que le package a été installé, mais quand je veux vérifier l'installation, j'ai ceci :

ierre@pierre-Skylake-Platform:~/Documents/programmesdeb$ dpkg -s eid-archive_2022.3_all.deb
dpkg-query: le paquet « eid-archive_2022.3_all.deb » n'est pas installé et aucune information n'est disponible
Use dpkg --info (= dpkg-deb --info) to examine archive files.

Commet puis-je procéder?

Merci

Pierre

Hors ligne

#2 Le 30/04/2022, à 18:19

xubu1957

Re : problème installation de eid-archive (lecteur de carte identité Belg

Bonjour,

Le 10/01/2021, nany a écrit :

Bonjour,

(...)
Montre nous tes fichiers de sources en donnant le retour de :

find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; [[ $1 = *".list" ]] && cat -n "$1"' _ '{}' \;

Peut-être qu’on arrivera à trouver ce qui cloche.

dans > Eid Belgique - le retour

et dans [ RESOLU ] - Installation eID software sur Ubuntu 20.04 - Impossible


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 30/04/2022, à 18:24

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

Bonjour xubu,
Merci de te pencher sur mon problème

pierre@pierre-Skylake-Platform:~$ find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; [[ $1 = *".list" ]] && cat -n "$1"' _ '{}' \;

/etc/apt/sources.list

     1	#deb cdrom:[Ubuntu 22.04 LTS _Jammy Jellyfish_ - Release amd64 (20220419)]/ jammy main restricted
     2	
     3	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4	# newer versions of the distribution.
     5	deb http://be.archive.ubuntu.com/ubuntu/ jammy main restricted
     6	# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy main restricted
     7	
     8	## Major bug fix updates produced after the final release of the
     9	## distribution.
    10	deb http://be.archive.ubuntu.com/ubuntu/ jammy-updates main restricted
    11	# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-updates main restricted
    12	
    13	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14	## team. Also, please note that software in universe WILL NOT receive any
    15	## review or updates from the Ubuntu security team.
    16	deb http://be.archive.ubuntu.com/ubuntu/ jammy universe
    17	# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy universe
    18	deb http://be.archive.ubuntu.com/ubuntu/ jammy-updates universe
    19	# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-updates universe
    20	
    21	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22	## team, and may not be under a free licence. Please satisfy yourself as to 
    23	## your rights to use the software. Also, please note that software in 
    24	## multiverse WILL NOT receive any review or updates from the Ubuntu
    25	## security team.
    26	deb http://be.archive.ubuntu.com/ubuntu/ jammy multiverse
    27	# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy multiverse
    28	deb http://be.archive.ubuntu.com/ubuntu/ jammy-updates multiverse
    29	# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-updates multiverse
    30	
    31	## N.B. software from this repository may not have been tested as
    32	## extensively as that contained in the main release, although it includes
    33	## newer versions of some applications which may provide useful features.
    34	## Also, please note that software in backports WILL NOT receive any review
    35	## or updates from the Ubuntu security team.
    36	deb http://be.archive.ubuntu.com/ubuntu/ jammy-backports main restricted universe multiverse
    37	# deb-src http://be.archive.ubuntu.com/ubuntu/ jammy-backports main restricted universe multiverse
    38	
    39	deb http://security.ubuntu.com/ubuntu jammy-security main restricted
    40	# deb-src http://security.ubuntu.com/ubuntu jammy-security main restricted
    41	deb http://security.ubuntu.com/ubuntu jammy-security universe
    42	# deb-src http://security.ubuntu.com/ubuntu jammy-security universe
    43	deb http://security.ubuntu.com/ubuntu jammy-security multiverse
    44	# deb-src http://security.ubuntu.com/ubuntu jammy-security multiverse
    45	
    46	# This system was installed using small removable media
    47	# (e.g. netinst, live or single CD). The matching "deb cdrom"
    48	# entries were disabled at the end of the installation process.
    49	# For information about how to configure apt package sources,
    50	# see the sources.list(5) manual.

/etc/apt/sources.list.d/google-chrome.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main

/etc/apt/sources.list.d/eid.list

     1	# To enable the candidate repository, uncomment the below line, put "deb" in
     2	# front of it, and run "dpkg-reconfigure eid-archive" to enable the archive
     3	# key.
     4	#
     5	# The candidate repository contains unsupported prerelease packages. Use at
     6	# your own risk.
     7	#
     8	# Note, however, that the candidate repository is usually empty; it is
     9	# used when we're preparing (and testing) a new release. Therefore, it
    10	# should be relatively safe.
    11	#
    12	# There is also another "continuous" repository, for which packages get
    13	# recompiled for each and every change to the source. This isn't listed
    14	# (so that it can't be accidentally enabled), but the configuration is
    15	# the same as the below, with "candidate" replaced by "continuous".
    16	#
    17	# http://files.eid.belgium.be/debian candidate/jammy main
    18	# NOTE: files2.eid.belgium.be is a mirror for the main repository ONLY.
    19	# That is, it does not contain the continuous or candidate repositories.
    20	
    21	# The regular repository with released packages. This is what you should
    22	# use.
    23	deb https://files.eid.belgium.be/debian jammy main

/etc/apt/sources.list.d/nordvpn.list

     1	#
     2	# NordVPN releases, stable
     3	#
     4	deb https://repo.nordvpn.com/deb/nordvpn/debian stable main
/etc/apt/sources.list.d/teamviewer.list

     1	###   TeamViewer DEB repository list
     2	
     3	### NOTE: Manual changes to this file
     4	###        - prevent it from being updated by TeamViewer package updates
     5	###        - will be lost after using the 'teamviewer repo' command
     6	###       The original file can be restored with this command:
     7	###       cp /opt/teamviewer/tv_bin/script/teamviewer.list /etc/apt/sources.list.d/teamviewer.list
     8	###       which has the same effect as 'teamviewer repo default'
     9	
    10	### NOTE: It is preferred to use the following commands to edit this file:
    11	###       teamviewer repo                - show current repository configuration
    12	###       teamviewer repo default        - restore default configuration
    13	###       teamviewer repo disable        - disable the repository
    14	###       teamviewer repo stable         - make all regular TeamViewer packages available (default)
    15	###       teamviewer repo preview        - additionally, make feature preview packages available
    16	###       teamviewer repo development    - additionally, make the latest development packages available
    17	
    18	
    19	deb https://linux.teamviewer.com/deb stable main
    20	
    21	# deb https://linux.teamviewer.com/deb preview main
    22	# deb https://linux.teamviewer.com/deb development main
pierre@pierre-Skylake-Platform:~$ 

Hors ligne

#4 Le 30/04/2022, à 18:29

xubu1957

Re : problème installation de eid-archive (lecteur de carte identité Belg

Donne le retour de :

sudo apt update

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 30/04/2022, à 18:40

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

pierre@pierre-Skylake-Platform:~$ sudo apt update
[sudo] Mot de passe de pierre : 
Réception de :1 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Atteint :2 https://linux.teamviewer.com/deb stable InRelease                   
Atteint :3 https://files.eid.belgium.be/debian jammy InRelease                 
Atteint :4 https://dl.google.com/linux/chrome/deb stable InRelease             
Atteint :5 http://be.archive.ubuntu.com/ubuntu jammy InRelease                 
Réception de :6 http://be.archive.ubuntu.com/ubuntu jammy-updates InRelease [109 kB]
Atteint :7 https://repo.nordvpn.com/deb/nordvpn/debian stable InRelease
Atteint :8 http://be.archive.ubuntu.com/ubuntu jammy-backports InRelease
220 ko réceptionnés en 1s (196 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dé[code]https://forum.ubuntu-fr.org/img/fluxtoolbar/smooth/bt_align_center.png[/code]pendances... Fait
Lecture des informations d'état... Fait      
6 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
W: https://linux.teamviewer.com/deb/dists/stable/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.
pierre@pierre-Skylake-Platform:~$ 
pierre@pierre-Skylake-Platform:~$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                                 Architecture Description
+++-==========================================-=======================================-============-================================================================================
pierre@pierre-Skylake-Platform:~$ 

Hors ligne

#6 Le 30/04/2022, à 18:42

xubu1957

Re : problème installation de eid-archive (lecteur de carte identité Belg

Montre :

sudo apt full-upgrade

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 30/04/2022, à 18:46

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

pierre@pierre-Skylake-Platform:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  base-files beid-mozilla-extension beid-mozilla-webext libbeidpkcs11-0
  libbeidpkcs11-bin snapd
6 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 21,7 Mo dans les archives.
Après cette opération, 50,2 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://be.archive.ubuntu.com/ubuntu jammy-updates/main amd64 base-files amd64 12ubuntu4.1 [62,8 kB]
Réception de :2 http://be.archive.ubuntu.com/ubuntu jammy-updates/main amd64 snapd amd64 2.55.3+22.04ubuntu1 [21,5 MB]
Réception de :3 https://files.eid.belgium.be/debian jammy/main amd64 libbeidpkcs11-bin amd64 5.0.28v5.0.28-0u2204-1 [11,9 kB]
Réception de :4 https://files.eid.belgium.be/debian jammy/main amd64 libbeidpkcs11-0 amd64 5.0.28v5.0.28-0u2204-1 [107 kB]
Réception de :5 https://files.eid.belgium.be/debian jammy/main amd64 beid-mozilla-webext all 5.0.28v5.0.28-0u2204-1 [12,8 kB]
Réception de :6 https://files.eid.belgium.be/debian jammy/main amd64 beid-mozilla-extension all 5.0.28v5.0.28-0u2204-1 [2.256 B]
21,7 Mo réceptionnés en 8s (2.761 ko/s)                                                                                                                                                                   
(Lecture de la base de données... 206299 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../base-files_12ubuntu4.1_amd64.deb ...
Dépaquetage de base-files (12ubuntu4.1) sur (12ubuntu4) ...
Paramétrage de base-files (12ubuntu4.1) ...
motd-news.service is a disabled or a static unit not running, not starting it.
(Lecture de la base de données... 206299 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libbeidpkcs11-bin_5.0.28v5.0.28-0u2204-1_amd64.deb ...
Dépaquetage de libbeidpkcs11-bin (5.0.28v5.0.28-0u2204-1) sur (5.0.28v5.0.28-0u1804-1) ...
Préparation du dépaquetage de .../libbeidpkcs11-0_5.0.28v5.0.28-0u2204-1_amd64.deb ...
Dépaquetage de libbeidpkcs11-0:amd64 (5.0.28v5.0.28-0u2204-1) sur (5.0.28v5.0.28-0u1804-1) ...
Préparation du dépaquetage de .../beid-mozilla-webext_5.0.28v5.0.28-0u2204-1_all.deb ...
Dépaquetage de beid-mozilla-webext (5.0.28v5.0.28-0u2204-1) sur (5.0.28v5.0.28-0u1804-1) ...
Préparation du dépaquetage de .../beid-mozilla-extension_5.0.28v5.0.28-0u2204-1_all.deb ...
Dépaquetage de beid-mozilla-extension (5.0.28v5.0.28-0u2204-1) sur (5.0.28v5.0.28-0u1804-1) ...
Préparation du dépaquetage de .../snapd_2.55.3+22.04ubuntu1_amd64.deb ...
Warning: Stopping snapd.service, but it can still be activated by:
  snapd.socket
Dépaquetage de snapd (2.55.3+22.04ubuntu1) sur (2.55.3+22.04) ...
Paramétrage de snapd (2.55.3+22.04ubuntu1) ...
snapd.failure.service is a disabled or a static unit not running, not starting it.
snapd.snap-repair.service is a disabled or a static unit not running, not starting it.
Paramétrage de libbeidpkcs11-bin (5.0.28v5.0.28-0u2204-1) ...
Paramétrage de libbeidpkcs11-0:amd64 (5.0.28v5.0.28-0u2204-1) ...
Paramétrage de beid-mozilla-webext (5.0.28v5.0.28-0u2204-1) ...
Paramétrage de beid-mozilla-extension (5.0.28v5.0.28-0u2204-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.35-0ubuntu3) ...
Traitement des actions différées (« triggers ») pour man-db (2.10.2-1) ...
Traitement des actions différées (« triggers ») pour cracklib-runtime (2.9.6-3.4build4) ...
Traitement des actions différées (« triggers ») pour plymouth-theme-ubuntu-text (0.9.5+git20211018-1ubuntu3) ...
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour dbus (1.12.20-2ubuntu4) ...
Traitement des actions différées (« triggers ») pour install-info (6.8-4build1) ...
Traitement des actions différées (« triggers ») pour mailcap (3.70+nmu1ubuntu1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour initramfs-tools (0.140ubuntu13) ...
update-initramfs: Generating /boot/initrd.img-5.15.0-27-generic
I: The initramfs will attempt to resume from /dev/sda2
I: (UUID=8009181b-7881-4e83-9ee6-9b11b24ef68b)
I: Set the RESUME variable to override this.
pierre@pierre-Skylake-Platform:~$ 

Hors ligne

#8 Le 30/04/2022, à 18:52

xubu1957

Re : problème installation de eid-archive (lecteur de carte identité Belg

sudo apt-get install eid-mw eid-viewer

répond quoi ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 30/04/2022, à 18:57

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

pierre@pierre-Skylake-Platform:~$ sudo apt-get install eid-mw eid-viewer
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
eid-mw est déjà la version la plus récente (5.0.28v5.0.28-0u2204-1).
eid-viewer est déjà la version la plus récente (5.0.28v5.0.28-0u2204-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
pierre@pierre-Skylake-Platform:~$ 

Hors ligne

#10 Le 30/04/2022, à 18:59

xubu1957

Re : problème installation de eid-archive (lecteur de carte identité Belg

La carte est-elle reconnue, maintenant ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#11 Le 30/04/2022, à 19:28

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

Malheureusement non.

Et j;ai toujours

pierre@pierre-Skylake-Platform:~$ dpkg -s eid-archive_2022.3_all.deb
dpkg-query: le paquet « eid-archive_2022.3_all.deb » n'est pas installé et aucune information n'est disponible
Use dpkg --info (= dpkg-deb --info) to examine archive files.
pierre@pierre-Skylake-Platform:~$ 

Hors ligne

#12 Le 30/04/2022, à 19:28

xubu1957

Re : problème installation de eid-archive (lecteur de carte identité Belg

Je vais essayer d'avoir du renfort.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#13 Le 30/04/2022, à 19:36

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

Merci de ton implication xubu!

Hors ligne

#14 Le 30/04/2022, à 20:53

nany

Re : problème installation de eid-archive (lecteur de carte identité Belg

Bonjour,


Avant toute chose, je tiens à préciser que je ne suis pas Belge et que je ne peux donc pas vérifier ce que j’affirme.

Au vu des différents retours de commandes, tout est bien installé.
Si tu testes le lecteur avec Firefox, c’est « normal » que ça ne marche pas : c’est la faute de snap.


antartic7100 a écrit :
pierre@pierre-Skylake-Platform:~$ dpkg -s eid-archive_2022.3_all.deb
dpkg-query: le paquet « eid-archive_2022.3_all.deb » n'est pas installé et aucune information n'est disponible

« eid-archive_2022.3_all.deb » n’est pas le nom du paquet mais le nom du fichier téléchargé.
Essaie ça :

dpkg -s eid-archive

Hors ligne

#15 Le 30/04/2022, à 21:25

jeange

Re : problème installation de eid-archive (lecteur de carte identité Belg

nany a écrit :

Avant toute chose, je tiens à préciser que je ne suis pas Belge

normal, y'a jamais eu de pirate en Belgique.
tongue


PCLF CLEVO W670SZQ i3-4000M Ram 8Go  Haswell HD4600 Ubuntu 20.04.4 et 22.04.1 LTS 64bit
033 V nospE  23.01.2 pmiG
Merci de donner les retours avec les balises < > et les allers avec les valises.
%NOINDEX%

Hors ligne

#16 Le 30/04/2022, à 22:34

ylag

Re : problème installation de eid-archive (lecteur de carte identité Belg

Bonsoir,

Vu au #11 :

pierre@pierre-Skylake-Platform:~$ dpkg -s eid-archive_2022.3_all.deb
dpkg-query: le paquet « eid-archive_2022.3_all.deb » n'est pas installé et aucune information n'est disponible
Use dpkg --info (= dpkg-deb --info) to examine archive files.
pierre@pierre-Skylake-Platform:~$

Si eid-archive_2022.3_all.deb a bien été installé, la commande pour voir les infos du paquet serait :

dpkg -s eid-archive

A+

Hors ligne

#17 Le 01/05/2022, à 14:59

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

Bonjour nany, ylag,

vous avez raison, merci.
Au vu du retour de commande le paquet a l'air installé. Par contre je ene comprends pas bien la fin du retour.

pierre@pierre-Skylake-Platform:~/Documents/programmesdeb$ dpkg -s eid-archive
Package: eid-archive
Status: install ok installed
Priority: extra
Section: misc
Installed-Size: 24
Maintainer: Fedict Servicedesk <servicedesk@fedict.be>
Architecture: all
Version: 2022.3
Depends: gpgv, lsb-release, ucf
Recommends: gnupg
Breaks: apt (<< 0.7.25.1)
Description: GnuPG archive keys of the Belgian eID package archive
 The Belgian eID package archive has digitally signed Release files.
 This package contains the archive keys used for that archive, as well
 as a sources.list configuration file which immediately enables it.
 .
 Install this package if you want to install packages from the eID
 package archive.
pierre@pierre-Skylake-Platform:~/Documents/programmesdeb$ 

Hors ligne

#18 Le 01/05/2022, à 15:24

nany

Re : problème installation de eid-archive (lecteur de carte identité Belg

antartic7100 a écrit :

Par contre je ene comprends pas bien la fin du retour.

Qu’est-ce que tu ne comprends pas ?



En #1, antartic7100 a écrit :
Creating config file /etc/apt/sources.list.d/eid.list with new version
Repository enabled, keys installed. Please run "apt-get update" followed by
"apt-get install eid-mw eid-viewer" to install the middleware and the viewer, respectively.

Le fichier /etc/apt/sources.list.d/eid.list a bien été créé et permet ainsi l’installation des paquets eid-mw et eid-viewer.

En #9, antartic7100 a écrit :
pierre@pierre-Skylake-Platform:~$ sudo apt-get install eid-mw eid-viewer
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
eid-mw est déjà la version la plus récente (5.0.28v5.0.28-0u2204-1).
eid-viewer est déjà la version la plus récente (5.0.28v5.0.28-0u2204-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
pierre@pierre-Skylake-Platform:~$ 

Les paquets sont bien installés.


En #14, nany a écrit :

Si tu testes le lecteur avec Firefox, c’est « normal » que ça ne marche pas : c’est la faute de snap.

Il faut donc tester avec un navigateur installé en deb.

Hors ligne

#19 Le 01/05/2022, à 15:31

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

C'est la partie

 Install this package if you want to install packages from the eID
 package archive.

que je ne comprenais pas. Elle faisait référence aux paquets eid-mv et eid viewer donc  de ce côté c'est OK.

J'ai voulu tester le lecteur avec Chrome et l’application "lecteur de cartes eID" qui me renvoie "Aucun lecteur de cartes trouvé

Hors ligne

#20 Le 01/05/2022, à 15:52

nany

Re : problème installation de eid-archive (lecteur de carte identité Belg

Pour Chrome, il y a cette réponse de la FAQ.

Hors ligne

#21 Le 01/05/2022, à 19:54

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

Merci nany,
Cependant j'obtiens une erreur

pierre@pierre-Skylake-Platform:~/Documents/programmesdeb$ cd                                          
modutil -dbdir sql:.pki/nssdb -add "Belgium eID" -libfile /usr/lib/x86_64-linux-gnu/libbeidpkcs11.so.0

WARNING: Performing this operation while the browser is running could cause
corruption of your security databases. If the browser is currently running,
you should exit browser before continuing this operation. Type 
'q <enter>' to abort, or <enter> to continue: 

ERROR: Failed to add module "Belgium eID". Probable cause : "Failure to load dynamic library".
pierre@pierre-Skylake-Platform:~$ 

Hors ligne

#22 Le 01/05/2022, à 20:15

nany

Re : problème installation de eid-archive (lecteur de carte identité Belg

antartic7100 a écrit :
Probable cause : "Failure to load dynamic library".
La FAQ a écrit :

Remarquez que le chemin d'accès vers « libbeidpkcs11.so » dépend de la distribution.
Etc…

Si vraiment tu n’y arrives pas, tu peux les contacter.

Hors ligne

#23 Le 03/05/2022, à 18:05

geoffroy-dussart

Re : problème installation de eid-archive (lecteur de carte identité Belg

Bonjour
j'ai le même soucis, mais avec pop os.
j'ai contacté eid après plusieurs blalbla
leur réponse est:
"Au Départ Pop OS est basé sur Ubuntu, mais il est différent ! Nous n'en effectuons pas le support pour cette version dérivée.

Pouvez-vous essayer de faire ceci

sudo apt purge eid-archive

Ensuite, téléchargez à nouveau eid-archives depuis le site, installez-le, puis relancez les commandes d'installation :

sudo apt-obtenir la mise à jour ( sudo apt update)
sudo apt-get install eid-mw eid-viewer
..."
Et cela à fonctionné
pas avec modzilla car je l'ai prit de snap ou Flatpak  et eid ne fonctionne pas avec snap ou Flatpak .
j'ai instalé google chrome en direct et cela à fonctionné.
voilà, je ne sais pas si cela peux vous servir, mais comme j'avais le même problème...
Bien à vous

Hors ligne

#24 Le 05/05/2022, à 10:37

antartic7100

Re : problème installation de eid-archive (lecteur de carte identité Belg

Merci Geoffroy,

Malheureusement pour moi cela n'a pas fonctionné (j'avais déjà essayé cela plusieurs fois mais j'ai quand même retenté);

C'est très irritant, je n'avais pas de problème sous Ubuntu 20.04, 18.04 ou 16.04

Hors ligne