Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/08/2022, à 14:03

Coeur Noir

22:04 : sous Wayland pas de signet Bureau dans Nautilus

Hello,

une image plutôt qu'un long discours :
nautilus-bureau.png

Les paramètres de Nautilus quand on les regarde dans dconf-editor sont identiques dans les 2 sessions.

Ainsi que la clé /org/gnome/desktop/background/show-desktop-icons qui est à vrai dans les 2 cas.
Dans la session B passer cette clé de vrai à faux puis vrai fait disparaître / réapparaître le signet Bureau.

Dans la session A, c'est sans effet, pourquoi ?

Dernière modification par Coeur Noir (Le 14/08/2022, à 14:36)


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#2 Le 12/08/2022, à 14:14

ylag

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Bonjour,

Ça va pas solutionner la chose, mais pour ton info, j'ai un comportement semblable sur ma 20.04 avec le bureau Gnome-shell.
J'ai dû mettre le répertoire ~/Bureau en signet pour l'avoir dans le panneau de gauche de Nautilus...

Voici mon fichier user-dirs.dirs sur cette 20.04 :

# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run.
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
# 
XDG_DESKTOP_DIR="$HOME/Bureau"
XDG_DOWNLOAD_DIR="$HOME/Téléchargements"
XDG_TEMPLATES_DIR="$HOME/Modèles"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Musique"
XDG_PICTURES_DIR="$HOME/Images"
XDG_VIDEOS_DIR="$HOME/Vidéos"

A+

Hors ligne

#3 Le 12/08/2022, à 21:07

Coeur Noir

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Déjà vérifié le user-dirs.dirs et pas de différence entre les 2 sessions.

Et tous les fichiers dans les répertoires personnels appartiennent bien à leurs propriétaires respectifs.


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#4 Le 14/08/2022, à 02:27

Coeur Noir

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Les fichiers ~/.config/gtk-3.0 sont construits de la même façon de part et d'autre ( pas de dossier bureau là-dedans ; bien sûr les signets~favoris diffèrent. )

Bien des mystères ( pour moi ) dans cette 22.04…


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#5 Le 14/08/2022, à 02:55

Coeur Noir

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

…rrrrooo à force de chercher les différences entre les 2 sessions, j'en ai bien trouvé une qui provoque le différence de comportement :
⋅ la session A est sous Wayland,
⋅ la session B sous Xorg.

Sous Wayland pas de signet Bureau dans le volet latéral de Nautilus !
C'est quoi la logique ?


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#6 Le 14/08/2022, à 14:34

Coeur Noir

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#7 Le 14/08/2022, à 14:41

ylag

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Bonjour,

Sur une session x11 Debian Bullseye avec le bureau Gnome, j'ai le même comportement que dans ton premier lien :
https://bbs.archlinux.org/viewtopic.php?id=230986

J'ai dû y créer un signet pour avoir l'icône Bureau dans le panneau latéral :
nautilus1.png

Ce comportement semble traîner depuis fort longtemps ? hmm

A+

Dernière modification par ylag (Le 14/08/2022, à 14:44)

Hors ligne

#8 Le 14/08/2022, à 14:48

Coeur Noir

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Sous 22.04 et Xorg, il suffit que la clé /org/gnome/desktop/background/show-desktop-icons soit à vrai dans dconf-editor pour que le signet apparaisse dans Nautilus.
Et c'est la situation par défaut, dès installation.

Mais c'est sans effet dès lors que la même session utilisateur est lancée sous Wayland, là queue'd'chi pas de signet Bureau.

Je ne saurais dire pour Debian, mais vérifie cette clé gsettings.


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#9 Le 14/08/2022, à 14:59

ylag

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Re,

Effectivement, tu as raison. Ma clé /org/gnome/desktop/background/show-desktop-icons était à 'false' ; un passage à 'true' rétabli les choses.
Plus besoin de signet pour afficher l'icône Bureau dans le panneau de gauche de Nautilus.
Merci du tuyau... smile

Maintenant, pourquoi cette clé était à la valeur 'false' ?
Mystère...

A+

Dernière modification par ylag (Le 14/08/2022, à 15:00)

Hors ligne

#10 Le 14/08/2022, à 15:58

Coeur Noir

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Non point de mystère : sous Gnome3 le concept de Bureau a disparu depuis longtemps, donc par défaut tout ce qui concerne ce concept jugé obsolète par les faiseurs de Gnome est désactivé.

Sous ×buntu, le paradigme du bureau « classique » reste l'expérience proposée par défaut donc les options le concernant sont activées.

Mais alors pourquoi pas sous Wayland ? ? ? Alors qu'on peut y utiliser le bureau « classiquement »…


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#11 Le 14/08/2022, à 16:02

ylag

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Bonjour,

Au #8, Coeur Noir a écrit :

Sous 22.04 et Xorg, il suffit que la clé /org/gnome/desktop/background/show-desktop-icons soit à vrai dans dconf-editor pour que le signet apparaisse dans Nautilus.
Et c'est la situation par défaut, dès installation.

Il semblerait que ce ne soit pas le cas sur Debian Bullseye :
dconf.png

La commande gsettings reset org.gnome.desktop.background show-desktop-icons ramène la clé à la valeur 'false'.

Je soupçonne que ce soit la même chose sur Ubuntu 20.04, à vérifier dès que j'aurai accès à ma 20.04.

A+

Dernière modification par ylag (Le 14/08/2022, à 16:13)

Hors ligne

#12 Le 14/08/2022, à 16:53

Coeur Noir

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Têtu lol

Sous Ubuntu 22.04 :
default-desktop-gnome.png

Dans un environnement 100% Gnome ( ≠ Ubuntu ), la valeur par défaut sera à Faux car Gnome ne veut plus de bureau depuis un moment…


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#13 Le 14/08/2022, à 17:33

ylag

Re : 22:04 : sous Wayland pas de signet Bureau dans Nautilus

Re,

Coeur Noir a écrit :

Dans un environnement 100% Gnome ( ≠ Ubuntu ), la valeur par défaut sera à Faux car Gnome ne veut plus de bureau depuis un moment…

Ah! Étant sur le bureau Gnome et session x11 autant en Debian qu'en Ubuntu, ça explique la chose chez-moi ; encore merci...

yvan@yvan-maison:~$ echo $XDG_SESSION_DESKTOP $XDG_SESSION_TYPE $XDG_CURRENT_DESKTOP
lightdm-xsession x11 GNOME
yvan@yvan-maison:~$

A+

Dernière modification par ylag (Le 14/08/2022, à 17:36)

Hors ligne