Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/08/2022, à 13:28

Bastien-mva

[Résolu] Installation ratée a cause de drivers nvidia

J'essaye de mettre a jour  Ubuntu 20.04 à 22.04. J'ai installé les drivers  nvidia-drivers-515 et ca marchait très bien avec la version 20.04. J'ai lancé

 sudo apt update && sudo apt dist-upgrade 

pour préparer la mise à jour. Je ne sais pas si c'est important mais une fois que j'ai redémarré, mon écran était très jaune (je pouvais à peine voir ce qu'il y avait à l'écran.) J'ai réussi à retrouver les couleurs en suivant https://ghitab.net/2022/05/06/ubuntu-22 … ia-driver/  and rebooting.
ensuite, j'ai essayé de mettre à jour en exécutant

 sudo do-release-upgrade

mais il m'a dit que je n'avais pas tous les paquets mis à jour, à savoir

libnvidia-ml-dev

n'était pas à jour.  I did not managed to update it so I removed it running

sudo apt autoremove

. Je n'ai pas réussi à le mettre à jour, alors je l'ai supprimé en exécutant

sudo apt autoremove

. Maintenant, je réussis à faire

sudo do-release-upgrade

mais il ne fait pas la mise à jour et n'affiche même pas de message d'erreur. Voici le résultat de

sudo do-release-upgrade

:

bastien@bastien:~$ sudo do-release-upgrade
Checking for a new Ubuntu release= Welcome to Ubuntu 22.04 'Jammy Jellyfish' =The Ubuntu team is proud to announce Ubuntu 22.04 'Jammy Jellyfish'.To see what's new in this release, visit:
  https://wiki.ubuntu.com/JammyJellyfish/ReleaseNotesUbuntu is a Linux distribution for your desktop or server, with a fast
and easy install, regular releases, a tight selection of excellent
applications installed by default, and almost any other software you
can imagine available through the network.We hope you enjoy Ubuntu.== Feedback and Helping ==If you would like to help shape Ubuntu, take a look at the list of
ways you can participate at  http://www.ubuntu.com/community/participate/Your comments, bug reports, patches and suggestions will help ensure
that our next release is the best release of Ubuntu ever.  If you feel
that you have found a bug please read:  http://help.ubuntu.com/community/ReportingBugsThen report bugs using apport in Ubuntu.  For example:  ubuntu-bug linuxwill open a bug report in Launchpad regarding the linux package.If you have a question, or if you think you may have found a bug but
aren't sure, first try asking on the #ubuntu or #ubuntu-bugs IRC
channels on Libera.Chat, on the Ubuntu Users mailing list, or on the
Ubuntu forums:  http://help.ubuntu.com/community/InternetRelayChat
  http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
  http://www.ubuntuforums.org/== More Information ==You can find out more about Ubuntu on our website, IRC channel and wiki.
If you're new to Ubuntu, please visit:  http://www.ubuntu.com/To sign up for future Ubuntu announcements, please subscribe to Ubuntu's
very low volume announcement list at:  http://lists.ubuntu.com/mailman/listinfo/ubuntu-announceContinue [yN] y
Get:1 Upgrade tool signature [819 B]
Get:2 Upgrade tool [1267 kB]
Fetched 1268 kB in 0s (0 B/s)
authenticate 'jammy.tar.gz' against 'jammy.tar.gz.gpg'
extracting 'jammy.tar.gz'Reading cacheChecking package manager
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Hit http://oem.archive.canonical.com jammy InRelease
Hit https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64  InRelease
Get:1 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Hit https://download.docker.com/linux/ubuntu focal InRelease
Hit http://archive.ubuntu.com/ubuntu jammy InRelease
Get:2 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [114 kB]
Get:3 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [99,8 kB]
Fetched 324 kB in 0s (0 B/s)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
nvidia-driver-515Checking for installed snapsCalculating snap size requirementsUpdating repository information
Get:1 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Hit http://archive.ubuntu.com/ubuntu jammy InRelease
Get:2 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [114 kB]
Hit https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64  InRelease
Hit https://download.docker.com/linux/ubuntu focal InRelease
Hit http://oem.archive.canonical.com jammy InRelease
Get:3 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [99,8 kB]
Fetched 324 kB in 0s (0 B/s)Checking package manager
Reading package lists... Done
Building dependency tree... Done
Reading state information... DoneCalculating the changesCalculating the changesRestoring original system stateAborting
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
bastien@bastien:~$

Notez que 

nvidia-driver-515

arrive de nulle part vers la fin de l'output. Voici le message quand j'éxécute

 sudo  update-manager 

et clique sur  'upgrade':

bastien@bastien:~$ sudo update-manager
Checking for a new Ubuntu release
authenticate 'jammy.tar.gz' against 'jammy.tar.gz.gpg'
extracting 'jammy.tar.gz'
nvidia-driver-515
bastien@bastien:~$

Encore une fois, nvidia-driver-515 surgit de nulle part. Je pense que c'est lié aux pilotes. Quelqu'un peut-il m'aider pour la maj de 22.04 ? Merci !

Dernière modification par Nuliel (Le 07/11/2022, à 20:53)

Hors ligne

#2 Le 24/08/2022, à 13:29

xubu1957

Re : [Résolu] Installation ratée a cause de drivers nvidia

Bonjour,

Montre, en te servant du Retour utilisable de commande :

lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
ubuntu-drivers devices
uname -a
dpkg -l | grep nvidia
dpkg -l | grep -v ^ii

et :

echo $XDG_SESSION_TYPE

pour voir si c'est Wayland ou x11.

Dernière modification par xubu1957 (Le 24/08/2022, à 20:05)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#3 Le 24/08/2022, à 13:44

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

Bonjour,

Merci pour ta réponse rapide. Voici les outputs:

bastien@bastien:~$ lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
0000:73:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA102GL [RTX A5000] [10de:2231] (rev a1) (prog-if 00 [VGA controller])
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
bastien@bastien:~$ 
bastien@bastien:~$ ubuntu-drivers devices
== /sys/devices/pci0000:72/0000:72:00.0/0000:73:00.0 ==
modalias : pci:v000010DEd00002231sv00001028sd0000147Ebc03sc00i00
vendor   : NVIDIA Corporation
model    : GA102GL [RTX A5000]
driver   : nvidia-driver-515-server - distro non-free recommended
driver   : nvidia-driver-510-server - distro non-free
driver   : nvidia-driver-470-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

== /sys/devices/virtual/dmi/id ==
modalias : dmi:bvnDellInc.:bvr2.14.0:bd07/27/2021:br2.14:svnDellInc.:pnPrecision7920Tower:pvr:rvnDellInc.:rn060K5C:rvrA05:cvnDellInc.:ct3:cvr:sku073A:
driver   : oem-release - third-party free
driver   : oem-somerville-meta - third-party free

bastien@bastien:~$ 
bastien@bastien:~$ uname -a
Linux bastien 5.14.0-1048-oem #55-Ubuntu SMP Mon Aug 8 14:58:10 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
bastien@bastien:~$ 
bastien@bastien:~$ dpkg -l | grep nvidia
ii  libnvidia-cfg1-515-server:amd64                   515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-515-server                       515.65.01-0ubuntu0.22.04.1                 all          Shared files used by the NVIDIA libraries
rc  libnvidia-compute-460:amd64                       460.106.00-0ubuntu1                        amd64        NVIDIA libcompute package
rc  libnvidia-compute-465:amd64                       465.19.01-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-470:amd64                       470.82.01-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-495:amd64                       495.29.05-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-510:amd64                       510.85.02-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-510-server:amd64                510.85.02-0ubuntu0.22.04.1                 amd64        NVIDIA libcompute package
ii  libnvidia-compute-515-server:amd64                515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA libcompute package
ii  libnvidia-compute-515-server:i386                 515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA libcompute package
ii  libnvidia-decode-515-server:amd64                 515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-515-server:i386                  515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-egl-wayland1:amd64                      1:1.1.9-1.1                                amd64        Wayland EGL External Platform library -- shared library
ii  libnvidia-encode-515-server:amd64                 515.65.01-0ubuntu0.22.04.1                 amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-515-server:i386                  515.65.01-0ubuntu0.22.04.1                 i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-515-server:amd64                  515.65.01-0ubuntu0.22.04.1                 amd64        Extra libraries for the NVIDIA Server Driver
ii  libnvidia-fbc1-515-server:amd64                   515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-515-server:i386                    515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-515-server:amd64                     515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-515-server:i386                      515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
rc  nvidia-compute-utils-510                          510.85.02-0ubuntu1                         amd64        NVIDIA compute utilities
rc  nvidia-compute-utils-510-server                   510.85.02-0ubuntu0.22.04.1                 amd64        NVIDIA compute utilities
ii  nvidia-compute-utils-515-server                   515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA compute utilities
rc  nvidia-dkms-510                                   510.85.02-0ubuntu1                         amd64        NVIDIA DKMS package
rc  nvidia-dkms-510-server                            510.85.02-0ubuntu0.22.04.1                 amd64        NVIDIA DKMS package
ii  nvidia-dkms-515-server                            515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA DKMS package
ii  nvidia-driver-515-server                          515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA Server Driver metapackage
rc  nvidia-kernel-common-510                          510.85.02-0ubuntu1                         amd64        Shared files used with the kernel module
rc  nvidia-kernel-common-510-server                   510.85.02-0ubuntu0.22.04.1                 amd64        Shared files used with the kernel module
ii  nvidia-kernel-common-515-server                   515.65.01-0ubuntu0.22.04.1                 amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-515-server                   515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA kernel source package
rc  nvidia-prime                                      0.8.17.1                                   all          Tools to enable NVIDIA's Prime
rc  nvidia-settings                                   515.65.01-0ubuntu1                         amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-515-server                           515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA Server Driver support binaries
ii  xserver-xorg-video-nvidia-515-server              515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA binary Xorg driver
bastien@bastien:~$ 
bastien@bastien:~$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                               Version                                    Architecture Description
+++-=================================================-==========================================-============-=========================================================================================================
rc  bsdmainutils                                      12.1.7+nmu3ubuntu2                         all          Transitional package for more utilities from FreeBSD
rc  crda                                              3.18-1build1                               amd64        wireless Central Regulatory Domain Agent
rc  cuda-toolkit-11-2                                 11.2.2-1                                   amd64        CUDA Toolkit 11.2 meta-package
rc  cuda-toolkit-11-5                                 11.5.1-1                                   amd64        CUDA Toolkit 11.5 meta-package
rc  cuda-toolkit-11-5-config-common                   11.5.117-1                                 all          Common config package for CUDA Toolkit 11.5.
rc  cuda-toolkit-11-config-common                     11.5.117-1                                 all          Common config package for CUDA Toolkit 11.
rc  cuda-toolkit-config-common                        11.5.117-1                                 all          Common config package for CUDA Toolkit.
rc  cuda-visual-tools-11-2                            11.2.2-1                                   amd64        CUDA visual tools
rc  cuda-visual-tools-11-5                            11.5.1-1                                   amd64        CUDA visual tools
rc  dell-eula                                         1.11                                       all          Dell End User License Agreement
rc  dell-recovery-bootloader                          1.64somerville11                           all          Bootloader configuration for Dell's factory process
rc  dmraid                                            1.0.0.rc16-8ubuntu3                        amd64        Device-Mapper Software RAID support tool
rc  emacs-common                                      1:26.3+1-1ubuntu2                          all          GNU Emacs editor's shared, architecture independent infrastructure
rc  fuse                                              2.9.9-3                                    amd64        Filesystem in Userspace
rc  grub-efi-amd64                                    2.04-1ubuntu44                             amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 version)
rc  hddtemp                                           0.3-beta15-53                              amd64        hard drive temperature monitoring utility
rc  idle-python3.9                                    3.9.5-3ubuntu0~20.04.1                     all          IDE for Python (v3.9) using Tkinter
rc  ippusbxd                                          1.34-2ubuntu1                              amd64        Daemon for IPP USB printer support
rc  kpartx-boot                                       0.8.3-1ubuntu2                             all          Provides kpartx during boot
rc  libcufile-11-5                                    1.1.1.25-1                                 amd64        Library for GPU Direct Storage with CUDA 11.5
rc  libnvidia-compute-460:amd64                       460.106.00-0ubuntu1                        amd64        NVIDIA libcompute package
rc  libnvidia-compute-465:amd64                       465.19.01-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-470:amd64                       470.82.01-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-495:amd64                       495.29.05-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-510:amd64                       510.85.02-0ubuntu1                         amd64        NVIDIA libcompute package
rc  libnvidia-compute-510-server:amd64                510.85.02-0ubuntu0.22.04.1                 amd64        NVIDIA libcompute package
rc  libreoffice-style-tango                           1:7.3.5-0ubuntu0.22.04.1                   all          transitional package for Tango symbol style
rc  libvdpau1:amd64                                   1.4-3build2                                amd64        Video Decode and Presentation API for Unix (libraries)
rc  linux-image-5.10.0-1023-oem                       5.10.0-1023.24                             amd64        Signed kernel image oem
rc  linux-image-5.10.0-1051-oem                       5.10.0-1051.53                             amd64        Signed kernel image oem
rc  linux-image-5.10.0-1052-oem                       5.10.0-1052.54                             amd64        Signed kernel image oem
rc  linux-image-5.10.0-1053-oem                       5.10.0-1053.55                             amd64        Signed kernel image oem
rc  linux-image-5.10.0-1055-oem                       5.10.0-1055.58                             amd64        Signed kernel image oem
rc  linux-image-5.10.0-1057-oem                       5.10.0-1057.61                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1024-oem                       5.14.0-1024.26                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1027-oem                       5.14.0-1027.30                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1029-oem                       5.14.0-1029.32                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1031-oem                       5.14.0-1031.34                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1033-oem                       5.14.0-1033.36                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1036-oem                       5.14.0-1036.40                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1038-oem                       5.14.0-1038.42                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1042-oem                       5.14.0-1042.47                             amd64        Signed kernel image oem
rc  linux-image-5.14.0-1044-oem                       5.14.0-1044.49                             amd64        Signed kernel image oem
rc  linux-modules-5.10.0-1023-oem                     5.10.0-1023.24                             amd64        Linux kernel extra modules for version 5.10.0 on 64 bit x86 SMP
rc  linux-modules-5.10.0-1051-oem                     5.10.0-1051.53                             amd64        Linux kernel extra modules for version 5.10.0 on 64 bit x86 SMP
rc  linux-modules-5.10.0-1052-oem                     5.10.0-1052.54                             amd64        Linux kernel extra modules for version 5.10.0 on 64 bit x86 SMP
rc  linux-modules-5.10.0-1053-oem                     5.10.0-1053.55                             amd64        Linux kernel extra modules for version 5.10.0 on 64 bit x86 SMP
rc  linux-modules-5.10.0-1055-oem                     5.10.0-1055.58                             amd64        Linux kernel extra modules for version 5.10.0 on 64 bit x86 SMP
rc  linux-modules-5.10.0-1057-oem                     5.10.0-1057.61                             amd64        Linux kernel extra modules for version 5.10.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1024-oem                     5.14.0-1024.26                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1027-oem                     5.14.0-1027.30                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1029-oem                     5.14.0-1029.32                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1031-oem                     5.14.0-1031.34                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1033-oem                     5.14.0-1033.36                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1036-oem                     5.14.0-1036.40                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1038-oem                     5.14.0-1038.42                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1042-oem                     5.14.0-1042.47                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  linux-modules-5.14.0-1044-oem                     5.14.0-1044.49                             amd64        Linux kernel extra modules for version 5.14.0 on 64 bit x86 SMP
rc  ltrace                                            0.7.3-6.1ubuntu6                           amd64        Tracks runtime library calls in dynamically linked programs
rc  node-duplexer3                                    0.1.4-5                                    all          Like duplexer but using streams3
rc  npm                                               6.14.4+ds-1ubuntu2                         all          package manager for Node.js
rc  nvidia-compute-utils-510                          510.85.02-0ubuntu1                         amd64        NVIDIA compute utilities
rc  nvidia-compute-utils-510-server                   510.85.02-0ubuntu0.22.04.1                 amd64        NVIDIA compute utilities
rc  nvidia-dkms-510                                   510.85.02-0ubuntu1                         amd64        NVIDIA DKMS package
rc  nvidia-dkms-510-server                            510.85.02-0ubuntu0.22.04.1                 amd64        NVIDIA DKMS package
rc  nvidia-kernel-common-510                          510.85.02-0ubuntu1                         amd64        Shared files used with the kernel module
rc  nvidia-kernel-common-510-server                   510.85.02-0ubuntu0.22.04.1                 amd64        Shared files used with the kernel module
rc  nvidia-prime                                      0.8.17.1                                   all          Tools to enable NVIDIA's Prime
rc  nvidia-settings                                   515.65.01-0ubuntu1                         amd64        Tool for configuring the NVIDIA graphics driver
rc  odbcinst                                          2.3.9-5                                    amd64        Helper program for accessing ODBC configuration files
rc  oem-config                                        20.04.15.11                                all          Perform end-user configuration after initial OEM installation
rc  oem-config-gtk                                    20.04.15.11                                all          GTK+ frontend for end-user post-OEM-install configuration
rc  popularity-contest                                1.71ubuntu3                                all          Vote for your favourite packages automatically
rc  python3.9-venv                                    3.9.5-3ubuntu0~20.04.1                     amd64        Interactive high-level object-oriented language (pyvenv binary, version 3.9)
rc  xul-ext-ubufox                                    3.4-0ubuntu1.17.10.1                       all          Ubuntu modifications for Firefox
bastien@bastien:~$ 

C'est x11:

bastien@bastien:~$ echo $XDG_SESSION_TYPE
x11
bastien@bastien:~$ 

Merci smile

Hors ligne

#4 Le 24/08/2022, à 13:46

xubu1957

Re : [Résolu] Installation ratée a cause de drivers nvidia

nvidia-driver-515-server - distro non-free recommended

Tu as un serveur ?

Pour purger les résidus de configuration marqués "rc" :

sudo apt purge ~c

comme expliqué à la machine à café.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#5 Le 24/08/2022, à 14:09

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

Un serveur ? J'ai un GPU sur mon ordi oui:

bastien@bastien:~$ nvidia-smi
Wed Aug 24 15:04:50 2022       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.65.01    Driver Version: 515.65.01    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA RTX A5000    Off  | 00000000:73:00.0  On |                  Off |
| 30%   34C    P8    22W / 230W |    558MiB / 24564MiB |      4%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      3284      G   /usr/lib/xorg/Xorg                165MiB |
|    0   N/A  N/A      3438      G   /usr/bin/gnome-shell               43MiB |
|    0   N/A  N/A      3971      G   ...9/usr/lib/firefox/firefox      254MiB |
|    0   N/A  N/A     23601      G   gnome-control-center               56MiB |
+-----------------------------------------------------------------------------+
bastien@bastien:~$ 

Voici l'output du purge:

bastien@bastien:~$ sudo apt purge ~c
[sudo] Mot de passe de bastien : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de bastien : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de bastien : 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages will be REMOVED
  bsdmainutils* crda* cuda-toolkit-11-2* cuda-toolkit-11-5* cuda-toolkit-11-5-config-common*
  cuda-toolkit-11-config-common* cuda-toolkit-config-common* cuda-visual-tools-11-2* cuda-visual-tools-11-5*
  dell-eula* dell-recovery-bootloader* dmraid* emacs-common* fuse* grub-efi-amd64* hddtemp* idle-python3.9*
  ippusbxd* kpartx-boot* libcufile-11-5* libnvidia-compute-460* libnvidia-compute-465* libnvidia-compute-470*
  libnvidia-compute-495* libnvidia-compute-510* libnvidia-compute-510-server* libreoffice-style-tango* libvdpau1*
  linux-image-5.10.0-1023-oem* linux-image-5.10.0-1051-oem* linux-image-5.10.0-1052-oem*
  linux-image-5.10.0-1053-oem* linux-image-5.10.0-1055-oem* linux-image-5.10.0-1057-oem*
  linux-image-5.14.0-1024-oem* linux-image-5.14.0-1027-oem* linux-image-5.14.0-1029-oem*
  linux-image-5.14.0-1031-oem* linux-image-5.14.0-1033-oem* linux-image-5.14.0-1036-oem*
  linux-image-5.14.0-1038-oem* linux-image-5.14.0-1042-oem* linux-image-5.14.0-1044-oem*
  linux-modules-5.10.0-1023-oem* linux-modules-5.10.0-1051-oem* linux-modules-5.10.0-1052-oem*
  linux-modules-5.10.0-1053-oem* linux-modules-5.10.0-1055-oem* linux-modules-5.10.0-1057-oem*
  linux-modules-5.14.0-1024-oem* linux-modules-5.14.0-1027-oem* linux-modules-5.14.0-1029-oem*
  linux-modules-5.14.0-1031-oem* linux-modules-5.14.0-1033-oem* linux-modules-5.14.0-1036-oem*
  linux-modules-5.14.0-1038-oem* linux-modules-5.14.0-1042-oem* linux-modules-5.14.0-1044-oem* ltrace*
  node-duplexer3* npm* nvidia-compute-utils-510* nvidia-compute-utils-510-server* nvidia-dkms-510*
  nvidia-dkms-510-server* nvidia-kernel-common-510* nvidia-kernel-common-510-server* nvidia-prime*
  nvidia-settings* odbcinst* oem-config* oem-config-gtk* popularity-contest* python3.9-venv* xul-ext-ubufox*
0 to upgrade, 0 to newly install, 75 to remove and 0 not to upgrade.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [O/n] o
(Reading database ... 494828 files and directories currently installed.)
Purging configuration files for linux-image-5.14.0-1024-oem (5.14.0-1024.26) ...
Purging configuration files for cuda-toolkit-config-common (11.5.117-1) ...
Purging configuration files for linux-modules-5.14.0-1042-oem (5.14.0-1042.47) ...
Purging configuration files for fuse (2.9.9-3) ...
Purging configuration files for kpartx-boot (0.8.3-1ubuntu2) ...
Purging configuration files for odbcinst (2.3.9-5) ...
Purging configuration files for linux-image-5.10.0-1057-oem (5.10.0-1057.61) ...
rmdir: failed to remove '/lib/modules/5.10.0-1057-oem': Directory not empty
Purging configuration files for linux-image-5.10.0-1053-oem (5.10.0-1053.55) ...
Purging configuration files for linux-modules-5.14.0-1027-oem (5.14.0-1027.30) ...
Purging configuration files for libnvidia-compute-465:amd64 (465.19.01-0ubuntu1) ...
Purging configuration files for cuda-toolkit-11-config-common (11.5.117-1) ...
Purging configuration files for nvidia-dkms-510 (510.85.02-0ubuntu1) ...
update-initramfs: deferring update (trigger activated)
Purging configuration files for linux-image-5.14.0-1029-oem (5.14.0-1029.32) ...
Purging configuration files for oem-config-gtk (20.04.15.11) ...
Purging configuration files for dell-eula (1.11) ...
Purging configuration files for linux-modules-5.14.0-1044-oem (5.14.0-1044.49) ...
dpkg: warning: while removing linux-modules-5.14.0-1044-oem, directory '/lib/modules/5.14.0-1044-oem' not empty so 
not removed
Purging configuration files for nvidia-prime (0.8.17.1) ...
Purging configuration files for linux-modules-5.14.0-1036-oem (5.14.0-1036.40) ...
Purging configuration files for npm (6.14.4+ds-1ubuntu2) ...
Purging configuration files for nvidia-kernel-common-510-server (510.85.02-0ubuntu0.22.04.1) ...
update-initramfs: deferring update (trigger activated)
Purging configuration files for popularity-contest (1.71ubuntu3) ...
Purging configuration files for libnvidia-compute-510:amd64 (510.85.02-0ubuntu1) ...
Purging configuration files for libnvidia-compute-470:amd64 (470.82.01-0ubuntu1) ...
Purging configuration files for ltrace (0.7.3-6.1ubuntu6) ...
Purging configuration files for nvidia-compute-utils-510-server (510.85.02-0ubuntu0.22.04.1) ...
Purging configuration files for libnvidia-compute-460:amd64 (460.106.00-0ubuntu1) ...
Purging configuration files for libreoffice-style-tango (1:7.3.5-0ubuntu0.22.04.1) ...
Purging configuration files for libcufile-11-5 (1.1.1.25-1) ...
Purging configuration files for linux-modules-5.14.0-1033-oem (5.14.0-1033.36) ...
Purging configuration files for linux-image-5.14.0-1033-oem (5.14.0-1033.36) ...
Purging configuration files for libnvidia-compute-495:amd64 (495.29.05-0ubuntu1) ...
Purging configuration files for linux-modules-5.14.0-1024-oem (5.14.0-1024.26) ...
Purging configuration files for linux-image-5.10.0-1023-oem (5.10.0-1023.24) ...
Purging configuration files for linux-image-5.14.0-1027-oem (5.14.0-1027.30) ...
Purging configuration files for linux-image-5.10.0-1055-oem (5.10.0-1055.58) ...
Purging configuration files for ippusbxd (1.34-2ubuntu1) ...
Purging configuration files for libnvidia-compute-510-server:amd64 (510.85.02-0ubuntu0.22.04.1) ...
Purging configuration files for linux-image-5.10.0-1051-oem (5.10.0-1051.53) ...
Purging configuration files for linux-modules-5.10.0-1053-oem (5.10.0-1053.55) ...
Purging configuration files for oem-config (20.04.15.11) ...
dpkg: warning: while removing oem-config, directory '/usr/lib/oem-config/post-install' not empty so not removed
Purging configuration files for linux-image-5.14.0-1031-oem (5.14.0-1031.34) ...
Purging configuration files for dmraid (1.0.0.rc16-8ubuntu3) ...
update-initramfs: deferring update (trigger activated)
Purging configuration files for linux-modules-5.10.0-1023-oem (5.10.0-1023.24) ...
Purging configuration files for nvidia-dkms-510-server (510.85.02-0ubuntu0.22.04.1) ...
update-initramfs: deferring update (trigger activated)
Purging configuration files for bsdmainutils (12.1.7+nmu3ubuntu2) ...
Purging configuration files for grub-efi-amd64 (2.04-1ubuntu44) ...
ucfr: Association belongs to grub-pc, not grub-efi-amd64
ucfr: Aborting
ucfr: Association belongs to grub-pc, not grub-efi-amd64
ucfr: Aborting
Purging configuration files for cuda-toolkit-11-5-config-common (11.5.117-1) ...
Removing alternatives
Purging configuration files for nvidia-compute-utils-510 (510.85.02-0ubuntu1) ...
Purging configuration files for linux-modules-5.14.0-1038-oem (5.14.0-1038.42) ...
dpkg: warning: while removing linux-modules-5.14.0-1038-oem, directory '/lib/modules/5.14.0-1038-oem' not empty so 
not removed
Purging configuration files for linux-image-5.14.0-1036-oem (5.14.0-1036.40) ...
Purging configuration files for linux-modules-5.14.0-1031-oem (5.14.0-1031.34) ...
Purging configuration files for cuda-toolkit-11-2 (11.2.2-1) ...
Removing alternatives
Purging configuration files for linux-image-5.14.0-1042-oem (5.14.0-1042.47) ...
Purging configuration files for cuda-visual-tools-11-5 (11.5.1-1) ...
Purging configuration files for linux-image-5.14.0-1038-oem (5.14.0-1038.42) ...
Purging configuration files for node-duplexer3 (0.1.4-5) ...
Purging configuration files for linux-modules-5.10.0-1055-oem (5.10.0-1055.58) ...
Purging configuration files for dell-recovery-bootloader (1.64somerville11) ...
Purging configuration files for idle-python3.9 (3.9.5-3ubuntu0~20.04.1) ...
Purging configuration files for libvdpau1:amd64 (1.4-3build2) ...
Purging configuration files for cuda-toolkit-11-5 (11.5.1-1) ...
Removing alternatives
Purging configuration files for hddtemp (0.3-beta15-53) ...
Purging configuration files for linux-image-5.14.0-1044-oem (5.14.0-1044.49) ...
Purging configuration files for nvidia-settings (515.65.01-0ubuntu1) ...
Purging configuration files for python3.9-venv (3.9.5-3ubuntu0~20.04.1) ...
Purging configuration files for xul-ext-ubufox (3.4-0ubuntu1.17.10.1) ...
Purging configuration files for emacs-common (1:26.3+1-1ubuntu2) ...
Purging configuration files for linux-modules-5.10.0-1052-oem (5.10.0-1052.54) ...
Purging configuration files for linux-modules-5.10.0-1057-oem (5.10.0-1057.61) ...
Purging configuration files for linux-modules-5.14.0-1029-oem (5.14.0-1029.32) ...
Purging configuration files for linux-modules-5.10.0-1051-oem (5.10.0-1051.53) ...
Purging configuration files for cuda-visual-tools-11-2 (11.2.2-1) ...
Purging configuration files for crda (3.18-1build1) ...
Purging configuration files for linux-image-5.10.0-1052-oem (5.10.0-1052.54) ...
Purging configuration files for nvidia-kernel-common-510 (510.85.02-0ubuntu1) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for libc-bin (2.35-0ubuntu3.1) ...
Processing triggers for dbus (1.12.20-2ubuntu4) ...
Processing triggers for initramfs-tools (0.140ubuntu13) ...
update-initramfs: Generating /boot/initrd.img-5.14.0-1048-oem
bastien@bastien:~$ 

Hors ligne

#6 Le 25/08/2022, à 07:22

xubu1957

Re : [Résolu] Installation ratée a cause de drivers nvidia

La Doc serveur.

Je ne suis pas habitué à cette particularité, et je ne sais pas quoi proposer.

Je vois cette page > askubuntu.com/questions/1423623/nvidia-graphic-card-is-recognized-as-3d-controller-in-ubuntu-22-04 pour une autre carte, mais il ressort une mention :

nvidia-driver-515 - distro non-free recommended

        _ _ _

(edit=messages regroupés)
        _ _ _

Ta carte graphique doit être vraiment récente, je trouve peu de réponses indiquant Linux.


                                                                    ==============

Bonjour,

Donne le retour de :

sudo apt update

et le sources.list avec la numérotation :

find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n\t$1\n"; [[ $1 = *".list" ]] && cat -n "$1"' _ '{}' \;

Dernière modification par xubu1957 (Le 25/08/2022, à 07:27)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#7 Le 25/08/2022, à 07:37

iznobe

Re : [Résolu] Installation ratée a cause de drivers nvidia

Bonjour , vu que nvidia pose probleme pour la mise a niveau .

Je te propose de purger tous les paquets nvidia ( pilote y compris ) , de faire ensuite les mises a jours et un nettoyage via la commande , puis evidemment de redemarrer pour passer sur le pilote nouveau temporairement .

Refaire un etat des lieux , et voir si la mise a niveau devient possible .
si oui effectuer la mise a niveau , puis alors , reinstaller le pilote nvidia recommandé .

Dernière modification par iznobe (Le 25/08/2022, à 07:38)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#8 Le 25/08/2022, à 08:51

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

xubu1957 a écrit :

La Doc serveur.

Je ne suis pas habitué à cette particularité, et je ne sais pas quoi proposer.

Je vois cette page > askubuntu.com/questions/1423623/nvidia-graphic-card-is-recognized-as-3d-controller-in-ubuntu-22-04 pour une autre carte, mais il ressort une mention :

nvidia-driver-515 - distro non-free recommended

        _ _ _

(edit=messages regroupés)
        _ _ _

Ta carte graphique doit être vraiment récente, je trouve peu de réponses indiquant Linux.


                                                                    ==============

Bonjour,

Donne le retour de :

sudo apt update

et le sources.list avec la numérotation :

find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n\t$1\n"; [[ $1 = *".list" ]] && cat -n "$1"' _ '{}' \;



Bonjour,

Oui la carte est assez récente, on a eu du mal a la faire marcher au début. Je vais regarder la page merci.

Voici les outputs:


bastien@bastien:~/Documents/Abracadabra$ sudo apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libnftables1 nftables
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.
bastien@bastien:~/Documents/Abracadabra$ 

A noter qu'hier, il y avait 0 package en 'not to upgrade'.


bastien@bastien:~/Documents/Abracadabra$ find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n\t$1\n"; [[ $1 = *".list" ]] && cat -n "$1"' _ '{}' \;

	/etc/apt/sources.list.save


	/etc/apt/sources.list~


	/etc/apt/sources.list.d/sublime-text.list

     1	# deb https://download.sublimetext.com/ apt/stable/ # désactivé pour la mise à niveau vers jammy

	/etc/apt/sources.list.d/cuda-ubuntu2004-11-3-local.list.save


	/etc/apt/sources.list.d/nvidia-docker.list

     1	# deb https://nvidia.github.io/libnvidia-container/stable/ubuntu18.04/$(ARCH) / # désactivé pour la mise à niveau vers jammy
     2	# deb https://nvidia.github.io/libnvidia-container/experimental/ubuntu18.04/$(ARCH) /
     3	# deb https://nvidia.github.io/nvidia-container-runtime/stable/ubuntu18.04/$(ARCH) / # désactivé pour la mise à niveau vers jammy
     4	# deb https://nvidia.github.io/nvidia-container-runtime/experimental/ubuntu18.04/$(ARCH) /
     5	# deb https://nvidia.github.io/nvidia-docker/ubuntu18.04/$(ARCH) / # désactivé pour la mise à niveau vers jammy

	/etc/apt/sources.list.d/docker.list

     1	deb [arch=amd64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/ubuntu   focal stable

	/etc/apt/sources.list.d/docker.list.distUpgrade


	/etc/apt/sources.list.d/vscode.list.save


	/etc/apt/sources.list.d/google-chrome.list.distUpgrade


	/etc/apt/sources.list.d/focal-oem.list.distUpgrade


	/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-focal.list.save


	/etc/apt/sources.list.d/google-chrome.list.save


	/etc/apt/sources.list.d/cuda-ubuntu2004-11-5-local.list.save


	/etc/apt/sources.list.d/cuda-ubuntu2004-11-2-local.list

     1	# deb file:///var/cuda-repo-ubuntu2004-11-2-local / # désactivé pour la mise à niveau vers jammy

	/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-focal.list

     1	# deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy main # désactivé pour la mise à niveau vers jammy
     2	# deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main

	/etc/apt/sources.list.d/cuda-ubuntu2004-11-5-local.list

     1	# deb file:///var/cuda-repo-ubuntu2004-11-5-local / # désactivé pour la mise à niveau vers jammy

	/etc/apt/sources.list.d/vscode.list.distUpgrade


	/etc/apt/sources.list.d/cuda-ubuntu2004-11-3-local.list

     1	# deb file:///var/cuda-repo-ubuntu2004-11-3-local / # désactivé pour la mise à niveau vers jammy

	/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-focal.list.distUpgrade


	/etc/apt/sources.list.d/sublime-text.list.distUpgrade


	/etc/apt/sources.list.d/focal-oem.list.save


	/etc/apt/sources.list.d/nvidia-docker.list.save


	/etc/apt/sources.list.d/cuda-ubuntu2004-11-2-local.list.save


	/etc/apt/sources.list.d/cuda-ubuntu2004-11-5-local.list.distUpgrade


	/etc/apt/sources.list.d/docker.list.save


	/etc/apt/sources.list.d/google-chrome.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main # désactivé pour la mise à niveau vers jammy

	/etc/apt/sources.list.d/cuda-ubuntu2004-11-2-local.list.distUpgrade


	/etc/apt/sources.list.d/cuda-ubuntu2004-11-3-local.list.distUpgrade


	/etc/apt/sources.list.d/nvidia-docker.list.distUpgrade


	/etc/apt/sources.list.d/sublime-text.list.save


	/etc/apt/sources.list.d/cuda-ubuntu2004-x86_64.list.save


	/etc/apt/sources.list.d/vscode.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb [arch=amd64,arm64,armhf] http://packages.microsoft.com/repos/code stable main # désactivé pour la mise à niveau vers jammy

	/etc/apt/sources.list.d/cuda-ubuntu2004-x86_64.list.distUpgrade


	/etc/apt/sources.list.d/cuda-ubuntu2004-x86_64.list

     1	deb [signed-by=/usr/share/keyrings/cuda-archive-keyring.gpg] https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ /

	/etc/apt/sources.list.d/focal-oem.list

     1	deb http://oem.archive.canonical.com/ jammy oem
     2	# deb-src http://oem.archive.canonical.com/ focal oem

	/etc/apt/sources.list

     1	
     2	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     3	# newer versions of the distribution.
     4	deb http://archive.ubuntu.com/ubuntu/ jammy main restricted
     5	# deb-src http://archive.ubuntu.com/ubuntu/ focal main restricted
     6	
     7	## Major bug fix updates produced after the final release of the
     8	## distribution.
     9	deb http://archive.ubuntu.com/ubuntu/ jammy-updates main restricted
    10	# deb-src http://archive.ubuntu.com/ubuntu/ focal-updates main restricted
    11	
    12	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    13	## team. Also, please note that software in universe WILL NOT receive any
    14	## review or updates from the Ubuntu security team.
    15	deb http://archive.ubuntu.com/ubuntu/ jammy universe
    16	# deb-src http://archive.ubuntu.com/ubuntu/ focal universe
    17	deb http://archive.ubuntu.com/ubuntu/ jammy-updates universe
    18	# deb-src http://archive.ubuntu.com/ubuntu/ focal-updates universe
    19	
    20	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    21	## team, and may not be under a free licence. Please satisfy yourself as to
    22	## your rights to use the software. Also, please note that software in
    23	## multiverse WILL NOT receive any review or updates from the Ubuntu
    24	## security team.
    25	deb http://archive.ubuntu.com/ubuntu/ jammy multiverse
    26	# deb-src http://archive.ubuntu.com/ubuntu/ focal multiverse
    27	deb http://archive.ubuntu.com/ubuntu/ jammy-updates multiverse
    28	# deb-src http://archive.ubuntu.com/ubuntu/ focal-updates multiverse
    29	
    30	## N.B. software from this repository may not have been tested as
    31	## extensively as that contained in the main release, although it includes
    32	## newer versions of some applications which may provide useful features.
    33	## Also, please note that software in backports WILL NOT receive any review
    34	## or updates from the Ubuntu security team.
    35	deb http://archive.ubuntu.com/ubuntu/ jammy-backports main restricted universe multiverse
    36	# deb-src http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    37	
    38	
    39	deb http://security.ubuntu.com/ubuntu jammy-security main restricted
    40	# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
    41	deb http://security.ubuntu.com/ubuntu jammy-security universe
    42	# deb-src http://security.ubuntu.com/ubuntu focal-security universe
    43	deb http://security.ubuntu.com/ubuntu jammy-security multiverse
    44	# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse
    45	
    46	
    47	# deb https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/ # désactivé pour la mise à niveau vers jammy
    48	# deb-src https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/
    49	# deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ / # désactivé pour la mise à niveau vers jammy
    50	# deb-src https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ /
    51	
    52	

	/etc/apt/sources.list.distUpgrade

bastien@bastien:~/Documents/Abracadabra$ 

Merci pour ton aide !

Hors ligne

#9 Le 25/08/2022, à 08:52

xubu1957

Re : [Résolu] Installation ratée a cause de drivers nvidia

Per favor :

Règles du forum= § Politesse a écrit :

(...)
3. Utilisez la citation avec modération : il ne sert à rien de citer l'intégralité du post précédent.
(...)

règles du forum

        _ _ _

(edit=messages regroupés)
        _ _ _

Montre :

apt policy nvidia-cuda-toolkit
     1	# deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy main # désactivé pour la mise à niveau vers jammy

Le ppa graphics-drivers/ppa est désactivé (commenté avec #).

Dernière modification par xubu1957 (Le 25/08/2022, à 09:51)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#10 Le 25/08/2022, à 09:19

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

iznobe a écrit :

Bonjour , vu que nvidia pose probleme pour la mise a niveau .

Je te propose de purger tous les paquets nvidia ( pilote y compris ) , de faire ensuite les mises a jours et un nettoyage via la commande , puis evidemment de redemarrer pour passer sur le pilote nouveau temporairement .

Refaire un etat des lieux , et voir si la mise a niveau devient possible .
si oui effectuer la mise a niveau , puis alors , reinstaller le pilote nvidia recommandé .

Bonjour,

Merci pour ton aide. J'ai purger tous les paquets et drivers nvidia, et ensuite j'ai redémarré. Ensuite c'est assez étrange, après le rédemarrage, la version était directement la 22.04, sans que je demande a faire l'upgrade en ligne de commande ...

Assez étrange mais ca a marché donc c'est le principal.

Merci a vous deux, je met ca en résolu!

[Edit]

en effet je suis allé un peu vite en besogne, je travaille à distance sur anydesk, la sortie de

lsb_release - a 

était en fait celle de mon pc perso qui est bien en 22.04. Je purge les drivers, ils ne se sont pas purgés après ma tentative finalement.

Dernière modification par Bastien-mva (Le 25/08/2022, à 09:29)

Hors ligne

#11 Le 25/08/2022, à 09:24

iznobe

Re : [Résolu] Installation ratée a cause de drivers nvidia

A mon avis , pour le moment cela me semble difficile d ' indiquer cela comme résolu , sans avoir fait un état des lieux avancés , notamment suite a la dernière remarque de @xubu1957 :

xubu1957 a écrit :

Montre :

apt policy nvidia-cuda-toolkit
     1	# deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy main # désactivé pour la mise à niveau vers jammy

Le ppa graphics-drivers/ppa est désactivé (commenté avec #).

Dernière modification par iznobe (Le 25/08/2022, à 09:25)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#12 Le 25/08/2022, à 09:32

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

xubu1957 a écrit :

Montre :

apt policy nvidia-cuda-toolkit
     1	# deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy main # désactivé pour la mise à niveau vers jammy

Voici l'output:

bastien@bastien:~$ apt policy nvidia-cuda-toolkit
nvidia-cuda-toolkit:
  Installed: (none)
  Candidate: 11.5.1-1ubuntu1
  Version table:
     11.5.1-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu jammy/multiverse amd64 Packages
bastien@bastien:~$ 

je vais essayer de décommenter la ligne indiquée dans

 /etc/apt/sources.list 

Hors ligne

#13 Le 25/08/2022, à 09:36

iznobe

Re : [Résolu] Installation ratée a cause de drivers nvidia

tu auras un avertissement : no_pub key ... avec apt update ensuite .
tu peux ajouter la clé avec une commande de la doc : https://doc.ubuntu-fr.org/apt-key

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com votre_n°_de_clé

Dernière modification par iznobe (Le 25/08/2022, à 09:37)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#14 Le 25/08/2022, à 09:48

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

J'ai essayé de décommenter la ligne indiquée dans

/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-focal.list

mais cela n'a rien donné en effet. Je l'ai recommenté.

Comment je trouve mon numéro de clé ?

Hors ligne

#15 Le 25/08/2022, à 09:52

xubu1957

Re : [Résolu] Installation ratée a cause de drivers nvidia

xubu a écrit :

Donne le retour de :

sudo apt update

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#16 Le 25/08/2022, à 09:54

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

xubu a écrit :

Donne le retour de :

sudo apt update
     bastien@bastien:~/Documents/Abracadabra$ sudo apt update
Hit:1 http://oem.archive.canonical.com jammy InRelease
Hit:2 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64  InRelease                                                
Hit:3 https://download.docker.com/linux/ubuntu focal InRelease                                                                             
Hit:4 http://archive.ubuntu.com/ubuntu jammy InRelease                                           
Hit:5 http://security.ubuntu.com/ubuntu jammy-security InRelease
Hit:6 http://archive.ubuntu.com/ubuntu jammy-updates InRelease
Hit:7 http://archive.ubuntu.com/ubuntu jammy-backports InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Skipping acquisition of configured file 'oem/binary-amd64/Packages', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/binary-i386/Packages', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/i18n/Translation-en', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/i18n/Translation-fr', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/i18n/Translation-en_GB', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/Components-amd64.yml', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/icons-48x48.tar', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/icons-64x64.tar', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/icons-64x64@2.tar', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/cnf/Commands-amd64', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
bastien@bastien:~/Documents/Abracadabra$ 
    

Dernière modification par Bastien-mva (Le 25/08/2022, à 09:55)

Hors ligne

#17 Le 25/08/2022, à 09:58

iznobe

Re : [Résolu] Installation ratée a cause de drivers nvidia

Bastien-mva a écrit :

Comment je trouve mon numéro de clé ?


il te faut re decommenter .
donner ensuite

sudo apt update

et

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

Dernière modification par iznobe (Le 25/08/2022, à 09:58)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#18 Le 25/08/2022, à 10:06

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

J'ai décommenté la ligne

deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy main # désactivé pour la mise à niveau vers jammy 

dans

/etc/apt/sources.list.d

Maintenant j'ai cela en sortie

bastien@bastien:/etc/apt/sources.list.d$ sudo apt update
Hit:1 http://archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://archive.ubuntu.com/ubuntu jammy-updates InRelease                                                                                         
Hit:3 http://archive.ubuntu.com/ubuntu jammy-backports InRelease                                                                                       
Get:4 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy InRelease [24,3 kB]                                                                   
Hit:5 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64  InRelease                               
Hit:6 http://oem.archive.canonical.com jammy InRelease                                         
Hit:7 http://security.ubuntu.com/ubuntu jammy-security InRelease                                          
Hit:8 https://download.docker.com/linux/ubuntu focal InRelease                                            
Get:9 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy/main i386 Packages [10,3 kB]
Get:10 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy/main amd64 Packages [19,7 kB]
Get:11 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy/main Translation-en [5200 B]
Fetched 59,6 kB in 2s (31,5 kB/s)              
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Skipping acquisition of configured file 'oem/binary-amd64/Packages', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/binary-i386/Packages', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/i18n/Translation-fr', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/i18n/Translation-en_GB', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/i18n/Translation-en', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/Components-amd64.yml', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/icons-48x48.tar', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/icons-64x64.tar', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/dep11/icons-64x64@2.tar', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
W: Skipping acquisition of configured file 'oem/cnf/Commands-amd64', as repository 'http://oem.archive.canonical.com jammy InRelease' doesn't have the component 'oem' (component misspelt in sources.list?)
bastien@bastien:/etc/apt/sources.list.d$ 

Les pacakges upgradbale:

bastien@bastien:/etc/apt/sources.list.d$ apt  list --upgradable
Listing... Done
libnftables1/jammy-updates 1.0.2-1ubuntu3 amd64 [upgradable from: 1.0.2-1ubuntu2]
nftables/jammy-updates 1.0.2-1ubuntu3 amd64 [upgradable from: 1.0.2-1ubuntu2]
bastien@bastien:/etc/apt/sources.list.d$ 

Dernière modification par Bastien-mva (Le 25/08/2022, à 10:10)

Hors ligne

#19 Le 25/08/2022, à 10:10

iznobe

Re : [Résolu] Installation ratée a cause de drivers nvidia

la clé n' a pas changé et il a bien recuperé les infos du dépôt :

Get:4 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy InRelease [24,3 kB]  

il faut donc laisser en l' etat ( ne pas recommenter ) .


Par contre tes composants " oem " ne sont plus pris en charge , pour ca que j' avais aussi demandé l' autre retour de commande , afin de voir si il etait possible de corriger ca .

Dernière modification par iznobe (Le 25/08/2022, à 10:10)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#20 Le 25/08/2022, à 10:10

xubu1957

Re : [Résolu] Installation ratée a cause de drivers nvidia

doesn't have the component 'oem'

C'est jamais très clair > how-to-fix-skipping-acquire-of-configured-file-in-ubuntu-22-04-lts avec les noyaux oem.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#21 Le 25/08/2022, à 10:11

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

Au temps pour moi:

bastien@bastien:/etc/apt/sources.list.d$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list.d/sublime-text.list

     1	# deb https://download.sublimetext.com/ apt/stable/ # désactivé pour la mise à niveau vers jammy

/etc/apt/sources.list.d/nvidia-docker.list

     1	# deb https://nvidia.github.io/libnvidia-container/stable/ubuntu18.04/$(ARCH) / # désactivé pour la mise à niveau vers jammy
     2	# deb https://nvidia.github.io/libnvidia-container/experimental/ubuntu18.04/$(ARCH) /
     3	# deb https://nvidia.github.io/nvidia-container-runtime/stable/ubuntu18.04/$(ARCH) / # désactivé pour la mise à niveau vers jammy
     4	# deb https://nvidia.github.io/nvidia-container-runtime/experimental/ubuntu18.04/$(ARCH) /
     5	# deb https://nvidia.github.io/nvidia-docker/ubuntu18.04/$(ARCH) / # désactivé pour la mise à niveau vers jammy

/etc/apt/sources.list.d/docker.list

     1	deb [arch=amd64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/ubuntu   focal stable

/etc/apt/sources.list.d/cuda-ubuntu2004-11-2-local.list

     1	# deb file:///var/cuda-repo-ubuntu2004-11-2-local / # désactivé pour la mise à niveau vers jammy

/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-focal.list

     1	deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu jammy main # désactivé pour la mise à niveau vers jammy
     2	# deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main

/etc/apt/sources.list.d/cuda-ubuntu2004-11-5-local.list

     1	# deb file:///var/cuda-repo-ubuntu2004-11-5-local / # désactivé pour la mise à niveau vers jammy

/etc/apt/sources.list.d/cuda-ubuntu2004-11-3-local.list

     1	# deb file:///var/cuda-repo-ubuntu2004-11-3-local / # désactivé pour la mise à niveau vers jammy

/etc/apt/sources.list.d/google-chrome.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main # désactivé pour la mise à niveau vers jammy

/etc/apt/sources.list.d/vscode.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb [arch=amd64,arm64,armhf] http://packages.microsoft.com/repos/code stable main # désactivé pour la mise à niveau vers jammy

/etc/apt/sources.list.d/cuda-ubuntu2004-x86_64.list

     1	deb [signed-by=/usr/share/keyrings/cuda-archive-keyring.gpg] https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ /

/etc/apt/sources.list.d/focal-oem.list

     1	deb http://oem.archive.canonical.com/ jammy oem
     2	# deb-src http://oem.archive.canonical.com/ focal oem

/etc/apt/sources.list

     1	
     2	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     3	# newer versions of the distribution.
     4	deb http://archive.ubuntu.com/ubuntu/ jammy main restricted
     5	# deb-src http://archive.ubuntu.com/ubuntu/ focal main restricted
     6	
     7	## Major bug fix updates produced after the final release of the
     8	## distribution.
     9	deb http://archive.ubuntu.com/ubuntu/ jammy-updates main restricted
    10	# deb-src http://archive.ubuntu.com/ubuntu/ focal-updates main restricted
    11	
    12	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    13	## team. Also, please note that software in universe WILL NOT receive any
    14	## review or updates from the Ubuntu security team.
    15	deb http://archive.ubuntu.com/ubuntu/ jammy universe
    16	# deb-src http://archive.ubuntu.com/ubuntu/ focal universe
    17	deb http://archive.ubuntu.com/ubuntu/ jammy-updates universe
    18	# deb-src http://archive.ubuntu.com/ubuntu/ focal-updates universe
    19	
    20	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    21	## team, and may not be under a free licence. Please satisfy yourself as to
    22	## your rights to use the software. Also, please note that software in
    23	## multiverse WILL NOT receive any review or updates from the Ubuntu
    24	## security team.
    25	deb http://archive.ubuntu.com/ubuntu/ jammy multiverse
    26	# deb-src http://archive.ubuntu.com/ubuntu/ focal multiverse
    27	deb http://archive.ubuntu.com/ubuntu/ jammy-updates multiverse
    28	# deb-src http://archive.ubuntu.com/ubuntu/ focal-updates multiverse
    29	
    30	## N.B. software from this repository may not have been tested as
    31	## extensively as that contained in the main release, although it includes
    32	## newer versions of some applications which may provide useful features.
    33	## Also, please note that software in backports WILL NOT receive any review
    34	## or updates from the Ubuntu security team.
    35	deb http://archive.ubuntu.com/ubuntu/ jammy-backports main restricted universe multiverse
    36	# deb-src http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    37	
    38	
    39	deb http://security.ubuntu.com/ubuntu jammy-security main restricted
    40	# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
    41	deb http://security.ubuntu.com/ubuntu jammy-security universe
    42	# deb-src http://security.ubuntu.com/ubuntu focal-security universe
    43	deb http://security.ubuntu.com/ubuntu jammy-security multiverse
    44	# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse
    45	
    46	
    47	# deb https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/ # désactivé pour la mise à niveau vers jammy
    48	# deb-src https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/
    49	# deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ / # désactivé pour la mise à niveau vers jammy
    50	# deb-src https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/ /
    51	
    52	
bastien@bastien:/etc/apt/sources.list.d$ 

Hors ligne

#22 Le 25/08/2022, à 10:14

iznobe

Re : [Résolu] Installation ratée a cause de drivers nvidia

il faudrait aussi , verifier ou ca en est pour ta carte graphique avec le passage a la 22.04

xubu1957 a écrit :

Bonjour,

Montre, en te servant du Retour utilisable de commande :

lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
ubuntu-drivers devices
uname -a
dpkg -l | grep nvidia
dpkg -l | grep -v ^ii

Dernière modification par iznobe (Le 25/08/2022, à 10:14)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#23 Le 25/08/2022, à 10:16

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

Je ne sais pas si tu as vu, mais en fait je ne suis pas passé a la 22.04, je me suis trompé de console ...

J'ai donc toujours ce pb de maj ubuntu 22.04 hmm

Je t'envoie les outuput.

Hors ligne

#24 Le 25/08/2022, à 10:22

Bastien-mva

Re : [Résolu] Installation ratée a cause de drivers nvidia

bastien@bastien:/etc/apt/sources.list.d$ lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
0000:73:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA102GL [RTX A5000] [10de:2231] (rev a1) (prog-if 00 [VGA controller])
	Kernel driver in use: nouveau
	Kernel modules: nvidiafb, nouveau
bastien@bastien:/etc/apt/sources.list.d$ 
bastien@bastien:/etc/apt/sources.list.d$ ubuntu-drivers devices
== /sys/devices/pci0000:72/0000:72:00.0/0000:73:00.0 ==
modalias : pci:v000010DEd00002231sv00001028sd0000147Ebc03sc00i00
vendor   : NVIDIA Corporation
model    : GA102GL [RTX A5000]
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-510-server - distro non-free
driver   : nvidia-driver-515-server - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

== /sys/devices/virtual/dmi/id ==
modalias : dmi:bvnDellInc.:bvr2.14.0:bd07/27/2021:br2.14:svnDellInc.:pnPrecision7920Tower:pvr:rvnDellInc.:rn060K5C:rvrA05:cvnDellInc.:ct3:cvr:sku073A:
driver   : oem-somerville-meta - third-party free
driver   : oem-release - third-party free

bastien@bastien:/etc/apt/sources.list.d$ 
bastien@bastien:/etc/apt/sources.list.d$ uname -a
Linux bastien 5.14.0-1048-oem #55-Ubuntu SMP Mon Aug 8 14:58:10 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
bastien@bastien:/etc/apt/sources.list.d$ 
bastien@bastien:/etc/apt/sources.list.d$ dpkg -l | grep nvidia
ii  libnvidia-cfg1-515-server:amd64                   515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-515-server                       515.65.01-0ubuntu0.22.04.1                 all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-515-server:amd64                515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA libcompute package
ii  libnvidia-compute-515-server:i386                 515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA libcompute package
ii  libnvidia-decode-515-server:amd64                 515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-515-server:i386                  515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-egl-wayland1:amd64                      1:1.1.9-1.1                                amd64        Wayland EGL External Platform library -- shared library
ii  libnvidia-encode-515-server:amd64                 515.65.01-0ubuntu0.22.04.1                 amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-515-server:i386                  515.65.01-0ubuntu0.22.04.1                 i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-515-server:amd64                  515.65.01-0ubuntu0.22.04.1                 amd64        Extra libraries for the NVIDIA Server Driver
ii  libnvidia-fbc1-515-server:amd64                   515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-515-server:i386                    515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-515-server:amd64                     515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-515-server:i386                      515.65.01-0ubuntu0.22.04.1                 i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  xserver-xorg-video-nvidia-515-server              515.65.01-0ubuntu0.22.04.1                 amd64        NVIDIA binary Xorg driver
bastien@bastien:/etc/apt/sources.list.d$ 
bastien@bastien:/etc/apt/sources.list.d$ dpkg -l | grep -v ^ii
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                              Version                                    Architecture Description
+++-=================================================-==========================================-============-=========================================================================================================
bastien@bastien:/etc/apt/sources.list.d$ 

Comme ttu vois, je n'ai pas encore réussi à purger les drivers et paquets. Dois-je essayer de le faire maintenant ?

Hors ligne

#25 Le 25/08/2022, à 10:37

iznobe

Re : [Résolu] Installation ratée a cause de drivers nvidia

on voit du jammy partout sauf un qu on va supprimer dans les sources , qui d' ailleurs est probablement la source du soucis de ton installation nvidia .
Pourquoi dis tu que la MAN ne s ' est pas faite ?
donne aussi

cat /etc/lsb*release

et

cd /etc/apt/sources.list.d && sudo rm nvidia-docker.list; cd

Dernière modification par iznobe (Le 25/08/2022, à 10:41)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne