Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 05/02/2010, à 08:41

RegisBurin

Re : Carte son M-Audio Delta 44

passe-partout a écrit :

Salut,

j'écris pour dire que AMHA, le nombre de sorties à 10, c'est pour pouvoir supporter la delta 1010. Le même driver et la même config de chip se faisant pour toutes les cartes de la famille.

Peut-être pouvez-vous abaisser le nombre de "channels" à celui que vous possédez réellement. ex:

quand on a:

        slave.format S32_LE
        slave.channels 12

mettre:

        slave.format S32_LE
        slave.channels 4

Par contre il faut modifier les lignes avec "ttable" dedant, pour qu'elles n'ai pas de références à des voies qui ne seraient plus là!
I.e: si on choisit "slave.channels 4" pour une delta 44, pas de "ttable 4.4 1" ou "ttable 5.5 1".

D'ailleur, à ce propos @ RegisBurin:

Dans ton ice1712.conf, tu peux rajouter ces deux lignes

        slave.format S32_LE
        slave.channels 4

(avec 4 ou 10 suivant ce que tu souhaites.)
à la fin de chaque sections (juste avant du texte entre <>). ça amène des choix supplémentaire dans les préférences sons.

...mon sauveur wink ça fait deux ans que je cherche ça... Je teste ce soir, je tiens au jus

Encore merci pour l'info (y'a moyen d'écrire une doc là)


Config (M-AUDIO Delta44/Wacom CTH661-Phone ZTE OpenC-FFOS2.1) | BabyBox[WIP]
Moi sur le web / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#27 Le 05/02/2010, à 20:03

passe-partout

Re : Carte son M-Audio Delta 44

Je viens enfin de réussir à router le signal par défaut sur les sorties que je souhaite!

C'est à dire, dans mon cas, avoir les sorties 7 et 8, pour la stéréo  comme sortie par défaut.
(je garde les 6 premières pour le 5.1) .
J'ai modifier le fichier de conf de la carte (/usr/share/alsa/cards/ICE1712.conf) de la sorte:

<confdir:pcm/front.conf>

ICE1712.pcm.front.0 {
	@args [ CARD ]
	@args.CARD {
		type string
	}
	type route
	ttable.0.6 1
	ttable.1.7 1
	slave.pcm {
		type hw
		card $CARD
	}
	slave.format S32_LE
        slave.channels 10 

}

J'ai modifié la partie "type route" en mettant 6 et 7 à la place de 0 et 1 pour les 2 lignes "ttable" (6 pour la sortie 7 et 7 pour la sortie 8, parce que la numérotation débute à 0).
Si ça peut aider...

Je me suis aidé de cette partie du wiki d'ALSA:
http://alsa.opensrc.org/index.php/1712_.asoundrc
et de celle là:
http://www.alsa-project.org/alsa-doc/al … cm_plugins

Dernière modification par passe-partout (Le 05/02/2010, à 23:05)

Hors ligne

#28 Le 08/02/2010, à 14:37

demo7

Re : Carte son M-Audio Delta 44

bonjour,

j'ai comme l'impression que nos cartes 2496 / delta44 / delta1010 / etc... sont maintenant toutes reconnues et fonctionnel sous karmic et UbuntuStudio. D'autres pistes ont été exploré http://forum.ubuntu-fr.org/viewtopic.ph … 2#p3028742.
RegisBurin proposait de commencer une doc, je vous propose mon aide.

demo7

Dernière modification par demo7 (Le 08/02/2010, à 14:38)

Hors ligne

#29 Le 28/02/2010, à 22:01

set

Re : Carte son M-Audio Delta 44

bonjour a tous et toutes;

Je vois que les heureux possesseurs d'une m-audio sont toujours autant delaissé par Karmic. a titre perso, j'ai laché l'affaire. Je n'ai pas de son avec ubuntu et je travaille sous Windoz pour la mao. Le probleme est trop complexe pour un bourrin de mon espece lol.
je réve d'une ligne de commande terminale remettant les choses en ordre... mais ca a l'air de ne pas etre simple.
Je croise les doigts pour les versions de bubuntu à venir.


ubuntustudio 16.04LTS (xubuntu 4.12-)
ASUS P5Q pro // core 2 duo E75004//4g mem DDR2 // RADEON HD4670//M-Audio delta 44

Asus T100 TAF32gb (Ubuntu 16-4 /64bit sans son)

Hors ligne

#30 Le 01/03/2010, à 12:28

RegisBurin

Re : Carte son M-Audio Delta 44

set a écrit :

bonjour a tous et toutes;

Je vois que les heureux possesseurs d'une m-audio sont toujours autant delaissé par Karmic. a titre perso, j'ai laché l'affaire...

Bah, justement non, on est tous en train de dire qu'elle sont particulièrement bien reconnu sous Ubuntu...

Essaies de reprendre les pistes évoquées dans ce topic.

Si ça prend toujours pas, postes nous tout ça:

lspci | grep audio

...pour le principe, c'est quasiment certain qu'elle est reconnue wink

cat /usr/share/alsa/cards/ICE1712.conf
cat /etc/pulse/default.pa

Petit résumé de ce qui a fonctionné chez moi:

Ajout de

slave.format S32_LE
slave.channels 4

dans /usr/share/alsa/cards/ICE1712.conf, section front

Ajout de

load-module module-alsa-sink device=hw:0
load-module module-alsa-source device=hw:0

dans /etc/pulse/default.pa

Désactivation (dans le bios) du chipset AC97 intégré à la carte mère (chez moi, impossible d'utiliser les deux matériels simultanéments).

Choix de la carte dans les préférences de son du menu système.

@+

Dernière modification par RegisBurin (Le 01/03/2010, à 12:29)


Config (M-AUDIO Delta44/Wacom CTH661-Phone ZTE OpenC-FFOS2.1) | BabyBox[WIP]
Moi sur le web / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#31 Le 06/03/2010, à 21:56

david96

Re : Carte son M-Audio Delta 44

Cool, étant à la recherche d'une carte son, c'est plutôt une bonne nouvelle, merci pour vos recherches et partage de celles-ci smile

Hors ligne

#32 Le 18/03/2010, à 18:46

set

Re : Carte son M-Audio Delta 44

sad dsl j'avais pas lu la deuxieme page...
mais ca change pas grand chose a mon probleme .. j'ai toujours pas de son en ayant modifier les fichiers ice1712.conf
suite la commande suivante ..

lspci | grep audio

Jai ca en reponse :

00:08.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)

ubuntustudio 16.04LTS (xubuntu 4.12-)
ASUS P5Q pro // core 2 duo E75004//4g mem DDR2 // RADEON HD4670//M-Audio delta 44

Asus T100 TAF32gb (Ubuntu 16-4 /64bit sans son)

Hors ligne

#33 Le 17/11/2010, à 23:36

_mx_

Re : Carte son M-Audio Delta 44

Bonjour,
j'ai une delta 44 qui marche sur ubuntu 10.10

Voila tout ce que j'ai fait :

Éditez le fichier /etc/pulse/default.pa

gksu gedit /etc/pulse/default.pa

Ajoutez ces lignes à la fin du fichier :

### M-Audio Delta 44
load-module module-alsa-sink device=hw:M44
load-module module-alsa-source device=hw:M44
set-default-sink output
set-default-source input

Notez que ce n'est pas "hw:0" mais "hw:M44".
La solution était dans ce ticket :
https://bugs.launchpad.net/ubuntu/+sour … bug/178442

Éditez le fichier /etc/modprobe.d/alsa-base.conf

gksu gedit /etc/modprobe.d/alsa-base.conf

Ajoutez ces lignes à la fin du fichier :

# driver ice1712 M-Audio Delta 44
options snd-ice1712 index=0

Sur cette page http://www.alsa-project.org/main/index. … le-ice1712 on nous dit qu'il faut activer le module avec cette commande :

sudo modprobe snd-ice1712

Éditez le fichier /usr/share/alsa/cards/ICE1712.conf

gksu gedit /usr/share/alsa/cards/ICE1712.conf

Trouvez la section suivante :

<confdir:pcm/front.conf>

ICE1712.pcm.front.0 {
    @args [ CARD ]
    @args.CARD {
        type string
    }
    type route
    ttable.0.0 1
    ttable.1.1 1
    slave.pcm {
        type hw
        card $CARD
    }
}

Ajoutez ces 2 lignes à la fin de la section

    slave.format S32_LE
    slave.channels 4 

Elle doit ensuite ressembler à ça :

<confdir:pcm/front.conf>

ICE1712.pcm.front.0 {
    @args [ CARD ]
    @args.CARD {
        type string
    }
    type route
    ttable.0.0 1
    ttable.1.1 1
    slave.pcm {
        type hw
        card $CARD
    }
    slave.format S32_LE
    slave.channels 10
}

Éditez ou créez le fichier ~/.asounrc :

gedit ~/.asounrc
pcm.ice1712 {
  type hw
  card 0
}

ctl.ice1712 {
  type hw
  card 0
}

Dernière modification par _mx_ (Le 19/11/2010, à 18:51)

Hors ligne

#34 Le 03/01/2011, à 20:18

passe-partout

Re : Carte son M-Audio Delta 44

SAlut,
_MX_
tu en as fait beaucoup pour pas grand chose...
Chez moi depuis la 9.4 (et ça a fonctionné sous 9.10, 10.04 et 10.10) les simples modifs de /etc/pulse/default.pa et /usr/share/alsa/cards/ICE1712.conf suffisent à faire fonctionner la carte.
Bon comme je dois retrouver ce post pour retrouver toutes les manips à chaque fois, je suis en train de rédiger une page dans le wiki pour la configuration de cette carte.
Si ça tente du monde... (je le dégrossie en fichier texte chez moi et je le publierait après.
Je mettrais toutes les modifs qui m'ont permis de rerouter les signaux en sortie de la carte pour avoir du 5.1 fonctionnel, etc...

Hors ligne

#35 Le 04/01/2011, à 08:17

RegisBurin

Re : Carte son M-Audio Delta 44

passe-partout a écrit :

SAlut,
_MX_
tu en as fait beaucoup pour pas grand chose...
Chez moi depuis la 9.4 (et ça a fonctionné sous 9.10, 10.04 et 10.10) les simples modifs de /etc/pulse/default.pa et /usr/share/alsa/cards/ICE1712.conf suffisent à faire fonctionner la carte.
Bon comme je dois retrouver ce post pour retrouver toutes les manips à chaque fois, je suis en train de rédiger une page dans le wiki pour la configuration de cette carte.
Si ça tente du monde... (je le dégrossie en fichier texte chez moi et je le publierait après.
Je mettrais toutes les modifs qui m'ont permis de rerouter les signaux en sortie de la carte pour avoir du 5.1 fonctionnel, etc...

Yep, comme tu dis, ces 2 simples modifs suffisent (sur n'importe quelle distrib d'ailleurs et depuis un moment) à faire fonctionner la carte.

Je te suis dans l'élaboration de la page de doc si tu veux (relecture, correction, tests...). Je n'ai jamais pris le temps de m'y coller, mais j'en avais depuis longtemps l'intention wink

Bon courage, @+


Config (M-AUDIO Delta44/Wacom CTH661-Phone ZTE OpenC-FFOS2.1) | BabyBox[WIP]
Moi sur le web / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#36 Le 04/01/2011, à 09:38

_mx_

Re : Carte son M-Audio Delta 44

Et ben ça me fait super plaisir pour vous (sans rire), mais j'ai galéré un peu plus que ça :
Sans mettre hw:M44 et pas hw:0 dans /etc/pulse/default.pa, la carte était pas là en faisant "cat /proc/asound/modules" environ 9 fois sur 10 et donc pas de son.
Et sans éditer le fichier /etc/modprobe.d/alsa-base.conf, pas de carte non plus et donc pas de son.
J'ai même du nouveau depuis :
Sans mettre la carte intégré en troisième dans alsa-base.conf pareille, du son, pas de son... Alors même que ma carte intégré est désactivée dans le bios
Et même comme ça si je démarre avec le clavier midi usb allumé, et ben pas de carte, pas de son.
En rajoutant ceci j'ai plus aucun problèmes (dans /etc/modprobe.d/alsa-base.conf) j'ai du son à tous les démarrages :

# load usb keyboard second
alias snd-card-1 snd-usb-audio
options snd-usb-audio index=1

# load hda intel third
alias snd-card-2 snd-hda-intel
options snd-hda-intel index=2

# load driver ice1712 for M-Audio Delta 44
options snd-ice1712 index=0

Je suis sur ubuntu 10.10 64-bit.

Dernière modification par _mx_ (Le 04/01/2011, à 09:38)

Hors ligne

#37 Le 04/01/2011, à 10:13

RegisBurin

Re : Carte son M-Audio Delta 44

Salut _MX_

Etonnant ton bug, et d'autant plus qu'il est aléatoire !!??
Là, je ne sais pas... enfin si cette modif de alsa-base.conf corrige ton problème, c'est déjà ça, et j'en prend note (au cas où)

Par contre, je trouve ça super étonnant le hw:M44 à la place de hw:0... Que te renvoie...

aplay -l

?

Chez moi (sous Debian, mais je ne vois pas où il pourrait y avoir une différence avec Ubuntu...), hw:0 est bien le nom de la carte, renvoyé par la commande précédente...?

Mais bon, pour tout ça, j'ai fait mon "petit joueur" en désactivant le chipset intégré à la mobo (AC97) dans le bios, je n'ai d'ailleurs jamais réesayé de l'activer (ne me servant uniquement des I/O de la Delta44)... faudrait que je re-teste car ta dernière remarque offre une soluce intéresante que je ne connaissais pas (priorité du lancement des modules)...

@+ (et merci pour ces pistes)


Config (M-AUDIO Delta44/Wacom CTH661-Phone ZTE OpenC-FFOS2.1) | BabyBox[WIP]
Moi sur le web / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#38 Le 04/01/2011, à 10:18

_mx_

Re : Carte son M-Audio Delta 44

Voici ce que me renvoie "aplay -l"

**** Liste des PLAYBACK périphériques ****
carte  0: M44 [M Audio Delta 44], périphérique 0 : ICE1712 multi [ICE1712 multi]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0

Hors ligne

#39 Le 04/01/2011, à 17:04

passe-partout

Re : Carte son M-Audio Delta 44

En fait, ces deux lignes existent déja dans le fichier de pulse:

load-module module-alsa-sink device=hw:n
load-module module-alsa-source device=hw:n

il suffit de les décommenter.
Et de mettre la bonne valeur.
n= le numéro de la carte. Ordre donné par:

aplay -l

Par exemple, chez moi:
le résultat de cette commande est:

**** Liste des PLAYBACK périphériques ****
carte  0: NVidia [HDA NVidia], périphérique 3 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  0: NVidia [HDA NVidia], périphérique 7 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  0: NVidia [HDA NVidia], périphérique 8 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  0: NVidia [HDA NVidia], périphérique 9 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  2: M1010LT [M Audio Delta 1010LT], périphérique 0 : ICE1712 multi [ICE1712 multi]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0

Donc n=2

D'ailleur, c'est marrant, le module de la carte son intégré à la CM est chargé chez moi aussi, mais la carte est désactivée dans le bios.
Par contre, le truc tout bête pour lequel on peux se faire avoir, c'est les niveaux des DAC qui sont à zéro.

RegisBurin a écrit :

... faudrait que je re-teste car ta dernière remarque offre une soluce intéresante que je ne connaissais pas (priorité du lancement des modules)...

@+ (et merci pour ces pistes)

C'est clair, mais je ne sais pas si ça sert à grand chose, surtout si tu n'as pas d'autres cartes.
Et j'accepte volontier ton aide pour la page.
Je fignole le tout et je te ferais parvenir le fichier texte.

Dernière modification par passe-partout (Le 04/01/2011, à 17:17)

Hors ligne

#40 Le 04/01/2011, à 22:54

RegisBurin

Re : Carte son M-Audio Delta 44

"Bon sang de bois !!"... mais chez moi aussi en fait j'ai le même 'aplay -l' que _MX_

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: M44 [M Audio Delta 44], device 0: ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Sauf que le chipset de la CM (désactivé dans le bios chez moi) n'apparaît pas via 'aplay -l' contrairement à toi passe-partout (?!?)

passe-partout a écrit :

C'est clair, mais je ne sais pas si ça sert à grand chose, surtout si tu n'as pas d'autres cartes.

Non que je n'ai d'autre carte, mais que celle pré-existante est désactivée.

Enfin je pense néanmoins que ça peut avoir un intérêt d'utiliser la M-Audio + le chipset. Par exemple, ma delta44 n'a que 4 entrées/sorties mono en Jack 6.35 (contrairement à la tienne 1010Lt qui a tout un panel de connectiques au cul). Peu m'importe dans le sens où elle ne me sert que pour faire ou écouter de la zic (gratte, ou instru/source quelconque en entrée - 2 sorties vers l'ampli de salon ou de puissance, les 2 autres pour un casque). Mais imaginons que j'ai un home cinéma, ou au moins que je veuille utiliser la sortie spdif, ou la RCA pour le caisson de basse, ou n'importe laquelle des autres sorties d'origines sur le PC... le principe d'utiliser (activer) les 2 deviendrait intéressant => la M-Audio pour la MAO et la Hi-Fi, le chipset pour les films...

Ca vaut un test quand même... Dès que j'aurais 1 heure à tuer (pas évident... lol )

passe-partout a écrit :

Par contre, le truc tout bête pour lequel on peux se faire avoir, c'est les niveaux des DAC qui sont à zéro.

Ha... ça... c'est mon premier réflexe, quel que soit le PC, le chipset et la distro, un petit coup de vérif d'alsamixer avant toute chose ne fait jamais de mal wink

Alors par contre, en écrivant ces quelques lignes, je suis en train de revoir tous ces fichiers de conf, et je m'aperçois que mon /etc/modprobe.d/alsa-base.conf est totalement "originel"... je n'y ai même pas touché, et n'y ai fait aucune mention de ice1712, et pourtant tout roule...

$ cat /etc/modprobe.d/alsa-base.conf 
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Idem pour /usr/share/alsa/cards/ICE1712.conf

Quant à /etc/pulse/default.pa... il n'existe même pas... J'ai bien un /etc/pulse/client.conf, mais totalement sans intérêt a priori car vierge de toute info...

cat /etc/pulse/client.conf 
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values a commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =

; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

Et je n'ai pas eu à créer ~/.asoundrc...

Autant sous "squeeze" (bureautique) que sous AVlinux (MAO)... Etonnant... Non ??

Alors c'est vrai que j'ai passé toute l'année dernière à tester différentes distros pour la MAO. Jusque là, j'avais une large préférence pour UbuntuStudio mais sur la 10.04 j'ai eu un problème d'installation de la tablette graphique, bref... Je m'étais habitué à modifier ces fichiers (et d'autres), mais je me suis finalement fixé sur Debian car tout y est bien reconnu/fonctionnel "out of the box" comme on dit. Je viens juste d'en prendre conscience !!

Alors de deux choses l'une... soit Debian n'a pas la même gestion du son que sa dérivée, soit j'ai un p*** de "deus in machina" qui m'a fait un genre de miracle électronique tongue

Là, pour le coup, je ne vois pas du tout où il pourrait y avoir de différence avec Ubuntu (?!?) Mais m'est avis que si je désire ré-activer le chipset, il va falloir que je remette les pattes dans tout ça, car mon "manque de soucis" doit venir du fait que le chipset était désactivé lors de l'installation (je ne vois que ça).

Bon, que dire pour conclure... Bah, je me sens moins apte à aider pour de la doc (techniquement j'entends, puisque je n'ai finalement aucun soucis, au contraire), à moins de réinstaller une Ubuntu juste pour des tests (Oulà, j'me connais, j'en suis cappable tongue ). Mais je t'invite quand même à créer une page, c'est très simple, tu te connectes avec ton login forum, tu cliques là => http://doc.ubuntu-fr.org/m-audio, tu cliques sur "créer" et c'est tipar'

Pis sinon, bah... migrez vers Debian les gars... lol (je déconne!)

Bonne soirée, dans le mystère le plus profond...
@+


Config (M-AUDIO Delta44/Wacom CTH661-Phone ZTE OpenC-FFOS2.1) | BabyBox[WIP]
Moi sur le web / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#41 Le 04/01/2011, à 23:20

david96

Re : Carte son M-Audio Delta 44

Pour Debian c'est fait, du moins sur mes deux serveurs dédiés et c'est clair que c'est calme, y'a pas de souci quoi, tout est easy tongue

Sinon, tu dis que tu étais sous Ubuntu Studio, la différence est dans le noyau (le fameux temps réel), jamais testé, car même sur une Ubuntu Desktop je n'ai pas de latence… Je n'ose imaginer smile

Dernière modification par david96 (Le 04/01/2011, à 23:22)

Hors ligne

#42 Le 05/01/2011, à 07:07

passe-partout

Re : Carte son M-Audio Delta 44

C'est vrai qu'à l'aube des derniers post, je me dis que peut-être les manips ne sont pas toujours les mêmes.
Faudrait voir si les personnes qui passent et qui utilisent les informations de ce post sont satisfait.

Hors ligne

#43 Le 07/01/2011, à 23:33

Bernardcyclo

Re : Carte son M-Audio Delta 44

Merci RegisBurin,

J'ai désactivé (dans le bios) le chipset AC97 intégré à la carte mère et enfin, le son est de retour sur mon Ubuntu 10.04!!!

Je dois vous dire que je commençais à me décourager.

Effectivement, passe-partout, dans mon cas j'ai fais plein de manip pour faire fonctionner ma delta 44 et je ne serais pas capable de me souvenire de tout ce que j'ai fait. Donc, vous tous qui semblez vous y retrouver dans toutes ses manipulations, ça serait génial si vous pouviez écrire un tuto pour les cartes M-Audio.
Moi, je m'y perds dans toutes vos explications mais, si je peux aider en vous envoyant la configuration de certains fichiers ou autre, je serais bien content de pouvoir aider mais, je suis nul en informatique.

Merci encore RegisBurin!!:D

Hors ligne

#44 Le 08/01/2011, à 00:01

david96

Re : Carte son M-Audio Delta 44

Bernardcyclo a écrit :

…Je dois vous dire que je commençais à me décourager. …

À bâ non faut pas ! Y'a toujours une solution wink

Hors ligne

#45 Le 21/01/2011, à 14:46

fredomart

Re : Carte son M-Audio Delta 44

Bonjour a tous. Moi j'ai une delta 44 qui fonctionne parfaitement sous ubuntu 10.10 64 bits, voila ce que j'ai fait si cela peut en aider certains (manip que j'ai réalisée maintes fois et qui fonctionne a chaque fois)
Avant toute choses ouvrir systeme,administration,utilisateurs et groupes,gerer les groupes et s'ajouter aux groupes adm, admin,audio, root, sudo, pulse et pulse acces.
Ensuite il faut modifier le fichier /usr/share/alsa/cards/ICE1712.conf
Copier ceci dans un terminal: gksu gedit /usr/share/alsa/cards/ICE1712.conf
Trouvez la section suivante :

<confdir:pcm/front.conf>

ICE1712.pcm.front.0 {
    @args [ CARD ]
    @args.CARD {
        type string
    }
    type route
    ttable.0.0 1
    ttable.1.1 1
    slave.pcm {
        type hw
        card $CARD
    }
}
Ajoutez ces 2 lignes à la fin de la section

slave.format S32_LE
    slave.channels 10

Elle doit ensuite ressembler à ça :

<confdir:pcm/front.conf>

ICE1712.pcm.front.0 {
    @args [ CARD ]
    @args.CARD {
        type string
    }
    type route
    ttable.0.0 1
    ttable.1.1 1
    slave.pcm {
        type hw
        card $CARD
    }
    slave.format S32_LE
    slave.channels 10
}
Ensuite dans un terminal:

sudo gedit /etc/modprobe.d/alsa-base.conf

Donc pour faire votre config c'est simple, commenter déjà toutes les lignes (rajouter devant les lignes un # comme ci dessous)

# Prevent abnormal drivers from grabbing index 0
#options bt87x index=-2
#options cx88_alsa index=-2
#options saa7134-alsa index=-2
#options snd-atiixp-modem index=-2
#options snd-intel8x0m index=-2
#options snd-via82xx-modem index=-2
#options snd-usb-audio index=-2
#options snd-usb-us122l index=-2
#options snd-usb-usx2y index=-2
#options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
#options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
#options snd-pcsp index=-2

Puis en dessous rajouter:

# My config
options snd-ice1712 index=0
options snd-hda-intel index=1
options snd-usb-audio index=2,3

Voila en principe votre carte est fonctionnelle,cliquez sur votre icone de son en haut a droite sur votre bureau,choisissez preferences du son,materiel, choisissez analog stereo outpout+digital stereo (iec958)input entree, choisissez ice1712, sortie, choisissez ice 1712.
Voila,ensuite lancez logitheque ubuntu recherchez envy24, installez le, cela va vous permettre de configurer votre mixeur audio de la delta 44.
Bonne chance

Hors ligne

#46 Le 20/03/2012, à 10:22

guillaumekai

Re : Carte son M-Audio Delta 44

Au secours!
Possesseur d'une carte delta 44 je viens d'installer ubuntu 11.10. Le son ne fonctionnant pas, j'ai suivi les conseils de fredomart puis ceux de  _MX_
Je viens de suivre les diverses solutions proposées, et le son ne marche toujours pas, mais en prime je crois bien avoir foutu la zone dans les différentes commandes modifiées!!
Comment tout remettre comme c'était avant?
Comment faire fonctionner ma carte son?
Quelqu'un peut-il me donner un coup de main?
Merci

Hors ligne

#47 Le 20/03/2012, à 22:00

RegisBurin

Re : Carte son M-Audio Delta 44

guillaumekai a écrit :

Au secours!
Possesseur d'une carte delta 44 je viens d'installer ubuntu 11.10. Le son ne fonctionnant pas, j'ai suivi les conseils de fredomart puis ceux de  _MX_
Je viens de suivre les diverses solutions proposées, et le son ne marche toujours pas, mais en prime je crois bien avoir foutu la zone dans les différentes commandes modifiées!!
Comment tout remettre comme c'était avant?
Comment faire fonctionner ma carte son?
Quelqu'un peut-il me donner un coup de main?
Merci

Salut à toi

Aucune possibilité de diagnostiquer dans l'immédiat (pas assez d'info), mais quelques pistes primaires:
- Vérifier que la Delta est bien la carte par défaut. Pour ça, lance la commande suivante dans un terminal:

aplay -l

- Lancer alsamixer (dans un terminal toujours) et vérifier qu'aucune piste n'est "mutée" ([MM])
- Nous poster les contenus des fichiers /usr/share/alsa/cards/ICE1712.conf et /etc/modprobe.d/alsa-base.conf

Ma Delta est super bien reconnue "Out-of-the-Box" depuis quelques noyaux déjà et en ce moment même sous Oneiric (mais je triche, j'ai désactivé le chipset son de la carte mère dans le bios).

@+
Bon courage

Dernière modification par RegisBurin (Le 20/03/2012, à 22:01)


Config (M-AUDIO Delta44/Wacom CTH661-Phone ZTE OpenC-FFOS2.1) | BabyBox[WIP]
Moi sur le web / Moi, IRL mais sur le web / Ma maison sur le web

Hors ligne

#48 Le 21/03/2012, à 00:15

guillaumekai

Re : Carte son M-Audio Delta 44

Merci Régis pour cette réponse rapide!
Entre temps j'ai tout réinstallé!
et grâce à tes conseils, j'ai pu régler le problème qui étais seulement une question de niveau en faisant sudo alsamixer!
Super! et merci beaucoup!!!!

Hors ligne

#49 Le 21/03/2012, à 01:03

guillaumekai

Re : Carte son M-Audio Delta 44

Par contre, si je pouvais abuser de ta gentillesse, j'aimerais pouvoir utiliser ardour pour enregistrer... Sauf qu'il me dit que jack n'est pas bien configuré que faut-il faire?

Hors ligne