Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/02/2009, à 13:57

3rwan

wifi lent (intel wifi link 5100 / iwlagn) (RESOLU)

(sujet résolu: voir le dernier post)

Bonjour,
après deux semaines de recherches intensives sur les différents forum qui composent la toile, je me décide enfin à faire appel à vous.

Mon débit entrant tournait jusqu'ici autour de 500/600 kbps avec une clé USB wifi  D-Link, nouvel acquéreur d'un Netbook Keynux ayant une carte intel wifi link 5100 intégré, le débit entrant avec cette dernière ne dépasse plus les 60/70 kbps quelque-soit la qualité de réception.

A l'installation d'Ubuntu(hé oui j'ai commandé un PC sans OS chez Keynux lorsque j'aurais pue l'avoir livré avec ubuntu installé...quand on veut faire le malin...) la carte wifi a été reconnu sans problème, le seul dysfonctionnement en fait est ce débit limité.

Le pilote pour la wifi link 5100 est iwlagn
Le point d'accès est une borne inventel fourni par wanadoo(à l'époque).
Nous ne sommes que deux connecter en wifi à cette borne, moi et un macbook.

*A savoir que la connection marche correctement lorsque j'utilise la clé USB wifi D-Link.

WIcd ne résout rien,
changer le bit-rat non plus,

Merci à tous pour l'attention que vous porterez à mon problème.

Dernière modification par 3rwan (Le 05/02/2009, à 13:46)

Hors ligne

#2 Le 02/02/2009, à 00:09

3rwan

Re : wifi lent (intel wifi link 5100 / iwlagn) (RESOLU)

j'ajoute, après test, que la connections via le fichier interfaces me donne une connection de meilleur qualité et me permet d'atteindre les 100kbps inaténiable via wicd ou nm. etrange. quoiqu'il en soit, la vitesse est toujours bridé.

Hors ligne

#3 Le 02/02/2009, à 22:02

3rwan

Re : wifi lent (intel wifi link 5100 / iwlagn) (RESOLU)

en comparant les iwconfig de la carte intel wfi link 5100(celle qui fonctionne mal) et de la D-link, j'ai remarqué deux choses:(wlan0 est la 5100)

wlan0     IEEE 802.11abgn  ESSID:"DW-B-200-19b1a"  #abgn?
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:90:4B:62:31:79   
          Bit Rate=11 Mb/s   Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality=15/100  Signal level:-83 dBm  Noise level=-89 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan1     IEEE 802.11bg  ESSID:"DW-B-200-19b1a"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:90:4B:62:31:79   
          Bit Rate=11 Mb/s   Tx-Power=9 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality=67/100  Signal level:-78 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

IEEE 802.11abgn pour wlan0 et IEEE 802.11bg pour wlan1,

j'ai bien fait quelque recherche, mais sans succes. Si quelqu'un pouvait expliquer ce que "abgn" signifie s'rait sympa alors.

Dernière modification par 3rwan (Le 02/02/2009, à 22:10)

Hors ligne

#4 Le 05/02/2009, à 13:57

3rwan

Re : wifi lent (intel wifi link 5100 / iwlagn) (RESOLU)

probleme résolu:
le probleme vient du driver iwlagn qui est intégré au kernel depuis le 2.6.24. il fallai donc recompiler tout un kernel pour avoir la derniere version de ces drivers.
heureusement un paquet contenant plusieurs drivers dont iwlagn est disponibleici. pour l'installer il suffit de suivre les instructions, soit(dans l'archive décomprésser):

make
sudo make install
sudo make unload        #décharge les drivers chargés
sudo modprobe iwlagn  #charge le nouveau iwlagn

et ça fonctionne, même apres redémarrage.
bye.

Dernière modification par 3rwan (Le 05/02/2009, à 14:04)

Hors ligne