Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#101 Le 19/02/2010, à 19:54

Hizoka

Re : [RESOLU] Ralentissement avec les pilotes ATI

j'ai lancé amdcccle et j'ai tout foutu à fond.

Hors ligne

#102 Le 20/02/2010, à 10:09

Lifesaver

Re : [RESOLU] Ralentissement avec les pilotes ATI

TNZ a écrit :

Bon ben essai des 10.2 : ça me bloque l'écran d'entrée en session. J'ai testé avec et sans le patch NoBackFill. J'suis redescendu en 10.1

PS : Le problème de redimensionnement des fenêtres n'est pas du tout réglé dans la version 10.1 sad

Tout pareil.
Je suis donc revenu au 10.1
Ce qui serait bien, c'est un tuto qui explique comment installer une nouvelle version de catalyst sans avoir de problèmes avec le Kernel.
Donc, en plus d'avoir la méthode d'installation de catalyst, il serait bon aussi de savoir ce qu'on doit faire avec son kernel.

Merci !


Kubuntu LTS partout partout partout !

Hors ligne

#103 Le 20/02/2010, à 15:16

Laonics

Re : [RESOLU] Ralentissement avec les pilotes ATI

Personnellement je suis encore avec le driver 9.11 car j'ai des bugs avec catalyst et ma TV HDMI sans parler de GDM. Alors j'utilise toujours le NoBackFill + 9.11. En fait, j'ai deux écrans : un VGA, l'autre TV HDMI que je désactive toujours sous linux (je ne l'active que sous Windows quand je veux regarder un blue-ray). Bref certains driver entre le 9.12 et le 10.2, catalyst refuse après redémarrage de l'ordinateur de garder mes paramètres d'affichage et surtout la désactivation de l'écran HDMI. Et bien sûr avec GDM soit j'ai une résolution trop grosse sur mon écran VGA, soit l'écran est décentré (résolution trop grande) pourtant dans catalyst mon écran HDMI est désactivé après redémarrage. Je ne comprends ces comportements qu'il semble parfaitement aléatoire. Et bien entendu avec le 9.11, je fixe après installation et j'ai plus de bug. Après je ne sais pas si ça vient du fait que j'utilise encore le NoBackFill avec les versions supérieures.
J'espère être assez clair.

PS: quelqu'un peut dire comment enlever le NoBackFill sans réinstaller linux (j'avais pensé à enlever le dépôt et à faire un --reinstall xorg) ?

Dernière modification par Laonics (Le 20/02/2010, à 15:18)

Hors ligne

#104 Le 21/02/2010, à 11:27

Lifesaver

Re : [RESOLU] Ralentissement avec les pilotes ATI

Qu'est-ce le NoBackFill ?


Kubuntu LTS partout partout partout !

Hors ligne

#105 Le 21/02/2010, à 14:00

petifrancais

Re : [RESOLU] Ralentissement avec les pilotes ATI

Bon, moi j'ai ces ralentissements de quelques secondes avec une hd 5850 + les catalyst 10.2 sous karmic... Vous avez une solution ? hmm


Kubuntu 12.10 - KDE 4.9.5
Venez nous rejoindre sur le serveur minecraft zcraft.fr : http://forum.zcraft.fr/index.php

Hors ligne

#106 Le 21/02/2010, à 15:51

sergei_ruskof

Re : [RESOLU] Ralentissement avec les pilotes ATI

salut

ouai la solution c'est de lire le post et de trouver la partie ou il parle du patch pour karmic et ensuite de l'appliquer

Hors ligne

#107 Le 21/02/2010, à 17:28

uboops

Re : [RESOLU] Ralentissement avec les pilotes ATI

Merci pour ce post:
http://forum.ubuntu-fr.org/viewtopic.php?pid=3009691#p3009691
Sous Jaunty, je suis passé de la version 10.1 à la version 10.2 avec ce tuto et ce qui m'étonne c'est que j'ai quasi doublé ne nombre de frames par secondes GPU apparemment !

avec v10.1
User1@PC1:~$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV730XT [Radeon HD 4670]
User1@PC1:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
8661 frames in 5.0 seconds = 1732.200 FPS
8755 frames in 5.0 seconds = 1751.000 FPS
8440 frames in 5.0 seconds = 1688.000 FPS
avec 10.2
Using GLX_SGIX_pbuffer
14589 frames in 5.0 seconds = 2917.800 FPS
15150 frames in 5.0 seconds = 3030.000 FPS
15074 frames in 5.0 seconds = 3014.800 FPS

...
OU

  b)Installer la dernière version du pilote (recommandé)
  1. Télécharger les derniers pilotes sur le site d'ATI içi http://support.amd.com/us/gpudownload/Pages/index.aspx

  2. Faites un clic droit sur le pilote puis propriété. Dans l'onglet permission cochez la case qui permet l'exécution.

  3. Faites: Applications/Accessoires/Terminal

  4. Tapez sudo (ou sudo sh) dans le terminal, faites une espace et glissez l'icône du fichier .run sur la fenêtre du terminal. Puis, faites Entrée sur votre clavier. Cela aura pour effet de lancer le .run en mode administrateur.

  5. Entrez votre mot de passe à l'aveuglette lorsque demandé et faites Entrée sur le clavier.

  6. Patientez pendant que l'utilitaire d'installation AMD Catalyst s'initialise. Après un certain temps, une fenêtre s'ouvre.

  7. Sélectionnez : Install Driver [numéro de release] on X.org 7.4 et faites Continue.

  8. Lisez la licence et faites I Agree (à moins que vous soyez contre).

  9. Sélectionnez automatic et cliquez sur Continue.

  11. Le pilote s'installera tout seul comme un grand.

  12. Lorsque l'installation sera terminée et que la fenêtre se sera fermée, entrez cette commande dans le terminal pour configurez votre fichier xorg.conf:

Code:

sudo aticonfig --initial -f

13. Redémarrez votre ordinateur
Note: cette méthode est extraite de la doc.

Après je ne sais pas si il y aura (enfin) une correction directement via les dépôts normaux mais en attendant ça marche bien comme ça.

Autre truc: est ce qu'on met ça dans le wiki?

Désinstallation du pilote ATI Proprietary Linux Graphics
# Lancez l'application Terminal / fenêtre et allez dans le répertoire / usr / share / ati dossier.
# With super user permissions, enter the command "sh ./fglrx-uninstall.sh" Avec des autorisations de super-utilisateur, entrez la commande "sh. / Fglrx-uninstall.sh"

Dernière modification par uboops (Le 22/02/2010, à 16:35)


“Au lieu de faire que ce qui fût juste fût fort, on a fait que ce qui fût fort fût juste.” (Blaise Pascal).

Hors ligne

#108 Le 21/02/2010, à 17:35

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'avais repris le tuto de la doc. Donc on peut dire MERCI la communautéééé. big_smile

Dernière modification par pipocas (Le 21/02/2010, à 21:58)

Hors ligne

#109 Le 21/02/2010, à 21:53

petifrancais

Re : [RESOLU] Ralentissement avec les pilotes ATI

sergei_ruskof a écrit :

salut

ouai la solution c'est de lire le post et de trouver la partie ou il parle du patch pour karmic et ensuite de l'appliquer

Le patch ? Je trouve juste la méthode pour installer les catalyst du site d'AMD (ce que j'ai fais) de façon automatique mais pas de patch. hmm
Il est bien dans ce topic ?


Kubuntu 12.10 - KDE 4.9.5
Venez nous rejoindre sur le serveur minecraft zcraft.fr : http://forum.zcraft.fr/index.php

Hors ligne

#110 Le 21/02/2010, à 21:57

pipocas

Re : [RESOLU] Ralentissement avec les pilotes ATI

Pour Karmic regarde là: http://forum.ubuntu-fr.org/viewtopic.ph … 1#p3009691
Étapes 1, 2 et 3.

Hors ligne

#111 Le 21/02/2010, à 22:02

petifrancais

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'espère que ça marche avec une HD 5850... Et que jockey-kde ne plantera pas comme quand j'avais tenté d'activer les pilotes proprio la dernières fois. big_smile
Merci, je reviens dire tout à l'heure si ça a marché.

EDIT : AH !!... Désolé je n'avais pas capté qu'il fallait dans tous les cas ajouter les dépôts.^^' big_smile

EDIT2 : Ca marche !! Bien content que les fenêtres ne mette plus 3 plombe à se redimensionner !
Par contre, le défilement avec Firefox est toujours aussi... Lent. sad

Dernière modification par petifrancais (Le 21/02/2010, à 22:16)


Kubuntu 12.10 - KDE 4.9.5
Venez nous rejoindre sur le serveur minecraft zcraft.fr : http://forum.zcraft.fr/index.php

Hors ligne

#112 Le 21/02/2010, à 23:43

Lifesaver

Re : [RESOLU] Ralentissement avec les pilotes ATI

petifrancais a écrit :

J'espère que ça marche avec une HD 5850... Et que jockey-kde ne plantera pas comme quand j'avais tenté d'activer les pilotes proprio la dernières fois. big_smile
Merci, je reviens dire tout à l'heure si ça a marché.

EDIT : AH !!... Désolé je n'avais pas capté qu'il fallait dans tous les cas ajouter les dépôts.^^' big_smile

EDIT2 : Ca marche !! Bien content que les fenêtres ne mette plus 3 plombe à se redimensionner !
Par contre, le défilement avec Firefox est toujours aussi... Lent. sad

Donc toi tu n'as pas de problèmes avec les drivers 10.2 sous Kubuntu Karmic 64 ?
J'ai mon écran qui se bloque à l'ouverture de session (après affichage du symbole disque dur)
Donc je suis redescendu à la v10.1


Kubuntu LTS partout partout partout !

Hors ligne

#113 Le 22/02/2010, à 12:39

TNZ

Re : [RESOLU] Ralentissement avec les pilotes ATI

Laonics a écrit :

Personnellement je suis encore avec le driver 9.11 car j'ai des bugs avec catalyst et ma TV HDMI sans parler de GDM. Alors j'utilise toujours le NoBackFill + 9.11. En fait, j'ai deux écrans : un VGA, l'autre TV HDMI que je désactive toujours sous linux (je ne l'active que sous Windows quand je veux regarder un blue-ray). Bref certains driver entre le 9.12 et le 10.2, catalyst refuse après redémarrage de l'ordinateur de garder mes paramètres d'affichage et surtout la désactivation de l'écran HDMI. Et bien sûr avec GDM soit j'ai une résolution trop grosse sur mon écran VGA, soit l'écran est décentré (résolution trop grande) pourtant dans catalyst mon écran HDMI est désactivé après redémarrage. Je ne comprends ces comportements qu'il semble parfaitement aléatoire. Et bien entendu avec le 9.11, je fixe après installation et j'ai plus de bug. Après je ne sais pas si ça vient du fait que j'utilise encore le NoBackFill avec les versions supérieures.
J'espère être assez clair.

PS: quelqu'un peut dire comment enlever le NoBackFill sans réinstaller linux (j'avais pensé à enlever le dépôt et à faire un --reinstall xorg) ?

Le plus simple est d'utiliser synaptic.

Au niveau des dépôts, tu décoches le dépôt qui fournit les 2 paquets patchés.

Puis ensuite, tu recherches les paquets installés avec comme mot-clé xserver, tu tries par paquets installés et tu dois pouvoir retrouver les 2 paquets (xserver-core et xserver-common ... à peu près et de tête).

Puis tu sélectionnes le 1er, et en fouillant dans les menus, tu forces la version à " gnagna version (Karmic-update)", puis tu recommences avec le 2nd paquet.

Et enfin, tu appliques les modifications (bouton appliquer) ... et tu rebootes. smile


L'engin : Msi 990FXA-GD65 , FX8350, 16 Go ddr3-1866, Radeon HD7970
Les softs : Kubuntu64 14.04 LTS & 15.10

Hors ligne

#114 Le 22/02/2010, à 12:44

TNZ

Re : [RESOLU] Ralentissement avec les pilotes ATI

Hizoka a écrit :

j'ai lancé amdcccle et j'ai tout foutu à fond.

Mouaif ... j'ai essayé ça vendredi soir avec les 10.1, mais sans succès.

Ceci dit il faudrait que je me fasse un aticonfig --initial -f (pas fait depuis l'installation de karmic) big_smile


L'engin : Msi 990FXA-GD65 , FX8350, 16 Go ddr3-1866, Radeon HD7970
Les softs : Kubuntu64 14.04 LTS & 15.10

Hors ligne

#115 Le 22/02/2010, à 21:00

petifrancais

Re : [RESOLU] Ralentissement avec les pilotes ATI

Lifesaver a écrit :
petifrancais a écrit :

J'espère que ça marche avec une HD 5850... Et que jockey-kde ne plantera pas comme quand j'avais tenté d'activer les pilotes proprio la dernières fois. big_smile
Merci, je reviens dire tout à l'heure si ça a marché.

EDIT : AH !!... Désolé je n'avais pas capté qu'il fallait dans tous les cas ajouter les dépôts.^^' big_smile

EDIT2 : Ca marche !! Bien content que les fenêtres ne mette plus 3 plombe à se redimensionner !
Par contre, le défilement avec Firefox est toujours aussi... Lent. sad

Donc toi tu n'as pas de problèmes avec les drivers 10.2 sous Kubuntu Karmic 64 ?
J'ai mon écran qui se bloque à l'ouverture de session (après affichage du symbole disque dur)
Donc je suis redescendu à la v10.1

Je n'ai plus tenté de SE 64bit depuis mes débuts sous linux (il y a 3 ans), trop peur de retomber dans les problèmes de compatibilité... tongue

Après non, aucun problème particulier en 32 bits, si ce n'est des pilotes avec des performances moisies. mad


Kubuntu 12.10 - KDE 4.9.5
Venez nous rejoindre sur le serveur minecraft zcraft.fr : http://forum.zcraft.fr/index.php

Hors ligne

#116 Le 22/02/2010, à 22:14

Lifesaver

Re : [RESOLU] Ralentissement avec les pilotes ATI

TNZ a écrit :

Bon ben essai des 10.2 : ça me bloque l'écran d'entrée en session. J'ai testé avec et sans le patch NoBackFill. J'suis redescendu en 10.1

PS : Le problème de redimensionnement des fenêtres n'est pas du tout réglé dans la version 10.1 sad

As-tu résolu ton problème avec le 10.2 ?


Kubuntu LTS partout partout partout !

Hors ligne

#117 Le 23/02/2010, à 00:20

TNZ

Re : [RESOLU] Ralentissement avec les pilotes ATI

Toujours pas, même avec un "aticonfig --initial -f" ... marche pas hmm

En plus en activant les options du CCC, plus moyen de démarrer les effets 3D (anti-crénelage, filtre anisotrope,  tout ça). Donc 10.1 brutes d'installation et je pense que j'vais remettre le patch NoBackFill.


L'engin : Msi 990FXA-GD65 , FX8350, 16 Go ddr3-1866, Radeon HD7970
Les softs : Kubuntu64 14.04 LTS & 15.10

Hors ligne

#118 Le 23/02/2010, à 01:14

Laonics

Re : [RESOLU] Ralentissement avec les pilotes ATI

J'ai une HD 4870 et je rappelle que j'ai deux écrans VGA et TV HDMI. Donc j'ai essayé sans le NoBackFill avec les drivers 10.1 et 10.2 et il y a toujours un ralentissement. De plus, j'ai de nouveau essayé avec le NoBackFill avec le 10.2 mais j'ai un problème déjà comme je l'avais déjà dit de résolution de GDM. De plus, CCC ne veut pas se lancer en console ou non avec un sudo/gksu ou pas. Voici l'erreur que j'ai si ça di quelque chose à quelqu'un :

sudo amdcccle
ASSERT: "!isEmpty()" in file /app/workarea/dk/lnx/qt/4.5.2-shared-64a-gui/include/QtCore/qlist.h, line 252
Abandon

Sans parler du fait que Compiz se coupe juste après avoir essayer de lancer CCC.
En plus je constate qu'avec les nouveaux drivers, on n'est obligé de redémarrer pour que les paramètres soient pris en compte, ce qu'on était pas obligé de faire avant et ça je ne comprends pas pourquoi. Donc finalement je constate que les drivers ati ne s'améliorent pas et je trouve ça un peu affligeant. Par conséquent je continue à utiliser le driver 9.11, seulement qui fonctionne à merveille !
Si certains ont des idées sur ces problèmes...

PS: Merci à TNZ pour son astuce !

Dernière modification par Laonics (Le 23/02/2010, à 01:15)

Hors ligne

#119 Le 23/02/2010, à 10:03

Lifesaver

Re : [RESOLU] Ralentissement avec les pilotes ATI

Et c'est quoi ce patch NoBackFill ?


Kubuntu LTS partout partout partout !

Hors ligne

#120 Le 23/02/2010, à 13:31

TNZ

Re : [RESOLU] Ralentissement avec les pilotes ATI

C'est un patch appliqués dans 2 paquets Xorg qui font que la mémoire vidéo n'est plus initialisée par défaut. Cela se traduit par des zones d'affichage toutes crados (genre neige de TV cathodique/stries etc ...) pendant quelques centièmes de secondes avant affichage de la fenêtre.

Son principal intérêt est de supprimer les lenteurs/saccades lors des redimensionnement des fenêtres et ça apporte aussi un peu plus de FPS à Kwin/Compiz smile


L'engin : Msi 990FXA-GD65 , FX8350, 16 Go ddr3-1866, Radeon HD7970
Les softs : Kubuntu64 14.04 LTS & 15.10

Hors ligne

#121 Le 23/02/2010, à 16:42

Leyna

Re : [RESOLU] Ralentissement avec les pilotes ATI

Pour info j'ai une Radeon Mobility HD2600, elle est relativement bien supportée par les pilotes par défaut (3D mais ralentissement des fenêtres).
La méthode de ce sujet (avec 10.2) a enfin supprimé le ralentissement, c'est super! Je tenais à remercier ceux qui nous font partager leurs solutions miracle.

Au fait je suis sous Linux Mint 8, ce qui équivaut à Karmic.

Hors ligne

#122 Le 23/02/2010, à 20:09

joko

Re : [RESOLU] Ralentissement avec les pilotes ATI

Bonsoir,
suis sous ubuntu 9.10.
Ordi : Tour (connexion filaire) avec une carte ATI 9600 (128mo-agp) et j'ai l'impression que la carte n'est pas vue car :

1- utilisation inkscape >80% cpu (2% sur mon ordi portable).

2- recordmydesktop super lent à capturer.

3- video flash très lente (assez rapide sur le portable qui est en wifi).
j'avais essayé d'installé les pilotes par synaptic mais cata (affichage grossier)  et impossible avoir effets 3D.

J'espère que vous pourrez me guider. D'avance merci.

Dernière modification par joko (Le 23/02/2010, à 20:11)


Je suis un homme, quoi de plus naturel en somme ?
linux on the rocks

Hors ligne

#123 Le 23/02/2010, à 20:17

uboops

Re : [RESOLU] Ralentissement avec les pilotes ATI

==>joko
Bonsoir,
Et ces commandes la donnent quoi ?

glxgears
fgl_glxgears

Dernière modification par uboops (Le 23/02/2010, à 20:17)


“Au lieu de faire que ce qui fût juste fût fort, on a fait que ce qui fût fort fût juste.” (Blaise Pascal).

Hors ligne

#124 Le 23/02/2010, à 20:59

joko

Re : [RESOLU] Ralentissement avec les pilotes ATI

@ uboops
glxgears (j'ai 3 rouages qui s'engrennent)

2969 frames in 5.0 seconds
3639 frames in 5.0 seconds
2969 frames in 5.0 seconds
2886 frames in 5.0 seconds

fgl_glxgears

Le programme « fgl_glxgears » n'est pas installé.  Vous pouvez l'installer en tapant :
sudo apt-get install xorg-driver-fglrx
fgl_glxgears: command not found

merci de te pencher sur mon pb.

Dernière modification par joko (Le 23/02/2010, à 21:00)


Je suis un homme, quoi de plus naturel en somme ?
linux on the rocks

Hors ligne

#125 Le 23/02/2010, à 22:31

uboops

Re : [RESOLU] Ralentissement avec les pilotes ATI

Tu peux essayer d'installer le driver v10.2 d'ati spécifique à ta carte ( apparemment  linux 86 - All in wonder - serie 9600)
pour vérifier ta GPU:

lspci | grep VGA

Avant, dans Systeme\Admin\pilotes de périphériques : désactiver le Pilote d'accélération graphique 3D pour les cartes ATI.

Voir post numéro 107 plus haut pour la procédure d'installation manuelle.
Liens téléchargement:
http://support.amd.com/us/gpudownload/Pages/index.aspx
http://support.amd.com/us/gpudownload/l … ng=English
...Puis refait des tests

Dernière modification par uboops (Le 23/02/2010, à 22:39)


“Au lieu de faire que ce qui fût juste fût fort, on a fait que ce qui fût fort fût juste.” (Blaise Pascal).

Hors ligne