Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 23/05/2010, à 17:46

elkasimi2010

Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

bonjour,
voila tout st dans le titre
je veux bien une procédure pour configurer mon modem inwi (Maroc) pour je me connecte sous ubuntu 10.4 lts lucid

je suis nouveau sur le monde d'Ubuntu(presque un mois).

et merci d'avance big_smile

Dernière modification par elkasimi2010 (Le 29/05/2010, à 15:00)

Hors ligne

#2 Le 23/05/2010, à 19:15

G-Second

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

Salut
Installe ces paquets dans l'ordre wvdial usb-modeswitch-data usb-modeswitch puis télecharge et installe ce paquet : http://sourceforge.net/projects/lg-evdo-reva-us/

Branche le modem, ouvre un terminal et tape :

sudo wvdial

Entre ton mot de passe et te voilà connecté

Et Bienvenue sur Ubuntu big_smile

Hors ligne

#3 Le 23/05/2010, à 21:04

elkasimi2010

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

J'ai installé les paquets wvdial usb-modeswitch-data  usb-modeswitch
dans cet ordre :
+usb-modeswitch-data
+usb-modeswitch
+wvdial

pour le paquet venant de :
http://sourceforge.net/projects/lg-evdo-reva-us/
je me suis positionné dans le répertoire  inwi-usbmodem/ qui contient un fichier makefile j'ai exécuté la commande "make install"

je crois que c'est comme ça qu'on installe le paquet, n'est ce pas?

mais ça pas marché sad

je te présente la sortie de mon terminal et le fichier /etc/wvdial.conf

terminal:

elkasimi@elkasimi-desktop:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 025: ID 1004:607f LG Electronics, Inc. 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 15d9:0a4c Dexon 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
elkasimi@elkasimi-desktop:~$ sudo wvdal
[sudo] password for elkasimi: 
sudo: wvdal: command not found
elkasimi@elkasimi-desktop:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: AT
--> Sending: ATQ0
--> Re-Sending: AT
--> Modem not responding.
elkasimi@elkasimi-desktop:~$

fichier wvdial.conf

# Dialer configuration for LG EVDO Rev.A USB Modem
# Installed by package lg-evdo-reva-usbmodem
#
[Dialer Defaults]
Init1 = AT
Init2 = ATE0V1&D2&C1S0=0
Modem Type = LG EVDO Rev.A USB Modem
ISDN = 0
Phone = #777
Carrier Check = no
New PPPD = yes
Modem = /dev/tty0
Username = wana
Password = wana
Baud = 408600

c'est quoi le problème svp?

merci pour vos conseils big_smile

Hors ligne

#4 Le 23/05/2010, à 23:06

G-Second

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

Pour inwi-usbmodem il s'agit d'un .deb donc pour l'installer il faut juste double cliquer dessus je ne vois pas l'interet du make install.
Sinon après installation redemarre ton pc et lance : sudo wvdial

Si ça ne marche pas n'hesite pas à le signaler

Hors ligne

#5 Le 24/05/2010, à 02:51

elkasimi2010

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

salut,
j'ai installé le pilote en double cliquant sur le .deb
ça pas marché encore roll
même en redémarrant sad

voici la sortie de mon terminal:

elkasimi@elkasimi-desktop:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 1004:6114 LG Electronics, Inc. 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 15d9:0a4c Dexon 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
elkasimi@elkasimi-desktop:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Initializing modem.
--> Sending: AT
--> Sending: ATQ0
--> Re-Sending: AT
--> Modem not responding.
elkasimi@elkasimi-desktop:~$

voici mon fichier /etc/wvdial.conf

# Dialer configuration for LG EVDO Rev.A USB Modem
# Installed by package inwi-usbmodem
#
[Dialer Defaults]
Modem Type = LG EVDO Rev.A USB Modem
Modem = /dev/ttyS0
Baud = 9600 
ISDN = 0
Init1 = AT
Init2 = ATE0V1&D2&C1S0=0
Init3 = ATS7=60
Init4 = ATS0=0
Phone = #777
Carrier Check = no
New PPPD = yes
Username = wana
Password = wana

mais ça marche pas encore !
j'ai installé ubuntu lucid depuis un CD et j'ai pas fait de mise à jour(car je n'arrive pas à me connecter smile)

j'ai installé gnome-ppp (faut il que je le désinstalle?)et j'ai testé de me connecter avec Network Manager mais ça pas marché.

merci pour votre suivi G-Second wink
à bientôt

Dernière modification par elkasimi2010 (Le 24/05/2010, à 10:35)

Hors ligne

#6 Le 24/05/2010, à 10:59

G-Second

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

Dans ton fichier wvdial.conf remplace la ligne

Modem = /dev/ttyS0

par

Modem = /dev/ttyUSB0

Enregistre puis relance

sudo wvdial

Dernière modification par G-Second (Le 24/05/2010, à 11:01)

Hors ligne

#7 Le 24/05/2010, à 13:23

elkasimi2010

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

salut,
j'ai fait la modification dont tu m as proposé et voici le résultat:

elkasimi@elkasimi-desktop:/dev$ ls ttyUSB*
ttyUSB0  ttyUSB1  ttyUSB2  ttyUSB3  ttyUSB4  ttyUSB5
elkasimi@elkasimi-desktop:/dev$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 005: ID 1004:6114 LG Electronics, Inc. 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 15d9:0a4c Dexon 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
elkasimi@elkasimi-desktop:/dev$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.

j'ai raté quelque chose, non?
merci de votre long suivi big_smile

Hors ligne

#8 Le 24/05/2010, à 23:53

G-Second

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

Dans ton fichier wvdial.conf remplace

Modem = /dev/ttyUSB0

par

Modem = /dev/ttyUSB1

Enregistre , debranche le modem, rebranche, attend quelques secondes puis lance

sudo wvdial

Si tu obtiens quelque chose du genre :

--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
CONNECT
--> Carrier detected.  Waiting for prompt.
--> Don't know what to do!  Starting pppd and hoping for the best.
--> Starting pppd at Mon May 24 22:22:09 2010
--> Pid of pppd: 2739
--> Using interface ppp0
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> local  IP address 10.63.208.115
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> remote IP address 192.168.55.14
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> primary   DNS address 192.168.50.58
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]
--> secondary DNS address 192.168.50.55
--> pppd: ��[07][08]��[07][08]��[07][08]��[07][08]

Alors tu es connecté

Hors ligne

#9 Le 25/05/2010, à 01:28

elkasimi2010

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

merci beaucoup maintenant je suis connecté  big_smile

Hors ligne

#10 Le 25/05/2010, à 01:32

G-Second

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

Derien big_smile
Et ajoute un [résolu] dans le titre du topic en modifiant ton premier message

Hors ligne

#11 Le 26/09/2010, à 21:33

mechakiss

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

G-Second a écrit :

Derien big_smile
Et ajoute un [résolu] dans le titre du topic en modifiant ton premier message

salut les amis

j'ai le meme problème avec le modem de inwi HDM EC122 et j'arrive pas a lui trouver une solution

Terminal :

ubuntu@ubuntu:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: AT
AT
OK
--> Sending: ATE0V1&D2&C1S0=0
ATE0V1&D2&C1S0=0
OK
--> Sending: ATS7=60
OK
--> Sending: ATS0=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
^MODE: 2
^RSSILVL:40
^HRSSILVL:0
CONNECT
--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!}!} }9}"}&} } } } }#}%B#}%}%}&} c=d}'}"}(}"#.~
--> PPP negotiation detected.
--> Starting pppd at Sun Sep 26 19:01:35 2010
--> Pid of pppd: 3992
--> Using interface ppp0
--> pppd: [06][7f]
--> pppd: [06][7f]
--> pppd: [06][7f]
--> pppd: [06][7f]
--> pppd: [06][7f]
--> Disconnecting at Sun Sep 26 19:01:56 2010
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds

fichier wvdial.conf

# Dialer configuration for LG EVDO Rev.A USB Modem
# Installed by package inwi-usbmodem
#
[Dialer Defaults]
Modem Type = LG EVDO Rev.A USB Modem
Modem = /dev/ttyUSB0
Baud = 9600
ISDN = 0
Init1 = AT
Init2 = ATE0V1&D2&C1S0=0
Init3 = ATS7=60
Init4 = ATS0=0
Phone = #777
Carrier Check = no
New PPPD = yes
Username = wana
Password = wana

pour phone,Username et Password dois je utiliser mes propres infos ??

Hors ligne

#12 Le 28/01/2011, à 18:31

jasson133

Re : Modem inwi Hdm-2100 et ubuntu 10.4 lts[RESOLU]

salut tous le monde ,

j'ai testé votre méthode mais ça fonctionne pas de tout, sachant que j'ai la version d'ubuntu suivante:
root# cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

j'ai installé les packets suivants:

root# aptitude search usb-modeswitch
i   usb-modeswitch                                                         - mode switching tool for controlling "flip flop" USB devices                     
i A usb-modeswitch-data                                                    - mode switching data for usb-modeswitch 

root# aptitude search wvdial
i   wvdial                                                                 - PPP dialer with built-in intelligence

le problème c'est que le modem est monté a chaque fois comme un lecteure CDROM

root# dmesg

[   50.464058] usb 1-3: new high speed USB device using ehci_hcd and address 2
[   50.599414] usb 1-3: configuration #1 chosen from 1 choice
[   50.603577] usbserial_generic 1-3:1.0: generic converter detected
[   50.603656] usb 1-3: generic converter now attached to ttyUSB0
[  408.977858] usb 1-3: USB disconnect, address 2
[  408.978074] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[  408.978097] usbserial_generic 1-3:1.0: device disconnected
[  921.328086] usb 4-2: new full speed USB device using uhci_hcd and address 2
[  921.491969] usb 4-2: configuration #1 chosen from 1 choice
[  921.530962] Initializing USB Mass Storage driver...
[  921.531167] scsi2 : SCSI emulation for USB Mass Storage devices
[  921.531285] usbcore: registered new interface driver usb-storage
[  921.531289] USB Mass Storage support registered.
[  921.532871] usb-storage: device found at 2
[  921.532874] usb-storage: waiting for device to settle before scanning
[  926.529310] usb-storage: device scan complete
[  926.532297] scsi 2:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 0
[  926.561272] sr0: scsi-1 drive
[  926.561276] Uniform CD-ROM driver Revision: 3.20
[  926.561423] sr 2:0:0:0: Attached scsi CD-ROM sr0
[  926.562000] sr 2:0:0:0: Attached scsi generic sg1 type 5
[  929.490511] ISO 9660 Extensions: Microsoft Joliet Level 1
[  929.512518] ISOFS: changing to secondary root

root# lsusb
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 12d1:1446 Huawei Technologies Co., Ltd.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Hors ligne