Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 29/05/2006, à 20:38

esion

[résolu]Configurer memory_limit dans php.ini

Bonjour,
J'ai un petit soucis de mémoire sur un script php (celui-ci liste des mp3 dans mon /home).
J'essai alors d'augmenter la mémoire alouée aux scripts dans le php.ini sauf que j'en ai plusieurs :

$ find / -name php.ini
/etc/php4/apache/php.ini
/etc/php5/apache2/php.ini
/etc/php5/cgi/php.ini
/etc/php5/apache/php.ini
/etc/php5/cli/php.ini

Comment savoir quel php.ini est chargé?

Bien sûr je ne me suis pas arreté là, j'ai tenté de modifier plusieurs de ces fichiers mais rien y fait, je me retrouve toujours avec :

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 8557994 bytes)

J'ai aussi essayé de modifier l'allocation mémoire via php (une option de configuration le permettait), le message reste le même avec d'autres chiffres.

Pour information, je tente d'utiliser http://www.ampache.org

Merci.

Dernière modification par esion (Le 29/05/2006, à 22:11)


- ^ _______  ^ -

Hors ligne

#2 Le 29/05/2006, à 20:52

samyboy

Re : [résolu]Configurer memory_limit dans php.ini

<?php
phpinfo();
?>

cool


Jabber : sam@fritalk.com ||| Kikoo \o/ rofl ... asv ?
http://www.gnurou.org/Writing/SmartQuestionsFr

Hors ligne

#3 Le 29/05/2006, à 22:10

esion

Re : [résolu]Configurer memory_limit dans php.ini

ah bah oui en effet, il y a tellement d'infos dedans que je n'ai pas pris le temps de le décortiquer, merci.

Configuration File (php.ini) Path :	/etc/php5/apache2/php.ini
memory_limit	16M	16M

Bon néanmoins rien à faire, le script bloc toujours au même endroit même si je change ces valeurs.

Je vais voir du coté de ampache s'il y a une astuce, parcontre c'est étrange qu'il y ait ce bug. J'espère qu'il n'y a pas un soucis de config, j'ai pas mal merdé avant de pouvoir faire tourner lamp à peu près correctement.


- ^ _______  ^ -

Hors ligne

#4 Le 29/05/2006, à 22:45

samyboy

Re : [résolu]Configurer memory_limit dans php.ini

Tu peux modifier ces variables de configuration (memory_limit, etc) dans le script carrément. Ca t'éviteras de bidouiller les fichiers de config.

Je crois que c'est avec la fonction ini_set.

http://ch2.php.net/ini_set


Jabber : sam@fritalk.com ||| Kikoo \o/ rofl ... asv ?
http://www.gnurou.org/Writing/SmartQuestionsFr

Hors ligne

#5 Le 30/05/2006, à 00:03

esion

Re : [résolu]Configurer memory_limit dans php.ini

Yep, mais il y a déjà dans ampache l'option qui va bien pour le configurer smile
Il y a aussi la possibilité de passer par un .htaccess.

Et j'ai trouvé d'où le bug venait, j'avais quelques mp3 un peu foireux qui bloquaient le script.
(mais ça m'a permis d'aller jeter un oeil dans d'autres horizons big_smile )


- ^ _______  ^ -

Hors ligne