Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 09/11/2010, à 20:59

wbreen

Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Bonjour,
J'ai acheté une souris super jolie, mais une fois connecté, elle marche une fois sur 10 !!!
Marque CYBORG model R.A.T 5
Avez vous des infos ? Par miracle, y a t il une solution ?

Merci de votre aide !

RAT5

Dernière modification par wbreen (Le 09/11/2010, à 21:22)


Portable Asus G74SX-TZ105V -- 17,3", Intel® Core™ i7, 2630QM, 2 GHz, 8192 Mo, NVIDIA® GeForce™ GTX 560M, 1000 Go, Linux Ubuntu 15.10

Hors ligne

#2 Le 09/11/2010, à 21:46

wbreen

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Ça a l air de fonctionner avec ceci :
Sous UBUNTU 10.10

rajouter dans xorg.conf ceci :

Section "InputClass"
        Identifier "Mouse Remap"
        MatchProduct "Saitek Cyborg R.A.T.5 Mouse"
        MatchDevicePath "/dev/input/event*"
        Option "ButtonMapping" "1 2 3 4 5 6 7 2 9 10 11 12 0 0 0 16 17 18 19 20 21"
EndSection

puis

I simply put this in my .Xmodmap file in the user directory:

xinput --set-button-map "Saitek Cyborg R.A.T.5 Mouse" 1 2 3 4 5 6 7 8 9 10 11 12 0 0 0 16 17 18 19 20 21

Ça roule pour le moment !!!

Elle est tellement belle comme souris wink


Portable Asus G74SX-TZ105V -- 17,3", Intel® Core™ i7, 2630QM, 2 GHz, 8192 Mo, NVIDIA® GeForce™ GTX 560M, 1000 Go, Linux Ubuntu 15.10

Hors ligne

#3 Le 05/12/2010, à 19:28

Racc00n

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Merci pour le retour wbreen !
Confronté au même problème sous Pinguy OS 10.10, j'ai appliqué ta méthode et je n'ai plus de souci depuis.

Hors ligne

#4 Le 28/12/2010, à 15:40

kikinou07

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Petit re up de sujet , comment modifier le fichier en question ? smile

Hors ligne

#5 Le 28/12/2010, à 15:53

wbreen

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Voila ! je t'ai retrouvé ca !!
Donc tu crée le fichier xorg.conf dans /etc/ voila pourquoi tu ne le trouves pas wink
Regarde ci dessous !

I can confirm this works on a Saitek Cyborg R.A.T.5 Mouse.
Although the xinput tool had no effect, putting this in the xorg.conf did had effect.

I did the following on Ubuntu 10.10:
create a /etc/xorg.conf file with:
Section "InputClass"
        Identifier "Mouse Remap"
        MatchProduct "Saitek Cyborg R.A.T.5 Mouse"
        MatchDevicePath "/dev/input/event*"
        Option "ButtonMapping" "1 2 3 4 5 6 7 2 9 10 11 12 0 0 0 16 17 18 19 20 21"
EndSection
Restart X or reboot.

wink


Portable Asus G74SX-TZ105V -- 17,3", Intel® Core™ i7, 2630QM, 2 GHz, 8192 Mo, NVIDIA® GeForce™ GTX 560M, 1000 Go, Linux Ubuntu 15.10

Hors ligne

#6 Le 28/12/2010, à 19:22

kikinou07

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Merci a toi ! sa commencer a être l'enfer de pas pouvoir jouer correctement avec cette souris , j'etait mmême pret a la ramenner au magasin xD

Hors ligne

#7 Le 28/12/2010, à 19:35

Bookaire

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Salut wbreen,
Je tenais à te remercier pour la solution apportée grâce à toi ma nouvelle souris marche enfin correctement wink

Hors ligne

#8 Le 01/01/2011, à 18:08

kikinou07

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

malgrer la modif le bug persiste , j'ai tout fait , sa commence a sincérement me monter la moutarde au nez ...

Hors ligne

#9 Le 23/01/2011, à 20:49

Racc00n

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Bonjour,

Vous allez me dire que je cherche les problèmes (ce qui ne serait d'ailleurs pas faux), mais j'ai de nouveau un souci avec ma R.A.T 5.
Lorsque je l'ai installée pour la première fois, j'ai appliqué le correctif décrit par Wbreen avec succès.

*mais*, pour des raisons de place, j'utilise maintenant un switch kvm pour basculer clavier, écran et souris d'une machine à l'autre.

Or, depuis l'installation de ce kvm, ma souris et mon clavier sont reconnus comme un seul périphérique usb ! (Comme un ensemble clavier + souris sans fil Microsoft, pour etre exact), et les même problèmes qu'au tout début recommencent...

Débutant sous ubuntu, je ne suis pas très sûr de comprendre tous les rouages de la manip décrite par Wbreen, mais j'imagine que dans mon cas la section ajoutée dans le xorg.conf renvoit désormais vers un matériel qui est considéré comme n'étant pas là... Si mon raisonnement est exact, peut-être suffirait-il de modifier la ligne MatchProduct en y inscrivant le nom du matériel que mon switch kvm fait reconnaître à l'ordinateur en guise de souris ? Si c'est le cas, comment trouver ce nom exact ? J'ai déjà essayé de rentrer le nom donné par la commande lsusb mais cela ne change rien.

Je précise que les symptômes sont exactement les même qu'au tout début (souris reconnue pendant quelques minutes en début de session, puis perte du clic et du focus, le bouton de changement de mode rétablit la situation ponctuellement)

PS: J'ai fait quelques recherches autour du thème du KVM, mais les threads trouvés traitent plus généralement de problèmes de résolution d'écran...

D'avance merci à qui pourra m'aider...

Hors ligne

#10 Le 20/07/2011, à 01:48

Saor In Aisce

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Alors moi aussi j'ai un petit problème avec cette souris, j'ai la version 3.
Elle fonctionne grâce à ceci : http://ubuntuforums.org/showthread.php?t=1698482

Mais je la trouve malgrés tout très lente par rapport à d'autres souris reconnus nativement, est-ce normale ?
Et mes boutons "retour/suivant" ne fonctionne, comment faire pour les faire marcher ?

Cordialement


Si la mort a mordu le coeur de cette noble dame, il ne restera que poussière de son pauvre corps.
Si mors a mors
En roue libre !

Hors ligne

#11 Le 06/04/2012, à 09:15

undeadie

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Bonjour,

après avoir essayer un peu tout ce que j'ai trouvé pour faire marcher ma zolie souris, je viens ici demander de l'aide ^^
J'ai trouvé 2 versions pour installer correctement la souris : modifier le fichier Xconf dans X11 ou dans ETC.
J'ai essayé dans etc, visiblement ca marche pas, mais je peux pas modifier celui dans X11 car je n'ai pas l'autorisation apparement, il veut pas sauvegarder les modifications.

Une idée de comment gérer ca ?
Merci

Edit : en fait j'ai réussi, j'ai modifier les droits sur le fichier xconf dans le dossier x11 ><

Dernière modification par undeadie (Le 11/04/2012, à 08:36)

Hors ligne

#12 Le 23/10/2012, à 17:55

STKRudy85

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

wbreen a écrit :

Donc tu crée le fichier xorg.conf dans /etc/ voila pourquoi tu ne le trouves pas

/etc/X11/xorg , je pense, je teste cette solution, je viendrais la valider, après quelques jours d'utilisation.

Merci à vous smile


Supertuxkart à besoin de graphiste 2D et surtout 3D, et encore + Soyez les bienvenus
Version 0.7.4 en cours

Hors ligne

#13 Le 25/10/2012, à 20:40

STKRudy85

Re : Problème avec ma Souris Cyborg R.A.T 5 une fois connecté déconne !

Bien, chez moi, ça ne marche pas, je suis obligé de redémarrer ma session pour profiter de ma souris


Supertuxkart à besoin de graphiste 2D et surtout 3D, et encore + Soyez les bienvenus
Version 0.7.4 en cours

Hors ligne