Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/05/2005, à 16:34

qstone

Samba, UTF8 et accents

J'ai une machine sur le réseau de ma boite qui tourne sous Hoary (la machine, pas le réseau...)
J'essaie de l'intégrer le mieux possible à l'environnement de boulot (login via le domaine NT, messagerie, etc.)
Un des point bloquants, c'est que je n'arrive pas à faire afficher correctement les noms de fichiers avec des accents sur les disques réseau montés via Samba. J'ai des "?" à la place des accents et des "(invalid encoding)" à la fin.
-Les fichiers sont sur un partage SMB sur une machine NT (en NTFS), utilisé par plein de monde, donc pas question de réencoder les noms de fichiers avec l'outil de conversion (j'vais me faire lyncher...)
-Les partages sont montés dans le fstab, système de fichier smbfs, pas d'options d'encodage (j'ai aussi essayé avec iocharset=iso8859-15, nls=iso8859-15,iocharset=utf8, nls=utf8, mais ça va pas mieux)
-Samba est configuré avec "dos charset=iso8859-15", "unix charset=utf8", et "display charset=utf8"
-ma locale est fr_FR.UTF8, et tant que je reste sur mon PC, pas de problèmes d'accents.

Quelqu'un aurait une idée sur comment monter une partition via SMB, en voyant correctement les accents ? Ah et puis pendant qu'on y est, si je crée un fichier avec des accents dans le nom sur ce même partage, faudrait que les autres les voient bien aussi...

Si j'arrive à résoudre ça, je suis en bonne voie pour me passer de windows au boulot !!!
Merci d'avance !

Hors ligne

#2 Le 12/05/2005, à 14:55

qstone

Re : Samba, UTF8 et accents

Hop... Autoréponse !!! On va encore me dire "bah tu vois quand tu veux !" wink

J'ai donc réussi avec le paramétrage suivant :
/etc/samba/smb.conf :

dos charset=CP850
unix charset=UTF-8
display charset=UTF-8

A ce niveau, redémarrez samba et faites un test avec smbclient (smbclient //machine/partage, donner son mot de passe, puis cd, dir etc.)

Ca doit marcher.

Etape suivante, monter correctement les partages dans le fstab:

/etc/fstab :

//serveur/partage /mnt/laoujemontemonpartage cifs iocharset=utf8,(autres options qui vont bien) 0 0

A priori les trucs importants c'est cifs à la place de smbfs (à confirmer) et iocharset=utf8.
Voilà, reste plus qu'à faire un ptit sudo mount -a pour activer tout ça et ça doit rouler !

Dernière modification par qstone (Le 12/05/2005, à 14:57)

Hors ligne

#3 Le 23/06/2005, à 10:46

GoodSpeed

Re : Samba, UTF8 et accents

ça marche super bien, merci qstone smile !!

Hors ligne

#4 Le 02/10/2005, à 21:34

pizzahunter

Re : Samba, UTF8 et accents

mici qstone, pour moi tout se passe bien jusqu'à la phase : "allez monte tout ça dans ton fstab"

ta solution fonctionne bien avec le smbclient, mais pas une fois le share monté sad je vais me petitsuicider

#5 Le 03/10/2005, à 07:51

qstone

Re : Samba, UTF8 et accents

mouais enfin chezmoiçamarche (c)
Bon c'est clairement un souci de montage
essaie dans un premier temps de monter ton partage à la main (commande mount cheminSMB pointDeMontage)
Regarde le résultat avec le shell et avec l'explorateur de fichiers gnome, pour être sûr. Regarde ce que ça donne sans paramètres pour le mount, puis en rajoutant le type de système de fichier (mount -t cifs/smbfs (essaie les 2)), et enfin en jouant avec les 2 options : iocharset et nls, qui sont toutes deux censées décrire des jeux de caractères (utf8 ou autre).

Mélange tout ça dans tous les sens jusqu'à avoir un résultat correct, et poste ta belle commande mount qui marche ici yikes)
Et, juste pour infos, comment apparaissent les caractères accentués chez toi avec mes paramètres ? Des petits carrés avec des 0028 dedans ? Des @Â quelquechose ?

Hors ligne

#6 Le 15/02/2006, à 16:23

Leoween

Re : Samba, UTF8 et accents

Bonjour

I don't speak french tongue, but I'm from Chile and I use Ubuntu in spanish, so I used to have the same problem until this morning when I type this on the console:

sudo mount.cifs //chicharra/usuarios /mnt/chicharra/usuarios -o ip=192.168.0.69,iocharset=utf8

and finally worked big_smile

au revoir.

Leoween

#7 Le 03/04/2006, à 23:25

castor_foudroyant

Re : Samba, UTF8 et accents

pour moi ça marche bien via smbclient mais on s'arrete là (ni avec mount.cifs, ni via fstab (logique))

un peu d'aide ?
(le serveur est ubuntu, le client est gentoo)

Hors ligne