Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#801 Le 31/10/2010, à 10:38

guigui85

Re : [Centralisation] "tuxguitar"

david96 a écrit :

Qu'as-tu dans Outils » Paramètres » Son ?
Rubrique Sequencer Midi : TG Sequencer
Port Midi : Midi Through Port-0 [14:0]
Pas d'autres sélections possibles

Quelle est ta version de java ?
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.1) (6b20-1.9.1-1ubuntu3)
OpenJDK Server VM (build 17.0-b16, mixed mode)


À savoir aussi que si tu as des applications autre que tuxguitar qui exploitent le son, je t'invite les couper, ces derniers pouvant entrer en conflit avec Tuxguitar.

Quand je clique sur play pour lancer une partition, j'entends le son système (peut être en conflit avec le son de TG ?)

Dernière modification par guigui85 (Le 31/10/2010, à 11:28)


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#802 Le 31/10/2010, à 11:29

david96

Re : [Centralisation] "tuxguitar"

guigui85 a écrit :
david96 a écrit :

Qu'as-tu dans Outils » Paramètres » Son ?

Rubrique Sequencer Midi : TG Sequencer
Port Midi : Midi Through Port-0 [14:0]
Pas d'autres sélections possibles

Pour ma part j'ai :
Rubrique Sequencer Midi : TG Sequencer
Port Midi : Java Sound Synthetiser

guigui85 a écrit :
david96 a écrit :

Quelle est ta version de java ?

java -version
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.1) (6b20-1.9.1-1ubuntu3)
OpenJDK Server VM (build 17.0-b16, mixed mode)

J'ai la suivante : java version "1.6.0_22" Mais la précédente ne posait pas de problème il me semble.

guigui85 a écrit :
david96 a écrit :

À savoir aussi que si tu as des applications autre que tuxguitar qui exploitent le son, je t'invite les couper, ces derniers pouvant entrer en conflit avec Tuxguitar.

Quand je clique sur play pour lancer une partition, j'entends le son système (peut être en conflit avec le son de TG ?)

Je ne pense pas, mais à vérifier si le fait déjà de changer de port Midi tout fonctionne wink

Hors ligne

#803 Le 31/10/2010, à 12:39

Loy

Re : [Centralisation] "tuxguitar"

Hello !
En général, le problème ne viens que rarement de java, TG ou autre (sauf si là effectivement tu n'arrive pas à lire les midi) mais surtout du serveur de son.
Donc, comme il à été dit, vérifier si tu as d'autres application utilisant le son. Le son système n'entre pas en conflit, c'est un "port audio" (si je puis dire) qui est ouvert dès le démarrage de ta machine.

Au démarrage de TG, enfin juste après, va dans les logs système (Système>Administration>journaux si j'ai bonne mémoire de comment c'est fait sous gnome, ou applications > système > KSystemlog )voir s'il n'y a pas des lignes toute récente concernant "alsa" (ou approchant)


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#804 Le 31/10/2010, à 13:14

guigui85

Re : [Centralisation] "tuxguitar"

Loy a écrit :

Hello !
En général, le problème ne viens que rarement de java, TG ou autre (sauf si là effectivement tu n'arrive pas à lire les midi) mais surtout du serveur de son.
Donc, comme il à été dit, vérifier si tu as d'autres application utilisant le son. Le son système n'entre pas en conflit, c'est un "port audio" (si je puis dire) qui est ouvert dès le démarrage de ta machine.

Au démarrage de TG, enfin juste après, va dans les logs système (Système>Administration>journaux si j'ai bonne mémoire de comment c'est fait sous gnome, ou applications > système > KSystemlog )voir s'il n'y a pas des lignes toute récente concernant "alsa" (ou approchant)

Ok Loy, mais je crois que ça devient compliquer pour moi, là...:o

Au niveau de la reconnaissance de mes cartes son (avec un Mixer) j'ai du Alsa et du Pulse Audio.  ça peut venir d'un conflit entre les 2 ?
Au niveau du sélecteur de système multimédia, je suis obligé de choisir Alsa ou Pulse, si je choisi détection automatique il ne reconnaît plus de périphérique (et mon système 5.1 bugge).

Je précise que quand j'étais sur la 10.04, tout marchait parfaitement (je pouvais même écouter du TG pendant que j'écoutais une autre émission audio, la radio ou autre....)


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#805 Le 31/10/2010, à 13:29

guigui85

Re : [Centralisation] "tuxguitar"

david96 a écrit :
guigui85 a écrit :
david96 a écrit :

Qu'as-tu dans Outils » Paramètres » Son ?

Rubrique Sequencer Midi : TG Sequencer
Port Midi : Midi Through Port-0 [14:0]
Pas d'autres sélections possibles

Pour ma part j'ai :
Rubrique Sequencer Midi : TG Sequencer
Port Midi : Java Sound Synthetiser

guigui85 a écrit :
david96 a écrit :

Quelle est ta version de java ?

java -version
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.1) (6b20-1.9.1-1ubuntu3)
OpenJDK Server VM (build 17.0-b16, mixed mode)

J'ai la suivante : java version "1.6.0_22" Mais la précédente ne posait pas de problème il me semble.

guigui85 a écrit :
david96 a écrit :

À savoir aussi que si tu as des applications autre que tuxguitar qui exploitent le son, je t'invite les couper, ces derniers pouvant entrer en conflit avec Tuxguitar.

Quand je clique sur play pour lancer une partition, j'entends le son système (peut être en conflit avec le son de TG ?)

Je ne pense pas, mais à vérifier si le fait déjà de changer de port Midi tout fonctionne wink

Je ne peux pas changer de port Midi, je n'ai qu'un choix possible dans TG.


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#806 Le 31/10/2010, à 13:52

fanfantasy7

Re : [Centralisation] "tuxguitar"

à lancer en console

bertrand@bertrand-desktop:~$ tuxguitar 
/dev/sequencer: Aucun fichier ou dossier de ce type

et vous, vous avez la même erreur ?


Fanfantasy7
pc fixe : Linux Mint
pc portable : Ubuntu LTS

Hors ligne

#807 Le 31/10/2010, à 14:09

guigui85

Re : [Centralisation] "tuxguitar"

fanfantasy7 a écrit :

à lancer en console

bertrand@bertrand-desktop:~$ tuxguitar 
/dev/sequencer: Aucun fichier ou dossier de ce type

et vous, vous avez la même erreur ?

Oui, TG se lance (sans son) et idem pour moi.


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#808 Le 31/10/2010, à 15:14

Loy

Re : [Centralisation] "tuxguitar"

Re.
Donc ça viens bien d'alsa, au vue de "/dev/sequencer no found. Utilises-tu timidity (ou utilisais-tu quand ça fonctionnait) ? En tout cas il vous faut vous tourner vers un problème de configuration d'alsa/pulseAudio.
À ce propos, alsa utilise pulse audio, l'un capturant le son et l'autre le "mixant" pour avoir un rendu sur une seule sortie (en gros hein, j'avais commencer à tenter de tout bien piger, et je suis encore dans le vague). Mais le conflit viens que 2 applications cherchent à "émettre" le son sur le même "port" (situé souvent à /dev/dsp ) et celui-ci ne peux le gérer (d'où ce bazard de pulse audio, alsa etc qui permet d'éviter ce problème).
Dans votre cas, il manque carrément le "port" pour le moment (/dev/sequencer) donc forcément, le son à du mal à ce faire entendre.

Après, bien qu'avec l'aide d'un ami gogole (c'est pas de sa faute tongue) je peux dire que tuxguitar n'est pas à incriminer mais la configuration du serveur son. Mais, je ne puis trop aider en ce sens, je ne maîtrise absolument pas la chose hmm .

EDIT : compléments d'explication sommaire

Dernière modification par Loy (Le 31/10/2010, à 16:23)


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#809 Le 01/11/2010, à 21:11

guigui85

Re : [Centralisation] "tuxguitar"

C'est pas gagné alors !
Pourquoi ça marchait avec la 10.4 et plus avec la dernière version 10.10 ?

Re installer tux guitar pourrait résoudre le problème ?


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#810 Le 01/11/2010, à 21:55

Loy

Re : [Centralisation] "tuxguitar"

As-tu d'installer tuxguitar-alsa (ou tuxguitar-jsa) ? Ça m'étonnerait que non mais bon.
Tu peux tenter la réinstallation mais ce n'est pas une dépendance manquante.
au pire, mais je ne suis pas sur du résultat :

padsp tuxguitar

ctrl+c si rien ne ce passe pour quitter (ou en fermant la console)

ÉDIT :

guigui85 a écrit :

Pourquoi ça marchait avec la 10.4 et plus avec la dernière version 10.10 ?

Car la configuration est retombée en "défault" je pense. Ça avait fonctionné directement sous 10.04 ?

Dernière modification par Loy (Le 01/11/2010, à 21:58)


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#811 Le 06/11/2010, à 17:29

guigui85

Re : [Centralisation] "tuxguitar"

guigui85 a écrit :
azmeuk a écrit :
royto a écrit :

Bonjour,

je viens de passer à Lucid et TuxGuitar de fonctionne plus.

J'obtiens l'erreur suivante au démarrage  :

Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Control
    at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Control
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
    ... 1 more

J'utilise le Opendjk

java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8) (6b18-1.8-0ubuntu1)
OpenJDK Server VM (build 14.0-b16, mixed mode)

j'ai essayer un réinstall ==> NOK
j'ai rajouter le dépot rzr ==> Tuxguitar n'est pâs encore packagé pour Lucid

Ma version est celle des dépots ubuntu qui est la 1.1-1ubuntu4

Même problème et j'utilise la JRE de Sun.

ramoloss@salameche:~$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Client VM (build 16.3-b01, mixed mode, sharing)
ramoloss@salameche:~$ tuxguitar 
Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Control
    at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Control
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
    ... 1 more
ramoloss@salameche:~$

Et pourtant aujourd'hui Lucid est en version stable…
Une idée ?

edit :

sudo aptitude reinstall libswt-gtk-3.5-java libswt-gtk-3.5-jni

Et ensuite ça roule !

Magnifique !
Merci. big_smile

Sous la 10.04 j'ai du faire cette manipulation pour que ça marche nickel.

Sinon, avec la 10.10, j'ai des problèmes de son. Des fois, j'ai mes baffles arrières (j'ai du 5.1) qui crépitent. Je suis obligé d'aller dans préférence et sélecteur de système multimédia pour que le son redevienne normal (en sélectionnant Alsa ou Pulse pour que ça s'arrange). Bizarre !


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#812 Le 07/11/2010, à 19:01

guigui85

Re : [Centralisation] "tuxguitar"

Bon ! pour Info, j'ai désinstallé puis re installé TG. Apparaissait ainsi un nouveau port midi "Gervill" dans les options du son. J'ai sélectionné et ça marche ! big_smile


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#813 Le 07/11/2010, à 19:03

Loy

Re : [Centralisation] "tuxguitar"

Tu as pris quelle version ? celle des dépots ?
En tout cas tout est bien qui finit bien smile

(À noter que les dev de TG ont ajouter il n'y a pas très longtemps l'adaptation de la tablature selon l'accordage, ce qui make the life better )


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#814 Le 07/11/2010, à 19:17

guigui85

Re : [Centralisation] "tuxguitar"

oui, dans la logitèque Ubuntu, quand tu réinstalles il fait le lien direct avec les dépôts afférents. Rien d'autre à faire. smile
Life is really better.


Le plus dur, c'est de ne pas penser.
Xubuntu 16.04

Hors ligne

#815 Le 16/11/2010, à 15:45

MysterStreet

Re : [Centralisation] "tuxguitar"

Salut,
3 questions de blaireau (surtout les 2 dernières - désolé je suis pas très à l'aise avec Ubuntu ...) :
   - est-ce obligatoire d'installer la 1.2 pour avoir les sons-qui-vont-bien ?
   - si oui, quel(s) fichier(s) faut-il telecharger sur le site de tuxguitar ?
   (- et après çà s'installe juste en les ouvrant, ou il y a une manip spéciale à faire ?)

Merci tongue


꙳♒⏅⚓ ЅаίԼίՈԶ ⚓⏅♒꙳ a écrit :

J'installe la 1.2 depuis le site officiel () puis les sons java (pack deluxe ici) que je décompresse dans mon /home dans un dossier que j'appelle "sons java pour TG". Je lance TG puis outils->greffons->Java sound API plugin->configurer->use custom soundbank->l'adresse de "sons java pour TG" ... et voilou.

Hors ligne

#816 Le 16/11/2010, à 22:46

Loy

Re : [Centralisation] "tuxguitar"

Hello !
La manip à partir du téléchargement de la banque sonore "deluxe" n'est qu'une manipulation qui permet un meilleur rendu.
Néanmoins, cela n'utilise pas les mêmes moyens pour faire sortir le son.

Donc, je récapépète :
Si tu es sous maverik (toute dernière version d'ubuntu) il te suffit de récupérer tuxGuitar dans la logithèque ubuntu (je suppose que tu ais l'environnement graphique par défaut, gnome).

Si tu as un doute ou si tu es sur de ne pas être sous la version 10.10 mais une plus ancienne, tu télécharge les paquets que tu as cité toi même, tu cliques dessus, ce qui te demandera ton mot de passe et logiquement, pas de problème (c'est un peu l'équivalent d'un .exe pour l'installation, sauf que le .deb c'est mieux smile ) . Si ça marque qu'il y a des dépendances manquantes... bon ba il faudra les choper (je ne sais plus du tout pour les récupérer via un deb là dessuite).

Le fichier "d'installation" est celui récupéré sur le site officiel de tuxG (si tu passe par là, sinon cette étape est automatisée par la "logithèque" ) l'autre est juste pour dire à javaSound de changer de voix tongue

Valà.
Bon début sous Ubuntu ! Ne te décourage pas si tu es un peu perdu, changer d'os sous entend forcément de ne pas retrouver les mêmes choses, mais même si le son ici est un peu chaotique ('faut l'admettre), une fois configurationné, il est beau (sisi, même sans parler de TuxG y tout) et tant que l'on reste correct, la communauté aide volontiers (en ayant au préalable chercher sur  la doc et le fofo tongue ), quel que soit le sujet (informatiquement parlant lol )

EDIT : Dans la peur de me faire grilled j'ai omis le 2nd point, et pas des moindres, vu le nombre de téléchargements possibles. Personnellement, je préfère les .deb, que l'on trouve ici ubuntu-i386 ou amd64 si architecture 64 bits c'est plus pratique je trouve (c'est tout autant officiel si la question te viendrait)

Dernière modification par Loy (Le 16/11/2010, à 22:56)


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#817 Le 17/11/2010, à 13:02

MysterStreet

Re : [Centralisation] "tuxguitar"

Merci !  smile

Alors ma version c'est Lucid, et du coup je n'ai pas accès a Tuxguitar 1.2 par la Logitheque (seule la 1.1 est accessible, d'où mes questions bêtes ...).
Donc j'ai installé le paquet ..amd64 (merci de m'avoir orienté, sinon je n'aurai pas trop su lequel choisir dans le tas !) , et ca fonctionne ... avec les sons "Bontempi"

Et il me reste un souci pour récuperer la banque de sons Java (http://java.sun.com/products/java-media … banks.html) : impossible d'accéder au site, soit car il ne marche pas, soit plus vraisemblablement car depuis le pays où j'habite maintenant, l'accès doit être interdit (?) roll
Bref, y aurait-il une ame charitable qui voudrait bien me balancer le contenu de ce lien (par dl.free par exemple, ou autre truc du style) ? tongue

Hors ligne

#818 Le 17/11/2010, à 13:30

david96

Re : [Centralisation] "tuxguitar"

Impossible de charger la page chez moi aussi ! hmm

Firefox a écrit :

Le délai d'attente est dépassé

Le serveur à l'adresse java.sun.com met trop de temps à répondre.

Dernière modification par david96 (Le 17/11/2010, à 13:31)

Hors ligne

#819 Le 17/11/2010, à 17:09

MysterStreet

Re : [Centralisation] "tuxguitar"

effectivement c'est pile le meme msg que moi : ca ne vient donc pas de ma connexion hmm
Du coup y'aurait pas qqn qui aurait ca sous le coude quand meme ?? Ou un autre lien pour recuperer le tout ?

david96 a écrit :

Impossible de charger la page chez moi aussi ! hmm

Firefox a écrit :

Le délai d'attente est dépassé

Le serveur à l'adresse java.sun.com met trop de temps à répondre.

Hors ligne

#820 Le 17/11/2010, à 21:24

Loy

Re : [Centralisation] "tuxguitar"

Je peux te la passer, je te contacte via message privé


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#821 Le 28/11/2010, à 13:40

Supo

Re : [Centralisation] "tuxguitar"

Salut,
J'ai recopié une partition sur tuxguitar.
J'ai changé l'accordage (DADGAD, irlandais) après avoir fini d'écrire la partition. J'espérais que cela conserverait les notes et me changerait juste l'affichage de la tablature. Au contraire cela me transforme les notes (la tablature reste la même), ce qui est pas très pratique. Y-a-t-il un moyen de remédier à cela ?

Merci d'avance.
Supo

PS: j'ai cherché dans le forum et j'ai pas trouvé.
Et j'ai essayé de copier coller sur une nouvelle piste déjà modifiée en dadgad mais cela ne résout rien.

Hors ligne

#822 Le 28/11/2010, à 23:23

Loy

Re : [Centralisation] "tuxguitar"

Hello !
Malheureusement, je crois bien que tu es obligé de créer une tab, de la faire passer en DADGAD (au passage, vérifie que tu n'ai pas inverser le sens on sait jamais ) puis de recopier la tab. La transposition d'un accordage à un autre adapte la tab de manière à avoir le même son sur un accordage différent. Du moins en théorie.


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#823 Le 30/11/2010, à 13:50

Supo

Re : [Centralisation] "tuxguitar"

Justement, changer l'accordage change le son, vu que ce que le logiciel conserve, c'est la position des doigts sur la corde.
Du coup j'ai bien du recopier ma tab en changeant l'accordage AVANT de recopier.
Merci quand même de la réponse.
Bye bye

Hors ligne

#824 Le 30/11/2010, à 21:01

Loy

Re : [Centralisation] "tuxguitar"

Étrange, je croyais sur le coup que c'était justement ce que tu cherchais tongue car chez moi ça marche bien. Tu as bien coché les 3 option "transpose chord" "transpose affected notes" et "Try keep notes at same string" ?

Tu utilise quelle version de Tg ? (perso la dernière, 1.2)

Si la même, réinstalle en allant la chercher directement chez tuxguitar ici car je me disais il y a moins d'un mois, "c'est vachement cool qu'ils aient enfin implémenté pour adapter la tablature à l'encodage" ...

Cordialement,
Loy.


Pensez à consulter la doc avant de poster…
Loy is back on Ubuntu ! (et pour de bon cette fois ci )
Créateur de Silence

Hors ligne

#825 Le 10/12/2010, à 00:47

Supo

Re : [Centralisation] "tuxguitar"

Oh you're right. J'ai la 1.1 je vais installer la 1.2 !
C'est cool !
Merci pour l'info !
++

Hors ligne