Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#226 Le 26/09/2006, à 11:00

FCBFlo

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Euh plutot comme ca:

Un  petit up pour ce qui ont réussi à résoudre leur problème de blue screen avec erreur 0x000007b (contrôleur IDE).

Voilà mon gestionnaire de périphérique:
gestionordinateurideyz8.th.png


Qu'est-ce que vous me conseillez de changer, quel config mettre??

#227 Le 26/09/2006, à 13:50

Jester

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Même problème. J'ai blue screen sur blue screen et je suis en SATA sad

Hors ligne

#228 Le 26/09/2006, à 21:48

pled

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Bonjour,

D'abord merci pour ce très bon tutorial.

Quelques infos sur l'activation Windows (XP Edition Familiale): quand j'ai démarrré Windows sous VMWare, mon Windows était déjà activé. Ce qui faisait échouer toute tentative d'activation. Il a donc fallu appeler le support MS. Voici la manip pour déactiver son Windows:

- booter Windows en mode sans échec
- aller dans c:\windows\system32
- effacer wpa.dbl (et wpa.bak s'il existe)
- aller dans c:\windows\system32\oobe
- editer actshell.html
- remplacer g_ready_activated == 0 par g_ready_activated == 1

Redémarrer Ubuntu, lancer la machine virtuelle, la procédure d'activation par internet a échoué, il faut choisir 'par téléphone' et appeler le numéro vert (0800 228 482).

Sinon, j'ai redémarré sous Windows, et il me demande l'activation (ce dont le type du support n'était pas certain).
Donc cette manip sous-entend tout de même de choisir de ne plus amorcer sous Widows... pour ce que je peux observer en tout cas. Activer / réactiver est tout de même fastidieux, et sans doute limité. Bien réfléchir avant donc.

A propos du tuto, j'ai mis un peu de temps à comprendre que pour les disques SATA, il fallait modifier non seulement le .vms (pour remplacer scsi par ide), mais aussi le fichier .vmdk (pour indiquer ddb.adapterType = "ide").

Sinon vraiment impec !
Merci,
Pascal

#229 Le 26/09/2006, à 22:00

margot

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

bonsoir à tous,

voilà, moi aussi j'essaie d'utiliser mon XP déjà installé sur une partition à partir de mon Ubuntu préférée (ordi portable acer TM 8103).
Je n'ai pas eu de probleme particulier durant l'install' de vmware, mais les choses se sont compliquées au moment de lancer XP : j'ai un dd en SATA.....donc bel écran bleu !
mais après avoir lu au moins 10 fois plusieurs des posts sur ce thème (je ne suis pas toujours très rapide  pour comprendre tout ça, je suis une vrai newbe.....), et en particulier celui de Canard (page 6), j'ai enfin résolu le pb :
- il m'a fallut changer le .vmx :
       - scsi0.present = "TRUE"
          en
         scsi0.present = "FALSE"
       - tous les scsi. par ide.
- et aussi changer le .vmdk
       - 'buslogic' devient 'ide'

et hop plus de BSOD !

mais comme d'autres, pas de souris ni de clavier dés que le logo winXP apparait et qu'il faut rentrer son pass ....
j'ai cherché un peu sur le forum de vmware, mais rien trouvé...
toujours pas de solution à ce probleme ?

ciao, et merci à la communauté ubuntu d'exister !
margot

Hors ligne

#230 Le 26/09/2006, à 23:51

Phoen1x

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Juste pour dire que le post de canard est bien correct, la modification du .vmx et vmdk permet de lancer un xp sur disque SATA wink

gg

Hors ligne

#231 Le 27/09/2006, à 16:29

LeKing56

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Pour le problème de la souris et du clavier, j'ai trouvé ceci :

To my knowledge, simplest thing to do (besides not dualbooting Windows) (after you created special VM hardware profile as advised in the manual) is to enable remote desktop in your Windows, then go to the Linux, boot them, connect to them with tsclient, and now go through add hardware... if you are more lucky, keyboard already works for you now. If you are sufficiently lucky, uninstall keyboard, mouse, and let it rediscover again... This time keyboard should start working for sure...

Il s'agit donc d'activer le bureau à distance de windows. Sur XP c'est facile, mais je ne vois pas à quoi ça correspond sur windows 2000 ! Et je ne comprends pas très bien la suite de la procédure je dois avouer... est-ce que quelqu'un aurait de meilleures explications à fournir ?

Hors ligne

#232 Le 27/09/2006, à 20:51

2fast4u

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

En gros tu te connect en TS, tu supprime le clavier/souri dans le gestionnaire de périphérique et tu relance pour qu'ils soitent automatiquement réinstallé.
Sur 2000, me rappel plus ou c'est roll

Hors ligne

#233 Le 29/09/2006, à 16:34

Uke

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Bonjour,

Chez moi la creation de la VM achoppe : "Failed to load partitions for device /dev/hdb: Permission denied"

Hors ligne

#234 Le 29/09/2006, à 23:04

LeKing56

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Pour le problème de la souris et du clavier, chez moi je l'ai  résolu de cette façon :

Dans le menu VM > Settings > Onglet Options > Section Advanced, j'ai coché la case  "Disable Acceleration".

Hors ligne

#235 Le 30/09/2006, à 08:43

Uke

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Bonjour,

Bon ok, maintenant ca marche ;-)
Une alternative à la disquette serait l'install de grub ou Xosl, m'enfin, moi je n'en pas un usage quotidien, alord je ne fait pas faire l'expérience smile

Hors ligne

#236 Le 02/10/2006, à 18:06

Phoen1x

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Avez-vous des problèmes avec la dernière mise à jour ? car lorsque je lance vmware, il me demande mon mot de pass et puis plus rien hmm

Hors ligne

#237 Le 02/10/2006, à 19:18

Vicks

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

The partition table on the physical disk has changed since the disk was created. Remove the physical disk from the virtual machine, then add it again

Salut, quelqu'un aurait-il des infos sur cette erreur?

Hors ligne

#238 Le 04/10/2006, à 10:51

FCBFlo

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Un  petit up pour ce qui ont réussi à résoudre leur problème de blue screen avec erreur 0x000007b (contrôleur IDE).

J'ai un disque IDE et j'ai changé le pilote IDE, mais ça marche pas, tjrs un BSOD.



Voilà mon gestionnaire de périphérique:
gestionordinateurideyz8.th.png

Quelqu'un aurait une idée de solution??

#239 Le 04/10/2006, à 18:18

aiglX

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Salut , j'ai tenté d'installer Vmware Server sur Ubuntu Edgy eft, ...
impossible de le mettre en route,
astuces pour ceux qui n'arrive pas:

sudo -s
LD_PRELOAD=/usr/lib/libdbus-1.so.3 vmware

++

#240 Le 04/10/2006, à 19:43

xUbuntu user

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Peut-on supprimer ensuite les paquets installés "linux-source" "linux-headers" et tout le toutim ? Car mine de rien, ça bouffe de la place ces bestioles...

Merci

#241 Le 04/10/2006, à 21:44

pristella

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Bonjour,

j'ai un problème lors du demarrage de windowsXP sur vmware. Après "power on " vmware se met en branle et je vois apparaitre l'image noir classique avec le logo de winxp et tout de suite après un ecran bleu furtif avec de multiple message puis on revient au depart? Pas le temps de lire les message d'erreur, la fenêtre se referme tout de suite. J'ai donc suivi ta procedure mais ça ne change rien.

J'ai un disque IDE.

Voilà le lien de mon impression ecran :

http://nlav1.free.fr/mon-site-web/
Pour info voilà les log messages (une partie wink:

Oct 04 21:50:26: vcpu-0| CPU reset: soft
Oct 04 21:50:26: vcpu-0| SVGA: Unregistering IOSpace at 0x1400 (0x1400)
Oct 04 21:50:26: vcpu-0| SVGA: Unregistering MemSpace at 0xf0000000(0xf0000000) and 0xe8000000(0xe8000000)
Oct 04 21:50:26: vcpu-0| SVGA: Registering MemSpace at 0xf0000000(0xf0000000) and 0xe8000000(0xe8000000)
Oct 04 21:50:26: vcpu-0| SVGA: Unregistering MemSpace at 0xf0000000(0xf0000000) and 0xe8000000(0xe8000000)
Oct 04 21:50:26: vcpu-0| SVGA: Registering MemSpace at 0xf0000000(0xf0000000) and 0xe8000000(0xe8000000)
Oct 04 21:50:26: vcpu-0| SVGA: Unregistering MemSpace at 0xf0000000(0xf0000000) and 0xe8000000(0xe8000000)
Oct 04 21:50:26: vcpu-0| SVGA: Registering IOSpace at 0x1400 (0x0)
Oct 04 21:50:26: vcpu-0| SVGA: Registering MemSpace at 0xf0000000(0xf0000000) and 0xe8000000(0xe8000000)
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: mks| Ignoring update request in VGA_Expose (mode change pending).
Oct 04 21:50:27: vcpu-0| VIDE: Curr CHS info cyls: 17475 heads: 15 sects: 63 lba_cap: 156301488
Oct 04 21:50:28: vcpu-0| BIOS-UUID is 56 4d 4a eb ef 16 ef e8-c3 0d 86 d9 f8 a3 cd 51
Oct 04 21:50:28: vcpu-0| DISKUTIL: ide0:0 : toolsVersion = 0
Oct 04 21:50:28: vcpu-0| DISKUTIL: Offline toolsVersion = 0

il semble que ça soit un problème d'affichage ?

merci d'avance

A+

Dernière modification par pristella (Le 04/10/2006, à 23:13)

Hors ligne

#242 Le 04/10/2006, à 23:56

pristella

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

bon, j'ai enfin reussi à ouvrir windowXP. Mais comme beaucoup d'autres , ma souris reste figé au login de windowsXP sad

si quelqu'un a la solution smile

Hors ligne

#243 Le 05/10/2006, à 10:18

yugo

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Apres avoir reactiver windøws (XP home) sous vmware, apres avoir reactiver windøws en le relancant physiquement, j'ose plus le relancer sous vmware!
Quelqu'un peut il me dire si je devrais encore reactiver windøws


Dans la vie il y a 3 sortes d'imbéciles: ceux qui doutent de tout et ceux qui doutent de rien

Hors ligne

#244 Le 05/10/2006, à 15:13

theClimber

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Bonjour,

Je débarque un peu dans ce topic. J'ai tenté de mettre VMWare en place hier afin de pouvoir accéder à ma partition windows directement à partir de linux. Dans l'ensemble pas trop de problèmes:
- Installation des en-têtes du noyeau : ok
- Installation de VMWare : ok
- Mise en place des paramètres sous windows : ok
- Configuration de ma session windows dans VMWare : ok
- Mise sous tension de la machine virtuelle : failed.

Ce qui me gêne le plus c'est que j'ai ni écran bleu, ni écran avec logo windows, ni quoique ce soit ... j'ai un écran noir. Je vois le CPU qui travaille pendant un petit temps ... puis fini ... un peu comme s'il avait fini de se logger ... mais je vois rien à l'écran, pas d'erreur. Serais-ce un problème de communication avec le module d'affichage? Ca me semblerais étrange?

Quelqu'un as-t-il eu ce problème là et a des éléments de solutions à me proposer? Ca serait cool. Je n'ai hélas pas décortiqué tous les problèmes qui ont déjà été abordés dans ce topic, donc d'avance désolé si je ne suis pas le premier à avoir ce problème. Et merci de m'éclairer.


pristella a écrit :

bon, j'ai enfin reussi à ouvrir windowXP. Mais comme beaucoup d'autres , ma souris reste figé au login de windowsXP sad

si quelqu'un a la solution smile

Regardes plus haut, on proposes pas mal de solutions pour régler les problèmes de souris

yugo a écrit :

Apres avoir reactiver windøws (XP home) sous vmware, apres avoir reactiver windøws en le relancant physiquement, j'ose plus le relancer sous vmware!
Quelqu'un peut il me dire si je devrais encore reactiver windøws

A la limite le mieux est d'activer ton windows une fois pour toute sur VMWare, comme ça tu ne dois plus redémarer windows. C'est à mon avis la solution la plus sage.
Voici une explication qui peut peut-être t'aider:
http://forum.ubuntu-fr.org/viewtopic.php?pid=502987#p502987


Think less, climb more
theClimber's blog

Hors ligne

#245 Le 05/10/2006, à 18:48

LeKing56

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Quand je tente de mettre vmware en mode full screen, j'obtiens le message d'erreur suivant :

Unable to find an appropriate host video mode.
Adding the guest mode to the 'display' subsection of the 'screen' of your /etc/X11/XF86Config and restarting X is likely to help.

Failed to switch to full screen SVGA mode.

Quelqu'un aurait une solution ?

Hors ligne

#246 Le 06/10/2006, à 08:48

nicky_larson9

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

seb

c'est quoi ça?! :> Selectionnez les option de machine privée [NON] car je ne trouve pas -.-

roll


je suis malentendant (sourd et muet), désolé pour mon orthographe ?
[ubuntu Dapper 6.06/ Gnome/ Firefox/ thunderbird/ Nvidia]
nouveau ! irc : irc.freenode.net / #frugalware-fr  &  #terranux, à vous chattez

Hors ligne

#247 Le 06/10/2006, à 11:49

benjou

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

Hello,

Ca marche pour moi: Dell inspiron 6000 avec la fameuse carte ultra ATA.

J'ai du enlever toute reference a scsi dans le fichier vmx et remblacer buslogic par ide dans le fichier vmdk.

Comme j'ai xp home edition, il veut un nouvel enregistrement hmm Donc je crois que tant pis pour vmware...


J'ai egalement eu un probleme avec Xgl/Compiz: l'affichage dans la console etait noire. Resolu en bootant dans gnome ou en ouvrant vmware avec la commande suivante:

DISPLAY=:0 sudo vmware

écrasons l'infâme

Hors ligne

#248 Le 06/10/2006, à 14:54

theClimber

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

benjou a écrit :

J'ai egalement eu un probleme avec Xgl/Compiz: l'affichage dans la console etait noire. Resolu en bootant dans gnome ou en ouvrant vmware avec la commande suivante:

DISPLAY=:0 sudo vmware

Merci pour cette solution, ça marche nickel chez moi. wink


Think less, climb more
theClimber's blog

Hors ligne

#249 Le 07/10/2006, à 01:11

margot

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

bonsoir tout le monde !
alors ? ce probleme de souris + clavier ? il y a une solution qui marche ???
j'ai essayé toutes les solutions présentées ici (enfin je crois) sans me sortir de mon pétrin.......

merci en tous cas à ceux qui essayent et trouvent de nouvelles astuces !!!

Dernière modification par margot (Le 07/10/2006, à 01:12)

Hors ligne

#250 Le 07/10/2006, à 10:26

philuser

Re : [HOWTO] WMware, lancer un windows installé "physiquement"

bonjour,

aprés avoir pris deux bonne heures à lire ce topic, me me lance dans l'aventure sur une distrib Edgy.

La machine : Athlon 64
Os : Edgy
/# uname -r
2.6.17-10-generic

je lance : # ./vmware-install.pl , cela ce passe bien jusqu'à :
...
Generating SSL Server Certificate

Unable to get the last modification timestamp of the destination file
/etc/vmware/ssl/rui.key.

1)ce fichier nexiste pas, je le crée, puis relance l'install : Idem
2)recherche sur http://www.vmware.com/community/message.jspa?messageID=368477
j'execute : touch /etc/vmware/ssl/rui.key , puis relance l'install : Idem

bien sur entre chaque nouvelle instal : vmware-uninstall.pl

est le fait d'être en 64bit sur une distrib trop fraiche « Edgy » ?

une autre explication ?

Merci

Hors ligne