Contenu | Rechercher | Menus

Annonce

T-shirt Disco Dingo : Série limitée

Ubuntu 19.04
T-shirt Ubuntu-FR « Disco Dingo » en série limitée !
Prix spécial pré-vente (15€) jusqu'au 21 avril 2019.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/11/2006, à 17:51

teke

htaccess non pris en compte

Bonjour,

J'ai regardé les 7 discutions que j'ai trouvé sur les problèmes du même type sans pouvoir résoudre le mien.

Sur une configuration d'apache fonctionnelle à 100% depuis plusieurs mois en local, je viens de rapatrier un site distant fonctionnel depuis 6 ans...

dans : /etc/apache2/sites-available/default j'ai

    Alias /avent06 "/home/svn-devel/mdmbl/dossiers/06-avent/branches/devel"
    <Directory "/home/svn-devel/mdmbl/dossiers/06-avent/branches/devel">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Directory>

Le dossier devel appartient à apache (www-data)avec les tous les droits pour tout le monde.

Le fichier .htaccess appartient à apache (groupe également) et a les droits en lecture et écriture pour le groupe et tout le monde. Son contenu est :

AddType text/html .html .htm
AddHandler server-parsed .html .htm
DirectoryIndex redir.htm

Le fichier redir.htm existe bien, il appartient à l'utilisateur mais a les droits de lecture et d'écriture pour le groupe et tout le monde.

Hors donc, apache n'en tient absolument pas compte ! Il me snobe complètement le fichier .htaccess en ne me présentant pas le fichier redir et sans exécuter le code.

je n'ai pas trop d'idée ou chercher... j'ai relu la page du wiki traitant d'apache (lamp) et tous ce que j'ai pu trouver ici... sans résultat.

Merci vraiment de vôtre aide.

#2 Le 25/11/2006, à 21:35

tigrou

Re : htaccess non pris en compte

AllowOverride None

cette ligne dans ton fichier de configuration dit à Apache de ne tenir compte d'aucune instruction dans les fichiers .htaccess
cf. la documentation http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

Hors ligne

#3 Le 25/11/2006, à 22:18

dexinou

Re : htaccess non pris en compte

Pour qu'il tienne compte des htaccess :

AllowOverride AuthConfig

Ubuntu 9.10 64bits ext4 ® Core 2 Duo
Unix..... il y a moins bien mais c'est plus cher.
Si t'as pas compris la réponse, pose mieux ta question.
Tutoriaux Linux, apache, pure-ftpd, bind, mysql, qmail...

Hors ligne

#4 Le 25/11/2006, à 22:27

tigrou

Re : htaccess non pris en compte

pas tout à fait,

AllowOverride AuthConfig

fait en sorte que ce qui concerne l'authentification (c'est à cela que servent 80% des .htaccess) dans les .htaccess soit pris en compte. Ici ce serait plutôt FileInfo et Indexes je pense.

Hors ligne

#5 Le 26/11/2006, à 01:37

teke

Re : htaccess non pris en compte

Merci beaucoup pour votre aide !!!

AllowOverride AuthConfig FileInfo Indexes Limit

Et c'est effectivement pris en compte... enfin presque... la plupart des ordres de limitations, d'index... fonctionnent, sauf le SSI... mais là je me demande si je n'ai pas carrément un module apache qui fait défaut. La doc dit que mod_ssi est chargé par défaut, et je n'ai rien trouvé dans synaptique se rapportant à ce module...

Bon pour moi l'essentiel était le reste, je ne fait que développer en local et j'en ai surtout besoin pour le graphisme et les positionnements par css...pour l'assemblage des fichiers ce n'est pas trop grave... mais j'aimerais quand même bien comprendre et apprendre...

Merci encore pour vôtre aide.

#6 Le 26/11/2006, à 10:20

dexinou

Re : htaccess non pris en compte

fait en sorte que ce qui concerne l'authentification (c'est à cela que servent 80% des .htaccess) dans les .htaccess soit pris en compte. Ici ce serait plutôt FileInfo et Indexes je pense.

Faux, la directives Indexes permet d'indexer ou pas le contenu.
La directives FileInfo permet d'afficher les pages d'erreurs personnalisées.
Seule la directive AuthConfig permet la lecture par le serveur des authentifications du .htaccess

Dernière modification par dexinou (Le 28/11/2006, à 18:57)


Ubuntu 9.10 64bits ext4 ® Core 2 Duo
Unix..... il y a moins bien mais c'est plus cher.
Si t'as pas compris la réponse, pose mieux ta question.
Tutoriaux Linux, apache, pure-ftpd, bind, mysql, qmail...

Hors ligne

#7 Le 27/11/2006, à 17:09

tigrou

Re : htaccess non pris en compte

c'est pas ce que dit la documentation de AllowOverride sur le site d'Apache :

When this directive is set to None, then .htaccess files are completely ignored. In this case, the server will not even attempt to read .htaccess files in the filesystem.

When this directive is set to All, then any directive which has the .htaccess Context is allowed in .htaccess files.

The directive-type can be one of the following groupings of directives.

Hors ligne

#8 Le 03/12/2006, à 12:12

teke

Re : htaccess non pris en compte

Merci encore pour vôtre aide,

Mais la chose ne fonctionne toujours pas...

Le problème n'est pas lié à l'authentification, mais à la prise en charge ssi (server side include)... et j'ai essayé ce que je pense être toutes les combinaisons possibles, mais sans succès...

Je suis convaincu que ce n'est qu'un petit paramêtre qui manque quelque part, mais je ne sais pas trouver où !!!

#9 Le 24/02/2007, à 11:13

teke

Re : htaccess non pris en compte

up

Je cherche depuis décembre... et j'ai réinstallé plusieurs fois... et j'ai toujours le même soucis...

J'ai fait une installation de debian pour voir et je n'ai plus ce problème... mais sous ubuntu je l'ai toujours...

Le pire c'est que je suis certains qu'il ne s'agit que d'un petit problème d'une petite ligne de configuration...

Personne pour m'aider ?

#10 Le 31/01/2008, à 18:47

Bogoris

Re : htaccess non pris en compte

Bonjour,

J'ai conscience de remonter un topic vieux de près d'un an, mais comme je ne sais pas si l'utilisateur a résolu son problème, et comme d'autre peuvent en avoir besoin, je conseille de consulter cette page à la partie "Controle des accès à un répertoire" : il y est dit que pour permettre l'utilisation de SSI, il faut rajouter Includes après Options wink.

Amicalement,

Bogoris

Hors ligne

#11 Le 31/01/2008, à 22:46

teke

Re : htaccess non pris en compte

Merci vraiment beaucoup !
Le problème n'a pas été résolut... là  je n'est pas d'installation apache sur mon actuelle machine... Mais je vais en faire une la semaine prochaine pour tester ça.

#12 Le 05/03/2008, à 10:45

florian15

Re : htaccess non pris en compte

Alors tu en est ou avec tes SSI ?

As-tu résolu ton problème ?

Je suis sur une Kubuntu.

Et je n'arrive pas moi non plus à faire fonctionner ces fichues SSI !!

Aidez nous !!

Hors ligne

#13 Le 05/03/2008, à 16:41

teke

Re : htaccess non pris en compte

Non... problème identique... ce que je ne comprend pas c'est que sous debian et gentoo cela fonctionne... du coup je travail avec lighthttpd...

#14 Le 10/01/2009, à 07:55

fazer1k

Re : htaccess non pris en compte

sad J'ai le même souci, et malheureusement confirmé par webmin:
Saut du fichier d'options Apache /home/voyages/www/eyeOS/xxxxx/users/rt4/root/trash/.htaccess, qui ne protège pas le répertoire

Je ne peux donc utiliser eyeOS sans risque. J'ai tout essayé, relancé apache, mais idem!

Hors ligne

#15 Le 10/01/2009, à 11:39

Bogoris

Re : htaccess non pris en compte

Vous avez essayé en mettant

AllowOverride All

dans le fichier /etc/apache2/apache2.conf ?
Puis de redémarre Apache par

sudo /etc/init.d/apache2 restart

?

Hors ligne

#16 Le 10/01/2009, à 16:14

teke

Re : htaccess non pris en compte

je me souviens qu'à l'époque j'avais essayé oui... sans résultat...

Maintenant... je sais que pour du bureau ubuntu est très bien... mais dès que l'on veut quelque chose de plus pointu il faut retourner dans les jupe à maman. Donc pour tous ce qui demande un peu plus, j'installe Debiane... qui n'a vraiment pas ce genre de soucis...

à noter que j'ai refais l'essai sur plusieurs machines avec plusieurs version... aussi en mode serveur...

#17 Le 18/01/2009, à 07:37

fazer1k

Re : htaccess non pris en compte

sad Vraiment dommage. Oui, j'ai bien sûr testé AllowOverride All, et redémarré x fois apache. Cela m'ennuie vraiment car j'ai monté le serveur complet sur ubuntu, et cela me gêne de repartir sur un debian "simple" car c'est moins simple... Et puis ubuntu, a quasi les mêmes sources non, c'est curieux que cela ne fonctionne pas!

Hors ligne

#18 Le 01/03/2009, à 10:26

fazer1k

Re : htaccess non pris en compte

big_smile Ca y est cela marche. En fait, dans un fichier .htaccess il manquait le A de AuthUserFile, surement supprimé lors d'une modif mad.
Donc maintenant le .htaccess contient AuthUserFile "/var/www/phpmyadmin/a/.htpasswd"
AuthName "Acces reservé"
AuthType Basic
Require valid-user

Il est à noter que le www ci dessus n'est pas celui du site vu sur le web. Donc, le fichier passwd peut être ailleurs que sur le site web , sur le serveur.

Hors ligne