Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 31/01/2012, à 14:57

lobo

[Résolu] Montage samba via fstab

Bonjour,

Je rencontre un problème afin de monter automatiquement au démarrage un partage réseau.

J'ai édité /etc/fstab en suivant pas mal de tutoriels sur le net mais je n'arrive jamais à ce que je veux.

Je commence déjà par tester le montage du partage réseau via la commande:

sudo mount -t cifs -o username=utilisateur,password=motdepasse,domain=mondomaine //serveur/partage /media/partage

Avec ça, mon dossier partagé est bien monté. Mais déjà je rencontre un soucis: seul root peut modifier/créer des fichiers.

ensuite je modifie /etc/fstab avec en ajoutant la ligne suivante:

//server/partage  /media/partage  cifs  rw,user,username=utilisateur,password=motdepasse,domain=mondomaine  0 0

Mais cela ne marche pas...
Alors ma question est la suivante:
Comment faire pour que mon dossier partagé se monte bien au démarrage et que mon utilisateur ait les droits d'écriture ?

Merci.

Dernière modification par lobo (Le 01/02/2012, à 12:15)


"Il faut cueillir les cerises avec la queue. J'avais déjà du mal avec les mains !"- Coluche

Hors ligne

#2 Le 31/01/2012, à 16:12

demonipuch

Re : [Résolu] Montage samba via fstab

Bonjour

Dans le fichier /etc/fstab :

//server/partage  /media/partage  cifs  rw,user=$USER,password=$PASSWD,domain=mondomaine  0 0

Dernière modification par demonipuch (Le 31/01/2012, à 16:18)

Hors ligne

#3 Le 31/01/2012, à 16:29

lobo

Re : [Résolu] Montage samba via fstab

En suivant ces indications, le partage apparait bien dans nautilus.
Si je clique dessus j'ai le message d'erreur suivant:

mount : seul le superutilisateur peut monter //serveur/partage sur /media/partage

"Il faut cueillir les cerises avec la queue. J'avais déjà du mal avec les mains !"- Coluche

Hors ligne

#4 Le 31/01/2012, à 16:50

demonipuch

Re : [Résolu] Montage samba via fstab

Même après une déconnexion de la session, voire un redémarrage du PC?

Sinon il es possible de monter des partages directement avec Nautilus : menu Fichier => se connecter à un serveur => partage Windows

Hors ligne

#5 Le 31/01/2012, à 17:02

lobo

Re : [Résolu] Montage samba via fstab

Oui, je prends bien soin de redémarrer le pc à chaque essai.
Si je passe par "Fichier => se connecter à un serveur => partage Windows" cela fonctionne bien, avec les droits d'écriture.
Mais à chaque redémarrage il faut relancer cette connexion et de plus on ne peut pas y accéder directement depuis les applications (comme thunderbird par exemple).
C'est pour cela que j'essaie de passer par fstab...


"Il faut cueillir les cerises avec la queue. J'avais déjà du mal avec les mains !"- Coluche

Hors ligne

#6 Le 01/02/2012, à 07:31

AlexandreP

Re : [Résolu] Montage samba via fstab

Salut,

lobo a écrit :

ensuite je modifie /etc/fstab avec en ajoutant la ligne suivante:

//server/partage  /media/partage  cifs  rw,user,username=utilisateur,password=motdepasse,domain=mondomaine  0 0

Mais cela ne marche pas...
Alors ma question est la suivante:
Comment faire pour que mon dossier partagé se monte bien au démarrage et que mon utilisateur ait les droits d'écriture ?

Le problème ici, c'est la gestion des droits d'accès de type Unix. Tout comme pour les volumes NTFS et FAT32, les droits d'accès dans les volumes CIFS (les dossiers partagés par SMB/CIFS) n'existent pas. Ubuntu doit simuler la gestion des droits d'accès; pour ce faire, au montage du volume, il attribue par défaut la propriété de l'ensemble des fichiers et dossiers du volume CIFS à l'utilisateur qui effectue le montage, c'est-à-dire root -- c'est toujours root qui ultimement effectue le montage des volumes dans Ubuntu.

Si on ne veut pas ce comportement et l'on veut attribuer la propriété des fichiers et dossiers du volume CIFS à un autre utilisateur (par exemple, ton compte d'utilisateur à toi), Il faut donc préciser une option à mount: l'option uid.

//server/partage  /media/partage  cifs  rw,user,username=utilisateur,password=motdepasse,domain=mondomaine,uid=TonIdentifiantSousUbuntu  0 0


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#7 Le 01/02/2012, à 12:14

lobo

Re : [Résolu] Montage samba via fstab

Bonjour,
et merci pour cette réponse car en respectant rigoureusement les options, cela marche désormais.

Merci à tous les deux pour votre aide.


"Il faut cueillir les cerises avec la queue. J'avais déjà du mal avec les mains !"- Coluche

Hors ligne

#8 Le 02/02/2012, à 15:02

Coeur Noir

Re : [Résolu] Montage samba via fstab

Ha... J'aimerais arriver au même résultat, monter au démarrage de mon ubuntu 10.04 des dossiers partagés qui se trouvent sur un pc sous winXP pro. Comme la discussion est récente je me permets l'incruste, bien qu'elle est résolue.

Je souhaite aussi modifier le /etc/fstab mais j'ai un souci avec la syntaxe à cause des noms d'ordi et de partage : ils contiennent des espaces, des accents, des majuscules...

L'ordi "distant" sous XP s'appelle LEPALACE
Les partages sur cet ordi s'appellent Bureau Frédéric et LE PALACE

Mon petit doigt me dit que si j'écris :

//LEPALACE/Bureau Frédéric /media/partage etc...
ou
//LEPALACE/LE PALACE etc...

ça va coincer ?

J'arrive à me connecter à ces dossiers partagés via samba en passant par raccourcis > signets, après avoir renseigné le mot de passe (qui n'est jamais retenu pour toujours, sans doute parce que j'utilise connexion automatique au démarrage du pc ubuntu)

Qu'en pensez-vous ?


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#9 Le 02/02/2012, à 16:27

Coeur Noir

Re : [Résolu] Montage samba via fstab

Mon actuel fstab :

#Entry for Bureau Frédéric
//LEPALACE/"Bureau Frédéric"     /media/Bureau_Frederic     cifs     _netdev,credentials=/root/.smbcredentials     0     0
#Entry for LE PALACE
//LEPALACE/"LE PALACE"     /media/Le_Palace     cifs     _netdev,credentials=/root/.smbcredentials     0     0

conséquence : message d'erreur au démarrage une erreur est survenue lors du montage de Frédéric" et une erreur est survenue lors du montage de PALACE"


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#10 Le 02/02/2012, à 17:06

demonipuch

Re : [Résolu] Montage samba via fstab

Essayez en remplaçant les espaces par \040 :

//LEPALACE/LE\040PALACE

Hors ligne

#11 Le 02/02/2012, à 17:17

Coeur Noir

Re : [Résolu] Montage samba via fstab

ô merveille, ça marche !

A titre d'exemple, extrait de mon fstab :

#Entry for Bureau Frédéric
//LEPALACE/Bureau\040Frédéric     /media/Bureau_Frederic     cifs     rw,uid=XXXXX,_netdev,credentials=/root/.smbcredentials     0     0
#Entry for LE PALACE
//LEPALACE/LE\040PALACE     /media/Le_Palace     cifs     rw,uid=XXXXX,_netdev,credentials=/root/.smbcredentials     0     0
#Entry for Docs Julie
//DHRFP92J/Julie     /media/Docs_Julie     cifs     rw,uid=XXXXX,_netdev,credentials=/root/.smbcredentials     0     0
#Entry for Bureau Julie
//DHRFP92J/Bureau\040Julie     /media/Bureau_Julie     cifs     rw,uid=XXXXX,_netdev,credentials=/root/.smbcredentials     0     0

Résolu, bis, donc !

Dernière modification par Coeur Noir (Le 02/02/2012, à 17:23)


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#12 Le 02/02/2012, à 17:22

demonipuch

Re : [Résolu] Montage samba via fstab

oui rw,uid

Dernière modification par demonipuch (Le 02/02/2012, à 17:23)

Hors ligne

#13 Le 05/02/2012, à 23:40

Coeur Noir

Re : [Résolu] Montage samba via fstab

Oh ! Et tiens, le fait de préciser "uid=machin" a une conséquence très intéressante : il permet de mettre des fichiers à la corbeille, et non plus seulement de les supprimer directement. Fonctionne aussi sur un montage en ntfs-3g...


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#14 Le 07/02/2012, à 15:38

Coeur Noir

Re : [Résolu] Montage samba via fstab

L'ordre des "options" a-t-il une importance ?

Vaut-il mieux mettre _netdev en premier par exemple ?

Peut-on ajouter errors=remount-ro ? Et où ?


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#15 Le 07/02/2012, à 16:12

demonipuch

Re : [Résolu] Montage samba via fstab

Coeur Noir a écrit :

L'ordre des "options" a-t-il une importance ?

Aucune importance

Hors ligne

#16 Le 07/02/2012, à 17:04

Coeur Noir

Re : [Résolu] Montage samba via fstab

à priori le errors=remount-ro ne fait pas ce que je croyais :

http://www.debian-fr.org/fstab-errors-r … 19917.html

C'est que parfois le montage ne se fait pas ou pas complètement (ressource occupée).

Je fais alors un sudo mount -a et c'est bon.

Je souhaiterais qu'il y ait une autre tentative de montage automatique :

errors=remount-rw ???


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne