Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#276 Le 09/12/2010, à 14:59

pem1664

Re : [Tuto] Bilan : comment récupérer des données perdues

Vi, j'ai essayé mount sur les 2 /dev/md0 et /dev/md0p1 avec md0 il me dit qu'il ne connait pas le type de fichier (linux_raid_autodetect) et avec le m0p1 il me dit que y'a de gros problemes de superblocks..
Quand tu me dit y acceder sous testdisk cad? rentrer dans le repertoire? non je n'ai acces qu'a l'option copier, je ne peux pas rentrer dans un des repertoires (genre vidéo a trier , je peux le copier (c) mais pas me déplacer pour voir ce qu'il y a dedans. C'est pas normal?

edit : bon.. je viens d'essayer la copie... "copie done (failed to copies some files)" hmm
c'est mort?
sad

Dernière modification par pem1664 (Le 09/12/2010, à 15:21)


Pas de problème sans solutions, mettre [résolu] dans son premier post permet de rechercher plus facilement une solution... ;)

Hors ligne

#277 Le 10/12/2010, à 00:09

rmy

Re : [Tuto] Bilan : comment récupérer des données perdues

Je crois bien que tu as du faire des dégâts avec ton fsck… ou bien que effectivement tes disques ne sont pas dans le bon ordre… Je ne peux pas grand chose de plus pour toi malheureusement. À réception de tes disques, fais une image à l'identique de chacun d'eux avec ddrescue, tu pourra ensuite essayer librement les différentes options sans faire plus de dégâts…

Hors ligne

#278 Le 10/12/2010, à 00:18

Hoper

Re : [Tuto] Bilan : comment récupérer des données perdues

Bonjour.

Je ne vais malheureusement pas pourvoir t'aider beaucoup... Au mieux je pourrai essayer de te montrer ou, à mon avis, se sont située tes plus grosses erreurs.


donc si c'est bien défini,


Et oui, ta réflexion est bonne. "Si c'est bien défini". Or, au lieu définir toi même comment créer le raid0 a l'aide d'une commande mdadm, tu as fait confiance à une interface graphique sad


(Et oui, la personne qui à indiqué cet outil dans la documentation est un idiot, probablement encore un gars qui s'imagine qu'on doit absolument pouvoir tout faire en mode graphique... Et bien voila ce que ca donne).


Bref que sait tu de cet outil graphique ? comment a t'il créer ton raid exactement ? taille de stripe et compagnie ? Tu n'en sais rien. Donc il est évidement difficile ensuite de ré-assembler le raid avec mdadm puisque tu n'a pas la moindre idée des bonnes options (et moi non plus).


Deuxième erreure, gravissime celle la :


hoper@scorpion:~$ mdadm --build --help
Usage:  mdadm --build device -chunk=X --level=Y --raid-devices=Z devices

 This usage is similar to --create.  The difference is that it creates
 a legacy array without a superblock. 

Alors, non seulement --build fait comme --create (autrement dit, il détruit tout) mais en plus, il construit un array un peu "crade" qui ne contient pas de superblock, et donc pas de meta donnés pour expliquer comment fonctionne le raid. Bref, je ne vois, a l'heure actuelle et avec mes faibles connaissances sur le sujet, AUCUN cas ou l'usage d'un --build peut etre intéresant (il y en a forcément sinon l'option n'existerai pas). Mais la, en l'occurance, c'était la pire des choses à faire. Pour ne pas détruire tes données, il ne fallait utiliser que le --assemble.


Enfin, pourquoi diable à tu voulu faire du raid0 !? As tu un tel besoin de performance !? La vitesse en lecture/écriture d'un seul disque (plusieurs dizaines de Mo/s quand même, ne te suffisait pas ?) Le raid0 est la solution la moins fiable (et de très loin) pour stocker des données. Tu multiplie par plus de deux le risque de perdre TOUTE tes informations par rapport à l'usage normal d'un disque. Dans ton cas, si il te fallait absolument une volumétrie de 4 To, alors c'est avec LVM qu'il fallait concaténer (et pas stripper !) les deux disques.


Voila... J'ai vraiment peur que tes données soient détruites. Et j'en suis navré. Mais c'était un risque que tu devais forcément être près à courir, sinon tu n'aurai pas fait du raid0...


Mes tutos et coups de gueule :
http://hoper.dnsalias.net/atdc/
Mastodon: @hoper@framapiaf.org

Hors ligne

#279 Le 10/12/2010, à 00:42

chopinhauer

Re : [Tuto] Bilan : comment récupérer des données perdues

pem1664 a écrit :

C'est assez étrange: si je fais un testdisk /dev/md0 il me trouve une taille de disque de 4To et des données a récuperer alors que si je fais un testdisk /dev/md0p1 il me trouve une taille de disque de 2,2To et testdisk ne trouve plus rien dedans..

Il faut que tu te rappelles de comment t'avais créé ton ensemble RAID, si et comment tu l'avais partitionné. En regardant la taille des disques, c'est normal que /dev/md0p1 fasse 2,2 Tio : les partitions MS-DOS ne peuvent pas faire plus. Et vu que t'as Linux comme type de partition et pas GPT, cela me fait penser que tu n'utilisais pas de table de partition sur le RAID et que celle que tu vois c'est le reste d'une autre installation.

Est-ce que tu peux refaire le

dd if=/dev/sdg1 bs=512 skip=2 count=1 | hd

sans le 'grep' de toute à l'heure ? Ce qui est sur est que /dev/sdh1 ne contient pas le début d'un système de fichiers ext2, l'autre je ne sais pas.

Pour tester le système de fichiers sur ton RAID utilise plutôt

e2fsck /dev/md0

pas la peine d'utiliser fsck qui essaie de deviner le système de fichiers.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#280 Le 10/12/2010, à 14:11

pem1664

Re : [Tuto] Bilan : comment récupérer des données perdues

Merci à vous trois pour vos réponses, meme si j'espérais une solution miracle!
Alors, je ne sais pas par ou commencer..
Je me lance :
A l'origine j'avais pour but de faire deux serveur de données un pour l'usage courant et l'autre (caché) pour faire la sauvegarde avec du mirroring réseau en raid1, j'ai pas eu le temps de faire mon 2eme serveur que j'avais déja bousillé les array du premier, c'est pour ca que j'avais choisi le raid0. Comme ca non seulement j'avais un acces rapide au serveur mais en plus j'avais de grosses partitions pour faire le stockage, j'aurai bien aimé faire du raid5 mais je n'avais pas assez de disques (il m'en aurai fallu au moins un de plus)
J'ai utilisé palimpset, a l'origine pour créer mon raid, la taille des blocs etaient de 512k puis j'ai formaté direct en ext2.
De ce que j'ai lu mdadm crée par défaut des tailles de blocs de 64k donc quand je fait mon build  je devrais peut etre préciser que --chunk=512?
Avant de faire un --build j'avais essayé de faire --assemble avec toutes les options imaginable, j'ai bien potassé le man de mdadm avant de poster, mais je crois avoir résumé toutes mes manip dans mon premier post (#265).
La premiere grosse bourde, c'est au niveau de l'installation d'ubuntu serveur, lors du partitionnement j'ai fait "gerer les raid" et je n'ai pas vu d'option pour réutiliser un raid existant, juste créer, ce que j'ai fait et j'ai tout arrété lorsqu'il m'as demandé de formater mon raid.
Y'avait bien l'option "gerer les disques avec LVM" mais comme ce n'etait pas ce que j'ai fait a la base, je ne m'en suis pas servi (a tort peut etre)

chopinhauer a écrit :

En regardant la taille des disques, c'est normal que /dev/md0p1 fasse 2,2 Tio : les partitions MS-DOS ne peuvent pas faire plus. Et vu que t'as Linux comme type de partition et pas GPT, cela me fait penser que tu n'utilisais pas de table de partition sur le RAID et que celle que tu vois c'est le reste d'une autre installation.

Il faudrait que tu me réexplique ca, je n'ai pas compris.. Les 2 disques de 2To etaient neuf et le seul travail que j'ai fait sur les disques c'est de créer l'array avec palimpset puis de le formater en ext2, il devait bien y avoir une table de partition?

Quand j'ai recréé mon array j'ai systématiquement utilisé l'option --assume-clean qui, si j'ai bien compris permet a mdadm de considérer que le raid a déja été construit et manipulé et donc évite de trop toucher a la structure.
voila ce que donne la commande dd que tu m'as demandé :

pem@Server-Atelier:~$ sudo dd if=/dev/sdi1 bs=512 skip=2 count=1 | hd
1+0 enregistrements lus
1+0 enregistrements écrits
512 octets (512 B) copiés, 0,000629587 s, 813 kB/s
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00000200
pem@Server-Atelier:~$ sudo dd if=/dev/sdj1 bs=512 skip=2 count=1 | hd
00000000  00 00 00 00 00 00 00 00  00 00 00 00 b6 8f 93 d1  |................|
00000010  d2 41 1c 80 00 00 00 00  b9 97 9f e4 00 00 00 00  |.A..............|
00000020  00 00 00 00 00 00 00 00  00 00 00 00 a1 b5 8e a3  |................|
00000030  60 00 c4 60 90 b7 0a 0c  bc af e4 ce 00 00 6f 7b  |`..`..........o{|
00000040  00 00 00 00 00 00 00 00  00 00 00 00 d0 00 50 3a  |..............P:|
00000050  02 14 3c 87 f6 af e3 0f  e3 9f e4 5c 00 00 51 bb  |..<........\..Q.|
00000060  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000070  01 2e 88 1c 00 00 4d ae  3c 45 fb b5 00 00 01 e2  |......M.<E......|
00000080  00 00 00 00 00 00 00 00  00 00 00 00 c3 3a 10 f0  |.............:..|
00000090  09 05 4c 5f 8d 4f d9 ed  ff f1 5d ff 00 00 fc ab  |..L_.O....].....|
000000a0  00 00 00 00 00 00 00 00  00 00 00 00 3d 5e e9 4b  |............=^.K|
000000b0  23 bd f4 2f e4 7f 7e 3f  c8 7f c9 ff 00 00 fd aa  |#../..~?........|
000000c0  00 00 00 00 00 00 00 00  00 00 00 00 d2 6b c9 bd  |.............k..|
000000d0  29 7c 88 a1 90 b7 0c 0c  a4 18 ac a0 00 00 4e 8b  |)|............N.|
000000e0  00 00 00 00 00 00 00 00  00 00 00 00 fc 72 b5 27  |.............r.'|
000000f0  b1 48 40 32 a7 85 53 12  fa 70 8f c9 00 00 c1 d1  |.H@2..S..p......|
00000100  00 00 00 00 00 00 00 00  00 00 00 00 a4 96 54 73  |..............Ts|
00000110  fe 98 10 f1 00 00 00 00  e1 37 03 35 00 00 00 00  |.........7.5....|
00000120  00 00 00 00 00 00 00 00  00 00 00 00 ab f5 8a 23  |...............#|
00000130  c8 d7 78 aa 9e 17 e2 91  22 82 0a 11 00 00 5e 11  |..x.....".....^.|
00000140  00 00 00 00 00 00 00 00  00 00 00 00 ed 04 92 61  |...............a|
00000150  c3 e6 9c 6f e4 a9 af bb  ec 92 ef e3 00 00 bd de  |...o............|
00000160  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000170  03 a7 e4 7e 00 00 0e 0b  1d 87 d0 28 00 00 54 52  |...~.......(..TR|
00000180  00 00 00 00 00 00 00 00  00 00 00 00 20 5b 9e d4  |............ [..|
00000190  82 c4 80 43 1d 0d 26 f1  61 1c 76 2d 00 00 85 aa  |...C..&.a.v-....|
000001a0  00 00 00 00 00 00 00 00  00 00 00 00 c3 0c 00 00  |................|
000001b0  fe 17 50 29 3f 65 3a 4c  fe 64 f8 24 00 00 00 00  |..P)?e:L.d.$....|
000001c0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
1+0 enregistrements lus
1+0 enregistrements écrits
512 octets (512 B) copiés, 0,00132417 s, 387 kB/s
00000200

les lettres de lecteur changent a chaque redémarage, je ne sais pas pourquoi habituellement il ne faisait pas ca..

Dernière modification par pem1664 (Le 10/12/2010, à 14:23)


Pas de problème sans solutions, mettre [résolu] dans son premier post permet de rechercher plus facilement une solution... ;)

Hors ligne

#281 Le 10/12/2010, à 14:51

chopinhauer

Re : [Tuto] Bilan : comment récupérer des données perdues

pem1664 a écrit :

Il faudrait que tu me réexplique ca, je n'ai pas compris.. Les 2 disques de 2To etaient neuf et le seul travail que j'ai fait sur les disques c'est de créer l'array avec palimpset puis de le formater en ext2, il devait bien y avoir une table de partition?

Sur les disques, oui, sur l'ensemble RAID probablement pas. Sinon t'aurais eu une partition de 2,2 Tio seulement ou le type de partition aurait du être GPT.

Si t'as utilisé le format de métadonnées par défaut de md (0.9) ton système de fichiers aurait du commencer au début d'une des deux partition qui constituent l'ensemble. Hélas, cela ne semble pas le cas, donc ton système de fichier a dût être au moins partiellement détruit.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#282 Le 10/12/2010, à 15:04

pem1664

Re : [Tuto] Bilan : comment récupérer des données perdues

C'est pas la manip que tu m'as fait faire hier avec fdisk -l /dev/sdX1?

pem@Server-Atelier:~$ sudo fdisk -l /dev/sdi1

Disque /dev/sdi1: 2000.4 Go, 2000396289024 octets
2 têtes, 4 secteurs/piste, 488378000 cylindres
Unités = cylindres de 8 * 512 = 4096 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x00000000

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdi1p1   *           3   536870914  2147483647+  83  Linux
pem@Server-Atelier:~$ sudo fdisk -l /dev/sdj1

Disque /dev/sdj1: 2000.4 Go, 2000396289024 octets
255 têtes, 63 secteurs/piste, 243200 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x070a02a7

Le disque /dev/sdj1 ne contient pas une table de partition valide

ca me donne le premier disque du raid soit sdi la non?

Dernière modification par pem1664 (Le 10/12/2010, à 15:05)


Pas de problème sans solutions, mettre [résolu] dans son premier post permet de rechercher plus facilement une solution... ;)

Hors ligne

#283 Le 10/12/2010, à 15:09

chopinhauer

Re : [Tuto] Bilan : comment récupérer des données perdues

Oui, on suppose que les chunks sont assez grands, donc le début d'une des deux périphérique doit être le début de l'ensemble RAID. Sur un des deux disques t'as une table de partitions MS-DOS qui est limitée à 2,2 Tio (2^32 blocs). Si t'avais mis une table de partitions sur l'ensemble, elle aurait été de type GPT qui consiste d'une table de partitions MS-DOS pour compatibilité qui contient une seule partition de la dimension du disque et type gpt.

Du coup tu n'as pas utilisé GPT ce qui rend fort probable que la partition soit fausse.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#284 Le 10/12/2010, à 15:19

pem1664

Re : [Tuto] Bilan : comment récupérer des données perdues

Ok, merci, je crois avoir compris, donc palimpset ne m'a pas créé une table pour l'ensemble du raid mais 1 table pour le premier disque et rien sur le second, c'est l'assemblage et le type de partition qui disait ou pointer pour les données?
qu'est ce que je peux faire? si je recrée une array avec la bonne taille de blocs (--chunk=512) et que je ne refait pas de table de partition il devrait me reconstruire l'array de la meme facon qu'au début?


Pas de problème sans solutions, mettre [résolu] dans son premier post permet de rechercher plus facilement une solution... ;)

Hors ligne

#285 Le 10/12/2010, à 15:27

chopinhauer

Re : [Tuto] Bilan : comment récupérer des données perdues

Regarde comment est fait un ensemble RAID 0 : c'est en alternance un morceau du premier disque et un morceau du deuxième. La table des partitions (si existe) se trouve au début de l'ensemble RAID, donc au début du premier disque.

Mais vu que aucun des deux disque n'a pas de table des partitions valide (celle qui est affichée probablement n'est pas la bonne), on peut en déduire que t'avais un système de fichier ext2 directement sur le RAID, pas une sous-partition. Un système de fichiers ext2 est caractérisé par la séquence 0x53 0xef à l'octet 1080. Ce n'est pas le cas pour aucune des deux disques.

Du coup quelque chose de mauvais c'est passé sur tes disques.


Pensez à donner un bon titre à vos sujets : cela permettra d'aider d'autres utilisateurs dans votre même situation. Ce n'est pas qu'en donnant des solutions qu'on aide, mais aussi en posant des bonnes questions et… facilement trouvables.

Hors ligne

#286 Le 11/12/2010, à 21:16

andso

Re : [Tuto] Bilan : comment récupérer des données perdues

Hoper a écrit :

Bonjour.

Voila... J'ai vraiment peur que tes données soient détruites. Et j'en suis navré. Mais c'était un risque que tu devais forcément être près à courir, sinon tu n'aurai pas fait du raid0...

roll
y' a une mise en garde dans la doc?
Couillon je suis, je zieute.
Ou l' art de ne rien dire....

J'ai utilisé palimpset, a l'origine pour créer mon raid

jamais compris l' intérêt de ce "truc" (et hyper dangereux)


IMPORTANT: Booster votre (X et K)ubuntu: http://forum.ubuntu-fr.org/viewtopic.php?id=241092 (pfou!...)
à essayer, et... demain debian? http://fr.wikipedia.org/wiki/Demain_les_chiens
demain les biens? mes biens biens? t' exagére ... la banque!

Hors ligne

#287 Le 12/12/2010, à 00:30

Hoper

Re : [Tuto] Bilan : comment récupérer des données perdues

y' a une mise en garde dans la doc?

Même si il n'y en avait pas (j'ai franchement la flemme d'aller voir) c'est quelque chose qui tombe sous le sens.


A partir du moment ou tu fais du raid, tu dois choisir un niveau de raid. Et la, soit tu choisit "au pif" (mais alors pourquoi faire du raid si tu ne sais pas ce que tu cherche à améliorer !?) soit tu choisit un niveau de raid précis. Ici en l'occurance c'est le niveau zéro qui à été choisit. Ce choix implique une connaissance des caractéristiques du raid0. Et a partir du moment ou tu comprend le minimum (les données sont réparties sur les deux disques), alors il n'y a pas besoin de réfléchir beaucoup pour comprendre à quel point c'est dangereux pour les données.


jamais compris l' intérêt de ce "truc" (et hyper dangereux)

Tu ne peux pas savoir à quel point on est d'accord la dessus.

Dernière modification par Hoper (Le 12/12/2010, à 00:31)


Mes tutos et coups de gueule :
http://hoper.dnsalias.net/atdc/
Mastodon: @hoper@framapiaf.org

Hors ligne

#288 Le 12/12/2010, à 01:31

rmy

Re : [Tuto] Bilan : comment récupérer des données perdues

à la décharge de pem, son intention se défend, il a dit vouloir faire du 0+1… le problème c'est qu'il a perdu les données avant, quoi…

Sinon, pour revenir au sujet, @pem1664, as tu reçu tes disques ? As-tu tenté une image, un create, et le reste ?

Hors ligne

#289 Le 12/12/2010, à 12:17

pem1664

Re : [Tuto] Bilan : comment récupérer des données perdues

Merci rmy, à l'origine c'est bien ce que je voulais faire, je suis bien conscient du risque du raid0 mais pour faire du raid5 il me fallait au minimum 3 disques de 2To ce que je n'avais pas, ma plus grosse erreur dans tout ca c'est d'avoir été radin sur le materiel.. wink
J'attend mes disques avant de continuer comme tu m'as suggéré, ils devraient etre la mardi avant 13h.. "patience et longueur de temps..."
Apres pour le débat sur les outils, c'est sur que tout faire en ligne de commande c'est mieux, mais bon y'en a qui ont développé des interfaces graphique pour que ce soit plus confortable, normalement pour le commun des utilisateurs ca devrait suffire, et d'ailleurs avant que je ne ré install mon systeme ca fonctionnait tres bien..


Pas de problème sans solutions, mettre [résolu] dans son premier post permet de rechercher plus facilement une solution... ;)

Hors ligne

#290 Le 16/12/2010, à 17:46

fr-loic

Re : [Tuto] Bilan : comment récupérer des données perdues

Bonjour,

J'ai fais une bêtise, j'ai mis à jour mon téléphone et il m'a tout supprimé et j'avais pas fais de sauvegarde avant...
Savez-vous comment je puisse utiliser foremost sur mon nokia e65? Je n'ai pas de carte mémoire, tout est dans la mémoire du téléphone...

Infiniment merci à celui qui pourra me venir en aide hmm


La liberté n'a de valeur que partagée → Into the wild

Hors ligne

#291 Le 16/12/2010, à 20:22

rmy

Re : [Tuto] Bilan : comment récupérer des données perdues

Oo ça risque d'être chaud. Quels sont les types de fichiers que tu veux récupérer ?
Foremost est obsolète je crois, c'est scalpel qui a pris le relais il me semble.
Photorec couvre plus de types de fichiers dans sa config par défaut je crois.

Que se passe-t-il quand tu branches ton téléphone en usb : est-ce un montage auto ? Si oui, donne le retour de mount… Je ne suis pas sûr que tu puisses faire une image du téléphone facilement…

Hors ligne

#292 Le 16/12/2010, à 21:26

fr-loic

Re : [Tuto] Bilan : comment récupérer des données perdues

Merci de ton aide, c'est essentiellement des photos, quand je branche le téléphone j'ai stockage de masse usb (mais ca me marque que j'ai pas de carte mémoire et donc ca ne marche pas) et sinon j'ai le mode PC Suite.

J'ai utiliser Gammu/Wammu (connection = at115200) mais y'a rien pour naviguer dans la mémoire du téléphone.

Il faudrait que j'arrive à monter le téléphone sous ubuntu... galère...

lsusb
Bus 005 Device 003: ID 0421:0508 Nokia Mobile Phones E65 (PC Suite mode)

Dernière modification par fr-loic (Le 16/12/2010, à 21:34)


La liberté n'a de valeur que partagée → Into the wild

Hors ligne

#293 Le 17/12/2010, à 03:35

rmy

Re : [Tuto] Bilan : comment récupérer des données perdues

Peut-être en faisant une connection par bluetooth et en regardant ou est monté "C" :
http://www.ugov.be/wiki/index.php?title … _Nokia_E65

Hors ligne

#294 Le 17/12/2010, à 13:59

fr-loic

Re : [Tuto] Bilan : comment récupérer des données perdues

Merci, je peux avec le bluetooth explorer le téléphone mais tout est vide hmm
Voici l'emplacement: "obex://[00:17:E3:E1:90:40]/C:"
J'ai essayé une simple commande dessus mais ca ne marche pas :

ls obex://[00:17:E3:E1:90:40]/C:/Data 
ls: impossible d'accéder à obex://[00:17:E3:E1:90:40]/C:/Data: Aucun fichier ou dossier de ce type

Une idée? Merci en tout cas.


La liberté n'a de valeur que partagée → Into the wild

Hors ligne

#295 Le 17/12/2010, à 23:24

rmy

Re : [Tuto] Bilan : comment récupérer des données perdues

Non, pas trop…
tu as regardé du côte de obexfs et obexftp ? L'idée serait de pourvoir accéder à ton mobile exactement comme si c'était un "matériel de type bloc". Ce qu'il faut, ce n'est pas y voir des données (ls et nautilus) mais faire une image à l'identique de son système de fichier… (dd / ddrescue)/

à tout hasard, que donne :

dd if="obex://[00:17:E3:E1:90:40]/C:" bs=512 count=1 | hd

Hors ligne

#296 Le 21/12/2010, à 22:08

keul007

Re : [Tuto] Bilan : comment récupérer des données perdues

Salut,

voulant récupérer 300 GB de  données sur un DD (pas endommagé )  identifié comme inconnu dans l'utilitaire de disque (suite à une mauvaise manipulation avec le cd supergrub), je suis arrivé sur cet excellent TUTO.

J'ai réussi à créer un fichier .img de 300GB en utilsant ddrescue et dd_rhelp , par contre impossible de le monter, lorsque je fait :

sudo mount dossierrecup/marecup.img /mnt/pointmontage/recup -o loop -t iso9660

j'ai le message d'erreur suivant :

mount : mauvais type de syst. de fichiers, option erronée, super bloc
        erroné sur /dev/loop0, page de code ou aide manquante, ou autre erreur
       Dans quelques cas certaines informations sont utiles dans syslog - essayez
       dmesg | tail  ou quelque chose du genre

Pareil avec gmount .  Quelqu'un sait comment monter ce type d'image ?

Dernière modification par keul007 (Le 21/12/2010, à 22:09)

Hors ligne

#297 Le 22/12/2010, à 01:42

rmy

Re : [Tuto] Bilan : comment récupérer des données perdues

Oui… tu as fait une image du disque et non de la partition.

Si tu veux monter l'image de la partition il faut placer un offset avec losetup. Sinon le mieux serait peut-être de réparer le MBR ?

Donne le retour de :

sudo sfdfisk -luS dossierrecup/marecup.img

et le retour de

sudo testdisk dossierrecup/marecup.img

(Début + QuickSearch)

Hors ligne

#298 Le 22/12/2010, à 13:30

keul007

Re : [Tuto] Bilan : comment récupérer des données perdues

Salut rmy ,

ubuntu@ubuntu:~$ sudo apt-get install sfdfisk
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet sfdfisk

Tu es sûr que ça s'écrit comme ça ? ou alors ça s'installe manuellement depuis un site ?

Sinon est-il possible de récupérer ses données à partir d'une image du disque ?
Réparer le MBR me semble difficile vu que windows a pris mon disque d'assaut en commençant une installation dessus sans me laisser le choix du disque ...
testdisk début :

Select a media (use Arrow keys, then press Enter):
Disk dossierrecup/marecup.img - 320 GB / 298 GiB

[Proceed ]  [  Quit  ]

testdisk Quick search :

Disk dossierrecup/marecup.img - 320 GB / 298 GiB - CHS 38914 255 63

     Partition                  Start        End    Size in sectors


No partition found or selected for recovery

[  Quit  ]  [Deeper Search]

Voici mon fdisk -l :  (le disque en question /dev/sda)

Disque /dev/sda: 400.1 Go, 400088457216 octets
255 têtes, 63 secteurs/piste, 48641 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x000e954e

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1               1       46668   374852608   83  Linux
/dev/sda2           46668       48642    15856641    5  Etendue
/dev/sda5           46668       48642    15856640   82  Linux swap / Solaris

Disque /dev/sdb: 320.1 Go, 320072933376 octets
255 têtes, 63 secteurs/piste, 38913 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0x06bdc935

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1   *           1          13      102400    7  HPFS/NTFS
La partition 1 ne se termine pas sur une frontière de cylindre.
/dev/sdb2              13       38914   312466432    7  HPFS/NTFS

Voici le log de ddrescue :

=== COMPUTED VERSION OF LOG :
chunk:
logcontent:
eof:nothing
=== parsing at 0k, for 0k, max continuous err: 2.5k >>> ===
dd_rescue: (info): ipos: 312571216.0k, opos: 312571216.0k, xferd: 312571216.0k
                   errs:      0, errxfer:         0.0k, succxfer: 312571216.0k
             +curr.rate:    21094kB/s, avg.rate:    26072kB/s, avg.load:-13.6%
dd_rescue: (info): /dev/sda (312571224.0k): EOF
Summary for /dev/sda -> dossierrecup/marecup.img:
dd_rescue: (info): ipos: 312571224.0k, opos: 312571224.0k, xferd: 312571224.0k
                   errs:      0, errxfer:         0.0k, succxfer: 312571224.0k
             +curr.rate:      190kB/s, avg.rate:    26072kB/s, avg.load:-13.6%
=== COMPUTED VERSION OF LOG :
chunk:0-312571224.0
logcontent:ipos=312571224.0:xferd=312571224.0:NR:errxfer=0.0:succxfer=312571224.0
eof:312571224.0

Merci bcp pour ton aide .

Dernière modification par keul007 (Le 22/12/2010, à 15:58)

Hors ligne

#299 Le 22/12/2010, à 18:00

rmy

Re : [Tuto] Bilan : comment récupérer des données perdues

oups, c'est sfdisk, pas sfdfisk…

dans ton fdisk c'est /dev/sdb qui fait 320G… es-tu sûr que tu veux récup sur le /dev/sda (400G) ?

Redonne le

sfdisk -luS dossierrecup/marecup.img

(normalement pas besoin de l'installer, il existe par défaut)
et le Deepersearch de testdisk…

Peux-tu donner aussi plus d'infos sur le type de partitions recherchées, et ce qui s'est passé exactement avec ton install windows… Qu'as-tu écrasé exactement ?

Hors ligne

#300 Le 22/12/2010, à 18:46

keul007

Re : [Tuto] Bilan : comment récupérer des données perdues

Oui les données que je veux récupérer sont (ou était) sur le 320GB.


(normalement pas besoin de l'installer, il existe par défaut)
et le Deepersearch de testdisk…

c'était une partition NTFS du disque entier que je pouvais utiliser à la fois sous windows et sous linux .

sfdisk -luS dossierrecup/marecup.img

Disque dossierrecup/marecup.img : impossible d'obtenir la géométrie

Disque dossierrecup/marecup.img : 38913 cylindres, 255 têtes, 63 secteurs/piste
Unités= secteurs de 512 octets, décompte à partir de 0

   Périph Amorce  Début       Fin   #secteurs Id  Système
dossierrecup/marecup.img1             0         -          0   0  Vide
dossierrecup/marecup.img2             0         -          0   0  Vide
dossierrecup/marecup.img3             0         -          0   0  Vide
dossierrecup/marecup.img4             0         -          0   0  Vide

Le Deepersearch :

Disk dossierrecup/marecup.img - 320 GB / 298 GiB - CHS 38914 255 63
     Partition               Start        End    Size in sectors

Structure: Ok.


Keys A: add partition, L: load backup, Enter: to continue

Je pense que ce qui c'est passé c'est qu' en bootant avec le cd de win7 j'ai choisi le mauvais disque dur, et il a commencé à installer sur celui contenant mes données.  J'ai toujours le fichier img du disque sinon.
Le disque avait une partition déclarée "inconnue" par l'utilitaire de disque.  Win7 a écrit sur ce même disque (donnée perdues ?)

Dernière modification par keul007 (Le 23/12/2010, à 14:45)

Hors ligne