Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 17/02/2007, à 12:00

aTx

apt-get inutilisable a cause d'un package

Bonjour,
Il a fallut que je mette a jour libstdc++ jsais plus pourquoi mais je n'ai plus besoin de la faire, et depuis que j'ai tenté de faire cette mise a jour, voilà ce qui se passe a chaque fois que je tente d'installer un packet :

E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
atx@atx-desktop:~/Desktop$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Reading state information... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libstdc++2.10-glibc2.2
Les NOUVEAUX paquets suivants seront installés :
  libstdc++2.10-glibc2.2
0 mis à jour, 1 nouvellement installés, 0 à enlever et 19 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 329ko dans les archives.
Après dépaquetage, 1384ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o

Si je fais o :

Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://archive.ubuntu.com edgy/universe libstdc++2.10-glibc2.2 1:2.95.4-24 [329kB]
329ko réceptionnés en 0s (694ko/s)
(Lecture de la base de données... 107268 fichiers et répertoires déjà installés.)
Dépaquetage de libstdc++2.10-glibc2.2 (à partir de .../libstdc++2.10-glibc2.2_1%3a2.95.4-24_i386.deb) ...
dpkg : erreur de traitement de /var/cache/apt/archives/libstdc++2.10-glibc2.2_1%3a2.95.4-24_i386.deb (--unpack) :
tentative de remplacement de « /usr/lib/libstdc++-3-libc6.2-2-2.10.0.so », qui appartient aussi au paquet libstdc++2.10
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libstdc++2.10-glibc2.2_1%3a2.95.4-24_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et je ne peux plus rien installer... Que faire svp ?

Merci.

Hors ligne

#2 Le 17/02/2007, à 13:10

reeth

Re : apt-get inutilisable a cause d'un package

A ta place je ferai un :

sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install

(je ne garanti pas que sa va marcher, je n'ai jamais eu ce problème)

Hors ligne

#3 Le 17/02/2007, à 14:40

copernic2006

Re : apt-get inutilisable a cause d'un package

Bonjour
Essaye avec la commande suivante :
sudo dpkg --configure -a

J'espère que ça t'aidera smile

Hors ligne

#4 Le 17/02/2007, à 16:06

aTx

Re : apt-get inutilisable a cause d'un package

Merci pour vos réponses, cela n'a rien changé malheuresement sad

voilà ce que ca me met copernic :

$ sudo dpkg --configure -a
dpkg : des problèmes de dépendances empêchent la configuration de libstdc++2.10-dev :
libstdc++2.10-dev dépend de libstdc++2.10-glibc2.2 (>= 1:2.95.4) ; cependant :
  Le paquet libstdc++2.10-glibc2.2 n'est pas installé.
dpkg : erreur de traitement de libstdc++2.10-dev (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libc6-dev :
libc6-dev dépend de libc6 (= 2.4-1ubuntu12) ; cependant :
  La version de libc6 sur le système est 2.4-1ubuntu12.3.
dpkg : erreur de traitement de libc6-dev (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de g++-2.95 :
g++-2.95 dépend de libstdc++2.10-dev (>= 1:2.95.4) ; cependant :
Le paquet libstdc++2.10-dev n'est pas encore configuré.
dpkg : erreur de traitement de g++-2.95 (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
libstdc++2.10-dev
libc6-dev
g++-2.95

Quand j'ai fait apt-get -f install :

sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Reading state information... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libc6-dev libstdc++2.10-glibc2.2
Paquets suggérés :
  glibc-doc manpages-dev
Les NOUVEAUX paquets suivants seront installés :
  libstdc++2.10-glibc2.2
Les paquets suivants seront mis à jour :
  libc6-dev
1 mis à jour, 1 nouvellement installés, 0 à enlever et 20 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 2181ko dans les archives.
Après dépaquetage, 1384ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://fr.archive.ubuntu.com edgy-updates/main libc6-dev 2.4-1ubuntu12.3 [1852kB]
Réception de : 2 http://archive.ubuntu.com edgy/universe libstdc++2.10-glibc2.2 1:2.95.4-24 [329kB]
2181ko réceptionnés en 2s (958ko/s)
(Lecture de la base de données... 107433 fichiers et répertoires déjà installés.)
Dépaquetage de libstdc++2.10-glibc2.2 (à partir de .../libstdc++2.10-glibc2.2_1%3a2.95.4-24_i386.deb) ...
dpkg : erreur de traitement de /var/cache/apt/archives/libstdc++2.10-glibc2.2_1%3a2.95.4-24_i386.deb (--unpack) :
tentative de remplacement de « /usr/lib/libstdc++-3-libc6.2-2-2.10.0.so », qui appartient aussi au paquet libstdc++2.10
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Préparation du remplacement de libc6-dev 2.4-1ubuntu12 (en utilisant .../libc6-dev_2.4-1ubuntu12.3_i386.deb) ...
Dépaquetage de la mise à jour de libc6-dev ...
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libstdc++2.10-glibc2.2_1%3a2.95.4-24_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Merci

Dernière modification par aTx (Le 17/02/2007, à 16:07)

Hors ligne

#5 Le 17/02/2007, à 16:48

copernic2006

Re : apt-get inutilisable a cause d'un package

As tu essayé l'option réparer les paquets casés de synaptic (Menu Edition) ??
Il est fort possible qu'il va te proposer d'effacer les paquets récalcitrants

Hors ligne

#6 Le 18/02/2007, à 10:48

aTx

Re : apt-get inutilisable a cause d'un package

ah, désolé, jsuis sur kubuntu et j'ai adept manager, je ne vois aucune option concernant la réparation des paquets.

Hors ligne