Contenu | Rechercher | Menus

#1 Le 27/01/2013, à 01:12

DonutMan75
Membre

[RESOLU] [raspberry pi] Apt get qui ne fonctionne pas :(

Bonjour,
en plus de ma machine sous Ubuntu, j'ai récemment investi dans un petit Raspberry dont je suis très content.

J'ai récemment voulu ajouter le paquet "nut" (voir : http://doc.ubuntu-fr.org/nut) et là ce ne fonctionne pas du tout.... sad

Avez-vous une suggestion ?

Merci d'avance smile))

Donut

 $ sudo apt-get install nut nut-usb
[sudo] password for Donut:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'nut-server' instead of 'nut-usb'
The following extra packages will be installed:
  libupsclient1 nut-client
Suggested packages:
  nut-cgi nut-snmp nut-dev nut-xml
The following NEW packages will be installed:
  libupsclient1 nut nut-client nut-server
0 upgraded, 4 newly installed, 0 to remove and 91 not upgraded.
Need to get 1,750 kB of archives.
After this operation, 3,417 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libupsclient1 armhf 2.6.4-1
  404  Not Found
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main nut-client armhf 2.6.4-1
  404  Not Found
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main nut-server armhf 2.6.4-1
  404  Not Found
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main nut all 2.6.4-1
  404  Not Found
Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/n/nut/libupsclient1_2.6.4-1_armhf.deb  404  Not Found
Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/n/nut/nut-client_2.6.4-1_armhf.deb  404  Not Found
Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/n/nut/nut-server_2.6.4-1_armhf.deb  404  Not Found
Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/n/nut/nut_2.6.4-1_all.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

edit modo : titre + déplacement

Dernière modification par DonutMan75 (Le 28/01/2013, à 08:36)

Hors ligne

#2 Le 27/01/2013, à 03:11

Vikin712
Invité

Re : [RESOLU] [raspberry pi] Apt get qui ne fonctionne pas :(

BonJour.

404  Not Found

#3 Le 27/01/2013, à 03:32

nesthib
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Re : [RESOLU] [raspberry pi] Apt get qui ne fonctionne pas :(

@Vikin712 : une réponse un peu plus claire serait la bienvenue, n'oublie pas qu'il y a beaucoup de débutants sur le forum wink (surtout qu'en l'état ta réponse n'apporte pas de solution et ne permet pas de comprendre le problème)

@DonutMan75 : il semble que tu aies mélangé dépôts debian et ubuntu. Peux tu donner le contenu du fichier /etc/apt/sources.list ?

Hors ligne

#4 Le 27/01/2013, à 20:36

DonutMan75
Membre

Re : [RESOLU] [raspberry pi] Apt get qui ne fonctionne pas :(

Bonsoir Nesthib,
merci pour cette piste.

Voici le contenu du fichier en question :

$ more /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi

Il n'a pas l'air bien gros... Mais je suis sous wheezy... Il faut peut-être que je rajoute d'autres lignes (il s'agit des fameux dépôts ?) ?

Merci à tous et bonne soirée smile

Donut

Hors ligne

#5 Le 27/01/2013, à 21:06

nesthib
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Re : [RESOLU] [raspberry pi] Apt get qui ne fonctionne pas :(

OK j'avais lu un peu vite, il s'agit de ton Raspberry pi… dans ce cas je pense que tu devrais demander sur un forum spécialisé. Je n'ai aucune idée de comment sont gérés les dépôts.

NB. je déplace dans le café

Hors ligne

#6 Le 28/01/2013, à 08:35

DonutMan75
Membre

Re : [RESOLU] [raspberry pi] Apt get qui ne fonctionne pas :(

Bonjour Nesthib,

bon en fait j'ai trouvé, à la fin de mon apt-get install, il m'a écrit :

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

J'ai donc testé un

$ sudo apt-get update

puis lorsque j'ai retenté l'install de nut, ça a fonctionné parfaitement Oo'

Je n'ai aucune idée de ce qu'il s'est passé... Faudrait que je prenne le temps de comprendre un peu ce qu'il se passe derrière un apt-get install ^^
Enfin bref, le problème est résolu.

Merci et bonne journée wink

Donut

Hors ligne

#7 Le 28/01/2013, à 09:42

Epehj
Membre

Re : [RESOLU] [raspberry pi] Apt get qui ne fonctionne pas :(

Si tu modifies ton fichier de source pour avoir accès à un nouveau paquet, il faut ensuite mettre à jour la liste des fichiers disponibles pour apt ; c'est ce que tu fais en utilisant la commande apt-get update smile
A exécuter après chaque modification de ton sources.list !


Linux user #447629 - Ubuntu user # 21770
C'est en sciant que Léonard devint scie

Hors ligne