Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/10/2013, à 15:03

Vaykadji

[Résolu]13.10 laptop : fermeture du capot = veille

Bonjour,

Sur mon eeePC, j'ai installé Xubuntu 13.10 (64bits) et je me retrouve face à un problème du gestionnaire d'alimentation :
- Malgré que j'ai choisi "ne rien faire lors de la fermeture du capot" pour empêcher la mise en veille lorsque je rabats l'écran, il se met tout de même en veille.

Le problème semble concerner xfce4-power-manager, comme si le panneau de configuration n'arrivait pas à modifier les paramètres du paquet.

Est-ce que vous auriez une solution ? C'est extrêmement embêtant de ne pas pouvoir refermer son écran sans que le PC ne se mette en veille. Merci smile

Dernière modification par Vaykadji (Le 21/10/2013, à 00:16)

Hors ligne

#2 Le 19/10/2013, à 15:28

kurapika29

Re : [Résolu]13.10 laptop : fermeture du capot = veille

Effectivement je viens de tester et il se mets en veille forcé , sûrement un bug qu'il va falloir rapporté wink


Disponible sur IRC, sur le serveur irc.freenode.net salon ##ubuntu-voyager (et aussi sur plein d'autre serveur/salon)
Venez si vous avec besoin d'aide ou pour causer ;) suffit d'avoir Xchat ou un autre client IRC
Où sinon en cliquant sur se lien http://kiwiirc.com/client/irc.freenode. … tu-voyager

Hors ligne

#3 Le 21/10/2013, à 00:15

Vaykadji

Re : [Résolu]13.10 laptop : fermeture du capot = veille

Solution trouvée :

1) éditer /etc/systemd/logind.conf

sudo mousepad /etc/systemd/logind.conf

2) dé-commenter les lignes suivantes (retirer la # qui est devant) et ajouter '=ignore'

HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore

3) sauvegarde (ctrl-s) et redémarrer.

=> TADAAAM.

note : normalement seule la ligne HandleLidSwitch sert à contrôler l'action du capot (le "lid", en anglais), mais j'ai préféré changer toutes les options, y compris les touches physiques veille/arrêt/veille prolongée, car mettre "ignore" revient lors d'une pression sur ces touches à afficher seulement le choix des options, selon la commande "xfce4-session-logout", et non pas directement s'éteindre/entrer en veille

Dernière modification par Vaykadji (Le 21/10/2013, à 00:17)

Hors ligne

#4 Le 11/02/2017, à 04:06

MathieuMQc

Re : [Résolu]13.10 laptop : fermeture du capot = veille

Vaykadji a écrit :

Solution trouvée :

1) éditer /etc/systemd/logind.conf

sudo mousepad /etc/systemd/logind.conf

2) dé-commenter les lignes suivantes (retirer la # qui est devant) et ajouter '=ignore'

HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore

3) sauvegarde (ctrl-s) et redémarrer.

=> TADAAAM.

note : normalement seule la ligne HandleLidSwitch sert à contrôler l'action du capot (le "lid", en anglais), mais j'ai préféré changer toutes les options, y compris les touches physiques veille/arrêt/veille prolongée, car mettre "ignore" revient lors d'une pression sur ces touches à afficher seulement le choix des options, selon la commande "xfce4-session-logout", et non pas directement s'éteindre/entrer en veille

Merci ça ma été utile !

Hors ligne