Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 12/02/2015, à 06:54

Korak

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Sais-tu démarrer le PC en session Live (Essayer Ubuntu sans l'installer)?


OS: Ubuntu 22.04 64 bits + Windows 11 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP 17-CP0308NF   Processeur: AMD Ryzen 7 5700U avec carte graphique AMD Lucienne intégrée au processeur.   Mémoire vive: 16 Go RAM
Quand vous ne trouvez pas la solution à un problème, cherchez des pistes menant à la solution !

Hors ligne

#27 Le 12/02/2015, à 10:02

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Oui, sans soucis

Hors ligne

#28 Le 12/02/2015, à 17:48

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Mais ensuite ? Que puis-je faire ?
J'ai l'impression que ce problème informatique n'inspire pas grand monde... Ce soir, je suis là, si quelqu'un veut bien faire avancer le schmilblick, ça me serait d'un grand secours !
Merci

Hors ligne

#29 Le 12/02/2015, à 20:29

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Bon, je vais me coucher sans avoir eu une seule réponse en 6 heures... Il faut que j'ouvre un nouveau sujet ? Mes autres soucis informatiques ont suscité plus d'émulation ! On verra bien demain, bonne nuit ! (en même temps, je dois pas tomber dans les meilleures heures, avec mon décalage horaire de +3 heures)

Hors ligne

#30 Le 13/02/2015, à 01:20

Babdu89

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Bonjour ou Bonsoir.
Est-ce que tu peux refaire un boot info stp.

Tu dis avoir réinstallé...

Dans les deux précédents boot info, comme il t'en à été fait la remarque.

On voit que tu as installé ton Ubuntu en mode Bios.
Disque dur partitionné en mode MSDOS.
Donc lors de l'installation tu as certainement du désactiver le mode UEFI pour installer.
Ou alors, tu ne t'es pas soucier de ce problème de mode UEFI , la machine étant lancée en mode Bios_Legacy.

Ta clé live /sdb est bien une clé compatible UEFI.

Dans tes boot info, on voit ceci ;

=================== UEFI/Legacy mode:
BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot maybe enabled. (maybe sec-boot, Please report this message to boot.repair@gmail.com)

Çà veut dire que ta machine démarre en mode UEFI pour la session live.

Donc l'UEFI est activé. Donc çà a été changé, on passe du mode de démarrage Bios_Legacy en mode UEFI.

On voit aussi ceci;

=================== Advices
The boot of your PC is in EFI mode, but no EFI partition was detected. You may want to retry after creating a EFI partition (FAT32, 100MB~250MB, start of the disk, boot flag).
Do you want to continue?

Le système rappelle que pour la session live Ubuntu est lancé en mode UEFI.
Mais qu'il ne trouve pas la partition  FAT32 /boot/efi  qui normalement devrait re présente.

Il n'y en a pas, puisque l'installation est faite en mode Bios_Legacy.

Tu continues, avec la réparation recommandée, qui propose de faire ceci.

=================== Recommended repair
The default repair of the Boot-Repair utility will reinstall the grub2 of sda1 into the MBR of sda.
Additional repair will be performed: unhide-bootmenu-10s

C'est normalement ce qu'il faut faire pour réinstaller grub.
La réparation se fait et Boot-Repair considère qu'il a bien fait son travail ...

Seulement, la session live est lancée en mode UEFI, pour réparer un système installé en mode Bios_Legacy ...

Le souci ne venait-il  pas de là?...

Alors comme tu as réinstallé sans succès... Un nouveau boot info sera le bien venu, pour essayer de comprendre,  où on en est maintenant... Merci de le faire.

@+.  Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#31 Le 13/02/2015, à 10:50

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Salut et merci de te préoccuper de mon problème.
Pour la réinstallation, j'ai suivi le post de malbo sur un sujet plus ancien :
http://forum.ubuntu-fr.org/viewtopic.ph … #p19218211
post #8
Pour ce qui est du boot-info, le voici :
http://paste.ubuntu.com/10201366/
Je reviens plus tard dans l'après-midi, merci de m'expliquer où le bât blesse ?

Hors ligne

#32 Le 13/02/2015, à 13:00

Babdu89

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Bonjour.

Je pense que ton souci est encore là...

http://forum.ubuntu-fr.org/viewtopic.ph … #p19218211

Des idées pour relancer ma machine ? Fallait-il refaire la table de partition ? J'ai utilisé Gparted sur la clé live usb pour supprimer et refaire les partitions comme indiqué ci-dessus mais je n'ai pas osé créer une nouvelle table de partition. Est-ce que cela pourrait réparer mon bug ?
Dans le menu de démarrage de ma clé, il y a possibilité de faire une sorte de check disc qui me renvoie une erreur sans rien me proposer par la suite...

Oui, comme le montre le boot info , tu n'as pas fais ta réinstallation en mode UEFI correctement...

Tu dis toi même que tu n'as pas osé changer la table de partitions. (MSDOS pour GPT).

Ton disque /dev/sda est partitionné avec une table de partition qui est restée en MSDOS. Alors qu'il aurait fallu la réécrire en type GPT,( avec Gparted) avant de réinstaller...

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1    *          2,048       411,647       409,600   b W95 FAT32
/dev/sda2             411,648    30,597,119    30,185,472  83 Linux
/dev/sda3          30,597,120    34,693,119     4,096,000  82 Linux swap / Solaris
/dev/sda4          34,693,120   976,773,119   942,080,000  83 Linux
sda	:551    not-GPT,	BIOSboot-not-needed,	has-correctEFI, 	not-usb,	has-os,	2048 sectors * 512 bytes

Une installation en mode UEFI nécessite un hdd avec une table de partitions de type GPT. pas MSDOS.


Dommage que tu n'aies pas osé réécrire la table de partition en type GPT...

Comme l'autre sujet est un file où  malbo est intervenu, je pense que l'on va le voir intervenir ici, pour confirmer mes observations.

Il faut refaire l'installation, en changeant le type de table de partitions  (GPT) avec Gparted avant de réinstaller en mode UEFI.

@+.  Babdu89 .

Dernière modification par Babdu89 (Le 13/02/2015, à 13:47)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#33 Le 13/02/2015, à 14:14

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Ok, je me lance dans la troisième installation, avec nouvelle table de partition en gpt.
Ce qui m'étonne dans tout ça, c'est que le système a bien tourné pendant un mois, aucun soucis de démarrage, aucun bug. Et ce n'est qu'à la suite d'un redémarrage demandé suite à une mise à jour que plus rien ne fonctionnait...
Allez ! C'est parti !

Hors ligne

#34 Le 13/02/2015, à 15:13

Babdu89

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

glopykemon a écrit :

Ok, je me lance dans la troisième installation, avec nouvelle table de partition en gpt.
Ce qui m'étonne dans tout ça, c'est que le système a bien tourné pendant un mois, aucun soucis de démarrage, aucun bug. Et ce n'est qu'à la suite d'un redémarrage demandé suite à une mise à jour que plus rien ne fonctionnait...
Allez ! C'est parti !

Il y a un moment, il me semble avoir lu que des utilisateurs avaient des soucis suite à des mises à jour, avec un changement de noyau pour 3.13.0-45 ...

Moi je tourne avec ce noyau, et je n'ai pas de souci...

@+.  Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#35 Le 13/02/2015, à 16:10

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Ah... Il va me falloir jeter un oeil là-dessus... Car la 3ème réinstallation n'a rien changé, toujours l'écran noir. Il semblerait qu'il se passe des choses sur le disque dur, l'écran noir lumineux s'éteint assez rapidement, aucune réaction visuelle, seule la diode Disque dur réagit à l'appui sur une touche.
Voici le nouveau boot-info : http://paste.ubuntu.com/10204952/

Hors ligne

#36 Le 13/02/2015, à 16:35

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Merci pour l'info sur le noyau 3.13.0-45, j'ai trouvé ceci :
http://vxlabs.com/2015/02/05/solving-th … een-issue/

Et ils proposent ceci :

1- Switch to console (Ctrl-Alt-F1) and stop lightdm: sudo service lightdm stop

2- Disable gpu-manager by commenting out everything in /etc/init/gpu-manager.conf

3- Switch to nvidia mode by doing sudo prime-select nvidia

4- Change your /etc/X11/xorg.conf to look like the one at the bottom of this answer, making sure that the nvidia BusId is correct (check with lspci):

5- Start X up again with sudo lightdm start

Je vais donc commencer à tester ces commandes, en espérant que Ctrl+Alt+F1 fonctionne, sinon, puis-je lancer le terminal de la session live ?
Et je ne comprend pas bien le 2 : il faut lancer gedit et mettre des hashtags partout (ou les enlever) ?

Hors ligne

#37 Le 13/02/2015, à 16:59

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Bon, ça ne marche pas, je n'arrive pas à ouvrir le terminal à l'aveugle, je vais tester avec la clé Live usb

Hors ligne

#38 Le 13/02/2015, à 17:04

Babdu89

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Avant de faire des tests au sujet du noyau ...

Je pense qu'il vaut mieux attendre l'avis d'experts en UEFI .
Dans ton titre , en modifiant le post#1, veux tu bien ajouter (UEFI) .
Çà va attirer l'attention des spécialistes en installation UEFI, que je ne suis pas .
Voir, peut-être passer un MP a malbo pour lui indiquer ton sujet.

Edit;
Est ce que la machine démarre sur le noyau 3.13.0-32 ?

Veux tu bien aussi donner le nom complet de ta machine?  Post#1 c'est incomplet.

@+.   Babdu89  .

Dernière modification par Babdu89 (Le 13/02/2015, à 17:13)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#39 Le 13/02/2015, à 17:17

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Où puis-je trouver le nom complet de ma machine et comment savoir sur quel noyau elle démarre ?

Hors ligne

#40 Le 13/02/2015, à 17:33

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Ah, tu voulais le modèle exact ? C'est un Asus F200MA-BING-KX448B
D'autre part, j'ai testé sur la live usb :
- la commande service lightdm stop m'a bien ennuyée puisqu'elle m'a remis dans le noir (mais écran lumineux, comme au début de mes soucis), j'ai fini par réussir à rallumer la lumière après divers essais...
- j'ai mis des hashtags sur toutes les lignes du fichier gpu-manager.conf, un message s'est affiché dans le terminal (peut-être anodin) :

(gedit:4897): Gtk-warning **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

- la commande prime-select n'a pas été trouvée, j'ai donc sauté cette étape en attendant
- j'ai édité le fichier /etc/X11/xorg.conf qui était vide et j'y ai mis

Section "ServerLayout"
 Identifier "layout"
 Screen 0 "nvidia"
 Inactive "intel"
EndSection
 
Section "Device"
 Identifier "intel"
 Driver "modesetting"
EndSection
 
Section "Screen"
 Identifier "intel"
 Device "intel"
EndSection
 
Section "Device"
 Identifier "nvidia"
 Driver "nvidia"
 BusID "PCI:1:0:0"
EndSection
 
Section "Screen"
 Identifier "nvidia"
 Device "nvidia"
 Option "UseDisplayDevice" "None"
EndSection

- j'ai tenté le sudo chattr +i /etc/X11/xorg.conf et j'obtiens :

chattr: Inappropriate ioctl for device while reading flags on /etc/X11/xorg.conf

Je vais tenter un redémarrage...

Hors ligne

#41 Le 13/02/2015, à 17:53

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Pas de changement...

Hors ligne

#42 Le 13/02/2015, à 18:10

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Et comment fait-on pour envoyer un message privé à un membre du forum ? malbo n'a point mis d'email de contact... Comment faire pour attirer son attention ?

Hors ligne

#43 Le 13/02/2015, à 18:24

Babdu89

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

glopykemon a écrit :

Et comment fait-on pour envoyer un message privé à un membre du forum ? malbo n'a point mis d'email de contact... Comment faire pour attirer son attention ?

J'ai posté ce message de demande d'aide sur 3 ou 4 sujets où il est intervenu aujourd'hui ...


Bonjour.
@  malbo...

Stp, besoin d'un avis éclairé ici, si c'est possible ,merci.

http://forum.ubuntu-fr.org/viewtopic.ph … #p19224361

Merci.

@+.   Babdu89  .

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#44 Le 13/02/2015, à 19:41

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Merci, je n'ai plus qu'à attendre !

Hors ligne

#45 Le 13/02/2015, à 20:02

malbo

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Moi, je n'ai pas d'avis.

Hors ligne

#46 Le 13/02/2015, à 20:38

Bougron

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Bonsoir
Pour une raison que j'ignore, il semble que ubuntu ne réussisse pas à dialoguer  correctement  avec le bios

=================== efibootmgr -v
                                                                <<<<<<========== ici on ne trouve aucun fichier!
=================== UEFI/Legacy mode:
BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot maybe enabled. 

j'espère que boot-repair qui propose de reconstruire    saura mieux le faire.

Je te propose l'essai suivant
Booter via la cle USB   choisir  "essayer ubuntu avant de l'installer"
   Faire la commande
       

sudo efibootmgr -v

Afin de vérifier s'il n'y a rien ou quelque chose.
S'il n'y a rien, tu répares via boot-repair qui propose

=================== Suggested repair
The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of sda2, using the following options:        sda1/boot/efi,


Puis de nouveau , tu relance via la clé usb 'essayer avant d'installer....'
et tu refais la commande

sudo efibootmgr -v

afin de vérifier ce qu'il y à

En fait c'est bien étrange qu'une simple installation VLC provoque cette situation

Hors ligne

#47 Le 13/02/2015, à 21:38

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

* efibootmgr -v me renvoie rien,
* j'ai lancé un boot-repair (sans rentrer dans les options avancées) et voici l'URL: http://paste.ubuntu.com/10208833/
Et si je fais maintenant la commande efibootmgr, j'obtiens :

BootOrder: 0000
Boot0000* ubuntu HD(1,800,64000,... (plein de chiffres et lettres)...)File(\EFI\ubuntu\shimx64.efi)

Je redémarre mon ordi sans la clé, j'ai le choix entre
Ubuntu
Advanced options for Ubuntu
EFI/ubuntu/MokManager.efi

Je lance donc Ubuntu
je prie...
l'écran reste noir et lumineux qq secondes puis s'éteint... inéluctablement !
le voyant wifi reste allumé, ainsi qu'un voyant avec une ampoule et bien sûr la batterie.
Si j'appuie sur une touche, le voyant disque dur clignote.

C'est désespérant !
Je vais me coucher, la suite demain, si des idées vous traversent l'esprit...
Le lien du post #36 ne vous semble pas intéressant ?

Hors ligne

#48 Le 13/02/2015, à 23:21

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Tiens ! Je viens de remarquer un nouveau changement, qui n'a peut-être guère d'importance, mais je préfère le signaler au cas où ça parlerait à quelqu'un...
Dans le Bios, pour le choix du boot option, j'ai maintenant un [Windows boot manager...]
ça vous inspire ?

Hors ligne

#49 Le 13/02/2015, à 23:27

glopykemon

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

et si je refais efibootmgr (après l'avoir réinstallé via la logithèque), je n'obtiens plus rien
Bon, j'y comprend rien... Cet ordi est neuf, il a un mois. Vais-je devoir abandonner Linux pour essayer d'apprivoiser ce démon de Windows ? en espérant encore que j'arrive à remettre le pc dans son éta initial...

Hors ligne

#50 Le 14/02/2015, à 00:59

Bougron

Re : Ecran noir au redémarrage après mise à jour 3.13.0-45

Bonsoir
J'ai l'impression qu'à l'issue du post #47, tu es quasiment revenu    au niveau du post #1
       qui avait le problème    "libkmod error."  qui est un truc qui me semble fréquent sur internet
Au post #48, tu as revu windows.   Pas surprenant        vu ce que je constate de la réparation de boot-repair.   Il aurait ajouté les fichiers de boot de windows!
Ce que j'ai du mal à croire. Pourtant j'ai revérifié, ils n'étaient pas présents au post précédant.

     File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bootx64.efi /EFI/ubuntu/MokManager.efi 
                       /EFI/ubuntu/grubx64.efi /EFI/ubuntu/shimx64.efi 
                       /EFI/Microsoft/Boot/bootmgfw.efi 
                       /EFI/Microsoft/Boot/bootx64.efi                                      

Ton post#50 met en évidence le problème.
      En standard, ce micro ACER n'accepte qu'une seule fois de booter un autre OS que windows sans être réinitialisé.

La solution est d'appuyer sur une touche (F8?  F12? ESC?) au moment du boot, Tu devrais avoir la liste des OS qui sont lançables et tu pourras sélectionner ubuntu.

Dans cette discussion  on évoque le cas d'un micro avec windows viré avec utilisation de la touche F12
On bâti alors une entrée windows qui lance ubuntu http://forum.ubuntu-fr.org/viewtopic.php?id=1614641
   

  sudo efibootmgr -c -L "Windows Boot Manager" -l "\EFI\ubuntu\grubx64.efi"

    Mais il faut désactiver le secure boot

Dans cette discussion on cherche avec la touche F12 puis ESC puis ESC http://forum.ubuntu-fr.org/viewtopic.ph … #p19065011



Personnellement: je retiens que le boot fonctionne mais que ubuntu 14.04.1 ne sait plus traiter l'écran.
Comme tu as lancé en sélectionnant  la ligne
ubuntu
tu devrais recommencer en sélectionnant la ligne
Advanced options for Ubuntu
puis choisir un noyau.    Dans l'ensemble ce boot est plus bavard et pourrait indiquer une piste pour l'incident.

PS1. Si tu prévois de remettre windows, tu dois rester EFI. Sinon un retour en LEGACY, une conversion du disque en MSDOS et une réinstallation de ubuntu résoudra le problème de l'appui sur la touche F12.    Mais je ne suis pas partisan (pour le moment) de  cette solution car cela ne va pas résoudre le problème d'écran.

PS2. Est-ce exactement le même modèle que celui de cette discussion? http://forum.ubuntu-fr.org/viewtopic.php?id=1658111

Dernière modification par Bougron (Le 14/02/2015, à 13:56)

Hors ligne