Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/01/2017, à 19:31

Mehdinefrance

[Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Bonjour,

Je viens de faire l'acquisition d'une mini-PC Euler 4785T sans OS connecté via HDMI à un écran LED 27" Iiyama ProLite X2783HSU-B1.

J'ai créé une clé live-usb avec Ubuntu 16.04 (via le créateur de disque de démarrage depuis un autre ordinateur sous Ubuntu 16.10), l'installation s'est apparemment bien passée, j'ai fait les mises à jour et redémarré l'ordi... j'étais déjà dans la personnalisation de mon environnement de bureau quand je m'aperçois en haut à droite de l'écran le témoin du niveau de contraste/luminosité augmenter et diminuer, sans interruption.

Cela est gênant car continu et m'empêche par exemple d'accéder aux options des menus contextuels qui disparaissent tout de suite ; la veille de l'écran ne peut plus s'effectuer...

Voici mes premières initiatives :
J'ai commencé par réinstaller tout le système : même problème.
J'ai testé la projection sur vidéoprojecteur : même problème, mon écran n'est donc pas en cause.
J'ai testé la projection depuis un autre ordi sur mon écran et sur vidéoprojecteur : pas de problème, mon cable HDMI n'est donc pas en cause.
J'ai contacté mon revendeur-assembleur pour qui il s'agit d'un bogue du système d'exploitation et m'invite à contourner en ajoutant une gestion du rétro éclairage comme ici par exemple : https://doc.ubuntu-fr.org/retro-eclaira … on_de_grub
Je n'ai pas trouvé de problème similaire sur le forum.

Ah, et je ne sais pas si ça peut-être lié, j'ai constaté que dans les paramètres systèmes, sous l'onglet affichage, le système reconnaît deux écrans (le mini-PC et l'écran externe) et active deux espaces de travail par défaut... mais même en clonant les écrans, mon problème persiste...
EDIT : lorsque je désactive l'écran "built-in display", ce n'est plus la touche de contraste qui est activée en permanence (suppression du petit encart avec niveau de luminosité) mais vraisemblablement une autre touche car les symptômes demeurent... ils sont similaires à ceux rencontrés dans cet autre billet : https://forum.ubuntu-fr.org/viewtopic.php?id=1573461

Voilà, vous savez tout ! Si vous avez des idées, je suis preneur !

Merci et belle année à vous :-)

Alimentation : Adaptateur externe 19V
Carte mère : Asus q87t
Chipset graphique : Intel HD Graphics 4600
Chipset Principal : Intel H87
Chipset Processeur : Intel Core i7 4785T
Disque dur : SSD 500Go
Mémoire : 16 Go

Dernière modification par Mehdinefrance (Le 03/04/2018, à 18:08)

Hors ligne

#2 Le 03/01/2017, à 22:30

hibou7

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Salut Mehdinefrance,

la gestion de la carte graphique semble poser quelques problèmes sous Ubuntu.
Il y a plusieurs discussion s à ce sujet en tout cas.

Et des idées ici.

Dernière modification par hibou7 (Le 03/01/2017, à 22:30)


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio
Débuter en Console et d'autres vidéos.
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne

#3 Le 04/01/2017, à 01:05

Mehdinefrance

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Bonsoir hibou7 et merci de ta contribution, qui me permet de circonscrire le problème et de me focaliser sur la carte graphique.

J'ai pris connaissance de ton lien (en anglais) et ai compris que le problème de la personne était que la carte graphique n'acceptait pas la résolution maximale de son écran, bogue qu'elle a résolu en reparamétrant le fichier grub. Ces paramétrages ne sont pas encore à ma portée hmm et ce problème me semble quelque peu différent du mien, même si la solution se trouve peut-être au même endroit smile

Toutefois, il est mentionné dans le billet une tentative de mise à jour du pilote Intel, avec ce lien. J'ai donc téléchargé et installé l'outil de mise à jour "Intel Graphics Update Tool for Linux* OS v2.0.2", puis redémarré l'ordi après une mise à jour... mais rien ne semble avoir changé sad

Il y a d'autres pilotes dans un paquet intitulé "2016Q4 Intel Graphics Stack Recipe" mais je ne sais pas si je dois installer tout ça aussi... voici la capture d'écran :
paquet pilotes graphiques Intel Linux

Bon, je crois que je ne suis pas encore au bout de mes peines roll

Dernière modification par Mehdinefrance (Le 04/01/2017, à 01:07)

Hors ligne

#4 Le 04/01/2017, à 01:51

hibou7

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Désolé, on ne trouve vraiment rien sur ce phénomène..

La soluce proposée par olfred n'est pas si difficile.
Il suffit de modifier le fichier /etc/default/grub.
Si tu veux apprendre en vidéo, suis le lien dans mon profil, il y en a une qui explique comment éditer (=modifier) un fichier en mode administrateur. 

À La ligne

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

tu remplaces "quiet splash" par l'une des expressions indiquées.

As-tu déjà regardé chez Launchpad?

Dernière modification par hibou7 (Le 04/01/2017, à 01:52)


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio
Débuter en Console et d'autres vidéos.
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne

#5 Le 04/01/2017, à 12:46

Mehdinefrance

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Merci pour ces précisions et des liens vers les tutoriels vidéos : cela m'encourage à poursuivre !

Voici les retours obtenus en utilisant les différentes expressions à la place de "quiet splash" avec les droits d'administration, et après un sudo update-grub :

i915.modeset=0 : après enregistrement du fichier grub, la console me renvoie les lignes suivantes

** (gedit:6330): WARNING **: Set document metadata failed: La définition de l'attribut metadata::gedit-spell-enabled n'est pas prise en charge

** (gedit:6330): WARNING **: Set document metadata failed: La définition de l'attribut metadata::gedit-encoding n'est pas prise en charge

; pas de changement apparent après mise à jour du grub

i915.i915_enable_rc6=1 : retour console suivant

(gedit:6385): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:6385): WARNING **: Set document metadata failed: La définition de l'attribut metadata::gedit-spell-enabled n'est pas prise en charge

; problème persistant (menu contextuel impermanent) mais je viens de constater qu'il ne se produit pas dans le terminal, où je peux faire des clics droits à loisir... sûrement car l'environnement graphique y est plus léger ?!

EDIT : OK, je constate que le bogue ne se produit plus qu'avec le navigateur internet (Firefox) mais plus dans l'environnement bureau habituel, ce qui représente déjà une nette amélioration... je reprends confiance dans la réussite de l'entreprise smile

Ajout des paramètres supplémentaires suivants à la suite de "i915.i915_enable_rc6=1" :

* acpi_osi=linux -> pas de changement constaté
* acpi_backlight=vendor -> pas de changement constaté
* noalpic -> pas de changement constaté

EDIT : après installation de Chromium, je constate que rien d'anormal se produit : le problème est donc exclusivement sur Firefox, y compris en mode sans échec (désactivation des modules) hmm

(suite des essais à venir) tongue

Dernière modification par Mehdinefrance (Le 04/01/2017, à 13:37)

Hors ligne

#6 Le 05/01/2017, à 02:11

hibou7

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

J'ai lancé une recherche sur Launchpad mais rien trouvé qui corresponde.
https://launchpad.net/+search?field.act … 0&start=20

Tu as testé la proposition du revendeur-assembleur?

Encore une autre idée: tester une autre version du kernel.

Si tu lances une session LIVE avec par ex. un live_usb, as-tu le même problème?

Dernière modification par hibou7 (Le 05/01/2017, à 02:15)


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio
Débuter en Console et d'autres vidéos.
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne

#7 Le 05/01/2017, à 19:17

Mehdinefrance

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

hibou7 a écrit :

J'ai lancé une recherche sur Launchpad mais rien trouvé qui corresponde.
https://launchpad.net/+search?field.act … 0&start=20

De mon côté, je suis tombé sur ce billet qui propose un utilitaire pour déboguer les cartes graphiques Intel sur Linux : j'ai installé la version pour Xenial et l'ai lancée, mais pas d'amélioration remarquée...

hibou7 a écrit :

Tu as testé la proposition du revendeur-assembleur?

L'expression "quiet splash acpi_osi=Linux acpi_backlight=vendor" ne donne malheureusement rien :-(

hibou7 a écrit :

Encore une autre idée: tester une autre version du kernel.

OK, je note cette possibilité.

hibou7 a écrit :

Si tu lances une session LIVE avec par ex. un live_usb, as-tu le même problème?

Avec des sessions LIVE Ubuntu 16.04 et 16.10 (aussi bien en 32 ou 64 bits), le problème est le même que décrit au départ.
Avec une session Linux Mint 18, idem mais bizarrement, sous Linux Mint XFCE 17 (32bits), tout semble fonctionner correctement roll

Dernière modification par Mehdinefrance (Le 09/01/2017, à 19:00)

Hors ligne

#8 Le 05/01/2017, à 22:53

hibou7

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Bon, voilà un début de solution. Si le bureau Xfce te convient, c'est jouable.

Si ça t'intéresse, tu peux également tester Xubuntu 16.04 en LIVE.

Donc c'est un bogue du système, propre à Ubuntu. Si tu veux rendre service à la communauté, annonce le sur Launchpad. Ça doit les intéresser.

Dernière modification par hibou7 (Le 05/01/2017, à 22:54)


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio
Débuter en Console et d'autres vidéos.
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne

#9 Le 05/01/2017, à 23:11

Mehdinefrance

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

hibou7 a écrit :

Si ça t'intéresse, tu peux également tester Xubuntu 16.04 en LIVE.

Test effectué sous Xubuntu sans plus de succès.

hibou7 a écrit :

Donc c'est un bogue du système, propre à Ubuntu. Si tu veux rendre service à la communauté, annonce le sur Launchpad. Ça doit les intéresser.

Je contribuerai volontiers. J'imagine que je dois expliquer le topo en mettant le lien fil de cette discussion sur Launchpad.
Je ne manquerai de poster ici une éventuelle solution à venir.

Hors ligne

#10 Le 06/01/2017, à 02:04

hibou7

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Pour Launchpad, tu peux te lancer ici.


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio
Débuter en Console et d'autres vidéos.
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne

#11 Le 09/01/2017, à 19:18

Mehdinefrance

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

hibou7 a écrit :

Pour Launchpad, tu peux te lancer ici.

Voilà qui est fait ici : https://bugs.launchpad.net/launchpad/+bug/1655085

Hors ligne

#12 Le 03/04/2018, à 18:07

Mehdinefrance

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Bonjour,

Ouf, la solution à mon problème vient de m'être donnée par un linuxien (merci à lui big_smile !).

Elle se trouve sur cette page

En éditant le fichier suivant

/usr/share/X11/xorg.conf.d/10-quirks.conf

Pour y ajouter le code suivant :

Section "InputClass"
  Identifier "Spooky Ghosts"
  MatchProduct "Video Bus"
  Option "Ignore" "on"
  EndSection

Le problème (qui vient de la carte mère Asus) disparaît au redémarrage.

La manipulation est à prévoir lors de certaines mises à jour importantes ou lors d'une réinstallation.

Je marque donc le sujet comme "résolu".

Merci à la communauté !

Dernière modification par Mehdinefrance (Le 03/04/2018, à 18:07)

Hors ligne

#13 Le 03/04/2018, à 23:40

hibou7

Re : [Résolu] : Bogue suite à installation Ubuntu 16.04 sur Euler 4785T

Content pour toi smile
Ah oui, faire une recherche en anglais est souvent un bon réflexe...
Bravo pour tes rapports détaillés sur Launchpad.

Dernière modification par hibou7 (Le 03/04/2018, à 23:41)


Xubuntu 16.04.4 LTS à noyau 4.4 | CPU: Pentium 4, 3 GHz | CG: NVIDIA NV 34 | RAM: 3,5 Gio
Débuter en Console et d'autres vidéos.
Si GNU/Linux ne répond plus, le redémarrer proprement avec la combinaison de touches:
Alt + SysRq + REISUB (Retourne en Islande sur un bateau).

Hors ligne