Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/10/2018, à 18:56

duo737

chown impuissant !

Bonjour ,

sur une config dual-boot SSD  WIN + Ubuntu 18.4 , j'ai 1 HDD avec 2 partitons :
- sda1 , 250 GB , en NTFS pour partager les données , monté comme /mnt/DATA
-sda2 , 750 GB , en ext4 , monté comme /media/toto/Data Ubuntu

Les dossiers du volume DATA  appartiennent apparemment tous à 'root' , et lorsque j'y copie des fichiers  au départ de sda2 , ceux-ci automatiquement changent de propriétaire , deviennent 'root' et je n'y ai plus accès en tant que 'toto'.

Nautilus en mode sudo , ou la commande 'sudo chown toto dossier/ " changent le propriétaaire pendant une fraction de seconde , mais tout de suite celui-ci redevient root .

Quelle en l'est l'explication , et quelle serait la solution ?

Hors ligne

#2 Le 24/10/2018, à 22:06

metalux

Re : chown impuissant !

Bonsoir,
la raison vient du fait que /mnt/DATA est sur une partition NTFS qui ne gère pas les droits. Il faut passer par le fstab pour simuler ceux-ci.
Que veux-tu faire exactement? Copier des fichiers ou répertoires de /media/toto/Data Ubuntu vers /mnt/DATA et pouvoir y avoir accès en tant qu'utilisateur? Ou autre chose? Détaille ce que tu souhaites faire et donne les retours de:

sudo fdisk -l

ainsi que de:

sudo blkid

Dernière modification par metalux (Le 24/10/2018, à 23:17)

Hors ligne

#3 Le 24/10/2018, à 22:33

Bwice

Re : chown impuissant !

Bonsoir,
Serait-ce un problème de ce type?

erresse a écrit :

Il est possible, si le volume n'a pu se monter normalement, il peut avoir été remonté en lecture seule par le système lors du démarrage...
Comme tu indiques qu'il est en NTFS, est-il partagé avec Windows ?
Et, dans ce cas, n'est-il pas tout simplement resté verrouillé par Windows lorsque tu as quitté la session ?

El catala a écrit :

Vous aviez raison, je suis en dual boot avec Win10. Le dossier était resté bloqué par Win. Un allez et retour sur windows et s' est reparti. le problème est réglé.

Vue sur ce topic

Dernière modification par Bwice (Le 24/10/2018, à 22:34)


Ubuntu-Mate 18.04 LTS 64-bit | HP-Pavilion-15-Notebook-PC | AMD A4-6210 apu with amd radeon r3 graphics × 4
Upgrade => 1x Crucial SO-DIMM DDR3L 8 Go 1600 MHz 1,35 Volts | SSD Corsair Force Series LE - 480 Go SATA 3 (6 Gb/s)

Hors ligne

#4 Le 24/10/2018, à 23:00

Coeur Noir

Re : chown impuissant !

La piste de Metalux est la bonne ( ntfs, pas de gestion de droit, automatiquement attribué à root ).
Bwice ta proposition n'était pas idiote mais son symptôme est « pas d'accès aux partitions windows », ce qui n'est pas le cas ici ;-)

J'ajouterais

cat /etc/fstab

aux commandes précédemment proposées.

Actuellement ils ont été créés comment-par-quoi les points de montage /mnt/DATA et /media/toto/Data Ubuntu ?
Traditionnellement /mnt c'est pour du montage manuel ou temporaire et /media a un fonctionnement un peu particulier, avec des ACL pour les montages automatiques de périphériques de stockage « externes ».

Un /home/data_win et un /home/data_ubu seraient bien aussi… en assignant les droits utiles à ces dossiers ( proprio, groupes, qui lit, qui écrit… ) par exemple le groupe users ( gid = 100 ) en rwX si ces montages sont destinés à être partagés entre tous les utilisateurs d'Ubuntu.

Attention : nautilus en mode sudo c'est mal. À proscrire. Pour vérifier si ça n'a pas fait de dégâts :

ls -la /home/<toi>

en théorie tout t'appartient là-dedans, si tu y vois du root:root faudra te réapproprier ça…

Dernière modification par Coeur Noir (Le 25/10/2018, à 00:45)

Hors ligne

#5 Le 24/10/2018, à 23:39

metalux

Re : chown impuissant !

@Coeur Noir
Merci, c'est corrigé l'oubli de sudo.

Pour les droits, l'uid, le gid, l'umask,etc peuvent être avantageusement remplacés par l'option permissions qui je pense conviendrait, et qui permet une gestion multi-utilisateur.

Hors ligne

#6 Le 25/10/2018, à 00:10

Coeur Noir

Re : chown impuissant !

…c'est en fonction de ce que voudra faire duo737 - je ne connais pas l'option permissions, tu expliqueras ?

Hors ligne

#7 Le 25/10/2018, à 11:40

metalux

Re : chown impuissant !

@Coeur Noir
Bonjour,

man ntfs-3g a écrit :

permissions
              Set  standard  permissions  on  created  files  and use standard
              access control.  This option is set by default when a user  map‐
              ping file is present.

L'option permissions donne les droits par défaut comme si tu es dans ton $HOME et attribue comme propriétaire l'utilisateur actuel. Ça simplifie la mise en place dans /etc/fstab et ça permet une gestion multi-utilisateur avec chacun sa corbeille.
Suppose que tu as 2 utilisateurs,  Coeur Noir et metalux par exemple. Lorsque Coeur Noir est connecté, il a accès aux fichiers de la partition NTFS partagée en tant que propriétaire avec les droits par défaut. Si il supprime 1 fichier, il va dans la corbeille de Coeur Noir.
Maintenant metalux se connecte et veut consulter, modifier ou supprimer les fichiers de cette partition. Il n'a aucun souci car les fichiers appartiennent à metalux et non plus à Coeur Noir lorsque c'est metalux qui les consulte.
Dans le passé j'utilisais les options suivantes dans /etc/fstab, cependant celles-ci posaient des problèmes dans un environnement multi-utilisateurs pour avoir une gestion correcte de la corbeille:

uid=1000,gid=100,umask=002,utf8

J'utilise désormais ceci qui fonctionne même quand j'ajoute un utilisateur ultérieurement sans s'embêter avec l'uid et le gid.

permissions,utf8

Pour duo737, cela donnerait cette ligne dans /etc/fstab selon ses indications actuelles, en remplaçant de préférence /dev/sda1 par son UUID:

/dev/sda1    /mnt/DATA    ntfs    permissions,utf8    0    0

Hors ligne