Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/10/2019, à 15:06

PierroTheMad

[RESOLU] Chromium ne voit pas mon 2e disque dur

Bonjour,

Je suis sous

Ubuntu 19.10 (Eoan Ermine) 64-bit, Noyau Linux 5.3.0-19-generic x86_64, MATE 1.22.2

J'ai fait la migration de 19.04 vers 19.10 avec l'outil de mise à jour.

Auparavant (sous 19.04) Chromium ne posait pas de problème, il voyait bien mon 2e disque dur

/dev/sdb1 qui est monté sur /a

J'utilise Firefox avec Adblock et Chrumium sans pour les sites qui ne veulent pas Adblock.

Firefox 70.0 (64 bits)

voit clairement mon 2e disque dur dont j'ai fait un lien

ln -s /a /home/pierrot/Bureau/a
Chromium "Version 78.0.3904.70 (Build officiel) snap (64 bits)"

ne voit ni la partition "/a" ni "/home/pierrot/Bureau/a"

J'ai fait un : 

sudo apt-get purge chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg

J'ai supprimé tout ce qui pouvait être lié à Chromium dans les répertoire de mon Home

/home/pierrot/.cache/chromium
/home/pierrot/.config/chromium

J'ai réinstallé Chrumium

sudo apt-get install chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg

Mais toujours pas de 2e disque dur.
Quelqu'un a une idée ?

Merci d'avance
Pierrot

Dernière modification par PierroTheMad (Le 29/10/2019, à 00:04)

Hors ligne

#2 Le 27/10/2019, à 15:20

GammaDraconis

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Eh oui c'est normale, maintenant Chromium n'existe plus en paquet deb sous Ubuntu, c'est un snap obligatoire. Quand tu fais "apt install chromium" en réalité ça t'installe le paquet Snap et non le paquet Debian.
Avec le paquet snap il y a des restrictions qui s'applique notamment les partitions.
Pour modifier les permissions, tu dois aller dans Gnome Software puis tu tapes "Chromium", tu vas dans "Autorisation" et tu actives les lecteurs externes et ça devrai marcher (lecteur amovible il me semble).


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#3 Le 27/10/2019, à 18:40

kamaris

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Il te faut saisir cette commande dans un terminal :

sudo snap connect chromium:removable-media

J'ai comme l'impression qu'il va falloir la ressortir un paquet de fois cette commande-là…

Hors ligne

#4 Le 27/10/2019, à 19:56

PierroTheMad

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Merci pour vos réponses GammaDraconis et kamaris mais j'ai effectué l'une et l'autre de vos solutions mais ça ne fonctionne pas.

lorsque je lance Chromium dans un terminal et que j'essaie d'enregistrer sur mon 2e disque dur, dans la fenêtre "enregistrée sous..." de chromium je vois tous mes partitions et mon 2e disque dur et indiqué non montés (dans chromium uniquement) car il est bel et bien monté, je clique dessus et j'ai un crash de Chromium

GLib-GIO:ERROR:../../../../gio/gunixvolume.c:324:eject_mount_do: assertion failed (error == NULL): Failed to execute child process “mount” (Permission denied) (g-exec-error-quark, 3)
zsh: abort (core dumped)  chromium-browser

Après avoir fait les manipulation avec Gnome Software j'ai redémarrer Chromium, ça n'a pas fonctionné
Après

sudo snap connect chromium:removable-media

idem

J'ai même redémarrer mon ordi, au cas ou un démon de Chromium aurait empêcher la modif...

Je ne comprends pas

Hors ligne

#5 Le 27/10/2019, à 20:57

GammaDraconis

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Tu es sûr qu'il est bien monté avant de lancer l'interface de Chromium ?
Attention sous linux par défaut tes partitions ne sont pas monté automatiquement SAUF si tu l'a monté manuellement avant (en cliquant sur le lecteur) ou si tu as ajouté une ligne de mount dans ton fichier de config /etc/fstab.

Ce que je veux dire par là c'est que même si tu vois ton lecteur apparaitre dans ton gestionnaire de fichier à gauche, ça veux pas dire qu'il est monté, ça veux juste dire qu'il est détecté.
Pour vérifier si il est bien monté, tu peux lancer la commande :

df -h

si ton lecteur apparait bien avec le point de montage, c'est qu'il est monté.

2ème chose à vérifier : si ta partition est monté c'est une chose mais il faut aussi vérifier si tu as bien accordé les bons droits d'accès dessus (sudo chmod etc...), vérifier que tu peux créer des fichiers dedans.

Enfin si ça ne marche toujours pas dans chromium, essaye de faire un lien symbolique dans ton dossier perso et tu indiques ton lien symbolique dans chromium.

Par exemple si ton login c'est "pierro" et que ton lecteur est monté dans /media/partition_data, tu peux créer un lien symbolique comme ça :

ln -s /media/partition_data /home/pierro/partition_data

tu vérifie qu'en allant dans /home/pierro/partition_data tu as bien accès à ton lecteur (qui en réalité est monté dans /media/partition_data) et si c'est le cas, tu indiques dans chromium comme chemin : /home/pierro/partition_data (ds mon exemple, à toi d'adapter bien-sûr).

Dernière modification par GammaDraconis (Le 27/10/2019, à 21:00)


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#6 Le 27/10/2019, à 21:39

kamaris

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

@PierroTheMad : peux-tu donner le retour de

snap connections chromium

Si l'interface mount-observe n'est pas connectée, peut-être essayer

sudo snap connect chromium:mount-observe

Hors ligne

#7 Le 28/10/2019, à 00:21

PierroTheMad

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

GammaDraconis a écrit :

Tu es sûr qu'il est bien monté avant de lancer l'interface de Chromium ?
Attention sous linux par défaut tes partitions ne sont pas monté automatiquement SAUF si tu l'a monté manuellement avant (en cliquant sur le lecteur) ou si tu as ajouté une ligne de mount dans ton fichier de config /etc/fstab.

Ce que je veux dire par là c'est que même si tu vois ton lecteur apparaitre dans ton gestionnaire de fichier à gauche, ça veux pas dire qu'il est monté, ça veux juste dire qu'il est détecté.
Pour vérifier si il est bien monté, tu peux lancer la commande :

df -h

si ton lecteur apparait bien avec le point de montage, c'est qu'il est monté.

2ème chose à vérifier : si ta partition est monté c'est une chose mais il faut aussi vérifier si tu as bien accordé les bons droits d'accès dessus (sudo chmod etc...), vérifier que tu peux créer des fichiers dedans.

Enfin si ça ne marche toujours pas dans chromium, essaye de faire un lien symbolique dans ton dossier perso et tu indiques ton lien symbolique dans chromium.

Par exemple si ton login c'est "pierro" et que ton lecteur est monté dans /media/partition_data, tu peux créer un lien symbolique comme ça :

ln -s /media/partition_data /home/pierro/partition_data

tu vérifie qu'en allant dans /home/pierro/partition_data tu as bien accès à ton lecteur (qui en réalité est monté dans /media/partition_data) et si c'est le cas, tu indiques dans chromium comme chemin : /home/pierro/partition_data (ds mon exemple, à toi d'adapter bien-sûr).

Oui ma partition monte automatique au démarrage, elle est dans mon fstab.
Mon 1er disque dur est un SSD sur lequel il y a mon système
Mon 2e disque dur est un HDD sur lequel je stocke mes données
Lorsque j'affirme que seul chromium ne vois pas la partition c'est le cas, toutes mes autres applications voient ma partition.

pierrot@ideapad-330-15ARR ~ % df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
udev               3,7G       0  3,7G   0% /dev
tmpfs              757M    3,0M  754M   1% /run
/dev/sda2           19G     14G  3,8G  79% /
tmpfs              3,7G    104M  3,6G   3% /dev/shm
tmpfs              5,0M    4,0K  5,0M   1% /run/lock
tmpfs              3,7G       0  3,7G   0% /sys/fs/cgroup
/dev/loop2          72M     72M     0 100% /snap/software-boutique/31
/dev/loop1          55M     55M     0 100% /snap/core18/1223
/dev/loop3          45M     45M     0 100% /snap/gtk-common-themes/1353
/dev/loop4         8,0M    8,0M     0 100% /snap/pulsemixer/250
/dev/loop0          16M     16M     0 100% /snap/ubuntu-mate-welcome/420
/dev/loop5          90M     90M     0 100% /snap/core/7917
/dev/loop7         8,0M    8,0M     0 100% /snap/pulsemixer/23
/dev/loop6          90M     90M     0 100% /snap/core/7713
/dev/loop8         128K    128K     0 100% /snap/software-boutique/39
/dev/loop10         16M     16M     0 100% /snap/ubuntu-mate-welcome/411
/dev/loop9         158M    158M     0 100% /snap/chromium/909
/dev/sda1           47M    7,9M   39M  17% /boot/efi
/dev/sda3           92G     34G   54G  39% /home
/dev/sdb1          916G    500G  370G  58% /a
tmpfs              757M     68K  757M   1% /run/user/1000

Dernière modification par PierroTheMad (Le 28/10/2019, à 00:38)

Hors ligne

#8 Le 28/10/2019, à 00:24

PierroTheMad

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

kamaris a écrit :

@PierroTheMad : peux-tu donner le retour de

snap connections chromium

Si l'interface mount-observe n'est pas connectée, peut-être essayer

sudo snap connect chromium:mount-observe

Voici ce que donne la comme :

Interface                 Plug                               Slot                            Notes
audio-playback            chromium:audio-playback            :audio-playback                 -
audio-record              chromium:audio-record              -                               -
browser-support           chromium:browser-sandbox           :browser-support                -
camera                    chromium:camera                    :camera                         -
content[gtk-3-themes]     chromium:gtk-3-themes              gtk-common-themes:gtk-3-themes  -
content[icon-themes]      chromium:icon-themes               gtk-common-themes:icon-themes   -
content[sound-themes]     chromium:sound-themes              gtk-common-themes:sound-themes  -
cups-control              chromium:cups-control              :cups-control                   -
desktop                   chromium:desktop                   :desktop                        -
gsettings                 chromium:gsettings                 :gsettings                      -
home                      chromium:home                      :home                           -
mount-observe             chromium:mount-observe             :mount-observe                  manual
mpris                     -                                  chromium:mpris                  -
network                   chromium:network                   :network                        -
network-bind              chromium:network-bind              :network-bind                   -
network-manager           chromium:network-manager           -                               -
opengl                    chromium:opengl                    :opengl                         -
password-manager-service  chromium:password-manager-service  -                               -
personal-files            chromium:chromium-config           :personal-files                 -
pulseaudio                chromium:pulseaudio                :pulseaudio                     -
removable-media           chromium:removable-media           :removable-media                manual
screen-inhibit-control    chromium:screen-inhibit-control    :screen-inhibit-control         -
u2f-devices               chromium:u2f-devices               :u2f-devices                    -
unity7                    chromium:unity7                    :unity7                         -
upower-observe            chromium:upower-observe            :upower-observe                 -
x11                       chromium:x11                       :x11                            -

le fait qu'il soit indiqué "manual" serait la cause ?

Hors ligne

#9 Le 28/10/2019, à 00:33

kamaris

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Non, le manual indique juste que c'est toi qui a connecté l'interface par une demande explicite.
Si ça ne marche pas avec ça, je ne vois pas ce que c'est, mais ça ne me semble pas lié aux interfaces, même si encore une fois il te faut à coup sûr la connexion de removable-media pour pouvoir accéder à ton hdd.
Et comme j'ai testé dans un autre sujet (https://forum.ubuntu-fr.org/viewtopic.p … #p22169601) que le sudo snap install --classic chromium ne sert à rien, je ne sais plus trop quoi te dire hmm.

Hors ligne

#10 Le 28/10/2019, à 00:53

PierroTheMad

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

kamaris a écrit :

Non, le manual indique juste que c'est toi qui a connecté l'interface par une demande explicite.
Si ça ne marche pas avec ça, je ne vois pas ce que c'est, mais ça ne me semble pas lié aux interfaces, même si encore une fois il te faut à coup sûr la connexion de removable-media pour pouvoir accéder à ton hdd.
Et comme j'ai testé dans un autre sujet (https://forum.ubuntu-fr.org/viewtopic.p … #p22169601) que le sudo snap install --classic chromium ne sert à rien, je ne sais plus trop quoi te dire hmm.

Bon je crois que je lâche l'affaire je viens d'installer Falkon.
J'ai fait quelques tests avec et ça va peut-être convenir.

kamaris et GammaDraconis merci pour votre aide

Hors ligne

#11 Le 28/10/2019, à 01:21

kamaris

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

PierroTheMad a écrit :

J'utilise Firefox avec Adblock et Chrumium sans pour les sites qui ne veulent pas Adblock.

Tu peux peut-être aussi essayer de remplacer adblock par ublock origin dans firefox, et voir si les sites qui t'embêtaient passent mieux.

Hors ligne

#12 Le 28/10/2019, à 18:58

GammaDraconis

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Tu as essayé au moins avec un lien symbolique comme je t'ai indiqué ?

Juste une chose, désolé de te faire un peu la leçon mais c'est une erreur de ta part de faire un montage dans /a, ce n'est pas propre du tout, fais tes montages de partition soit dans /media soit dans /mnt.
Il est possible que les snaps interdisent formelement le montage directement dans un dossier à la racine. Fais déjà un montage propre, par exemple dans /mnt/data
et réessaye (ou /media/data).


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#13 Le 28/10/2019, à 19:10

kamaris

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Oui, ça c'est une bonne remarque :

https://snapcraft.io/docs/removable-media-interface a écrit :

removable-media allows read/write access to mounted removable storage in /media, /run/media and /mnt.

En dehors de ça, à mon avis, aucune chance, car comme je le disais plus haut :

$ sudo snap install --classic chromium
Avertissement : flag --classic ignored for strictly confined snap chromium

chromium 78.0.3904.70 par Canonical✓ installé
$

Dernière modification par kamaris (Le 28/10/2019, à 19:14)

Hors ligne

#14 Le 29/10/2019, à 00:04

PierroTheMad

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Merci

J'ai modifié mon fstab pour qu'il pointe vers /media/a, j'ai recréé mon lien

ln -s /media/a /hone/pierrot/Bureau/a

Et maintenant Chromium accepte enfin de voir mon 2e HDD et son raccourci sur le Bureau.

Lorsque l'on a 41 ans, qu'on est autodidacte sous GNU/Linux depuis 1998, les mauvaises habitudes ont la vie dure, et par fainéantise et/ou facilité je vais toujours au plus simple et au plus court, il fallait bien que ça finisse par me jouer des tours.

Encore MERCI à vous 2

Très bonne soirée kamaris et GammaDraconis

Hors ligne

#15 Le 29/10/2019, à 01:01

kamaris

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

Du coup, je pense que tu peux déconnecter l'interface mount-observe, qui ne doit pas avoir grand chose à voir dans cette histoire, contrairement à l'interface removable-media :

sudo snap disconnect chromium:mount-observe

Au pire, si ça ne marche plus, tu la remets. Et si tel est le cas, merci de le signaler ici, qu'on soit au courant wink.

Hors ligne

#16 Le 29/10/2019, à 12:58

PierroTheMad

Re : [RESOLU] Chromium ne voit pas mon 2e disque dur

kamaris a écrit :

Du coup, je pense que tu peux déconnecter l'interface mount-observe, qui ne doit pas avoir grand chose à voir dans cette histoire, contrairement à l'interface removable-media :

sudo snap disconnect chromium:mount-observe

Au pire, si ça ne marche plus, tu la remets. Et si tel est le cas, merci de le signaler ici, qu'on soit au courant wink.

J'ai effectué la commande

sudo snap disconnect chromium:mount-observe

et effectivement Chromium voit toujours mon 2e HDD, et me permets d'enregistrer ce que je veux dessus.

Voilà pour le retour.

Très bonne journée à toi  kamaris big_smile

Hors ligne