Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/03/2020, à 21:23

EsterFreyja

[RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bonjour,

Tout d'abord bien sûr désolé si ce topic n'est pas au bon endroit, c'est celui qui me semblait le plus approprié.
En suite, j'ouvre le mien parce que j'ai fait tous les forums FR et ENG en quête d'une solution que je n'ai pas trouvé.

Explications :

J'ai un pc qui sert de serveur de stockage et de serveur multimédia TV.
Puis j'ai mon pc dans ma chambre.

Au départ, c'était tout sous Windows. Le système de réseau local fonctionnait sans problème au Gigabit (donc ~114 Mo/s en réel) dans les deux sens.

En suite le serveur est passé en Ubuntu 19.10 desktop, et mon pc est en dual boot ubuntu 19.10 desktop/ Windows 10 Pro

Pour continuer à utiliser mon réseau comme avant, j'utilise samba. Ubuntu vers Ubuntu fonctionne dans les deux sens, et Windows vers Ubuntu fonctionne mais pas l'inverse, de toute manière ce n'est pas ce qui m'importe.

Le problème, c'est que peu importe l'OS et peu importe la direction du transfert, je me retrouve avec du 100Mbps (donc ~10Mo/s voir moins).
Sur les deux machines le matériel fonctionne puisque avant sous Win10 ça fonctionnait comme attendu. Et Sur les deux machines sous Ubu la connexion filaire est marquée comme 1000Gb/s. Les switch sont neufs et les câbles 5e sont un peu long mais les mêmes qu'avant sous Win10 donc ce n'est pas le problème.

J'ai essayé de triturer le smb.conf dans tous les sens, en pensant bien sûr à relancer le service samba sur les deux machines en même temps à chaque essai de modif, rien n'y fait. Je n'ai plus aucune idée de quoi faire, quoi essayer de modifier.

A noter que c'est le seul pépin que j'ai avec Ubuntu, tout le reste, même les configs d'imprimantes et scanner fonctionnent. C'est donc pour ça que c'est la première fois que je demande de l'aide.
Je fournirai les screens et les logs que vous demanderez bien sûr, et désolé si je ne suis pas assez clair.

Merci d'avance,

Ester

Dernière modification par EsterFreyja (Le 10/04/2020, à 14:45)

Hors ligne

#2 Le 29/03/2020, à 10:43

L_d_v_c@

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bonjour Ester.
Je ne vais peut-être pas pouvoir t'aider mais tu peux jeter un œil à cette page et essayer quelques tests.

https://doc.ubuntu-fr.org/trafic


Bogue -1 : Derrière chaque bogue se cache constamment la faille humaine.
Les programmes conçus par méthodes formelles ne bogueront JAMAIS et ils n'auront pas besoin de mise à jour corrective, puisque tout fonctionnera comme prévu.
Abandon des GNU/Linux disharmonieux pour un bien meilleur projet : Haiku !

Hors ligne

#3 Le 01/04/2020, à 20:26

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bon je viens de tester mon réseau local, en passant par les switch concernés, et j'ai ça : https://i.ibb.co/pR39pvw/Capture.jpg

(edit : on voit rien sur l'image, en montant il y a 11 Mo/s et en descendant environ 80Mo/s)

Comment c'est possible ? C'est asymétrique un RJ45 ? Ou est-ce qu'il y a des cartes réseau avec des protocoles asymétriques ?


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Dernière modification par cqfd93 (Le 01/04/2020, à 21:45)

Hors ligne

#4 Le 01/04/2020, à 20:32

xubu1957

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bonjour,

Montre, en te servant du Retour utilisable de commande :

lspci -k -nn | grep -A 3 -i net

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 01/04/2020, à 20:38

Coeur Noir

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Pour poster une image → héberger l'image sur un site type imgbb, casaimage, toilelibre → poster sur le forum le lien BBcode de la miniature, qui renvoie sur l'image hébergée. Voir « insérer une image » ci-dessous en signature.

Peut-être une histoire de protocole smb v1 2 ou 3 à harmoniser entre les différentes machines ?

Chercher server max protocol via ctrl+f dans https://www.samba.org/samba/docs/curren … onf.5.html

Hors ligne

#6 Le 01/04/2020, à 21:01

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bonjour Xubu, voici la liste sur mon pc perso (le dual boot windows/linux) :

03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
	Subsystem: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:3118]
	Kernel driver in use: ath9k
	Kernel modules: ath9k
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
	Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]
	Kernel driver in use: r8169
	Kernel modules: r8169
05:00.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 41)

Et voila du côté du serveur :

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)

_________________________________________

Bon update, j'ai changé le câble RJ45, c'est celui que j'ai testé qui me semblait asymétrique, je suis maintenant à 45 Mo/s d'écriture, ce qui est mieux mais pas capé aux 110Mo/s. Donc les deux pcs sous ubuntu sont sous Samba 4.10.7. Dans les deux smb.conf le server max protocol est même pas écrit donc ça doit être set de manière automatique. Du coup vaudrait mieux que je les rajoute ?

(edit: je viens de repasser sous windows je suis à 22,4 Mo/s donc y avait bien une question de câble. Mais est-ce qu'il y aurait pas une question de conversion du fait de passer d'un fichier stocké sur du exFAT à ext4 ? Dans les deux cas Windows ou Ubu, je teste avec des fichiers d'origine venant de exFAT vers le serveur en ext4)

Dernière modification par EsterFreyja (Le 01/04/2020, à 21:24)

Hors ligne

#7 Le 01/04/2020, à 21:20

xubu1957

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:3118]
    Kernel driver in use: ath9k
    Kernel modules: ath9k
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
    Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]
    Kernel driver in use: r8169
    Kernel modules: r8169
05:00.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 41)

Et voila du côté du serveur :

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)

Pour ajouter toi-même les balises code à ton précédent message #6 :

  • Cliquer sur  le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

1578079461.png

_ _ _

Fournis :

ip a

Dernière modification par xubu1957 (Le 01/04/2020, à 21:22)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#8 Le 01/04/2020, à 21:29

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Voila ip a du côté pc perso :

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether fc:aa:14:ca:5e:0b brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.34/24 brd 192.168.1.255 scope global dynamic noprefixroute enp4s0
       valid_lft 85410sec preferred_lft 85410sec
    inet6 fe80::2949:6f77:503:1d05/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 60:e3:27:25:16:35 brd ff:ff:ff:ff:ff:ff

Et côté serv :

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 50:3e:aa:10:06:0f brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.40/24 brd 192.168.1.255 scope global dynamic noprefixroute enp2s0
       valid_lft 86185sec preferred_lft 86185sec
    inet6 fe80::2e0:db8:ce70:9490/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Dernière modification par EsterFreyja (Le 01/04/2020, à 21:31)

Hors ligne

#9 Le 01/04/2020, à 21:33

xubu1957

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Installe ethtool :

sudo apt install ethtool

tu donneras ensuite :

sudo ethtool enp4s0
sudo ethtool enp2s0

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#10 Le 01/04/2020, à 21:40

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Coté perso :

Settings for enp4s0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     1000baseT/Full 
	Link partner advertised pause frame use: Symmetric
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 1000Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000033 (51)
			       drv probe ifdown ifup
	Link detected: yes

et coté serv :

Settings for enp2s0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     1000baseT/Full 
	Link partner advertised pause frame use: Symmetric
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 1000Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000033 (51)
			       drv probe ifdown ifup
	Link detected: yes

Hors ligne

#11 Le 01/04/2020, à 21:52

xubu1957

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Pour les deux cartes, on voit :

Speed: 1000Mb/s
	Duplex: Full

Il n'y a pas de souci de blocage matériel.

Il faut attendre les conseils des autres aidants.

_ _ _

Ludo avait eu une limitation pour une carte >   [Résolu] Carte mère censée être gigabit détectée en 100Mbits.

Dernière modification par xubu1957 (Le 01/04/2020, à 22:00)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#12 Le 01/04/2020, à 21:59

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Yup, merci bien smilecool

Hors ligne

#13 Le 02/04/2020, à 02:09

Coeur Noir

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Peut-être des pistes en navigant dans les articles de ce site https://www.redhat.com/sysadmin/samba-windows-linux ?

Hors ligne

#14 Le 02/04/2020, à 02:27

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Merci, mais il me semble être déjà tombé sur le site red hat pour samba.

Et de toute manière c'est pas que pour windows, faut aussi régler ça de ubuntu à ubuntu. hmm

Hors ligne

#15 Le 06/04/2020, à 12:41

Dude

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

EsterFreyja a écrit :

faut aussi régler ça de ubuntu à ubuntu.

Il te reste encore des machines Windows à connecter ?

Hors ligne

#16 Le 06/04/2020, à 14:10

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bah j'ai un Windows qui n'y est pas connecté mais y a pas vraiment besoin. Pourquoi ?

Hors ligne

#17 Le 06/04/2020, à 15:09

Dude

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Et bien tu laisses tomber SMB et tu montes tes répertoires via le système fichier de ta partition

Hors ligne

#18 Le 06/04/2020, à 17:02

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bah non parce que mes données sont stockées sur une machine Ubuntu et doivent être accessibles depuis Windows et Ubuntu neutral

Hors ligne

#19 Le 07/04/2020, à 15:32

Dude

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

EsterFreyja a écrit :

Bah non parce que mes données sont stockées sur une machine Ubuntu et doivent être accessibles depuis Windows et Ubuntu

Et deux messages plus haut, tu dis :

EsterFreyja a écrit :

Bah j'ai un Windows qui n'y est pas connecté mais y a pas vraiment besoin.

Donc y-a besoin ou pas ? roll

De toute façon, rien ne t'empêche de faire le test.
Tu pourras alors, si le débit est toujours aussi médiocre, écarter un problème SMB.

Hors ligne

#20 Le 07/04/2020, à 20:14

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Y a rien besoin de connecter en plus, et si c'était le cas ce n'est pas le problème peu importe l'OS.

Le problème c'est que j'ai un débit dégueulasse alors que c'est OK matériellement.

Et le serveur restera en Ubuntu, et aucune autre machine sous aucun autre OS n'a de stockage suffisant pour assumer le rôle de serveur local.

Hors ligne

#21 Le 08/04/2020, à 12:10

Dude

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

EsterFreyja a écrit :

Le problème c'est que j'ai un débit dégueulasse alors que c'est OK matériellement.

Bis repetitae :

Dude a écrit :

De toute façon, rien ne t'empêche de faire le test.
Tu pourras alors, si le débit est toujours aussi médiocre, écarter un problème SMB.

EsterFreyja a écrit :

Et le serveur restera en Ubuntu

Qui te parle de changer d'OS ?
Est-ce que tu comprends ce que je t'indique quand je parle de monter un répertoire du serveur ?

Hors ligne

#22 Le 08/04/2020, à 17:54

Coeur Noir

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

On va formuler autrement :

si toutes les machines qui ont besoin de partager des dossiers/ressources tournent sous Linux alors il n'y a pas besoin de Samba.
→ dans ce cas nfs ou sftp/ssh suffiront.

Sur un réseau local, Samba sert si tu dois rendre accessible à des machines sous Windows, des données stockées sous Linux.
→ exemple : sur le réseau de mon bureau j'ai un serveur Linux ( dans lequel sont stockés des documents pour tous les membres du bureau ), et les ordinateurs clients de mes collègues sont essentiellement sous Windows.

Dernière modification par Coeur Noir (Le 08/04/2020, à 18:01)

Hors ligne

#23 Le 08/04/2020, à 18:55

EsterFreyja

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Coeur Noir a écrit :

On va formuler autrement :

si toutes les machines qui ont besoin de partager des dossiers/ressources tournent sous Linux alors il n'y a pas besoin de Samba.
→ dans ce cas nfs ou sftp/ssh suffiront.

Sur un réseau local, Samba sert si tu dois rendre accessible à des machines sous Windows, des données stockées sous Linux.
→ exemple : sur le réseau de mon bureau j'ai un serveur Linux ( dans lequel sont stockés des documents pour tous les membres du bureau ), et les ordinateurs clients de mes collègues sont essentiellement sous Windows.

Oui, c'est exactement mon cas, sinon ce serait tout sous NFS. Les dossiers partagés fonctionnent très biens et sont bien configurés sous Smb, j'ai juste un problème de débit.

Hors ligne

#24 Le 09/04/2020, à 10:41

Dude

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

Bon si tu t'obstines à ne pas tester ce qu'on te demande, tu vas rester tout seul avec ton petit problème.

Bon courage.

Hors ligne

#25 Le 09/04/2020, à 17:26

Coeur Noir

Re : [RESOLU] Samba bloqué à 100 Mbps plutôt que Gigabit [RESOLU]

On va formuler encore autrement, pour confirmer qu'on comprend bien ton contexte :

⋅ tu as donc bien un réseau local sur lequel il y a des machines sous Linux et Windows connectées entre elles,
⋅ où la ( ou les ) machine(s) sous Windows doivent aller chercher des fichiers dans la ( ou les ) machine(s) sous Linux.

Le ( ou les ) Windows c'est du 10 ou 7 ?

Le ( ou les ) Linux sont tous à la même version de Samba ?

Si dans les smb.conf tu « forces » le smb v3 ça change quelque chose ( dans le cas où tous les win sont des 10 ) ?

https://askubuntu.com/questions/193545/ … tu-windows
https://forums.centos.org/viewtopic.php?t=54926
https://wiki.samba.org/index.php/Performance_Tuning

Hors ligne