Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/10/2020, à 19:30

descat85

Mise à jour opengl

Je viens d'installer xubuntu 20.04 sur un vieux pc pour mon fils, et au lancement du jeux warzone2100 le message suivant s'affiche "openGL 2.0 not surpported! upgrade your drivers"

j'ai fait

glxinfo | grep 'version'
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
    Max core profile version: 0.0
    Max compat profile version: 1.4
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 2.0
OpenGL version string: 1.4 Mesa 20.0.8
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 20.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16

puis j'ai tenté

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get dist-upgrade

OpenGL était toujours en version 1.4

Après un

sudo apt-get install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers

j'ai testé avec

sudo add-apt-repository ppa:xorg-edgers/ppa
 == Xorg packages fresh from git ==

Currently supported releases are Xenial/16.04 and Yakkety/16.10

* WARNING: Do not use this PPA with enabled HWE stack.

Be sure to revert this PPA before doing a release upgrade or the upgrade will not succeed. To revert to official packages, install the ppa-purge package and run "sudo ppa-purge xorg-edgers".

== Important notice ==

This PPA is currently meant to be used as a whole. Please do _not_ individually install packages from it, add it to your sources and let your package manager pull in every update. The packages here build against each other and compile different features based on whats available at build time. Do not assume that because it lets you install a DDX with just the driver and libdrm update that it will work.  These packages are made with scripts that use the the current packages as the base, so some dependencies can be wrong and your package manager will not resolve that for you.  If you want to individually install something from here, grab the source and rebuild it in your current environment instead.

** Please do not publish instructions for how to install from this archive without linking to this page! Anyone using packages from this archive is expected to read this page first and it is recommended to check back occasionally for notice on problems that may arise. **

** Please use ppa-purge to remove this PPA. It is *particularly* recommended to do this before upgrading to a new ubuntu release! **
 Plus d’info : https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa
Appuyez sur [ENTRÉE] pour continuer ou sur Ctrl-c pour annuler l'ajout.

Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease
Atteint :3 http://security.ubuntu.com/ubuntu focal-security InRelease 
Ign :4 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu focal InRelease
Atteint :5 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease
Err :6 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu focal Release
  404  Not Found [IP : 91.189.95.83 80]
Lecture des listes de paquets... Fait             
E: Le dépôt http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu focal Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
xxxxxxxxxx@xxxxxxxxxxxxxx:~$ glxinfo | grep 'version'
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
    Max core profile version: 0.0
    Max compat profile version: 1.4
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 2.0
OpenGL version string: 1.4 Mesa 20.0.8
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 20.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16

Sans résultat.


Le PC étant vieux (<2010) peut-être tout simplement que la puce n'est pas compatible?  J'ai cherché mais n'ai rien trouvé comme info (il semble que la puce soit (intel corporation 82945g/gz integrated graphics controller (rev 02) prog-if 00 [VGA controller]).

Un tuyau?

Dernière modification par descat85 (Le 18/10/2020, à 21:50)

Hors ligne

#2 Le 18/10/2020, à 19:31

xubu1957

Re : Mise à jour opengl

Bonjour,

Montre, en te servant du Retour utilisable de commande :

lspci -vnn | grep -A12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 18/10/2020, à 20:11

descat85

Re : Mise à jour opengl

dupont@dupont-GX599AA:~$ lspci -vnn | grep -A12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02) (prog-if 00 [VGA controller])
	Kernel driver in use: i915
	Kernel modules: i915, intelfb
dupont@dupont-GX599AA:~$ 

Hors ligne

#4 Le 18/10/2020, à 20:20

xubu1957

Re : Mise à jour opengl

Il faut des aidants connaisseurs !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne