Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/06/2021, à 18:48

Sputnik93

[Résolu] Perte de connexion temporaire

Bonjour,

sur un Ubuntu Studio (20.04.2 LTS (Focal Fossa)) connecté en filaire à ma box Bouygues, j'ai parfois une perte de connexion subite à Internet (je ne peux plus pinger les DNS de google par exemple).

Voici le retour de ip a :

alex@studio:~$ sudo ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether fc:aa:14:e7:07:b1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.78/24 brd 192.168.1.255 scope global dynamic noprefixroute enp3s0
       valid_lft 69469sec preferred_lft 69469sec
    inet6 fe80::e098:9fa0:3d02:f9cd/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp6s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether c0:25:e9:2b:e2:bb brd ff:ff:ff:ff:ff:ff

Pour la partie matérielle:

alex@studio:~$ lspci -nnk | grep -A 2 -i ethernet
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
	Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]
	Kernel driver in use: r8169
	Kernel modules: r8169

A part les serveurs DNS, c'est la box qui gère tout la config réseau (DHCP, routage, parefeu...)

Quand le problème survient, il ne dure pas forcément longtemps mais c'est un peu pénible.
J'ai peut-être identifié quelque chose dans les messages du noyau:

alex@studio:~$ sudo dmesg
[blablabla]
[    7.099626] RTL8211E Gigabit Ethernet r8169-300:00: attached PHY driver [RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
[    7.332393] r8169 0000:03:00.0 enp3s0: Link is Down
[    7.705260] resource sanity check: requesting [mem 0x000c0000-0x000fffff], which spans more than PCI Bus 0000:00 [mem 0x000d0000-0x000d3fff window]
[    7.705509] caller os_map_kernel_space.part.0+0x77/0xa0 [nvidia] mapping multiple BARs
[    8.894147] r8169 0000:03:00.0 enp3s0: Link is Up - 100Mbps/Full - flow control rx/tx
[    8.894156] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready

Mon noyau est le 'Linux studio 5.8.0-53-lowlatency' (quand je démarre sur le 5.8.0-55-lowlatency le processus de démarrage ne va pas au bout, je n'ai pas cherché pourquoi, je préfère démarrer sur celui qui va bien).

Je précise que la perte de connexion ne semble pas être du fait de la box, le PC est en dual-boot avec Windows 10, et je n'ai jusqu'à présent jamais remarqué ce problème sur Windows, alors que chaque je démarre le PC sur chaque OS une fois sur deux à peu près.

Si vous avez une idée de la cause du soucis et de sa possible résolution, ce serait chouette !

Dernière modification par Sputnik93 (Le 13/06/2021, à 17:09)

Hors ligne

#2 Le 12/06/2021, à 19:21

xubu1957

Re : [Résolu] Perte de connexion temporaire

Bonjour,

Il faut tenter :

sudo ip link set enp3s0 down
sudo ip link set enp3s0 up
sudo dhclient enp3s0

_ _ _

Fournis les noyaux présents :

echo; dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

et :

dpkg -l | grep -v ^ii

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 12/06/2021, à 19:31

Sputnik93

Re : [Résolu] Perte de connexion temporaire

Merci pour ta réponse !

voici les éléments demandés:

alex@studio:~$ sudo ip link set enp3s0 down
alex@studio:~$ sudo ip link set enp3s0 up
alex@studio:~$ sudo dhclient enp3s0
RTNETLINK answers: File exists

J'essaierai de rejouer ces commandes lorsque le problème se déclenchera à nouveau, mais ses occurrences me paraissent aléatoires.

Pour les noyaux:

alex@studio:~$ echo; dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

ii  linux-headers-5.4.0-26                         5.4.0-26.30           all
ii  linux-modules-5.4.0-26-lowlatency              5.4.0-26.30           amd64
ii  linux-hwe-5.8-headers-5.8.0-53                 5.8.0-53.60~20.04.1   all
ii  linux-headers-5.8.0-53-lowlatency              5.8.0-53.60~20.04.1   amd64
ii  linux-image-5.8.0-53-lowlatency                5.8.0-53.60~20.04.1   amd64
ii  linux-modules-5.8.0-53-lowlatency              5.8.0-53.60~20.04.1   amd64
ii  linux-modules-nvidia-460-5.8.0-53-lowlatency   5.8.0-53.60~20.04.1   amd64
ii  linux-modules-nvidia-460-lowlatency-hwe-20.04  5.8.0-53.60~20.04.1   amd64
ii  linux-signatures-nvidia-5.8.0-53-lowlatency    5.8.0-53.60~20.04.1   amd64
ii  linux-hwe-5.8-headers-5.8.0-55                 5.8.0-55.62~20.04.1   all
ii  linux-headers-5.8.0-55-lowlatency              5.8.0-55.62~20.04.1   amd64
ii  linux-image-5.8.0-55-lowlatency                5.8.0-55.62~20.04.1   amd64
ii  linux-modules-5.8.0-55-lowlatency              5.8.0-55.62~20.04.1   amd64
ii  linux-headers-lowlatency-hwe-20.04             5.8.0.55.62~20.04.39  amd64
ii  linux-image-lowlatency-hwe-20.04               5.8.0.55.62~20.04.39  amd64
ii  linux-lowlatency-hwe-20.04                     5.8.0.55.62~20.04.39  amd64

Noyau courant : 5.8.0-53-lowlatency x86_64
alex@studio:~$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                                         Version                                Architecture Description
+++-===========================================================-======================================-============-======================================================================================================
rc  linux-image-5.8.0-41-lowlatency                             5.8.0-41.46~20.04.1                    amd64        Signed kernel image lowlatency
rc  linux-image-5.8.0-44-lowlatency                             5.8.0-44.50~20.04.1                    amd64        Signed kernel image lowlatency
rc  linux-image-5.8.0-45-lowlatency                             5.8.0-45.51~20.04.1+1                  amd64        Signed kernel image lowlatency
rc  linux-image-5.8.0-48-lowlatency                             5.8.0-48.54~20.04.1                    amd64        Signed kernel image lowlatency
rc  linux-image-5.8.0-50-lowlatency                             5.8.0-50.56~20.04.1                    amd64        Signed kernel image lowlatency
rc  linux-modules-5.8.0-41-lowlatency                           5.8.0-41.46~20.04.1                    amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-44-lowlatency                           5.8.0-44.50~20.04.1                    amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-45-lowlatency                           5.8.0-45.51~20.04.1                    amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-48-lowlatency                           5.8.0-48.54~20.04.1                    amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-50-lowlatency                           5.8.0-50.56~20.04.1                    amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-nvidia-460-5.8.0-44-lowlatency                5.8.0-44.50~20.04.1                    amd64        Linux kernel nvidia modules for version 5.8.0-44
rc  linux-modules-nvidia-460-5.8.0-45-lowlatency                5.8.0-45.51~20.04.1+1                  amd64        Linux kernel nvidia modules for version 5.8.0-45
rc  linux-modules-nvidia-460-5.8.0-48-lowlatency                5.8.0-48.54~20.04.1                    amd64        Linux kernel nvidia modules for version 5.8.0-48
rc  linux-modules-nvidia-460-5.8.0-50-lowlatency                5.8.0-50.56~20.04.1+1                  amd64        Linux kernel nvidia modules for version 5.8.0-50
rc  linux-objects-nvidia-460-5.8.0-50-lowlatency                5.8.0-50.56~20.04.1+1                  amd64        Linux kernel nvidia modules for version 5.8.0-50 (objects)

Hors ligne

#4 Le 12/06/2021, à 19:37

xubu1957

Re : [Résolu] Perte de connexion temporaire

C'est pas à cause de l'IPv6 ?

Pour nettoyer :

Le 11/02/2017, moko138 a écrit :

Pour supprimer tous ces fichiers de configuration devenus sans objets et marqués "rc", et uniquement ces fichiers, exécute :

dpkg -l | awk '/^rc/{print $2}' | xargs -r sudo dpkg -P

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 12/06/2021, à 19:49

Sputnik93

Re : [Résolu] Perte de connexion temporaire

xubu1957 a écrit :

C'est pas à cause de l'IPv6 ?

Ah oui, c'est une piste.
Je viens de désactiver ipv6 dans la conf sysctl, et j'ai blacklisté le module ipv6 du noyau, je ferai tourner un ping ou autre en tâche de fond sur quelques heures, pour voir. Je te tiendrai informé.

Hors ligne

#6 Le 13/06/2021, à 14:56

Sputnik93

Re : [Résolu] Perte de connexion temporaire

J'ai envoyé 30 000 ping cette nuit, il n'y a visiblement pas eu de perte de connexion, on dirait bien que le problème a disparu en désactivant l'IPv6.
Merci pour les suggestions !

Hors ligne

#7 Le 13/06/2021, à 15:00

xubu1957

Re : [Résolu] Perte de connexion temporaire

Bonjour,

Pour éditer ta discussion et rajouter [Résolu] au début du titre, il faut utiliser le bouton Modifier au bas de ton premier message.

Merci wink


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne