Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/09/2021, à 21:22

Hayao_Yugen

Erreurs key/signatures [Résolu]

Bonsoir, j'ai les erreurs ci dessous quand je update quelqu'un pourrait m'aider svp ?

W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : http://download.opensuse.org/repositories/home:/strycore/Debian_10 ./ InRelease : Les signatures suivantes ne sont pas valables : EXPKEYSIG 2F7F0DA5FD5B64B9 home:strycore OBS Project <home:strycore@build.opensuse.org>
W: Impossible de récupérer http://download.opensuse.org/repositories/home:/strycore/Debian_10/./InRelease  Les signatures suivantes ne sont pas valables : EXPKEYSIG 2F7F0DA5FD5B64B9 home:strycore OBS Project <home:strycore@build.opensuse.org>
W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Dernière modification par Hayao_Yugen (Le 07/09/2021, à 09:25)

Hors ligne

#2 Le 06/09/2021, à 21:23

abelthorne

Re : Erreurs key/signatures [Résolu]

Si la clé est dans les dépôts publics, essaie ça :

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 2F7F0DA5FD5B64B9

Sinon, la méthode pour la récupérer et l'ajouter doit être sur la page de présentation du dépôt.

EDIT : apparemment, la clé du dépôt a changé il y a quelques mois, quelqu'un mentionne le même problème sur les forums de Lutris. Si la commande que j'ai donnée ne fonctionne pas, essaie ça :

wget -nv http://download.opensuse.org/repositories/home:/strycore/Debian_10/Release.key -O Release.key
sudo apt-key add - < Release.key

Cela dit, tu es sur Ubuntu ou Debian ? Si c'est bien le dépôt pour Lutris que tu utilises, attention, il n'est pas adapté à Ubuntu, il y a un PPA dédié (cf https://lutris.net/downloads/).

Dernière modification par abelthorne (Le 06/09/2021, à 21:29)

Hors ligne

#3 Le 07/09/2021, à 09:24

Hayao_Yugen

Re : Erreurs key/signatures [Résolu]

Effectivement je suis sur Ubuntu, mais les commandes que tu m'a envoyés fonctionnent, plus aucune erreur. merci smile

Hors ligne

#4 Le 07/09/2021, à 10:20

abelthorne

Re : Erreurs key/signatures [Résolu]

Oui mais tu te retrouveras probablement avec des problèmes de dépendances à un moment ou un autre. Il vaudrait mieux supprimer le dépôt et utiliser celui qui est fait pour Ubuntu :

ls /etc/apt/sources.list.d

Hors ligne

#5 Le 14/09/2021, à 12:19

Hayao_Yugen

Re : Erreurs key/signatures [Résolu]

et ça va pas faire de problème si je change ? du style suppression ou logiciels rendus inutilisable ?

brave-browser-release.list
brave-browser-release.list.save
fyrmir-ubuntu-livewallpaper-daily-focal.list
fyrmir-ubuntu-livewallpaper-daily-focal.list.save
git-core-ubuntu-ppa-focal.list
git-core-ubuntu-ppa-focal.list.save
gnome3-team-ubuntu-gnome3-focal.list
gnome3-team-ubuntu-gnome3-focal.list.save
google-chrome.list
google-chrome.list.save
home:manuelschneid3r.list
home:manuelschneid3r.list.save
kisak-ubuntu-kisak-mesa-focal.list
kisak-ubuntu-kisak-mesa-focal.list.save
lutris.list
lutris.list.save
lutris-team-ubuntu-lutris-focal.list
lutris-team-ubuntu-lutris-focal.list.save
mdeslaur-ubuntu-steamos-focal.list
mdeslaur-ubuntu-steamos-focal.list.save
morphis-ubuntu-anbox-support-focal.list
morphis-ubuntu-anbox-support-focal.list.save
nilarimogard-ubuntu-webupd8-focal.list
nilarimogard-ubuntu-webupd8-focal.list.save
obsproject-ubuntu-obs-studio-focal.list
obsproject-ubuntu-obs-studio-focal.list.save
sublime-text.list
sublime-text.list.save
vala-team-ubuntu-ppa-focal.list
vala-team-ubuntu-ppa-focal.list.save
virtualbox.list
virtualbox.list.save
vivaldi.list
vivaldi.list.save
vscode.list
vscode.list.save
wine-ubuntu-wine-builds-focal.list
wine-ubuntu-wine-builds-focal.list.save

Hors ligne

#6 Le 14/09/2021, à 12:22

abelthorne

Re : Erreurs key/signatures [Résolu]

Non, c'est juste le paquet de Lutris qui est concerné, pas tes paramètres perso (le système n'y touchera pas).

D'ailleurs, je vois que tu as deux dépôts pour Lutris, dont probablement un désactivé. Vraisemblablement celui pour Debian + celui pour Ubuntu. Donne leur contenu :

cat /etc/apt/sources.list.d/lutris.list /etc/apt/sources.list.d/lutris-team-ubuntu-lutris-focal.list

Hors ligne

#7 Le 14/09/2021, à 12:25

Hayao_Yugen

Re : Erreurs key/signatures [Résolu]

deb http://download.opensuse.org/repositories/home:/strycore/Debian_10/ ./
deb http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal main
# deb-src http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal main

Hors ligne

#8 Le 14/09/2021, à 12:54

abelthorne

Re : Erreurs key/signatures [Résolu]

En plus, les deux dépôts sont actifs. Je te suggère de faire comme suit :
1) Supprime Lutris et les dépendances libérées :

sudo apt-get remove lutris
sudo apt-get autoremove --purge

2) Supprime le dépôt Debian :

sudo rm /etc/apt/sources.list.d/lutris.list /etc/apt/sources.list.d/lutris.list.save

3) Recharge la liste des dépôts :

sudo apt-get update

4) Réinstalle Lutris :

sudo apt-get install lutris

Si tout se passe bien, ça devrait être bon.

Le premier point (et par conséquent le dernier) n'est peut-être pas indispensable mais dans le doute, comme il pourrait y avoir des conflits de dépendances si ta version installée vient du dépôt Debian, je préfère te le faire désinstaller/réinstaller proprement.

Hors ligne