Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/12/2021, à 14:57

u120

Scanner HP 5540 : Pas de scan au-delà des 300 dpi

Bonjour et meilleure vœux pour l'année 2022,
Que tous vos systèmes fonctionnent bien sous GNU/Linux smile

Pour moi, en attendant, je dois régler ce problème là !

Le scanner de ma HP All-in-One ENVY 5540 fonctionne bien à 300 dpi sur Document Scanner ou Simple Scan (lancé en CLI) sous Ubuntu 20.04.3 et un Dell G3 15
Si je règle à 600 dpi et plus, le scanner lui-même fonctionne bien et affiche son message de 'scan réussi' mais l'application répond que le scan n'a pas démarré !
Mon scanner à une résolution de 2400/1200 dpi

J'ai lancé un scan en usb, même pb, cela lance bien le scanner pas toujours le même erreur 'Unable to start the scan'



J'ai fait beaucoup de recherches : hpcli, cups, ...

Mon imprimante est bien reconnue dans le hpcli
`HP Envy 5540 All-in-one Printer Series     3.15.9     Yes     No     Full (End of support)     Color     Yes     No     USB,Network      `

J'ai fait un `hp-check` et j'ai la réponse suivante pour le scanner :

----------------------
| Scan Configuration |
----------------------

 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.21.12         OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.21.12         OK         -

Par contre, j'ai les problèmes suivants (=>>>>) :

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP_ENVY_5540_series_4F82F2_
---------------------------
Type: Unknown
Device URI: implicitclass://HP_ENVY_5540_series_4F82F2_/
PPD: /etc/cups/ppd/HP_ENVY_5540_series_4F82F2_.ppd

=>>>> warning: Failed to read /etc/cups/ppd/HP_ENVY_5540_series_4F82F2_.ppd ppd file

PPD Description: 
Printer status: printer HP_ENVY_5540_series_4F82F2_ is idle.  enabled since jeu. 23 déc. 2021 15:24:17

=>>>> warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

HP_ENVY_5540_series_4F82F2_@HP30E1714F82F2.local
------------------------------------------------
Type: Unknown
Device URI: implicitclass://HP_ENVY_5540_series_4F82F2_%40HP30E1714F82F2.local/
PPD: /etc/cups/ppd/HP_ENVY_5540_series_4F82F2_@HP30E1714F82F2.local.ppd
warning: Failed to read /etc/cups/ppd/HP_ENVY_5540_series_4F82F2_@HP30E1714F82F2.local.ppd ppd file
PPD Description: 
Printer status: printer HP_ENVY_5540_series_4F82F2_@HP30E1714F82F2.local is idle.  enabled since jeu. 30 déc. 2021 13:38:33
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

Imprimante_Perso_multifonction
------------------------------
=>>>> Type: Unknown
Device URI: ///dev/null

Je ne pense pas que cela impact mon problème ?!
Le scanner fonctionne jusqu'à 300 DPI (standard) mais pas au-delà !


J'ai tenté un `hp-scan`

jrd_10@my-pc:~$ hp-scan

HP Linux Imaging and Printing System (ver. 3.21.12)
Scan Utility ver. 2.2

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

-----------------
| SELECT DEVICE |
-----------------

  Num       Scan device URI               
  --------  ------------------------------
  0         escl:https://192.168.1.106:443
  1*        escl:http://192.168.1.106:8080

Enter number 0...1 for device (q=quit, <enter>=default: 1*) ?
warning: No destinations specified. Adding 'file' destination by default.
Using device escl:http://192.168.1.106:8080
Opening connection to device...
Capability : [(null)]
Capability : [image/jpeg]
Capability : [image/jpeg]
error: Failed to get the source from device.
Traceback (most recent call last):
  File "/usr/bin/hp-scan", line 971, in <module>
    if len(source_option) == 1 and 'ADF' in source_option:
NameError: name 'source_option' is not defined

Là encore, je ne pense pas que cela viennent de ce message d'erreur, le scan marche à 300 dpi smile.

Merci de votre aide par avance et bonne année 2022 pour vos et vos proches

Amicalement, jrd10

Dernière modification par u120 (Le 30/12/2021, à 14:59)


Amicalement, José
-------------------------------------------------
Sur Troyes et l'Aube-en-Champagne

Hors ligne