Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/01/2022, à 21:27

Fanda

Problème de Boot avec Ubuntu

Bonjour,

Je suis un utilisateur relativement débutant d'Ubuntu que j'utilise en DualBoot avec Windows. Après m'être amusé à renommer la partition Linux avec MiniTool depuis Windows (je pense très fortement cela soit la cause du problème) je n'arrive plus à lancer Ubuntu.

Le message suivant apparait dans la console quelques secondes après l'allumage :

*******************************************************************************************************
Usage: run-init [-d CAP ,CAP...] [-n] [-c CONSOLE_DEV] NEW_ROOT NEW_INIT [ARGS]

Free initramfs and switch to another root fs:
chroot to NEW_ROOT, delete all in /, move NEW_ROOT to /,
execute NEW_INIT. PID must be 1. NEW_ROOT must be a mountpoint.

     -c DEV     Reopen stdio to DEV after switch
     -d CAPS  Drop capabilities
     -n             Dry run
No init found. Try passing init=bootarg.


BusyBox v1.30.1 (Ubuntu 1:1.30.1-4ubuntu6.4) multi-call binary.
Enter  'help' for a list of built-in commands.

(initramfs)
*********************************************************************************************************


J'ai également effectuer récemment une mise à jour du BIOS et la migration des OS d'un SSD de 250Go à un SSD de 500Go. Mais pour moi le problème ne vient pas de la car tout marchait correctemennt après ça.

Le renommage de la partition Ubuntu à du modifier un paramètre pour le BIOS. Mais je n'arrive pas vraiment à savoir lequel.

Configuration :
- Dualboot windows et ubuntu sur SSD 500Go (GPT) partionner ainsi :
         - Partition 1: FAT32 - 100Mo de partition syst EFI
         - Partition 2: NTFS  - 226Go C: (windows)
         - Partition 3: NTFS  - 837Mo Partition de récupération
         - Partition 4: Ext4    - 250Go  Linux 
- Les données personnels sont sur un 3ème HDD
- Carte mère : MSI B360M PRO-VH
- BIOS : 1.B0

Voilà, merci d'avance pour vos réponses.

Hors ligne

#2 Le 10/01/2022, à 21:42

geole

Re : Problème de Boot avec Ubuntu

Bonsoir.
Pourrais-tu faire un boot-info ( https://doc.ubuntu-fr.org/tutoriel/boot-info ) et poster l'url qui sera générée.

En ligne

#3 Le 10/01/2022, à 22:23

Fanda

Re : Problème de Boot avec Ubuntu

https://paste.ubuntu.com/p/dqZzMSmDXd/

Voici l'URL généré par Boot-Repair depuis une virtual Box Ubuntu et non depuis un liveUSB. Mais je suppose que ça revient au même...

Dernière modification par Fanda (Le 10/01/2022, à 22:42)

Hors ligne

#4 Le 11/01/2022, à 12:23

geole

Re : Problème de Boot avec Ubuntu

Bonjour
Je ne suis pas certain de pouvoir aider. D'après le boot-info

===================================== UEFI =====================================
This installed-session is not in EFI-mode.

installation  LEGACY donc boot sur le MBR

============================== Boot Info Summary 
 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for (,msdos5)/boot/grub. It also embeds following components:

La suite doit se passer dans la partition 5

sda5: __________________________________________________________________________
    File system:       ext4
    Operating System:  Ubuntu 20.04.3 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub 
                       /boot/grub/i386-pc/core.img

Dont le contenu semble bon puisque le  boot est réussi
================================ 1 OS detected =================================
OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession on sda5



Le problème est que tu évoques un dual boot avec windows mais windows n'est pas présent dans le boot-info et la structure de boot de ubuntu ne le prévoit pas.

====================== sda5/boot/grub/grub.cfg (filtered) ======================
Ubuntu   5a6af84a-8d05-417f-8714-49655f64f9df
Ubuntu, avec Linux 5.11.0-44-generic   5a6af84a-8d05-417f-8714-49655f64f9df
Ubuntu, avec Linux 5.11.0-27-generic   5a6af84a-8d05-417f-8714-49655f64f9df
### END /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_uefi-firmware ###

Je ne connais pas MiniTool.

Dernière modification par geole (Le 11/01/2022, à 12:24)

En ligne

#5 Le 11/01/2022, à 12:49

xubu1957

Re : Problème de Boot avec Ubuntu

Bonjour,

Collage du Boot-info :

boot-info-4ppa157                                              [20220110_2217]

============================== Boot Info Summary ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for (,msdos5)/boot/grub. It also embeds following components:
    
    modules
    ---------------------------------------------------------------------------
    fshelp ext2 part_msdos biosdisk
    ---------------------------------------------------------------------------

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda2: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info: 

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.3 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub 
                       /boot/grub/i386-pc/core.img


================================ 1 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession on sda5

================================ Host/Hardware =================================

CPU architecture: 64-bit
Video: SVGAIIAdapter from   VMware
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.11.0-44-generic root=UUID=5a6af84a-8d05-417f-8714-49655f64f9df ro quiet splash
df -Th / : /dev/sda5        ext4    98G    9,9G   83G  11% /


===================================== UEFI =====================================

This installed-session is not in EFI-mode.



============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: notGPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	no-wind,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda5	: is-os,	64, apt-get,	grub-pc ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
sda1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far

Partitions info (2/3): _________________________________________________________

sda5	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

sda5	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	sda
sda1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 100 GiB, 107374182400 bytes, 209715200 sectors
Disk identifier: 0xd388153d
      Boot   Start       End   Sectors  Size Id Type
sda1  *       2048   1050623   1048576  512M  b W95 FAT32
sda2       1052670 209713151 208660482 99.5G  5 Extended
sda5       1052672 209713151 208660480 99.5G 83 Linux

parted -lm (filtered): _________________________________________________________

sda:107GB:scsi:512:512:msdos:ATA VBOX HARDDISK:;
1:1049kB:538MB:537MB:fat32::boot;
2:539MB:107GB:107GB:::;
5:539MB:107GB:107GB:ext4::;
sr0:61.1MB:scsi:2048:2048:unknown:VBOX CD-ROM:;

Free space (filtered): _________________________________________________________

sda:102400MiB:scsi:512:512:msdos:ATA VBOX HARDDISK:;
1:0.00MiB:1.00MiB:1.00MiB:free;
1:513MiB:514MiB:1.00MiB:free;
1:102399MiB:102400MiB:1.00MiB:free;

gdisk (filtered): ______________________________________________________________

Found invalid GPT and valid MBR; converting MBR to GPT format
Disk /dev/sda: 209715200 sectors, 100.0 GiB
Disk identifier (GUID): 34EB2956-87C9-4E52-A3B0-25E2BE455DDB
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 209715166
Partitions will be aligned on 2048-sector boundaries
Total free space is 6077 sectors (3.0 MiB)
Number  Start (sector)    End (sector)  Size       Code  Name
1            2048         1050623   512.0 MiB   0700  Microsoft basic data
5         1052672       209713151   99.5 GiB    8300  Linux filesystem

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL           PARTLABEL
sda                                                                                                       
├─sda1 vfat     6E44-91C5                            d388153d-01                                          
├─sda2                                               d388153d-02                                          
└─sda5 ext4     5a6af84a-8d05-417f-8714-49655f64f9df d388153d-05                                          

df (filtered): _________________________________________________________________

                                Avail Use% Mounted on
sda5                            82.6G  10% /

Mount options: __________________________________________________________________

sda5                           rw,relatime,errors=remount-ro

====================== sda5/boot/grub/grub.cfg (filtered) ======================

Ubuntu   5a6af84a-8d05-417f-8714-49655f64f9df
Ubuntu, avec Linux 5.11.0-44-generic   5a6af84a-8d05-417f-8714-49655f64f9df
Ubuntu, avec Linux 5.11.0-27-generic   5a6af84a-8d05-417f-8714-49655f64f9df
### END /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_uefi-firmware ###

========================== sda5/etc/fstab (filtered) ===========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=5a6af84a-8d05-417f-8714-49655f64f9df /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=6E44-91C5  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

======================= sda5/etc/default/grub (filtered) =======================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

==================== sda5: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
  88,688034058 = 95,228051456   boot/grub/grub.cfg                             2
  96,637428284 = 103,763648512  boot/grub/i386-pc/core.img                     1
   6,731639862 = 7,228043264    boot/vmlinuz                                   1
   5,564449310 = 5,974781952    boot/vmlinuz-5.11.0-27-generic                 2
   6,731639862 = 7,228043264    boot/vmlinuz-5.11.0-44-generic                 1
   5,564449310 = 5,974781952    boot/vmlinuz.old                               2
  10,384216309 = 11,149967360   boot/initrd.img                                2
  10,231029510 = 10,985484288   boot/initrd.img-5.11.0-27-generic              1
  10,384216309 = 11,149967360   boot/initrd.img-5.11.0-44-generic              2
  10,231029510 = 10,985484288   boot/initrd.img.old                            1

===================== sda5: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 18151 août  12 11:18 10_linux
-rwxr-xr-x 1 root root 42359 août  12 11:18 10_linux_zfs
-rwxr-xr-x 1 root root 12894 août  12 11:18 20_linux_xen
-rwxr-xr-x 1 root root 12059 août  12 11:18 30_os-prober
-rwxr-xr-x 1 root root  1424 août  12 11:18 30_uefi-firmware
-rwxr-xr-x 1 root root   214 août  12 11:18 40_custom
-rwxr-xr-x 1 root root   216 août  12 11:18 41_custom




Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would purge (in order to fix packages) and reinstall the grub-efi of
sda5,
using the following options:        sda1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s  use-standard-efi-file    

Blockers in case of suggested repair: __________________________________________

 The current session is in BIOS-compatibility mode. Please disable BIOS-compatibility/CSM/Legacy mode in your UEFI firmware, and use this software from a live-CD (or live-USB) that is compatible with UEFI booting mode. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode. This will enable this feature.

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession entry (sda1/efi/****/grub****.efi (**** will be updated in the final message) file) !
The boot of your PC is in BIOS-compatibility/CSM/Legacy mode. You may want to retry after changing it to UEFI mode.

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 14/01/2022, à 09:37

Fanda

Re : Problème de Boot avec Ubuntu

Bonjour désolé pour le temps de réponse.

Oui je confirme j'utilise bien Windows en DualBoot c'est dailleurs avec la session Windows que je suis sur le forum actuellement.

Qu'est-ce que je peux faire du coup? je ré-instal tous?

Hors ligne

#7 Le 14/01/2022, à 09:48

iznobe

Re : Problème de Boot avec Ubuntu

Bonjour ,

J'ai également effectuer récemment une mise à jour du BIOS

Premiere chose a faire apres cela , remettre les parametres comme avant .
la MAJ du BIOS , remet de nouveau les parametres par defaut .
verifier au minimum , le secure boot , le fast boot , les parametres de prise en charge des controleurs des HDD : AHCI / RAID et surement que j' en oublie un ou 2 , le UEFI / LEGACY / CSM .

Dernière modification par iznobe (Le 14/01/2022, à 10:00)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

En ligne

#8 Le 14/01/2022, à 09:56

geole

Re : Problème de Boot avec Ubuntu

Bonjour.
Le boot-info ne détecte pas la présence du SSD ni du 3eme disque.
Seul un disque de 100 Go est détecté.
Peux-tu aller dans le bios pour vérifier que tous tes disques sont bien accèdés en mode AHCI et pas avec un autre mode.
vu le nom du disque :ATA VBOX HARDDISK:;  n'aurais-tu pas fait une installation en mode virtuel depuis windows?

Dernière modification par geole (Le 14/01/2022, à 10:03)

En ligne

#9 Le 15/01/2022, à 00:36

Fanda

Re : Problème de Boot avec Ubuntu

J'ai fais une capture du gestionnaire de disque pour facilité les choses. On peut la trouver à cette adresse :

https://ibb.co/WBDqH7C
- Disque 0 : Partition I: c'est pour faire tournéer mes VM
- Disque 2 et 2 : ce sont des disque de données personnels chiffrer avec TrueCrypt et accessible Windows et Ubuntu.
- Disque 3 : on retrouve les partitons pour les deux OS.

Je prendrais le temps de regarder pour l'accès en AHCI. Je vais évité de faire une bétises et planter mon Windows aussi.

Merci

Hors ligne

#10 Le 15/01/2022, à 07:48

geole

Re : Problème de Boot avec Ubuntu

Bonjour
Pourrais-tu refaire un boot-info depuis un support d'installation de ubbuntu

En ligne

#11 Le 15/01/2022, à 20:01

Fanda

Re : Problème de Boot avec Ubuntu

https://paste.ubuntu.com/p/bXbrbGkwf6

Voici le nouveau liens du boot-info fait depuis un live-usb

Merci

Dernière modification par Fanda (Le 15/01/2022, à 20:03)

Hors ligne

#12 Le 15/01/2022, à 22:57

geole

Re : Problème de Boot avec Ubuntu

Bonsoir.
La partition qui contient UBUNTU n'est plus en bon état.

nvme0n1p4: _____________________________________________________________________
    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Mounting failed:   mount: /mnt/BootInfo/nvme0n1p4: cannot mount; probably corrupted filesystem on /dev/nvme0n1p4.
  

Je pense qu'une réinstallation s'impose.
Cependant, avant de le faire, tu peux tenter une réparation. A faire depuis le support d'installation.

sudo fsck  /dev/nvme0n1p4

Dernière modification par geole (Le 15/01/2022, à 22:59)

En ligne

#13 Le 16/01/2022, à 02:11

Fanda

Re : Problème de Boot avec Ubuntu

@geole Comme tu me l'as indiqué j'ai exécuté

sudo fsck  /dev/nvme0n1p4

Et ça a marché. La partition Ubuntu est de nouveau fonctionnelle. Tout remarche très bien

Merci beaucoup

à bientôt

Dernière modification par Fanda (Le 16/01/2022, à 02:12)

Hors ligne