Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/07/2022, à 20:24

CaffBleu

Impossible d'installer Docker

Rebonsoir tout le monde !
J'ai un dernier petit soucis avec mon installation de docker. J'essaie de le réinstaller en suivant la documentation docker comme d'habitude mais bizarrement l'installation coince ! voila le retour via ssh :

sudo apt-get update

 sudo apt-get install docker-ce docker-ce-cli containerd.io docker-compose-plugin
Hit:1 http://de.archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://de.archive.ubuntu.com/ubuntu jammy-updates InRelease                                                                                                                  
Hit:3 http://de.archive.ubuntu.com/ubuntu jammy-backports InRelease                                                                                                                
Hit:4 https://download.docker.com/linux/ubuntu jammy InRelease                                             
Hit:5 http://security.ubuntu.com/ubuntu jammy-security InRelease                                           
Hit:6 https://ppa.launchpadcontent.net/yannubuntu/boot-repair/ubuntu jammy InRelease 
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  python3-cached-property python3-docker python3-dockerpty python3-docopt python3-dotenv python3-texttable python3-websocket
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  aufs-tools cgroupfs-mount | cgroup-lite
The following NEW packages will be installed:
  containerd.io docker-ce docker-ce-cli docker-compose-plugin
0 upgraded, 4 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/96.3 MB of archives.
After this operation, 414 MB of additional disk space will be used.
Selecting previously unselected package containerd.io.
(Reading database ... 221681 files and directories currently installed.)
Preparing to unpack .../containerd.io_1.6.6-1_amd64.deb ...
Unpacking containerd.io (1.6.6-1) ...
Selecting previously unselected package docker-ce-cli.
Preparing to unpack .../docker-ce-cli_5%3a20.10.17~3-0~ubuntu-jammy_amd64.deb ...
Unpacking docker-ce-cli (5:20.10.17~3-0~ubuntu-jammy) ...
Selecting previously unselected package docker-ce.
Preparing to unpack .../docker-ce_5%3a20.10.17~3-0~ubuntu-jammy_amd64.deb ...
Unpacking docker-ce (5:20.10.17~3-0~ubuntu-jammy) ...
Selecting previously unselected package docker-compose-plugin.
Preparing to unpack .../docker-compose-plugin_2.6.0~ubuntu-jammy_amd64.deb ...
Unpacking docker-compose-plugin (2.6.0~ubuntu-jammy) ...
Setting up containerd.io (1.6.6-1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/containerd.service → /lib/systemd/system/containerd.service.
Setting up docker-compose-plugin (2.6.0~ubuntu-jammy) ...
Setting up docker-ce-cli (5:20.10.17~3-0~ubuntu-jammy) ...
Setting up docker-ce (5:20.10.17~3-0~ubuntu-jammy) ...
Created symlink /etc/systemd/system/multi-user.target.wants/docker.service → /lib/systemd/system/docker.service.
Created symlink /etc/systemd/system/sockets.target.wants/docker.socket → /lib/systemd/system/docker.socket.
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
     Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: exit-code) since Sun 2022-07-03 19:24:18 UTC; 9ms ago
TriggeredBy: ● docker.socket
       Docs: https://docs.docker.com
    Process: 23384 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
   Main PID: 23384 (code=exited, status=1/FAILURE)
        CPU: 125ms
dpkg: error processing package docker-ce (--configure):
 installed docker-ce package post-installation script subprocess returned error exit status 1
Processing triggers for man-db (2.10.2-1) ...
Errors were encountered while processing:
 docker-ce
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#2 Le 03/07/2022, à 20:29

xubu1957

Re : Impossible d'installer Docker


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#3 Le 03/07/2022, à 20:32

CaffBleu

Re : Impossible d'installer Docker

Non du tout, j'avais déjà installé docker sans soucis sur cette machine de la même manière qu'ajourd'hui... mais du coup non aucun vpn hmm

Hors ligne

#4 Le 03/07/2022, à 20:37

xubu1957

Re : Impossible d'installer Docker

Fournis :

dpkg -l | grep -i docker

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#5 Le 03/07/2022, à 20:48

CaffBleu

Re : Impossible d'installer Docker

xubu1957 a écrit :

Fournis :

dpkg -l | grep -i docker

après une désinstallation complète la commande retourne rien mais lorsque j'essaye de reinstaller j'ai toujours la même erreur et ça retourne :

iF  docker-ce                             5:20.10.17~3-0~ubuntu-jammy                amd64        Docker: the open-source application container engine
ii  docker-ce-cli                         5:20.10.17~3-0~ubuntu-jammy                amd64        Docker CLI: the open-source application container engine
ii  docker-ce-rootless-extras             5:20.10.17~3-0~ubuntu-jammy                amd64        Rootless support for Docker.
ii  docker-compose-plugin                 2.6.0~ubuntu-jammy                         amd64        Docker Compose (V2) plugin for the Docker CLI.
ii  docker-scan-plugin                    0.17.0~ubuntu-jammy                        amd64        Docker scan cli plugin.

Hors ligne

#6 Le 03/07/2022, à 20:50

xubu1957

Re : Impossible d'installer Docker

Tente, pour voir :

sudo apt install --reinstall docker-ce

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#7 Le 03/07/2022, à 20:52

CaffBleu

Re : Impossible d'installer Docker

xubu1957 a écrit :

Tente, pour voir :

sudo apt install --reinstall docker-ce

voilà le retour ! (merci pour ton aide au passage !)

sudo apt install --reinstall docker-ce
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for docker-ce:amd64

Hors ligne

#8 Le 03/07/2022, à 20:54

xubu1957

Re : Impossible d'installer Docker

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#9 Le 03/07/2022, à 20:56

CaffBleu

Re : Impossible d'installer Docker

xubu1957 a écrit :

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

pour le coup il y'en a pas mal lol

dpkg -l | grep -v ^ii
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                  Version                                    Architecture Description
+++-=====================================-==========================================-============-================================================================================
rc  ca-certificates-mono                  6.8.0.105+dfsg-3.2                         all          Common CA certificates (Mono keystore)
iF  docker-ce                             5:20.10.17~3-0~ubuntu-jammy                amd64        Docker: the open-source application container engine
ic  firefox                               1:1snap1-0ubuntu2                          amd64        Transitional package - firefox -> firefox snap
rc  fuse                                  2.9.9-5ubuntu2                             amd64        Filesystem in Userspace
rc  grub-efi-amd64                        2.06-2ubuntu7                              amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 version)
rc  grub-efi-amd64-bin                    2.06-2ubuntu7                              amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 modules)
rc  grub2-common                          2.06-2ubuntu7                              amd64        GRand Unified Bootloader (common files for version 2)
rc  hddtemp                               0.3-beta15-54                              amd64        hard drive temperature monitoring utility
rc  libnunit-console-runner2.6.3-cil      2.6.4+dfsg-1.1                             all          Unit test framework for CLI - Assemblies
rc  libnunit-core-interfaces2.6.3-cil     2.6.4+dfsg-1.1                             all          Unit test framework for CLI - Assemblies
rc  libnunit-core2.6.3-cil                2.6.4+dfsg-1.1                             all          Unit test framework for CLI - Assemblies
rc  libnunit-framework2.6.3-cil           2.6.4+dfsg-1.1                             all          Unit test framework for CLI - Assemblies
rc  libnunit-mocks2.6.3-cil               2.6.4+dfsg-1.1                             all          Unit test framework for CLI - Assemblies
rc  libnunit-util2.6.3-cil                2.6.4+dfsg-1.1                             all          Unit test framework for CLI - Assemblies
rc  libpython3.9-minimal:amd64            3.9.7-2build1                              amd64        Minimal subset of the Python language (version 3.9)
rc  libx2go-server-db-perl                4.1.0.3-5                                  amd64        Perl X2Go::Server:DB package
rc  linux-image-5.13.0-21-generic         5.13.0-21.21                               amd64        Signed kernel image generic
rc  linux-image-5.13.0-22-generic         5.13.0-22.22                               amd64        Signed kernel image generic
rc  linux-image-5.13.0-37-generic         5.13.0-37.42                               amd64        Signed kernel image generic
rc  linux-image-5.13.0-44-generic         5.13.0-44.49                               amd64        Signed kernel image generic
rc  linux-modules-5.13.0-21-generic       5.13.0-21.21                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  linux-modules-5.13.0-22-generic       5.13.0-22.22                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  linux-modules-5.13.0-37-generic       5.13.0-37.42                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  linux-modules-5.13.0-44-generic       5.13.0-44.49                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.13.0-21-generic 5.13.0-21.21                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.13.0-22-generic 5.13.0-22.22                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.13.0-37-generic 5.13.0-37.42                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.13.0-44-generic 5.13.0-44.49                               amd64        Linux kernel extra modules for version 5.13.0 on 64 bit x86 SMP
rc  mono-runtime-common                   6.12.0.122-0xamarin1+ubuntu2004b1          amd64        Mono runtime - common files
rc  nxagent                               2:3.5.99.26-5                              amd64        Nested Xserver (aka NX Agent) supporting the NX compression protocol
rc  pkg-config                            0.29.2-1ubuntu3                            amd64        manage compile and link flags for libraries
rc  python3.9-minimal                     3.9.7-2build1                              amd64        Minimal subset of the Python language (version 3.9)
rc  shim-signed                           1.51+15.4-0ubuntu9                         amd64        Secure Boot chain-loading bootloader (Microsoft-signed binary)
rc  x2goserver-common                     4.1.0.3-5                                  all          X2Go Server (common files)
rc  x2goserver-x2goagent                  4.1.0.3-5                                  amd64        X2Go Server's X2Go Agent

Hors ligne

#10 Le 03/07/2022, à 20:59

xubu1957

Re : Impossible d'installer Docker

Pour purger les résidus de configuration marqués "rc" :

sudo apt purge ~c

comme expliqué à la machine à café.

Si tu vois une idée dans forums.docker.com/t/ubuntu-18-04-4-lts-docker-install-failed/91408/2


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#11 Le 03/07/2022, à 21:02

CaffBleu

Re : Impossible d'installer Docker

xubu1957 a écrit :

Pour purger les résidus de configuration marqués "rc" :

sudo apt purge ~c

comme expliqué à la machine à café.

Si tu vois une idée dans forums.docker.com/t/ubuntu-18-04-4-lts-docker-install-failed/91408/2

la commande fini par un drole de message qui fait peur :

sudo apt purge ~c
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages will be REMOVED:
  ca-certificates-mono* firefox* fuse* grub-efi-amd64* grub-efi-amd64-bin* grub2-common* hddtemp* libnunit-console-runner2.6.3-cil* libnunit-core-interfaces2.6.3-cil*
  libnunit-core2.6.3-cil* libnunit-framework2.6.3-cil* libnunit-mocks2.6.3-cil* libnunit-util2.6.3-cil* libpython3.9-minimal* libx2go-server-db-perl*
  linux-image-5.13.0-21-generic* linux-image-5.13.0-22-generic* linux-image-5.13.0-37-generic* linux-image-5.13.0-44-generic* linux-modules-5.13.0-21-generic*
  linux-modules-5.13.0-22-generic* linux-modules-5.13.0-37-generic* linux-modules-5.13.0-44-generic* linux-modules-extra-5.13.0-21-generic* linux-modules-extra-5.13.0-22-generic*
  linux-modules-extra-5.13.0-37-generic* linux-modules-extra-5.13.0-44-generic* mono-runtime-common* nxagent* pkg-config* python3.9-minimal* shim-signed* x2goserver-common*
  x2goserver-x2goagent*
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  shim-signed
0 upgraded, 0 newly installed, 34 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
E: Removing essential system-critical packages is not permitted. This might break the system.

Hors ligne

#12 Le 03/07/2022, à 21:05

xubu1957

Re : Impossible d'installer Docker

Je vais essayer d'avoir du renfort.
        _ _ _

(edit=messages regroupés)
        _ _ _

Fournis les noyaux présents :

echo; dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

et :

 mono --version

> tutsmake.com/how-to-install-and-use-mono-on-ubuntu-22-04

Dernière modification par xubu1957 (Le 03/07/2022, à 21:16)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#13 Le 03/07/2022, à 21:10

CaffBleu

Re : Impossible d'installer Docker

xubu1957 a écrit :

Fournis les noyaux présents :

echo; dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

et :

 mono --version

> tutsmake.com/how-to-install-and-use-mono-on-ubuntu-22-04

echo; dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

ic  linux-image-5.13.0-21-generic          5.13.0-21.21  amd64
ic  linux-modules-5.13.0-21-generic        5.13.0-21.21  amd64
ic  linux-modules-extra-5.13.0-21-generic  5.13.0-21.21  amd64
ic  linux-image-5.13.0-22-generic          5.13.0-22.22  amd64
ic  linux-modules-5.13.0-22-generic        5.13.0-22.22  amd64
ic  linux-modules-extra-5.13.0-22-generic  5.13.0-22.22  amd64
ic  linux-image-5.13.0-37-generic          5.13.0-37.42  amd64
ic  linux-modules-5.13.0-37-generic        5.13.0-37.42  amd64
ic  linux-modules-extra-5.13.0-37-generic  5.13.0-37.42  amd64
ic  linux-image-5.13.0-44-generic          5.13.0-44.49  amd64
ic  linux-modules-5.13.0-44-generic        5.13.0-44.49  amd64
ic  linux-modules-extra-5.13.0-44-generic  5.13.0-44.49  amd64
ii  linux-headers-5.15.0-33                5.15.0-33.34  all
ii  linux-headers-5.15.0-33-generic        5.15.0-33.34  amd64
ii  linux-image-5.15.0-33-generic          5.15.0-33.34  amd64
ii  linux-modules-5.15.0-33-generic        5.15.0-33.34  amd64
ii  linux-modules-extra-5.15.0-33-generic  5.15.0-33.34  amd64
ii  linux-headers-5.15.0-40                5.15.0-40.43  all
ii  linux-headers-5.15.0-40-generic        5.15.0-40.43  amd64
ii  linux-image-5.15.0-40-generic          5.15.0-40.43  amd64
ii  linux-modules-5.15.0-40-generic        5.15.0-40.43  amd64
ii  linux-modules-extra-5.15.0-40-generic  5.15.0-40.43  amd64
ii  linux-generic                          5.15.0.40.42  amd64
ii  linux-headers-generic                  5.15.0.40.42  amd64
ii  linux-image-generic                    5.15.0.40.42  amd64

Noyau courant : 5.15.0-40-generic x86_64
root@moi ~ #  mono --version
Command 'mono' not found, but can be installed with:
apt install mono-runtime

Hors ligne

#14 Le 03/07/2022, à 21:14

CaffBleu

Re : Impossible d'installer Docker

après l'installation de mono voilà le resultat :

mono --version
Mono JIT compiler version 6.8.0.105 (Debian 6.8.0.105+dfsg-3.2 Wed Jun 30 05:34:49 UTC 2021)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug 
        Interpreter:   yes
        LLVM:          supported, not enabled.
        Suspend:       hybrid
        GC:            sgen (concurrent by default)

Hors ligne

#15 Le 03/07/2022, à 21:18

xubu1957

Re : Impossible d'installer Docker

Il faut attendre des aidants connaisseurs.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#16 Le 03/07/2022, à 21:21

CaffBleu

Re : Impossible d'installer Docker

pas de soucis je te remercie en tout cas !

Hors ligne

#17 Le 04/07/2022, à 12:50

iznobe

Re : Impossible d'installer Docker

Bonjour , dans le lien donné par @xubu1957 , on trouve un autre lien qui indique comment faire pour resoudre le soucis rencontré : https://medium.com/@randima.somathilaka … 70762c2187
certes en anglais ...


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#18 Le 06/07/2022, à 01:46

CaffBleu

Re : Impossible d'installer Docker

iznobe a écrit :

Bonjour , dans le lien donné par @xubu1957 , on trouve un autre lien qui indique comment faire pour resoudre le soucis rencontré : https://medium.com/@randima.somathilaka … 70762c2187
certes en anglais ...

salut désolé pour le retard ! J'ai bien essayé tout ça mais j'ai toujours le même résultat

sudo apt-get install docker-ce=5:20.10.15~3-0~ubuntu-jammy docker-ce-cli=5:20.10.15~3-0~ubuntu-jammy containerd.io
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  docker-ce-rootless-extras docker-scan-plugin libslirp0 slirp4netns
Suggested packages:
  aufs-tools cgroupfs-mount | cgroup-lite
The following NEW packages will be installed:
  containerd.io docker-ce docker-ce-cli docker-ce-rootless-extras docker-scan-plugin libslirp0 slirp4netns
0 upgraded, 7 newly installed, 0 to remove and 11 not upgraded.
Need to get 73.1 MB/101 MB of archives.
After this operation, 421 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://de.archive.ubuntu.com/ubuntu jammy/main amd64 libslirp0 amd64 4.6.1-1build1 [61.5 kB]
Get:2 http://de.archive.ubuntu.com/ubuntu jammy/universe amd64 slirp4netns amd64 1.0.1-2 [28.2 kB]             
Get:3 https://download.docker.com/linux/ubuntu jammy/stable amd64 docker-ce-cli amd64 5:20.10.15~3-0~ubuntu-jammy [40.6 MB]
Get:4 https://download.docker.com/linux/ubuntu jammy/stable amd64 docker-ce amd64 5:20.10.15~3-0~ubuntu-jammy [20.8 MB]
Get:5 https://download.docker.com/linux/ubuntu jammy/stable amd64 docker-ce-rootless-extras amd64 5:20.10.17~3-0~ubuntu-jammy [8,163 kB]
Get:6 https://download.docker.com/linux/ubuntu jammy/stable amd64 docker-scan-plugin amd64 0.17.0~ubuntu-jammy [3,521 kB]
Fetched 73.1 MB in 2s (38.5 MB/s)             
Selecting previously unselected package containerd.io.
(Reading database ... 221054 files and directories currently installed.)
Preparing to unpack .../0-containerd.io_1.6.6-1_amd64.deb ...
Unpacking containerd.io (1.6.6-1) ...
Selecting previously unselected package docker-ce-cli.
Preparing to unpack .../1-docker-ce-cli_5%3a20.10.15~3-0~ubuntu-jammy_amd64.deb ...
Unpacking docker-ce-cli (5:20.10.15~3-0~ubuntu-jammy) ...
Selecting previously unselected package docker-ce.
Preparing to unpack .../2-docker-ce_5%3a20.10.15~3-0~ubuntu-jammy_amd64.deb ...
Unpacking docker-ce (5:20.10.15~3-0~ubuntu-jammy) ...
Selecting previously unselected package docker-ce-rootless-extras.
Preparing to unpack .../3-docker-ce-rootless-extras_5%3a20.10.17~3-0~ubuntu-jammy_amd64.deb ...
Unpacking docker-ce-rootless-extras (5:20.10.17~3-0~ubuntu-jammy) ...
Selecting previously unselected package docker-scan-plugin.
Preparing to unpack .../4-docker-scan-plugin_0.17.0~ubuntu-jammy_amd64.deb ...
Unpacking docker-scan-plugin (0.17.0~ubuntu-jammy) ...
Selecting previously unselected package libslirp0:amd64.
Preparing to unpack .../5-libslirp0_4.6.1-1build1_amd64.deb ...
Unpacking libslirp0:amd64 (4.6.1-1build1) ...
Selecting previously unselected package slirp4netns.
Preparing to unpack .../6-slirp4netns_1.0.1-2_amd64.deb ...
Unpacking slirp4netns (1.0.1-2) ...
Setting up docker-scan-plugin (0.17.0~ubuntu-jammy) ...
Setting up containerd.io (1.6.6-1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/containerd.service → /lib/systemd/system/containerd.service.
Setting up docker-ce-cli (5:20.10.15~3-0~ubuntu-jammy) ...
Setting up libslirp0:amd64 (4.6.1-1build1) ...
Setting up docker-ce-rootless-extras (5:20.10.17~3-0~ubuntu-jammy) ...
Setting up slirp4netns (1.0.1-2) ...
Setting up docker-ce (5:20.10.15~3-0~ubuntu-jammy) ...
Created symlink /etc/systemd/system/multi-user.target.wants/docker.service → /lib/systemd/system/docker.service.
Created symlink /etc/systemd/system/sockets.target.wants/docker.socket → /lib/systemd/system/docker.socket.
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
     Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: exit-code) since Wed 2022-07-06 00:43:58 UTC; 30ms ago
TriggeredBy: ● docker.socket
       Docs: https://docs.docker.com
    Process: 200441 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
   Main PID: 200441 (code=exited, status=1/FAILURE)
        CPU: 124ms
dpkg: error processing package docker-ce (--configure):
 installed docker-ce package post-installation script subprocess returned error exit status 1
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for libc-bin (2.35-0ubuntu3) ...
Errors were encountered while processing:
 docker-ce
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Le retour des commandes du tuto :

root@moi ~ # apt-cache policy docker-ce
docker-ce:
  Installed: (none)
  Candidate: 5:20.10.17~3-0~ubuntu-jammy
  Version table:
     5:20.10.17~3-0~ubuntu-jammy 500
        500 https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
     5:20.10.16~3-0~ubuntu-jammy 500
        500 https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
     5:20.10.15~3-0~ubuntu-jammy 500
        500 https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
     5:20.10.14~3-0~ubuntu-jammy 500
        500 https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
     5:20.10.13~3-0~ubuntu-jammy 500
        500 https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
root@moi ~ # apt-cache madison docker-ce
 docker-ce | 5:20.10.17~3-0~ubuntu-jammy | https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
 docker-ce | 5:20.10.16~3-0~ubuntu-jammy | https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
 docker-ce | 5:20.10.15~3-0~ubuntu-jammy | https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
 docker-ce | 5:20.10.14~3-0~ubuntu-jammy | https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages
 docker-ce | 5:20.10.13~3-0~ubuntu-jammy | https://download.docker.com/linux/ubuntu jammy/stable amd64 Packages

Hors ligne

#19 Le 06/07/2022, à 02:07

CaffBleu

Re : Impossible d'installer Docker

Re !
J'ai réussi à régler le problème. C'était si bête...
Après avoir effectué cette commande :

journalctl -xeu docker.service

J'ai pu lire :

unable to configure the Docker daemon with file /etc/docker/daemon.json: EOF

du coup un petit rm du deamon.json puis un redemarrage de docker voilà l'erreur qui ressort :

failed to start daemon: pid file found, ensure docker is not running or delete /var/run/docker.pid

du coup pareil un rm de docker.pid a réglé le problème !

Je suppose que le json été endommagé un jour où j'ai surement voulu lier un nom de domaine à docker. Mais du coup voilà le soucis est réglé ! merci à vous d'avoir essayé d'aider ! En espérant que mon cas puisse aider d'autres personnes !

Hors ligne

#20 Le 06/07/2022, à 05:49

xubu1957

Re : Impossible d'installer Docker

Bonjour,

Pour éditer ta discussion et rajouter [Résolu], au début du titre, il faut utiliser le bouton Modifier au bas de ton premier message.

Merci wink


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne